Select

From OCAD 12 Wiki - English
Jump to: navigation, search

Select and Edit Object Space.PNGThis function is available in OCAD 12 Professional.This function is available in OCAD 12 Orienteering.This function is available in OCAD 12 Starter.This function is available in OCAD 12 Course Setting.

Choose Select and Edit Object in the Select menu or click the Select and Edit Object icon Icon SelectAndEditObject.PNG in the Editing and Drawing Toolbar to select and edit an object. The cursor changes to a black arrow like on the icon Icon SelectAndEditObject.PNG. You are now in the Select and Edit Object mode.
Click on an object to select it. The selection looks as follows if you have Object Stretching in the Object category in OCAD Preferences activated:
SelectandEditObjectSelection.PNG
hint Objects can be selected by either clicking on them or clicking outside and drawing a window over the object. Achtung.PNGYou can select multiple objects on the same time with this method.
hint While moving/stretching/rotating an object, it's new position is shown with a draft line.

Stretch an Area or Line Object

If you have Object Stretching in the Object category in OCAD Preferences activated, you can click and drag the black squares BlackSquare.PNG (stretching points) to stretch the object. If you want to keep the shape of the object drag a square from the corner. If you drag a square from the middle, the object is distorted in the corresponding direction. If you hold down the shift key while dragging a stretching point BlackSquare.PNG, the object is stretched relative to the center.
Stretching does not work for point and text objects. If you stretch line text objects, the line is stretched and not the text.
If Object Stretching is not enabled, the stretching points BlackSquare.PNG are not visible.

Move an Object

Click and drag one of the unfilled squares WhiteSquare.PNG (moving points) to move the object. Each square represents a vertex. If a hole is selected, you can move it in the same way. Line, area and text objects don't need to be picked by their moving points to be moved, a simple click and drag in the object is sufficent.

Objects can also be moved using the arrow keys. Press additional the Shift key to move the object faster.

hintObjects can be moved by clicking inside the object and moving the mouse after the object got selected. If the mouse is in a correct spot, it changeds to an cross shaped cursor CrossCursor.PNG.

Select a Hole in an Area

It is possible to select a hole in an area object by clicking inside the desired hole. Only the hole will be selected. You can accomplish editing operations (e.g. Enlarge/Reduce, Fill, Rotate, Move or Delete) as for a normal area object. Find more about cutting holes on the Edit Object page.

hint If you have enabled the Auto select symbol when selecting object option in the Symbol category of OCAD Preferences, the corresponding symbol is automatically selected when selecting an object. This does not work for a selection of multiple objects.
hint Disable Context menu in drawing area in the GUI (Graphical User Interface) category of OCAD Preferences to switch easily to the current Drawing mode and the Select Object and Edit Vertex mode by a simple click with the right mouse button on the drawing area. If this option is enabled, the context menu appears by clicking on the drawing area with the right mouse button. Read more about the context menu on the OCAD Preferences page.

Select Object and Edit Vertex Space.PNGThis function is available in OCAD 12 Professional.This function is available in OCAD 12 Orienteering.This function is available in OCAD 12 Starter.This function is available in OCAD 12 Course Setting.

Choose Select Object and Edit Vertex in the Select menu or click the Select Object and Edit Vertex icon Icon SelectObjectAndEditVertex.PNG in the Editing and Drawing Toolbar to select and edit vertices. The cursor changes to a transparent arrow like on the icon Icon SelectObjectAndEditVertex.PNG. You are now in the Select Object and Edit Vertex mode. Click on an object to select it.
SelectAndEditAVertexSelection.PNG
The characteristics of every vertex are visible in this selection.

hint Objects can be selected by either clicking on them or clicking outside and drawing a window over the object. Achtung.PNGYou can select multiple objects on the same time with this method.
hint While moving vertices, a draft line shows the connection to the previous and next unmoved vertex.

Move Single Vertices

Once an object is selected you can move a single vertex of the selected object. Simply drag the desired point to the new position. hint Right angles are kept by holding down SHIFT key while moving a single vertex.

Right angle is kept when holding down SHIFT key while moving vertex

Move Vertex With Arrow Keys

It is also possible to move a vertex with arrow keys. Double click on a vertex and move it then with the arrow keys. The selected vertex gets shown a little bigger after double click.

Double click on a vertex to move it with arrow keys

Move a Segment

A selected object can be changed by moving its segments. Just click on the segment and drag it.
Move segment

hint The moved segment doesn't get transformed, but the ones it is connected to.

hint If a corner is rectangular, the angle will be kept and the segment can be move only along this/these straight/s.

Move segment with right angles


Samples:
Move building edge Move vegetation borderline

Edit a Bezier Vertex

Once an object containing Bezier vertices is selected you can edit those.

BezierCurveEditVertex.PNG

Drag a tangent endpoint O to edit the tangent.

Select a Hole in an Area

It is possible to select a hole in an area object by clicking inside the desired hole. Only the vertices of the hole will be marked. You can accomplish editing operations (e.g. Fill, Rotate, Move or Delete) as for a normal area object. Find more about cutting holes on the Edit Object page.

hint If you select an object in the Select Object and Edit Vertex Icon SelectObjectAndEditVertex.PNG mode, you can move it using the arrow keys on the keyboard.

hint If you select an object in the Select Object and Edit Vertex Icon SelectObjectAndEditVertex.PNG mode and then double click on a vertex, the mark gets bigger and the vertex can be moved by using the arrow keys on the keyboard.

hint If you have enabled the Auto select symbol when selecting object option in the Symbol category of OCAD Preferences, the corresponding symbol is automatically selected when selecting an object. This does not work for a selection of multiple objects.

hint Disable Context menu in drawing area in the GUI (Graphical User Interface) category of OCAD Preferences to switch easily between the current Drawing mode and the Select Object and Edit Vertex mode by a simple click with the right mouse button on the drawing area. If this option is enabled, the context menu appears by clicking on the drawing area with the right mouse button. Read more about the context menu on the OCAD Preferences page.

hint Text object can be selected an marked with a double click in the text.

Select and Edit Multiple Objects Space.PNGThis function is available in OCAD 12 Professional.This function is available in OCAD 12 Orienteering.This function is available in OCAD 12 Starter.This function is available in OCAD 12 Course Setting.

Drag an area in the Icon SelectAndEditObject.PNG Select and Edit Object or Icon SelectObjectAndEditVertex.PNG Select Object and Edit Vertex mode to select all objects which are in it.
You can choose between two modes to select multiple objects in the Select category of OCAD Preferences in the Options menu: Either all objects must be with at least one vertex in the selection or all objects must be completely in the selection.

Select and edit multiple objects

Alternatively, you can select every object individually by holding the Shift key while clicking the objects.
In the Icon SelectAndEditObject.PNG Select and Edit Object mode it is possible to enlarge or reduce a selection of objects. For that purpose, drag one of the black squares BlackSquare.PNG in the desired direction.
It is also possible to move a selection of objects in both modes. If you move the mouse over the selection the cursor changes its appearance to MousePointerMove.PNG. By clicking and dragging the selection or using the arrow keys you can move it.

hint Enable the Move multiple objects option in the Warnings category of OCAD Preferences to get a warning message when you move multiple objects. Use this option in order to guard against moving multiple objects accidentally.

Select Object with Lasso Tool

  1. Choose Select Object with Lasso Tool in the Select menu or click the Select Object with Lasso Tool icon Icon SelectObjectWithLassoTool.PNG in the Editing and Drawing Toolbar. The transparent arrow with a loop behind shows that you are now in the Select Object with Lasso Tool mode.
  2. Draw a Freehand line by holding down the left mouse button when moving the mouse cursor.
  3. Finish the lasso line by leaving the left mouse key. The objects within the lasso line are selected.


hint It depends from the Select Preferences if objects that are only partially within the lasso line are selected.

Select object with lasso tool

Select Objects by Symbol Space.PNGThis function is available in OCAD 12 Professional.This function is available in OCAD 12 Orienteering.This function is available in OCAD 12 Starter.

Choose Select Objects by Symbol in the Select menu to select all objects with certain symbols or in a certain layer. As an example you can select all roads. The Select By Symbol dialog box appears.

SelectbySymbolDialog.PNG

All objects with a selected symbol

Choose this option and click on the OK button to select all objects with the selected symbol(s). Select the symbol(s) before you choose the Select Objects by Symbol command. For the example given above, select all road symbols. All roads are selected and you can for example measure their total length or make a modification to them.

All objects in layer

If you import files like PDF, DXF, Adobe Illustrator or OpenStreetMap with layer information, the layer information does not get lost, though OCAD does not support layers as they are known in Adobe Illustrator or similar applications. Choose the All objects in a layer option to select all objects which are in the same layer. Choose a layer in the dropdown list. If you have selected an object of this layer before choosing this command, the layer name will already be filled in. For example, choose the layer which contains all the roads and click the OK button to select all roads.

Objects without symbol

Choose this option and click on the OK button to select all Unsymbolized Objects.

Objects with unknown symbol

Choose this option and click on the OK button to select all Objects with Unknown Symbol.

Objects with invalid symbol type

Choose this option and click on the OK button to select all Objects with Invalid Symbol Type.

Graphic objects

Choose this option and click on the OK button to select all Graphic Objects.

Image objects

Choose this option and click on the OK button to select all Image Objects.

Select Objects by Property Space.PNGThis function is available in OCAD 12 Professional.This function is available in OCAD 12 Orienteering.

Choose Select Objects by Property in the Select menu to select objects by particular properties. The Select by Property dialog box appears.

SelectbyPropertyDialogBox.PNG


In the Select field you can choose between two options:

  • The All Objects option means that the selection is made out of all objects on the map.
  • The Objects with a selected symbol option means that the selection is reduced to the objects with a symbol that is selected in the symbol box.


In the Condition field you can impose conditions.

  • Choose a property like Number of vertices, Length [m] in the first box.
  • Choose an operator like < > = in the second box.
  • Enter a condition value in the third box.


Click the Select button to continue.
The Object Information table dialog box appears and the desired objects are selected. The number of selected objects is shown in the header of the dialog. You have now different options:

  • Click the Save Selection button to save the selection.
  • Click the Report button to save a report in a Microsoft Excel (.xls), Text (.txt), Website (.htm) or Microsoft Word (.doc) file.
  • Click the Close button to close the dialog and return to the Select Objects by Property dialog.


Hint.jpg The Object Information and the Select Objects by Property dialog are non-modal dialogs. This means, that you can edit the map without closing the dialogs. If the Object Information dialog box is opened, you can for example select other objects on the map. The object information is refreshed automatically.

Example 1: Select all objects which are longer than 200m.

  1. Choose the All objects option in the Select Objects by Property dialog.
  2. In the Condition field choose Length [m] as the Property, > as an operator and enter the value 200.
  3. Click on the Select button to continue. The Object Information table dialog box appears. All objects longer than 200m are selected and listed in the table dialog box.


Example 2: Select all lakes and ponds with an area smaller or equal than 3000m2.

  1. Select the symbol for a lake and a pond in the symbol box. It is possible to do this even if the Select Objects by Property dialog is opened because it is a non-modal dialog.
  2. Choose the Objects with a selected symbol option in the Select Objects by Property dialog.
  3. In the Condition field choose Area [m2] as the Property, <= as an operator and enter the value 3000.
  4. Click on the Select button to continue. The Object Information table dialog box appears. All lakes and ponds with an area smaller or equal than 3000m2 are selected and listed in the table dialog box.


Select Objects by Date

With this function objects can be selected either by their Creation date or Modification date.It allso allows to differ between All objects and All objects from selected symbols.
hintAll objects from selected symbols means to select only the previously selected symbol within the time frame.

  1. Choose the Select Object by Date command from the Select menu.
  2. A dialog appears where you can pick the date mode, enter the time frame and deside which symbols shall be selected.
    hintBy default, the actual date is picked.
  3. Click the OK button to select the object(s).

SelectObjectbyDate.png

The Object Information dialog appears.
SelectObjectbyDateSort.png

hintIt's possible to sort the values by double clicking on the top row.

Last Modified Objects

Click the Last modified button to select the last 100 changed objects. The Object Information dialog appears. The objects are sorted by the Modification date.

Select Object by Object Index Space.PNGThis function is available in OCAD 12 Professional.

With this function objects can be selected by their object index. The object index is an internal index for each object and cannot be changed. The object information is shown in the Object Information dialog which can be found in the Select menu.

Choose the Select Object by Object Index command from the Select menu. A dialog appears where you can enter the object index. Click the OK button to select the object.

The first drawn or imported object has the object index 1. The object index is a number and unique in a ocd file.

Select Duplicate Objects Space.PNGThis function is available in OCAD Professional.This function is available in OCAD Orienteering.

Choose this function from the Select menu.
With this function you can find all duplicate objects. The objects must be identical and on the same position that they can be found. The selection can be saved with OCAD 12 Professional right after carrying out the command (Save a Selection).

hint Objects with different symbols whose geometry is identical are not selected.

Select Self Intersected Objects Space.PNGThis function is available in OCAD Professional.This function is available in OCAD Orienteering.

Choose this function from the Select menu.

This function selects all line, area and line text objects with a self-intersecting geometry. The selection can be saved right after carrying out the command (Save a Selection).

Select Objects with Invalid Geometry Space.PNGThis function is available in OCAD Professional.

Choose this function from the Select menu to select all objects with invalid geometry.

The following objects are selected:

  • Objects which start with a hole: OCAD selects all objects, whose first vertex has a hole flag. This can be a hole with no exterior ring.
  • Damaged Bezier curves: A Bezier curve is composed of minimum a start point, a first Bezier vertex, a second Bezier vertex and an end point (see illustration).
MinimumBezier.PNG
If a Bezier curve has less than these vertices, it is selected.
  • Line objects with invalid hole flag: A line object which contains a vertex with a hole flag is selected.
  • Area object with invalid geometry: OCAD selects all area objects, whose vertices have the same coordinate. This problem can occur when the scale is reduced.
  • Line objects with the same start and end point: This problem can occur when the scale is reduced. In this case, the start and end point of a really short line object can fall together.
  • Area object with an invalid hole: A hole must have minimum three vertices. A hole with one or two vertices is selected (see illustration).
HoleWithOnlyTwoVertices.PNG
  • Area object with an invalid exterior ring: An invalid exterior ring can be a ring with only one vertex (see illustration).
InvalidExteriorRing.PNG
  • Graphic object with invalid object type: Graphic Objects are either areas or lines. OCAD selects all other types.
  • Object with invalid number of vertices: A line object must have minimum two vertices and an area object three. If they have less vertices, they are selected. In addition, text and line text objects containing no text are selected. To select line text objects with a too short line, use the Select Line Text Objects with too Short Line function.

It is difficult to get an object with invalid geometry. It can happen when you import files or change the scale.

After choosing the function, OCAD searches objects with invalid geometry, selects them and displays them in the Object Information dialog. In addition, a text file opens with a report. This file is stored in a temporary folder.

SelectObjectsWithInvalidGeometry.PNG

The selected objects should be deleted, otherwise they can cause problems when exporting files like PDF or Shape.

The object index is indicated in the Object Information dialog as well as in the text file. Use the Select Object by Object Index function to find the object later with help of the object index.

Select Line Text Objects with Line too Short Space.PNGThis function is available in OCAD Professional.

Choose this function from the Select menu.

This function selects all line text objects whose text is longer than the line length. This can happen when the font of a text symbol has been increased. The selection can be saved right after carrying out the command (Save a Selection).

Select All Space.PNGThis function is available in OCAD 12 Professional.This function is available in OCAD 12 Orienteering.

Choose Select All in the Select menu to select all symbolized (also from protected and hidden symbols), unsymbolized, graphic and image objects. Layout objects are not selected.

Clear Selection Space.PNGThis function is available in OCAD 12 Professional.This function is available in OCAD 12 Orienteering.

Choose Clear Selection in the Select menu or press the Esc key to deselect all objects.

Invert Selection Space.PNGThis function is available in OCAD 12 Professional.This function is available in OCAD 12 Orienteering.

Choose Invert Selection in the Select menu to deselect all selected objects and select all unselected object. Layout objects are not selected.

Select Next Object Space.PNGThis function is available in OCAD 12 Professional.This function is available in OCAD 12 Orienteering.

This menu item is only available if an object is already selected. Choose Select Next Object in the Select menu to select an object which is behind an object that is already selected.

Hint.jpg To select an object behind an already selected object you can also keep the Alt or Alt Gr key pressed and click on the already selected object.

Save Selection Space.PNGThis function is available in OCAD 12 Professional.

Choose Save Selection in the Select menu to save the current selection. The Save Selection dialog box appears.

SaveSelection.PNG

Enter the name of the selection and click on the Save button.

hint Choose Select Objects by Symbol in the Select menu to select all objects of the selected symbols.

hint Due to performance issues the number of objects in a selection is limited by 50'000 objects.

Reload Selection Space.PNGThis function is available in OCAD 12 Professional.

Choose Reload Selection in the Select menu to select all objects from a saved selection. Choose a saved selection and the Reload Selection dialog appears.

ReloadSelection.PNG

The list of the selected objects with aditional information is shown in the dialog. The number of selected objects is shown in the caption in brackets.

Select one object in the list and OCAD selects this object in the drawing area in the edit mode.

Hint.jpg The Reload Selection function selects also symbolized objects from symbols with the status Protect or Hide.

Edit Selection Space.PNGThis function is available in OCAD 12 Professional.

Choose Edit Selection in the Select menu to rename or delete saved selections.

EditSelection.PNG

Delete a Selection

Select a selection in the Edit Selection dialog and click the Delete button to delete it. Click the Delete all button to delete all selections.

Rename a Selection

Select a selection in the Edit Selection dialog. Then enter a new name for the selection in the Selection name field. Click the Rename button to apply the new name.

Click the OK button to save and quit the Edit Selection dialog. Click the Cancel button to close the Edit Selection dialog without saving any changes.

Select Group Space.PNGThis function is available in OCAD 12 Professional.

If you have Grouped objects on your map, you can select them easily by choosing the Select Group command in the Select menu.


video available [Selection]



Back to Main Page

Previous Chapter: Drawing an Object

Next Chapter: Edit Object