Drawing an Object

From OCAD Wiki - English
Jump to: navigation, search

Order SymbolizedAndGraphicObjects.PNG


Draw a Point Object Space.PNGThis function is available in OCAD Mapping Solution.This function is available in OCAD Orienteering.This function is available in OCAD Starter.This function is available in OCAD Course Setting.

Drawing Point Symbol
  1. Choose a point symbol.
  2. Select any drawing mode. The cursor appears as a crosshair with a point in the lower right-hand corner.
  3. Click a position in the drawing window.
  4. The point object appears.
hint -To define a specific direction of for the object, click and hold the left mouse button on desired position; then drag to the direction you wish the object to be oriented to.
-The object can be adjusted retrospectively. To do this, select the point object and align it using the Indicate direction of area pattern, point or text object function.
video available Drawing point objects

Draw a Line or Area Object Space.PNGThis function is available in OCAD Mapping Solution.This function is available in OCAD Orienteering.This function is available in OCAD Starter.This function is available in OCAD Course Setting.

You must select one of the eight drawing modes to draw a line or area object.

  • The cursor appears as a crosshair with the symbol for the selected drawing mode in the lower right-hand corner.
  • In the lower left-hand corner will be shown the total line length.

Hint.jpgIf you draw an area the finishing line is shown dashed, whilst the left mouse button is pressed.

Draw a Straight Line Space.PNGThis function is available in OCAD Mapping Solution.This function is available in OCAD Orienteering.This function is available in OCAD Starter.This function is available in OCAD Course Setting.

draw a straight line
Draw a straight line
  1. To draw straight lines such as streets, power lines or sidewalks, select Straight line mode.
  2. Select a line or area symbol from the symbol box.
  3. Select Straight line mode.
  4. Position the cursor at the point where you want to start the line, then click and hold the left mouse button and drag the cursor in the desired direction. The help line provides a preview of the line that has just been drawn.
  5. To add a vertex to the straight line, release the left mouse button. Now press and hold the left mouse button once more and drag the cursor in the desired direction. Repeat this process as often as necessary.
  6. Click the left mouse button when you have finished drawing and the help line is transformed into the selected line or area symbol.
video available Drawing straight object

Draw a Curve Space.PNGThis function is available in OCAD Mapping Solution.This function is available in OCAD Orienteering.This function is available in OCAD Starter.This function is available in OCAD Course Setting.

curve mode
Drawing a curve

Select Bézier Curve mode to draw flowing or curved lines such as contours or shore lines. Drawing Bézier Curves requires some practice as you need to get a feeling for where the radius or curvature of a flowing or curved line changes. The turning point is where the vertex and its tangents need setting. Once you have mastered this technique, you will be able to draw curved lines and area objects efficiently and precisely.

Beside the Bézier Curve mode, you can change in the OCAD Preferences to the Adobe Illustrator mode.

hint Download this exercise to draw Bézier curves.

Inflection point of a Bézier curve
  1. Select a line or area symbol from the symbol box.
  2. Select Bézier-Curve mode.
  3. Position the cursor at the point where you want to start the line, click and hold the left mouse button and drag the cursor to form the radius you want and release the left mouse button.
  4. Position the cursor at the next inflection, click and hold the left mouse button and drag the cursor to form the radius you want and release the left mouse button. The help line provides a preview of the curved line that has just been drawn. Repeat this process for each inflection point.
  5. Click the left mouse button when you have finished drawing and the help line is transformed into the selected line or area symbol.
Draw a Bézier curve
hint -If you are unhappy with the tangent, simply click the Backspace backspace button. The last tangent will be deleted and you can try again. You can delete as many tangents as you like up to the beginning of the line. This is not possible once the object has been completed.
-Sinuous lines can be managed easily by placing tangents at the outermost points.
Outermost inflection point of a Bézier curve
hintYou can force a corner vertex by dragging two tangents from the same vertex point. Curve: Tangents 2 and 3 start at the same point but move in different directions. A corner vertex is created.
Create a corner vertex in a Bézier curve
video available Drawing curve object

Change Drawing Mode

You can draw parts of a line or area object using different drawing modes. Select the appropriate symbol and draw the first part of your object using a drawing mode. Now press the Tab button until the desired drawing mode appears and then continue drawing.

ChangeDrawingMode.gif

Continuing existing objects

You can lengthen existing line objects or expand area objects. Simply select the appropriate symbol, press and hold the Shiftshift button and start drawing at the beginning or end of the existing object. Release the Shift shift button once the line or area has been added.

This can be used instead of the Icon Merge.PNG Merge function.

ContinueLineArea.gif

video available Continuing existing objects

Draw Horizontal Lines

To draw horizontal or vertical lines, press and hold the Alt button. The line snaps in a vertical or horizontal direction. This can be useful when drawing a border or north lines.
The Shift shift and Alt button functions can be combined.

DrawHorizontalLines.gif

Change to Straight Line Mode

This function makes it easier to combine curves and straight lines.

First activate this option Curve mode: Change to straight line mode when clicking in drawing area in the Preferences -> Drawing and Editing tab.

Start drawing the curve. To draw a straight line click in the drawing area and release the left mouse button. So you can easy switch between straight line mode and curve mode. Double click the left mouse button to finish drawing.

To finish the object with the right mouse button change the corresponding setting in Right click in drawing area opens context menu

ChangeToStraightLineMode.gif

Draw a Freehand Line Space.PNGThis function is available in OCAD Mapping Solution.This function is available in OCAD Orienteering.This function is available in OCAD Starter.

freehand mode
Draw a freehand line

Freehand drawing mode plots the movement of the cursor and converts it into a line. Tracing flowing or curved lines using this mode is not very efficient or precise. Depending on the drawing speed and selected smoothing factor (1, 2 or 3), the line may appear somewhat angular because the vertices are connected using straight lines.

  1. Select a line or area symbol from the symbol box.
  2. Select Freehand mode.
  3. Position the cursor at the beginning of the line, press the left mouse button briefly and trace the line you want using the mouse.
  4. Click the left mouse button when you have finished drawing and the help line is transformed into the selected line or area symbol.

If you draw in freehand mode the same way as in straight mode, normal points will be placed at the corners. Unlike corner points, normal points do not affect dashed lines.

Draw a Rectangular Area Space.PNGThis function is available in OCAD Mapping Solution.This function is available in OCAD Orienteering.This function is available in OCAD Starter.

RectangularMode.JPG
Draw a rectangular area

Select Rectangular mode if you want to draw rectangular areas or objects such as buildings or squares. This drawing mode creates a right-angle in every corner and ensures the start and end points of the outline are identical.

  1. Select a line or area symbol from the symbol box.
  2. Select Rectangular mode.
  3. Position the cursor on one of the corners of the longest side of the rectangular area. Press and hold the left mouse button and drag the cursor along the longest side to the next corner.
  4. When the cursor reaches the corner, release the left mouse button and then press it again. Hold the left mouse button and drag the cursor towards the next corner. The help line provides you with a preview of the straight line that has just been drawn. A broken line shows you what the rectangular object will look like when you have finished. Repeat the above process to draw a line to the third corner.
  5. Click the left mouse button to finish the drawing; the help line is then transformed into the selected line or area symbol.

You should always draw the longest side of a rectangular area first since it is easier to define the rectangular orientation of an area from the longer side.

Draw a rectangular area or line
video available Drawing rectangular objects

Draw a Rectangular Line Space.PNGThis function is available in OCAD Mapping Solution.This function is available in OCAD Orienteering.

rectangular line mode
Draw a rectangular line

Select Rectangular line mode if you want to draw rectangular line objects such as sidewalks or stairs. This drawing mode creates a right-angle in every corner. The only difference between Rectangular line mode and Rectangular mode is that the start and end points are not identical when using rectangular line mode.

  1. Select a line symbol from the symbol box.
  2. Select Rectangular line mode.
  3. Position the cursor at the beginning of the rectangular line. Press and hold the left mouse button and drag the cursor along the longest side to the next corner.
  4. When the cursor reaches the corner, release the left mouse button and then press it again. Hold the left mouse button and drag the cursor towards the next corner. The help line provides a preview of the line that has just been drawn. Repeat this process until you reach the end of the rectangular line.
  5. Click the left mouse button when you have finished drawing and the help line is then transformed into the selected line symbol.

You should always draw the longest side of a rectangular line first since it is easier to define the rectangular orientation of a line from the longer side.

Draw a Stairway Space.PNGThis function is available in OCAD Mapping Solution.This function is available in OCAD Orienteering.

Stairway drawing mode
Draw a stairway

Select Stairway drawing mode if you want to draw a rectangular stairway.

  1. Select a line symbol from the symbol box.
  2. Select Stairway mode.
  3. Position the cursor at the beginning of the stairway. Press and hold the left mouse button and drag the cursor along the longest side to the next corner.
  4. When the cursor reaches the corner, release the left mouse button and then press it again. Hold the left mouse button and drag the cursor towards the next corner. The help line provides a preview of the line that has just been drawn.
  5. Hold the left mouse button and drag the cursor to the first step. The step help lines provide a preview of the stairway. Release the left mouse button.
DrawStairway.png

Draw a Circular Object Space.PNGThis function is available in OCAD Mapping Solution.This function is available in OCAD Orienteering.This function is available in OCAD Starter.

circle mode
Draw a circular object

Select Circle mode if you want to draw circular objects such as roundabouts or silos.

  1. Select a line or area symbol from the symbol box.
  2. Select Circle mode.
  3. Position the cursor at the edge of the object, then press and hold the left mouse button and drag the cursor to the opposite edge. Release the mouse button. The help line is transformed into the selected line or area symbol.
hint -The outline or circular line is drawn as a Bézier curve.
-You can also drag the circle from the center point. Simply press and hold the Shift shift button and drag a radius.
-Clicking the center of the circle with the right mouse button without dragging displays the Draw Circle dialog box. Here you can enter the radius of the circle in mm or m.
video available Drawing circular objects

Draw an Elliptical Object Space.PNGThis function is available in OCAD Mapping Solution.This function is available in OCAD Orienteering.This function is available in OCAD Starter.

Ellipse mode
Draw a elliptical object

Select Ellipse mode if you want to draw oval objects such as hills or dips.

  1. Select a line or area symbol from the symbol box.
  2. Select Ellipse mode.
  3. Position the cursor at the beginning of the longer ellipse axis, then press and hold the left mouse button and drag the cursor towards the end of the axis.
  4. Position the cursor at the beginning of the shorter ellipse axis, then press and hold the left mouse button and drag the cursor towards the end of the axis. Release the mouse button. The help line is transformed into the selected line or area symbol.
Draw an ellipse
video available Draw an ellipse
hint The outline or ellipse line is drawn as a Bézier curve.
video available Drawing elliptical objects

Draw Multiple Point Objects Space.PNGThis function is available in OCAD Mapping Solution.This function is available in OCAD Orienteering.

drawing multiple point objects
Draw multiple point objects

This drawing tool is used to draw several point objects that are placed on a line with a constant interval.

  1. Choose a point symbol in the symbol box.
  2. Choose the drawing tool Drawing multiple point objects from the Edit and Drawing toolbar.
  3. Draw a line from the position of the first to the position of the last feature.
  4. The Dialog Draw Multiple Point Objects appears:
number of objects

Enter the number of objects and click the OK button.

The defined number of objects are drawn:

Defined number of objects
hint If the number of objects is 1, the objects position will be in the center of the drawn line.

Laser Rangefinder Drawing Mode Space.PNGThis function is available in OCAD Mapping Solution.This function is available in OCAD Orienteering.

Icon LaserDistance.PNG

Laser rangefinder drawing tool.

Numerical Drawing Mode Space.PNGThis function is available in OCAD Mapping Solution.This function is available in OCAD Orienteering.

numeric mode
Numerical drawing mode

Select Numeric mode if you have measurement values or coordinate pairs for specific objects.

video available Numeric drawing mode


Construct a point object using distance or azimuth measurements.

  1. Select a point symbol from the symbol box.
  2. Select Numeric mode.
  3. Enter the coordinates of your location in the Easting and Northing fields. A small cross highlights the position in the drawing window.
  4. Enter the length in mm or m in the Length field and the Angle in a clockwise or counterclockwise direction.
  5. Click End.
  6. The angle and distance measurements are used to position the point object.
hint -You can change the direction from clockwise to counterclockwise, or vice-versa, by clicking the Counterclockwise or Clockwise buttons.
-You can change the unit of measurement from millimeter to meter, or vice-versa, by clicking the Millimeter or Meter button.


Construct a line or area object using coordinate pairs.

  1. Select a line or area symbol from the symbol box.
  2. Select Numeric mode.
  3. Enter the coordinates of your first coordinate pair in the Easting and Northing fields. A small gray cross highlights the position of the first coordinate pair in the drawing window.
  4. Select the construction mode construction mode position Enter positions.
  5. Enter the coordinates of the second coordinate pair in mm or m and click Next. A help line appears between the first and second coordinate pair. Repeat this process as often as necessary; the help line is extended each time. Click End once you have entered the final coordinate pair.
  6. The sections are then transformed into the selected line or area symbol.


Construct a line or area object using distance or azimuth measurements.

  1. Select a line or area symbol from the symbol box.
  2. Select Numeric mode.
  3. Enter the coordinates of your starting point in the Easting and Northing fields. A small cross highlights the position of the starting point in the drawing window
  4. Select the construction mode construction mode terangle Enter length and angle.
  5. Enter the length in mm or m in the Length field and enter the Angle in a clockwise or counterclockwise direction. A help line appears that displays the distance and azimuth from the starting point. Repeat this process as often as necessary; the help line is extended each time. Click End once you have entered the final distance and azimuth values.
  6. The sections are then transformed into the selected line or area symbol.

Place a Text Object Space.PNGThis function is available in OCAD Mapping Solution.This function is available in OCAD Orienteering.This function is available in OCAD Starter.This function is available in OCAD Course Setting.

Text and line text symbols are available for placing text. Text symbols are generally aligned horizontally. Line text symbols follow the flow of rivers or streets.

Place text object

Place a text object

You can choose text frames or anchor points for placing text objects.

video available Writing text


Define a text frame

  1. Select a text symbol from the symbol box.
  2. Select a drawing mode.
  3. Position the cursor on the upper left-hand corner of the desired text frame, then click and hold the left mouse button and drag the cursor to the lower right-hand corner. Release the mouse button. The text cursor for inputting text appears.
  4. Enter the desired text. The line break is added automatically Press Enter to start a new paragraph.
Place text using a text frame
video available Writing text
hint You can't draw a text frame with a text symbol whose Drawing Mode is set to Rotated Text.

Define a text anchor point

  1. Select a text symbol from the symbol box.
  2. Select a drawing mode.
  3. Position the cursor at the point where the text is to be anchored. Release the mouse button. The text cursor for inputting text appears.
  4. Enter the desired text. Press Enter to start a new paragraph.
video available Writing text
hint The text objects line length gets enlarged while writing.

Place a Line Text Object

Select a Line Text symbol if you want your text to follow the flow of a curve.

  1. Select a Line Text symbol from the symbol box.
  2. Select Bézier Curve mode.
  3. Draw a curve
    1. Once you have finished drawing the line, a help line appears as well as the text cursor for inputting text.
  4. Enter the desired text.
Place text using a text symbol
video available Writing text

hint Line text object's line length is enlarged while writing text if the line text symbol alignment is left aligned.

Following Existing Objects Space.PNGThis function is available in OCAD Mapping Solution.This function is available in OCAD Orienteering.This function is available in OCAD Starter.

Following existing objects

Ctrl button: Following existing objects

Area objects are often limited by line objects. You can trace existing line or area objects without having to redraw them.

  1. Select a line or area symbol from the symbol box.
  2. Select a drawing mode.
  3. Press and hold the Ctrl button, then position the cursor at the point from which you want to trace the line. This does not have to be the start or end point of the line. The help line will appear with its vertices.
  4. Click and hold the left mouse button and drag the cursor to the desired point. This does not have to be the start or end point of the line.
  5. Release the mouse button. The traced line is transformed into the selected line or area symbol.
Trace a line


hint -With double lines (e.g. streets), you can trace the middle line as well as both side lines. If you do not require this option, you can deactivate it under Preferences, Drawing in the Options menu.
-Line tracing is only possible in straight, Bézier and freehand mode.
-It is possible to trace the outline of existing area objects. However, it is only possible to trace up to one half of the outline, otherwise the trace would be in the opposite direction. The point, up to which the object can be traced, is represented by a large square large square.
video available Following existing objects

Snapping

Please look at the Snapping page.

Live Preview

The live preview can be turned on in the OCAD Preferences in the menu Options and check Enable Live Preview in the category Drawing and Editing.

LivePreview.PNG

Edit a VertexSpace.PNGThis function is available in OCAD Mapping Solution.This function is available in OCAD Orienteering.This function is available in OCAD Starter.This function is available in OCAD Course Setting.

Select object and edit vertex

To edit a vertex, select the Select Object and Edit Vertex editing mode Icon SelectObjectAndEditVertex.PNG. You will then be able to move, delete or change the type of vertex.

For point objects, the middle of the symbol is represented by a large square large square . For line and area objects, the first point of the object is represented by a large square large square , vertices by small squares small square , and the last point of the object by a cross X. With Bézier curves, circle symbols circle symbol are used to represent the ends of the tangents.

For more and detailed information, please visit the Select Object and Edit Vertex page.

Edit an Object Space.PNGThis function is available in OCAD Mapping Solution.This function is available in OCAD Orienteering.This function is available in OCAD Starter.This function is available in OCAD Course Setting.

Select and edit object

To edit an object, you must select the Select and Edit Select and edit object object mode. As soon as you have selected the object, the object frame appears with anchor points Anchor point.
SelectedObjetWithObjectFrame.PNG
You can now move, rotate, cut, stretch or reduce the size of the object. You find all functions in the Toolbars or in the Object Menu.

EditAndDrawingToolbar.png

EditFunctionsToolbar.png

For more and detailed information, please visit the Edit Object page.

Tips with Keyboard and Mouse

Please visit the Tips with Keyboard and Mouse page for more information.


Back to Main Page

Previous Chapter: Import Files

Next Chapter: Select