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About this Wiki

About this Wiki
This wiki will help familiarize you with the functions of OCAD.

How to Get to the OCAD Wiki
There are different ways to open the Wiki from OCAD:
• In the Help menu you can choose the following items:

• Contents: You will go to the Main Page of the OCAD Wiki.
• Menu: You will go to the Menu part of the Graphical User Interface page.
• Toolbar: You will go to the Toolbar part of the Graphical User Interface page.
• What's New: You will go to the What is New page.

• If you want to go directly to an article about a function, press the F1 key when you have selected the function
from the menu or toolbar.

• Many dialog boxes provide a Help button. Click it to go directly to the article for that function.

OCAD Learn Videos
OCAD offers you learn videos for various subjects on YouTube [1].

 Some videos are made with earlier versions of OCAD. Functions or dialog boxes may have changed. Look for
the OCAD Wiki article on the corresponding function to get help for the most recent version of OCAD.

Conventions
The following conventions are used in this Wiki:
• Bold: Menu commands, buttons, keyboard, dialog boxes
• Italics: Files
•• "Quotation marks": Input values, selection values
•  Hint
•  This function is available in OCAD Mapping Solution.
•  This function is available in OCAD Orienteering.
•  This function is available in OCAD Starter.
•  This function is available in OCAD Course Setting.
•  This function is available in OCAD Viewer.

https://www.ocad.com/wiki/ocad/en/index.php?title=Main_Page
https://www.ocad.com/wiki/ocad/en/index.php?title=Graphical_User_Interface%23Menu
https://www.ocad.com/wiki/ocad/en/index.php?title=Graphical_User_Interface%23Toolbars
https://www.ocad.com/wiki/ocad/en/index.php?title=What_is_New
https://www.youtube.com/user/ocadcom/playlists
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Mas40px.png
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Ori40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Sta40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:CS40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:View40px.PNG
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Terms/Glossary
The following terms from the disciplines of geospatial technology, computer science and cartography, are used in
this manual. An explanation of the most important terms is provided here to keep the explanations as short as
possible and avoid any possible misunderstanding.
• Vertex: Vertices are specified by a pair of coordinates (x/y values). Vertices are used to define the position of

points, lines and areas.
• Object: Each element on a map is referred to as an object (map object). There are point, line, area and text

objects.
• Point Object: The position of a point object on the map is defined by a single vertex. These points can be moved,

deleted or rotated. The vertex generally represents the center of the symbol.
• Line Object: A line object on the map is defined using a sequence of vertices. Individual vertices can be moved

or deleted and new ones added. The object can be disconnected, rotated, reshaped or merged with lines of the
same symbol. The vertices represent the center of the line. Line objects are directional.

• Area Object: An area object on the map is defined by a sequence of vertices. Individual vertices can be moved or
deleted and new ones added. The object can be stretched, reshaped, reduced, rotated or merged with other areas
with the same kind of symbol.

• Image Object: An image object is an imported vector graphic element. These are solely line and area objects.
Not all OCAD editing functions can be applied to image objects. An image object must be converted into an
object or assigned to a symbol before it can be edited. Image objects can be converted individually or
automatically based on a reference table.

• Graphic Object: A graphic object is an element created using the Convert To Graphic Object function. This
function is used to break an object down into its individual basic elements or to convert it into an outline.

• Layout Object: A layout object is on the layout layer at the top of the map. The layout layer may contain raster
images and vector objects like lines, areas or text. The vector layout objects color model is CMYK. The layout
images' color model is RGB.

• Symbol: Symbols are used to define a map object’s graphic appearance. For example, a tree may be represented
by a green circle on the map. Every map object drawn using the “tree” symbol will therefore have the same
graphic appearance. If the symbol is changed using the symbol editor, all map objects drawn using it also change.
OCAD provides four basic symbol types that correspond to the properties of their respective objects:
•• Point symbol
•• Line symbol
•• Area symbol
•• Text symbol

• Georeferencing: Georeferencing refers to the allocation of spatial reference information to the map so that its
content can be mapped to a geodetic reference system, i.e. augmented by geographic coordinates (geocoding).
OCAD supports more than 50 geographic coordinate systems. Information about the geographic coordinate
system appropriate for your application is available from national land surveying offices, cartographic institutes
or data suppliers.

• Vector Maps: Vector maps are made up of vectors (points, lines or area objects) defined by vertices. Raster maps
can be created using vector maps. OCAD maps are vector maps.

• Georeferenced Vector Maps: A georeferenced vector map refers to a vector map whose vectors have been
referenced using geographic coordinates (geocoded).

• Background Map: Background map refers to a raster map or OCAD file used as a background. It serves as a
drawing template or background map image. Examples include scanned draft maps, satellite pictures,
orthophotos, and shading. OCAD cannot be used to edit background maps.

https://www.ocad.com/wiki/ocad/en/index.php?title=Drawing_an_Object%23Draw_a_Point_Object
https://www.ocad.com/wiki/ocad/en/index.php?title=Drawing_an_Object%23Draw_a_Line_or_Area_Object
https://www.ocad.com/wiki/ocad/en/index.php?title=Drawing_an_Object%23Draw_a_Line_or_Area_Object
https://www.ocad.com/wiki/ocad/en/index.php?title=Image_Objects
https://www.ocad.com/wiki/ocad/en/index.php?title=Background_Map%23Open_a_Background_Map
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• Raster Map: A raster map (bitmap) is made up of a series of regularly spaced pixels positioned at right angles. In
OCAD, they can only be used as background maps. They can neither be edited nor converted into vector maps
using OCAD. OCAD supports the following raster map formats:
•• BMP - Bitmap
•• TIFF - Tagged Image File Format
•• JPG - Joint Photographic Experts Group
•• GIF - Graphics Interchange Format
•• PNG - Portable Network Graphics

• Georeferenced Raster Map: A georeferenced raster map refers to a raster map whose pixels have been
referenced using geographic coordinates (geocoded). Georeferencing information is usually stored in a “world
file”, a second file with the same name as the raster map file. The file extension is made up of three letters. The
first two letters refer to the raster map file format, the third letter for world file. The world file should be neither
renamed nor edited. With TIFF files, georeferencing information can be stored in the raster map file itself; a
world file is therefore not always required. OCAD supports the following world files and/or georeferenced raster
map file formats:
•• BPW -World file for a BMP file
•• TFW -World file for a TIFF file
•• JGW -World file for a JPG file
•• GFW -World file for a GIF file
•• PGW -World file for a PNG file

Contact
OCAD AG
Mühlegasse 36
CH-6340 Baar/Switzerland
Tel (+41) 41 763 18 60
Fax (+41) 41 763 18 64
info@ocad.com [2]

https:/ / www. ocad. com

Back to Main Page

References
[1] https:/ / www. youtube. com/ user/ ocadcom/ playlists
[2] mailto:info@ocad. com

mailto:info@ocad.com
https://www.ocad.com
https://www.ocad.com/wiki/ocad/en/index.php?title=Main_Page
https://www.youtube.com/user/ocadcom/playlists
mailto:info@ocad.com
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Installation and Activation

Installation

OCAD Installation
OCAD requires Windows 7 or Windows 8 or Windows 10 (32 or 64 bit).

1.1. Download the OCAD installation file from the download link you received by email. The installation wizard
starts after double-clicking the downloaded file.

2.2. The installation wizard will guide you through the OCAD installation.
3.3. The license name, the license number and license checksum are sent to you by email.
4.4. Please keep the email with the download link and license information!

https://www.ocad.com/wiki/ocad/en/index.php?title=File:Installation1.png
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Installation2.png
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https://www.ocad.com/wiki/ocad/en/index.php?title=File:Installation3.png
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Installation4.png
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https://www.ocad.com/wiki/ocad/en/index.php?title=File:Installation5.png
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Installation6.png
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https://www.ocad.com/wiki/ocad/en/index.php?title=File:Installation7.png
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Installation8.png
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https://www.ocad.com/wiki/ocad/en/index.php?title=File:Installation9.png
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Installation10.png
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Silent Installation
Please visit the Silent Installation page for further information.

Installation in the Cloud
OCAD runs as app on clouds like DropBox or OneDrive. Install your Team or Single User Licenses in the Cloud
and make updating and sharing of Team Licenses much easier.

OCAD Activation
Please visit the Activation page for further information.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:Installation11.png
https://www.ocad.com/wiki/ocad/en/index.php?title=Silent_Installation
https://www.ocad.com/wiki/ocad/en/index.php?title=Activation
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Activation/Reactivation

Activation
Before you can run OCAD you have to activate the software. While starting the software for the first time, the
Activation Wizard will start automatically and guide you through the activation procedure.
• OCAD for Teams can only be activated once.
• OCAD for Single Users can be activated automatically on 1 device (desktop or notebook). In order to allow the

use on several own devices at the same time (desktop, notebook, tablet) further activations for own devices can be
granted by OCAD on request. Contact OCAD Support [1].

Read more about activation in the Subscription Model [2] section in the FAQ on our webpage or in the License
Terms.
In case of purchasing a new PC or a total failure of your hard disk, please contact OCAD via the Transfer form [3]

for re-installation and re-activation.
In the License Transfer Utility you can transfer your license to another user. By doing so, the license on your
computer will be deactivated and you can activate the license again on another one.

Online Activation

https://www.ocad.com/en/#support
https://www.ocad.com/en/faq/#subscription
https://www.ocad.com/wiki/ocad/en/index.php?title=License_Terms
https://www.ocad.com/wiki/ocad/en/index.php?title=License_Terms
https://www.ocad.com/transfer/transferform.php
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Activation1.png
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 Activation can only be done online.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:Activation2.png
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Activation3online.png
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
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 If the error message Internal Error http.GetHttps.Url: .../testConnection.php appears while setting up
connection... then a firewall may blocks the connection.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:Activation4.png
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Activation5online.png
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Reactivation
If you start OCAD and have no Internet Connection, you will get a message.

License number: The number or your license.
Name: How the license is named.
Subscription start date: The date your Subscribtion has started.
Activation date: The date you have activated OCAD.
Last verification: The date your license was verified the last time.
Pending Verification: The date after that your license has to be verified within 30days.
Subscription end date: When your Subscription will end. After this date, OCAD will not run anymore.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:Activation6.png
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Reactivation.png
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Pending Verification
Due to the subscription model OCAD needs to check, if your license is valid. If you have no internet connection (e.g.
during fieldwork), this can't be done. That's why there is a Pending Verification date. After the Pending Verification
Date, you need to start OCAD once within 30 days with an internet connection, so OCAD can verify the license
again (will be done automatically at the startup). Then, the date for the Pending Verification will be shifted
backwards. If you do not verify the license again in these 30 days, you can't use OCAD anymore offline until you
reactivate OCAD online.

 The Pending Verification date can be seen under About OCAD in the Help menu.

References
[1] https:/ / www. ocad. com/ en/ #support
[2] https:/ / www. ocad. com/ en/ faq/ #subscription
[3] https:/ / www. ocad. com/ transfer/ transferform. php

OCAD as Cloudable App
OCAD runs as app on clouds like Dropbox or OneDrive. Install your Team or Single User Licenses in the Cloud.
See below how it works and what you gain.

OCAD Team User Licenses in the Cloud

Advantages
•• Only one installation, easier to update
•• Easier to transfer a Team license from one member to another one
•• Information about the free licenses when starting OCAD

https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
https://www.ocad.com/en/#support
https://www.ocad.com/en/faq/#subscription
https://www.ocad.com/transfer/transferform.php
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Example
•• Your club bought 5 OCAD Course Setting Team Licenses.
•• You get an email from OCAD with the license information and download links for all 5 licenses.

Installation
•• You install one OCAD Team license on your Dropbox. For that, you need to change the installation folder to your

Dropbox
during the installation.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:Cloud_SelectDestinationLocation.png
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Activation
• Start and activate your OCAD Team license using the Activation Wizard.
•• You are ready to use OCAD Course Setting.

Install Addition Licenses
• Open the License Manager in Help menu and click on Add additional Team licenses.
•• Paste the complete text with the license data of all 5 licenses from your order email here.

•• You will get a confirmation when the licenses have been added successfully.

 It is only possible to add licenses for the same OCAD edition. It is the Course Setting edition in your example.
Also, you need to run OCAD as administrator to be able to add the additional licenses.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:Cloud_AddAdditionalTeamLicenses.png
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Cloud_AddedTeamLicense.png
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
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Dropbox
•• Share OCAD Dropbox folder with other team members.

Start OCAD as a Team member
•• Go to the Dropbox folder and start OCAD. Multiple users can start OCAD the same time.
•• You see the information about the available and used license.
•• Choose an available license.

•• You do not need to install OCAD.
• If you have not activated the license before, you also need to follow the Activation Wizard.

•• If you choose a license, that you have activated before, you do not need to fill in all license information again.

Release a OCAD Team License
• When you or a Team member has finished the work, you need to close all ocd files first and open the Transfer

License Utility from the Help menu. There you can deactivate your license and release it for another team
member.

• The released license will be shown shown as Available in the Choose a License window.

How to update the license
•• When OCAD releases a new Service Update, you only need to update the installation in your Dropbox folder.

OCAD Single User Licenses in the Cloud
It also makes sense to install Single User Licenses in the Cloud. If you have several devices (e.g. Home PC, Laptop),
all Service Updated only need to be done once.
•• Install and activate OCAD the same way as described above.
•• You can not add additional licenses in the License Manager.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:Cloud_ChooseALicense.png
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OCAD on Mac OS X

OCAD is a Windows software.
However, running OCAD on an Intel-based Mac is possible in different ways. We tested it with a Virtual Machine (
VirtualBox [1]) and VMWare Fusion.

Virtual Machines
OCAD can be run perfectly within a virtual machine.

 OCAD runs also with Parallels Desktop for Mac. Please note that Windows needs 2 GB RAM or more that
OCAD works stable.

VMware Fusion
As in contrast to Virtual box VMWare Fusion [2] is not free but more stable. We have installed Windows 8.1 with
VMWare Fusion on Mac OS X 10.9. You can work with OCAD/Windows in the so called single Window Mode or
complete transparent in the Unity mode.

 VMWare Fusion is enough to use OCAD. OCAD does not need VMWare Fusion Pro.
Screenshots from the OCAD:
Single Window Mode

Unity Window Mode

https://www.ocad.com/wiki/ocad/en/index.php?title=File:AppleLogo.JPG
https://www.virtualbox.org
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
http://www.vmware.com/products/fusion
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=File:VMWare_MacOSX_SingleWindowMode.png
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Virtual Box
The advantage of VirtualBox [1] is that it is free. Well, at least the software is free but you will need a Windows
license in addition which can cause costs. To show how it looks like, we installed VirtualBox [1] on a MacBook Pro
with Mac OS X Mountain Lion and took some screenshots.
Installation:

Activation:

https://www.ocad.com/wiki/ocad/en/index.php?title=File:VMWare_MacOSX_UnityWindowMode.png
https://www.virtualbox.org
https://www.virtualbox.org
https://www.ocad.com/wiki/ocad/en/index.php?title=File:MacOSX1.PNG


OCAD on Mac OS X 20

Run OCAD in Seamless Mode:

Run OCAD in Scale Mode:

https://www.ocad.com/wiki/ocad/en/index.php?title=File:MacOSX3.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:MacOSX4.PNG
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Run OCAD in Fullscreen Mode:

VirtualBox can also be used with Linux and Solaris systems as a host.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:MacOSX5.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:MacOSX6.JPG
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Comparison Virtual Machines
Our exprience shows that VMWare Fusion is approx. 30-40% more performant than VirtualBox

Problems
At the moment, there are no OCAD problems known.

CrossOver
OCAD doesn't run on CrossOver [3].

BootCamp
OCAD can also be run on a Mac with help of BootCamp [4].

References
[1] https:/ / www. virtualbox. org
[2] http:/ / www. vmware. com/ products/ fusion
[3] https:/ / www. codeweavers. com/
[4] http:/ / www. apple. com/ support/ bootcamp

https://www.codeweavers.com/
http://www.apple.com/support/bootcamp
https://www.virtualbox.org
http://www.vmware.com/products/fusion
https://www.codeweavers.com/
http://www.apple.com/support/bootcamp
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Drawing in OCAD

Graphical User Interface

Toolbars
Toolbars can be moved within the graphical user interface. The buttons can be individually shown or hidden in the
GUI (Graphical User Interface) category of the OCAD Preferences which can be found in the Options menu.
Alternatively, click the small arrow at the end of each toolbar to adjust it.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:GUI.JPG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Toolbars.png
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Standard Toolbar

 New: Create a new map.
 Open: Open an existing map.
 Save: Save changes made to the map.
 Print: Print out the map.
 Undo: Undo previous actions.
 Redo: Cancel the previous undo action.

 Manage Background Maps: Manage the background maps.
 Symbol Status Manager: Manage the symbol status settings.

 Open Google Street View: Opens Google Street View in your web browser at the chosen position of the
map.

Edit Functions Toolbar

 Delete: Delete the selected object(s).
 Rotate (Enter Angle): Rotate selected object(s) by entering an angle.
 Align Objects: Horizonal Coordinates: Align objects at a horizontal coordinate.

 Align Objects: Horizontal Coordinate Centered: Align objects at horizontal centered coordinates.
 Align Objects: Vertical Coordinates: Align objects at a vertical coordinate.
 Distribute Objects: Horizontal Coordinate: Distributes the selected objects horizontal with equal space

between.
 Distribute Objects: Vertical Coordinate: Distributes the selected objects vertical with equal space

between.
 Crop Objects: Crop objects in a designated area (desired sector, hole, delete selected objects).

 Move/Duplicate Parallel by Specified Distance: Move/Duplicate an object by a speciefied distance and
direction.

 Interpolate Objects: Insert line or point objects regularly between existing objects.
 Duplicate Object: Create a copy of the selected objects.
 Fill or Make Border: Fill a line or area object an with area object, make a line border for an area object

or duplicate the object identically. Create a line text object on a selected line object.
 Merge: Merge multiple line, area and text objects with the same symbol.
 Reverse Object: Reverse the direction of the selected line object(s).
 Change to Polyline Convert the selected line or area object(s) into a polyline.
 Change To Bézier Curve: Convert the selected line or area object(s) drawn in freehand mode into Bezier

curves.
 Convert To Graphic Object: Convert the selected object(s) into their graphic elements (lines and areas).
 Smooth: Smooth line or area objects.
 Generalize Buildings: Simplify the building geometry or rectangle it.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:StandardToolbar.png
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_New.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=Create_a_New_Map%23Create_a_New_Map
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_Open.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File%23Open
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_Save.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File%23Save
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_Print.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_Undo.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_Redo.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_BackgroundMapManager.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=Background_Map%23Manage_Background_Maps
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_SymbolStatusManager.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_OpenGoogleStreetView.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:EditFunctionsToolbar.png
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_Delete.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=Object%23Delete
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_RotateEnterAngle.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=Edit_Object%23Rotate_an_Object_by_Angle
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_AlignObjectsHorizontal.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_AlignObjectsHorizontalCoordinateCentered.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_AlignObjectsVertical.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_DistributeObjectsHorizontalCoordinate.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_DistributeObjectsVerticalCoordinate.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_Crop.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_MoveDuplicatebySpecifiedDistance.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=Move_Parallel_and_Move_Duplicate_Parallel_by_Specified_Distance%23Move_Duplicate_Parallel_by_Specified_Distance
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_InterpolateObjects.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_DuplicateObject.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_FillOrMakeBorder.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=Edit_Object%23Fill_or_Make_Border_or_Duplicate_Identically
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_Merge.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=Edit_Object%23Merge
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_ReverseObject.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=Edit_Object%23Reverse_Object_Direction
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_ChangeToPolyline.png
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_ChangeToBezierCurve.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_ConvertToGraphicObject.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=Convert_to_Graphic_Object
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_Smooth.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_GeneralizeBuildings.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=Topology%23Generalize_Buildings
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 Snapping: Snap vertices automatically to other curves or points.
 Join: Move the ends of the selected line object to connect to adjoining objects.
 Change Symbol of Object: Assign the symbol selected in the symbol box to the selected object(s).
 Change Symbol For All Objects With This Symbol: Change the symbol of all objects with a symbol A

to symbol B.
 Measure: Measure the selected line or area object or the distance between 2 selected point objects.

 Object Information: Shows the object informations.

 Automatic Joining: Automatically join the ends of lines and areas during the drawing process.
 Select Duplicate Objects: Selects identical objects at the same position.
 Select Self-Intersected Objects: Selects all line, area and line text objects with a self-intersecting

geometry.

 Select Line Text Objects with Line too Short: Selects all line text objects whose text is longer than the
line length.

View Toolbar

Various functions are available for increasing or reducing the size of map view as well as repositioning it.

 Find Selected Objects: Move screen to the selected object.
 Pan: Reposition the map view

 Pan Locked: Reposition the map view a number of times in succession.
 Zoom In: Zoom in the map view to greater magnification.
 Zoom In Locked: Zoom in the map view a number of times in succession.
 Zoom Out: Zoom out the map view to lesser magnification.
 Zoom Out to Previous View: Zoom out to the last map view of lesser magnification.
 Zoom to Selected Objects: Zoom the view to the biggest possible view showing the selected objects.

 Show Entire Map: Display the entire map in the drawing window.
 Zoom to Previous View: Return to last map view.
 Zoom to Next View: Undo "Zoom to Previous View".
 Show Screen Grid: Display the coordinate grid in the drawing window.
 Show Rulers: Show rulers along the top and left side of the drawing area.
 Ruler Guides: Display all ruler guides in the drawing area.

 Draft Mode Slider: The upper slider (M for map) is used to fade out the map objects; the
lower slider (B for background) to fade out the Background Map. The Draft Mode Slider is only visible if
the Draft Mode is activated in the View menu.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_Snapping.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_Join.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=Topology%23Join
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_ChangeSymbolOfObject.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_ChangeSymbolForAllObjectsWithThisSymbol.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_Measure.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=Edit_Object%23Measure
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_ObjectInformation.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=Object%23Object_Information
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_AutomaticJoining.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=Topology%23Automatic_Joining
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_SelectDuplicateObjects.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=Select%23Select_Duplicate_Objects
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_SelectSelfIntersectedObjects.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=Select%23Select_Self_Intersected_Objects
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_SelectLineTextObjectswithLinetooShort.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=Select%23Select_Line_Text_Objects_with_Line_too_Short
https://www.ocad.com/wiki/ocad/en/index.php?title=File:ViewToolbar.png
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_FindSelectedObjects.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=View%23Find_Selected_Objects
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_Pan.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=View%23Pan
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_PanLocked.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=View%23Pan_Locked
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_ZoomIn.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=View%23Zoom_In
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_ZoomInLocked.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=View%23Zoom_In_Locked
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_ZoomOut.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=View%23Zoom_Out
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_ZoomOutToPreviousView.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=View%23Zoom_Out_to_Previous_View
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_ZoomtoSelectedObjects.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=View%23Zoom_to_Selected_Objects
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_ShowEntireMap.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=View%23Show_Entire_Map
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_ZoomToPreviousView.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=View%23Zoom_to_Previous_View
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_ZoomToNextView.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=View%23Zoom_to_Next_View
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_ShowGrid.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=View%23Show_Screen_Grid
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_ShowRulers.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_ShowRulerGuides.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:DraftMode.JPG
https://www.ocad.com/wiki/ocad/en/index.php?title=View_Mode%23Draft_Mode
https://www.ocad.com/wiki/ocad/en/index.php?title=View_Mode%23Draft_Mode
https://www.ocad.com/wiki/ocad/en/index.php?title=View_Mode%23Draft_Mode
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Editing and Drawing Toolbar

Edit modes

 Select and Edit Object: Select and move objects.
 Select Object and Edit Vertex: Select objects or move points of objects.
 Select Object with Lasso Tool: Select objects with a Lasso.

 Normal Vertex: Add a vertex. This will not influence a dashed line.
 Corner Vertex: Add a corner vertex or turn a normal vertex into a dash vertex. This will affect the dashed

line so that it will start with a full dash from this point, and/or the specific main symbol of a line will appear at
the corner vertex.

 Dash Vertex: Add a dash vertex or turn a normal vertex into a dash vertex. This will affect the dashed
line, which will start with half a dash from this point.

 Remove Vertex

 Indicate Direction of Area Pattern, Point or Text Object: Indicate the direction of an area pattern,
point or text object.

 Rotate Object: Rotate the selected object(s).
 Cut hole: Cut a hole into the selected area object.
 Cut area: Cut the selected area object.
 Cut: Cut the selected line object or the borderline of the selected double line or area.
 Move parallel: Move the selected line or area object parallel to the original object.
 Reshape: Redraw part of a line, area or text object.

Drawing modes

 Curve mode: Draw in curve mode.
 Ellipse mode: Draw elliptical (oval) objects.
 Circle mode: Draw circular objects.
 Rectangular line mode: Draw rectangular line objects with any number of corners.
 Rectangular mode: Draw rectangular area objects with any number of corners.

 Stairway drawing mode: Draw a rectangular stairway.
 Straight line mode: Draw objects with straight lines.
 Freehand mode: Draw objects in freehand mode.
 Drawing multiple point objects: Draw several point objects that are placed on a line with a constant

interval.
 Numeric Mode: Draw objects in numeric mode.
 Laser Rangefinder drawing mode: Draw objects by distances transmitted from a laser distance meter.

 Numeric Mode
Toolbar

https://www.ocad.com/wiki/ocad/en/index.php?title=File:EditAndDrawingToolbar.png
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_SelectAndEditObject.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=Select%23Select_and_Edit_Object
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_SelectObjectAndEditVertex.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=Select%23Select_Object_and_Edit_Vertex
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_SelectObjectWithLassoTool.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=Select%23Select_Object_with_Lasso_Tool
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_NormalVertex.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=Vertices%23Add_Normal_Vertex
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_CornerVertex.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=Vertices%23Add_Corner_Vertex
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_DashVertex.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=Vertices%23Add_Dash_Vertex
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_RemoveVertex.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=Vertices%23Remove_Vertex
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_IndicateDirectionOfAreaPatternPointOrTextObject.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=Edit_Object%23Indicate_Direction_of_Area_Pattern_or_Point_or_Text_Object
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_RotateObject.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=Edit_Object%23Rotate
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_CutHole.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=Cut%23Cut_Hole
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_CutArea.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=Cut%23Cut_Area
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_Cut.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=Cut%23Cut_Line
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_MoveParallel.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=Move_Parallel_and_Move_Duplicate_Parallel_by_Specified_Distance%23Move_Parallel
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_Reshape.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_CurveMode.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=Drawing_an_Object%23Draw_a_Curve
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_EllipseMode.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=Drawing_an_Object%23Draw_an_Elliptical_Object
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_CircleMode.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=Drawing_an_Object%23Draw_a_Circular_Object
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_RectangularLineMode.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=Drawing_an_Object%23Draw_a_Rectangular_Line
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_RectangularMode.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=Drawing_an_Object%23Draw_a_Rectangular_Area
https://www.ocad.com/wiki/ocad/en/index.php?title=File:DrawingModeStairway.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=Drawing_an_Object%23Draw_a_Stairway
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_StraightLineMode.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=Drawing_an_Object%23Draw_a_Straight_Line
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_FreehandMode.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=Drawing_an_Object%23Draw_a_Freehand_Line
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_DrawingMultiplePointObjects.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=Drawing_an_Object%23Draw_Multiple_Point_Objects
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_NumericMode.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=Drawing_an_Object%23Numerical_Drawing_Mode
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_LaserDistance.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:NumericToolbar.JPG
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Numeric Keypad Toolbar    

This toolbar can be used as an alternative to the numeric keypad. Some tablet PCs do not have a keyboard; Numeric
Toolbar can be used to enter numbers.

Mobile Toolbar    

This toolbar can be used as an alternative to the keyboard. Some tablet PCs do not have a keyboard with these
special keys; use the Mobile Toolbar to use these keys.

Customize Toolbar Dialog Box
Choose this command to customize toolbars. The dialog box is opened by clicking Customize in the GUI
(Graphical User Interface) page in OCAD Preferences dialog box (Menu Options) or by clicking on the right end
of a toolbar. When the box above the button is checked the button will be visible otherwise it will be hidden.

 The Numeric keypad toolbar cannot be customized.
 In Orienteering edtion some icons and checkboxes are disabled. That means that these functions are not in the

Orienteering edition.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:Space.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Mas40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Ori40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:NumericKeypadToolbar.png
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Space.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Mas40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Ori40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:MobileToolbar.png
https://www.ocad.com/wiki/ocad/en/index.php?title=File:CustomizeToolbars.png
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
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Menu
OCAD Mapping Solution Edition features the following menus:

• File: File management, file import and export functions, printing
• View: Functions for viewing the map
• Select: Functions for selecting an object or a vertex
• Object: Object editing functions
• Symbol: Functions for creating and editing symbols
• Map: Map editing functions
• Layout: Layout management functions
• Multiple Representation: Multiple representation management functions
• Database: Functions for connecting and editing databases
• Thematic Map: Create, modify and delete thematic maps
• Background Map: Functions for loading and managing background maps
• DEM: Functions for the import, export and processing of Digital Elevation Models
• GPS: Functions for connecting GPS devices or importing GPS data
• Options: Functions for customizing personal preferences
• Window: Functions for arranging the map window
• Help: OCAD Help

File Menu
New: Create a new map file.
New Map Wizard: Create a new map file with the wizard.
New Course Setting Project Wizard: Create a new course setting project.
Open: Open a map file.
Open Sample Map: Open a sample map file.
Close: Close the current map file.
Save: Save changes in the current map file.
Save As: Save the current map file under a new name.
Undo: Undo the last draw or edit operation.
Redo: Reverse the effect of the last Undo operation.
Print: Print a color map or color separations.
Import: Import a map file.
Export: Export the map in a different file format.
Export OCAD Internet Map: Export the map as an OCAD Internet Map.
Export Encrypted File: Export the map to encrypted OCAD file format.
Send File by Email: Send the map file by email.
Execute XML Script: Execute functions defined in a XML script file.
Create Backup: Make a backup copy of the current map file.
Restore Backup: Restore a map file saved with the Backup function.
Open Recently Exported Documents: Open one of the documents you have exported recently from the file
that you have open.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:Menu.JPG
https://www.ocad.com/wiki/ocad/en/index.php?title=File%23Open
https://www.ocad.com/wiki/ocad/en/index.php?title=File%23Open_Sample_Map
https://www.ocad.com/wiki/ocad/en/index.php?title=File%23Close
https://www.ocad.com/wiki/ocad/en/index.php?title=File%23Save
https://www.ocad.com/wiki/ocad/en/index.php?title=File%23Save_As
https://www.ocad.com/wiki/ocad/en/index.php?title=Export_Files%23Export_Encrypted_File
https://www.ocad.com/wiki/ocad/en/index.php?title=Create_Backup_and_Restore_Backup
https://www.ocad.com/wiki/ocad/en/index.php?title=Create_Backup_and_Restore_Backup
https://www.ocad.com/wiki/ocad/en/index.php?title=File%23Open_Recently_Exported_Documents
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Open Recently Used OCAD Files: Open one of the map files you have worked on recently.
Exit OCAD: Terminate OCAD.

View Menu
Normal Mode: Normal mode view.
Spot Color Mode: Spot color view.
Draft Mode: Draft mode view. The Background Map can be seen behind the map.
Draft Mode Only Background Map Favorites: Draft mode view. Only favorited Background Maps are
shown.
Keyline: Show objects as a rough sketch.
Hatch Areas: Display full areas as hatched areas on the screen.
Anti-Aliasing: Activate or disable Anti-Aliasing.
Line Objects Appearance as in OCAD 10: Shows line objects as in OCAD 10.
Redraw: Redraw the drawing area.
Pan: Move the view.
Move To: Move the view to a desired position.
Find Selected Objects: Move the view to selected objects in sequence.
Zoom In: Display the map with a higher magnification.
Zoom Out: Display the map with lesser magnification.
Zoom to Selected Objects: Display the map zoomed in to selected objects.
Show Entire Map: Display the entire map on the screen.
Zoom: Select the magnification in which the map is to be displayed.
User Defined: Set the view to a zoom factor defined in Preferences.
Bookmarks: Create and manage bookmarks.

- Create: Create a new bookmark
- Manage: Manage available bookmarks

Show Screen Grid: A screen grid is shown in the drawing area.
Show Rulers: Rulers are shown around the drawing area.
Ruler Guides: Manage ruler guides.

- Show: Show vertical or horizontal ruler guides.
- Manage: Add a new ruler guide.

https://www.ocad.com/wiki/ocad/en/index.php?title=File%23Open_Recently_Used_OCAD_Files
https://www.ocad.com/wiki/ocad/en/index.php?title=File%23Exit_OCAD
https://www.ocad.com/wiki/ocad/en/index.php?title=View_Mode%23Normal_Mode
https://www.ocad.com/wiki/ocad/en/index.php?title=View_Mode%23Spot_Color_Mode
https://www.ocad.com/wiki/ocad/en/index.php?title=View_Mode%23Draft_Mode
https://www.ocad.com/wiki/ocad/en/index.php?title=View_Mode%23Draft_Mode_Only_Background_Map_Favorites
https://www.ocad.com/wiki/ocad/en/index.php?title=View%23Line_Objects_Appearance_as_in_OCAD_10
https://www.ocad.com/wiki/ocad/en/index.php?title=View%23Redraw
https://www.ocad.com/wiki/ocad/en/index.php?title=View%23Pan
https://www.ocad.com/wiki/ocad/en/index.php?title=View%23Move_To
https://www.ocad.com/wiki/ocad/en/index.php?title=View%23Find_Selected_Objects
https://www.ocad.com/wiki/ocad/en/index.php?title=View%23Zoom_In
https://www.ocad.com/wiki/ocad/en/index.php?title=View%23Zoom_Out
https://www.ocad.com/wiki/ocad/en/index.php?title=View%23Zoom_to_Selected_Objects
https://www.ocad.com/wiki/ocad/en/index.php?title=View%23Show_Entire_Map
https://www.ocad.com/wiki/ocad/en/index.php?title=View%23Zoom
https://www.ocad.com/wiki/ocad/en/index.php?title=View%23User_Defined
https://www.ocad.com/wiki/ocad/en/index.php?title=View%23Bookmarks
https://www.ocad.com/wiki/ocad/en/index.php?title=Show_Screen_Grid
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Select Menu
Select and Edit Object: Select, move or stretch object(s).
Select Object and Edit Vertex: Select or move vertex of object(s).
Select Object with Lasso Tool: Select objects with a Lasso.
Select Objects by Symbol: Select all objects with a specified symbol or layer.
Select Objects by Property: Select all objects with same properties.
Select Objects by Date: Select objects by their creation or modification date.
Select Object by Object Index: Select the object with a given index.
Select Duplicate Objects: Select objects with identical coordinates.
Select Self-Intersected Objects

Select Objects with Invalid Geometry

Select Line Text Objects with Line too Short

Select Group: Select a group of objects.
Select All: Select all objects in map.
Clear Selection: Nothing is selected.
Invert Selection: Change current selection such that everything previously unselected will now be selected
and vice versa
Select Next Object: Selects the next obvious object.
Save Selection: Save current selection for later use.
Reload Selection: Reload saved selection.
Edit Selection: Manage saved selection.

Object Menu
Cut: Copy the selected object(s) to the clipboard and delete them in the current map.
Copy: Copy the selected object(s) to the clipboard.
Paste: Insert the object(s) in the clipboard into the current map.
Delete: Delete the selected object(s).
Rotate Object: Rotate object(s).

-Rotate: Rotate the selected object(s).
-Rotate Object by Angle: Rotate the selected point object(s) by specifying a rotation angle.

Align Objects: Align the selected objects horizontally or vertically.
-Horizontally

-Horizontally Centered

-Vertically

Distribute Objects: Distributes objects to equal spaces.
Indicate Direction of Area Pattern, Point or Text Object: Change direction of selected point object, area
pattern or text.
Cut Objects: Cut hole, area or line.

-Cut hole: Cut a hole in an object.
-Cut area: Divides an area.

https://www.ocad.com/wiki/ocad/en/index.php?title=Select%23Select_and_Edit_Object
https://www.ocad.com/wiki/ocad/en/index.php?title=Select%23Select_Object_and_Edit_Vertex
https://www.ocad.com/wiki/ocad/en/index.php?title=Select%23Select_Object_with_Lasso_Tool
https://www.ocad.com/wiki/ocad/en/index.php?title=Select%23Select_Objects_by_Symbol
https://www.ocad.com/wiki/ocad/en/index.php?title=Select%23Select_Objects_by_Property
https://www.ocad.com/wiki/ocad/en/index.php?title=Select%23Select_Objects_by_Date
https://www.ocad.com/wiki/ocad/en/index.php?title=Select%23Select_Object_by_Object_Index
https://www.ocad.com/wiki/ocad/en/index.php?title=Select%23Select_Duplicate_Objects
https://www.ocad.com/wiki/ocad/en/index.php?title=Select%23Select_Self-Intersected_Objects
https://www.ocad.com/wiki/ocad/en/index.php?title=Select%23Select_Objects_with_Invalid_Geometry
https://www.ocad.com/wiki/ocad/en/index.php?title=Select%23Select_Line_Text_Objects_with_Line_too_Short
https://www.ocad.com/wiki/ocad/en/index.php?title=Select%23Select_Group
https://www.ocad.com/wiki/ocad/en/index.php?title=Select%23Select_All
https://www.ocad.com/wiki/ocad/en/index.php?title=Select%23Clear_Selection
https://www.ocad.com/wiki/ocad/en/index.php?title=Select%23Invert_Selection
https://www.ocad.com/wiki/ocad/en/index.php?title=Select%23Select_Next_Object
https://www.ocad.com/wiki/ocad/en/index.php?title=Select%23Save_Selection
https://www.ocad.com/wiki/ocad/en/index.php?title=Select%23Reload_Selection
https://www.ocad.com/wiki/ocad/en/index.php?title=Select%23Edit_Selection
https://www.ocad.com/wiki/ocad/en/index.php?title=Object%23Cut
https://www.ocad.com/wiki/ocad/en/index.php?title=Object%23Copy
https://www.ocad.com/wiki/ocad/en/index.php?title=Object%23Paste
https://www.ocad.com/wiki/ocad/en/index.php?title=Object%23Delete
https://www.ocad.com/wiki/ocad/en/index.php?title=Edit_Object%23Rotate_Object
https://www.ocad.com/wiki/ocad/en/index.php?title=Edit_Object%23Rotate_an_Object
https://www.ocad.com/wiki/ocad/en/index.php?title=Edit_Object%23Rotate_an_Object_by_Angle
https://www.ocad.com/wiki/ocad/en/index.php?title=Edit_Object%23Align_Objects
https://www.ocad.com/wiki/ocad/en/index.php?title=Edit_Object%23Distribute_Objects
https://www.ocad.com/wiki/ocad/en/index.php?title=Edit_Object%23Indicate_Direction_of_Area_Pattern_or_Point_or_Text_Object
https://www.ocad.com/wiki/ocad/en/index.php?title=Edit_Object%23Cut_a_Hole_or_Area_or_Line
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-Cut line: Divides a line.
Crop Objects: Crop selected Object(s).
Move Parallel: Move the selected line or area object parallel from the original object.
Move Parallel with Distance: Move the selected line or area object parallel with a distance from the original
object.
Reshape: To shape a part of an object again or differently.
Interpolate Objects: Interpolate selected Objects to each other.
Duplicate: Duplicate (create a copy of) the selected object(s).
Move and Duplicate: Duplicate selected object and move it.
Mirror and Duplicate: Mirror selected object and duplicate it.
Fill, Make Border, Duplicate Identically: Fill a line or area object(s) with area object(s) or make line border
of area object(s).
Merge: Merge multiple line, area and text objects into one object.
Reverse Object Direction: Reverse the direction of the selected line object(s).
Change to Polyline: Change selected object to polyline.
Change to Bézier Curve: Change selected object to a Bézier curve.
Convert into Graphic Object: Convert the selected object(s) to their graphic elements (lines and areas).
Convert into Image Object: Convert the selected object(s) to their graphic elements (lines and areas) as
image objects.
Convert into Layout Object: Convert selected object to layout object.
Smooth: Smooth selected line or area object(s) drawn in freehand mode.
Create Color Gradient

Change Vertex Types to: Change vertex types for the selected object(s).
Change Symbol (Selected objects)

Change Symbol (All Objects with Corresponding Symbol)

Group

Ungroup

Find and Replace Text

Insert Glyphs: Insert special letters.
Measure: Measure the selected line or area object or the distance between 2 selected point objects
Change Creation Date: Change the creation date of the selected object(s).
Object Information: Show information about selected object(s).

https://www.ocad.com/wiki/ocad/en/index.php?title=Move_Parallel_and_Move_Parallel_with_Distance%23Move_Parallel
https://www.ocad.com/wiki/ocad/en/index.php?title=Move_Parallel_and_Move_Parallel_with_Distance%23Move_Parallel_with_Distance
https://www.ocad.com/wiki/ocad/en/index.php?title=Duplicate_and_Move_and_Duplicate%23Duplicate
https://www.ocad.com/wiki/ocad/en/index.php?title=Duplicate_and_Move_and_Duplicate%23Move_and_Duplicate
https://www.ocad.com/wiki/ocad/en/index.php?title=Edit_Object%23Fill_or_Make_Border_or_Duplicate_Identically
https://www.ocad.com/wiki/ocad/en/index.php?title=Edit_Object%23Merge
https://www.ocad.com/wiki/ocad/en/index.php?title=Edit_Object%23Reverse_Object_Direction
https://www.ocad.com/wiki/ocad/en/index.php?title=Change_to_Polyline_and_Change_to_Bezier_Curve%23Change_to_Polyline
https://www.ocad.com/wiki/ocad/en/index.php?title=Change_to_Polyline_and_Change_to_Bezier_Curve%23Change_to_Bezier_Curve
https://www.ocad.com/wiki/ocad/en/index.php?title=Edit_Object%23Change_Vertex_Types_to
https://www.ocad.com/wiki/ocad/en/index.php?title=Edit_Object%23Find_and_Replace_Text
https://www.ocad.com/wiki/ocad/en/index.php?title=Edit_Object%23Measure
https://www.ocad.com/wiki/ocad/en/index.php?title=Edit_Object%23Change_Creation_Date
https://www.ocad.com/wiki/ocad/en/index.php?title=Edit_Object%23Object_Information
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Topology Menu
Join: Move the ends of the selected line object to connect to adjoining objects.
Smooth: Smooth ‘dithered’ line or area objects.
Generalize Buildings: Simplify the buildings geometry.
Make Objects Rectangular: Make objects rectangular.
Close Area Objects

Change Area Objects to CCW

Lengthen Line Text Objects: Lengthen line text objects if the line is too short for the objects' text.
Remove Overshoots and Undershoots

Insert, Cut or Add at Intersections

Remove Duplicate Vertices From Selected Objects

Symbol Menu
New: Create a new symbol.
Edit: Define or redefine the selected symbol.
Icon: Draw or edit the symbol's icon, which appears in the symbol box.
Enlarge/Reduce: Enlarge or reduce the selected symbol or all symbols.
Copy: Copy the selected symbol to the clipboard.
Paste: Copy a symbol from the clipboard to the current map.
Delete: Delete the selected symbol.
Duplicate: Make a copy of the selected symbol.
Sort Symbol Box: Sort the symbols in the symbol box.

-By Symbol Number: Sort symbol in symbol box by symbol number.
-By Color: Sort symbol in symbol box by color.
-By Symbol Type: Sort symbol in symbol box by symbol type.
-By Status (Normal, Protect or Hide): Sort symbol in symbol box by status.
-Usage Frequency: Sort symbol in symbol box by Usage Frequency.

Select: Select certain symbols in the symbol box.
-Used: Select used symbols in symbol box.
-Unused: Select unused symbols in symbol box.
-Invert: Change current selection such that everything previously unselected will now be and vice
versa.
-All: Select all symbols in symbol box.
-By Symbol Number: Select Symbols by Symbol Number.
-By Symbol Type: Select Symbols by Symbol Type.
-By Status (Normal, Protected or Hidden): Select Symbols by Status.
-By Color: Select all Symbols with same color.
-By Font: Select all Sybmols with same font.

Replace:

-Font

https://www.ocad.com/wiki/ocad/en/index.php?title=Topology%23Join
https://www.ocad.com/wiki/ocad/en/index.php?title=Topology%23Smooth
https://www.ocad.com/wiki/ocad/en/index.php?title=Topology%23Generalize_Buildings
https://www.ocad.com/wiki/ocad/en/index.php?title=Topology%23Make_Objects_Rectangular
https://www.ocad.com/wiki/ocad/en/index.php?title=Topology%23Close_Area_Objects
https://www.ocad.com/wiki/ocad/en/index.php?title=Topology%23Change_Area_Objects_to_CCW
https://www.ocad.com/wiki/ocad/en/index.php?title=Topology%23Lengthen_Line_Text_Objects
https://www.ocad.com/wiki/ocad/en/index.php?title=Topology%23Remove_Overshoots_and_Undershoots
https://www.ocad.com/wiki/ocad/en/index.php?title=Topology%23Insert.2C_Cut_or_Add_at_Intersections
https://www.ocad.com/wiki/ocad/en/index.php?title=Topology%23Remove_Duplicate_Vertices_from_selected_Objects
https://www.ocad.com/wiki/ocad/en/index.php?title=Symbol%23New
https://www.ocad.com/wiki/ocad/en/index.php?title=Symbol%23Edit
https://www.ocad.com/wiki/ocad/en/index.php?title=Symbol%23Icon
https://www.ocad.com/wiki/ocad/en/index.php?title=Symbol%23Enlarge_Reduce
https://www.ocad.com/wiki/ocad/en/index.php?title=Symbol%23Copy
https://www.ocad.com/wiki/ocad/en/index.php?title=Symbol%23Paste
https://www.ocad.com/wiki/ocad/en/index.php?title=Symbol%23Delete
https://www.ocad.com/wiki/ocad/en/index.php?title=Symbol%23Duplicate
https://www.ocad.com/wiki/ocad/en/index.php?title=Symbol_Box%23Sort_Symbol_Box
https://www.ocad.com/wiki/ocad/en/index.php?title=Symbol_Box%23Select
https://www.ocad.com/wiki/ocad/en/index.php?title=Symbol%23Replace
https://www.ocad.com/wiki/ocad/en/index.php?title=Symbol%23Replace_Font_in_Symbols
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-Color

Normal (Visible and Selectable): Make objects with the selected symbol(s) appear normal.
Protect Objects: Make objects with the selected symbol(s) protected from editing.
Hide Objects: Objects with the selected symbol(s) do not appear.
Symbol Status Manager: Choose this command to save, load, export or import the status of your Symbol
box.
Show Objects without Symbols: Normal / Hide.
Show Graphic Objects: Normal / Hide.
Image Objects: Protected / Hidden

-Protected: Selected image objects that are visible but cannot be selected, edited, moved or deleted.
-Hidden: Selected image objects that are not visible .

Show Symbol Favorites: Display the symbol favorites in symbol box.
Add To Favorites: Add the selected symbol(s) to symbol favorites.
Remove From Favorites: Remove the selected symbol(s) from symbol favorites.
Show Symbol Tree: Display the symbol tree in symbol box.
Remove From Symbol Tree: Remove the selected symbol(s) from symbol tree.

Map Menu
Optimize/Repair: Remove empty space in the map file and repair damaged objects.
Set Scale and Coordinate System: Set map scale and define the coordinate system.
Change Scale: Change the scale of the map and enlarge/reduce the map according to the new scale.
Create Map Grid: Create grid lines on the map.
Create WGS84 Grid: Create a WGS84 grid on your current view.
Hide: Hide the map on the screen.
Transform: Adjust the map to the background map.

-Move: Move the entire map to a different location in the coordinate system.
-Stretch / Shrink: Stretch (enlarge or reduce) the entire map horizontally or vertically.
-Mirror: Mirror the entire map horizontally or vertically.
-Rotate Map: Rotate the entire map.
-Rotate Map to Magnetic North: Rotate the map to Magnetic North.
-Change Coordinate System: Change current coordinate system to another.
-Affine: Adjust the whole map on background map or on grid.
-Rubbersheeting: Adjust a part of the map on a georeferenced background map.
-Local Transformation: Local Transformation is an interactive tool to eliminate local distortions.
-Center map in Drawing Area

Convert Imported Layers to Symbols: Convert the layers of an imported *.dxf or *.ai file.
Convert Area or Line Objects to Point Objects: Convert area to point object(s).
Convert Text Objects to Point Objects: Convert text to point object(s).
Convert Text Objects from OEM to Unicode: Convert text objects from OEM to Unicode.
Export Objects by Selected Symbol: Export all objects with a selected symbol to a new map file.

https://www.ocad.com/wiki/ocad/en/index.php?title=Symbol%23Replace_Color_in_Symbols
https://www.ocad.com/wiki/ocad/en/index.php?title=Symbol%23Normal
https://www.ocad.com/wiki/ocad/en/index.php?title=Symbol%23Protect
https://www.ocad.com/wiki/ocad/en/index.php?title=Symbol%23Hide
https://www.ocad.com/wiki/ocad/en/index.php?title=Symbol%23Show_Objects_without_Symbols
https://www.ocad.com/wiki/ocad/en/index.php?title=Symbol%23Show_Graphic_Objects
https://www.ocad.com/wiki/ocad/en/index.php?title=Symbol%23Image_Objects
https://www.ocad.com/wiki/ocad/en/index.php?title=Symbol_Box%23Show_Symbol_Favorites
https://www.ocad.com/wiki/ocad/en/index.php?title=Symbol_Box%23Add_to_Symbol_Favorites
https://www.ocad.com/wiki/ocad/en/index.php?title=Symbol_Box%23Remove_from_Symbol_Favorites
https://www.ocad.com/wiki/ocad/en/index.php?title=Symbol_Box%23Show_Symbol_Tree
https://www.ocad.com/wiki/ocad/en/index.php?title=Symbol_Box%23Remove_from_Symbol_Tree
https://www.ocad.com/wiki/ocad/en/index.php?title=Map%23Optimize_and_Repair
https://www.ocad.com/wiki/ocad/en/index.php?title=Map%23Set_Scale_and_Coordinate_System
https://www.ocad.com/wiki/ocad/en/index.php?title=Map%23Change_Scale
https://www.ocad.com/wiki/ocad/en/index.php?title=Map%23Create_Map_Grid
https://www.ocad.com/wiki/ocad/en/index.php?title=Create_WGS84_Grid
https://www.ocad.com/wiki/ocad/en/index.php?title=Map%23Hide
https://www.ocad.com/wiki/ocad/en/index.php?title=Map_Transform%23Move
https://www.ocad.com/wiki/ocad/en/index.php?title=Map_Transform%23Stretch_or_Shrink
https://www.ocad.com/wiki/ocad/en/index.php?title=Map_Transform%23Mirror
https://www.ocad.com/wiki/ocad/en/index.php?title=Map_Transform%23Rotate_Map
https://www.ocad.com/wiki/ocad/en/index.php?title=Map_Transform%23Rotate_Map_to_Magnetic_North
https://www.ocad.com/wiki/ocad/en/index.php?title=Map_Transform%23Change_Coordinate_System
https://www.ocad.com/wiki/ocad/en/index.php?title=Map_Transform%23Affine
https://www.ocad.com/wiki/ocad/en/index.php?title=Map_Transform%23Rubbersheeting
https://www.ocad.com/wiki/ocad/en/index.php?title=Map_Transform%23Local_Transformation
https://www.ocad.com/wiki/ocad/en/index.php?title=Map_Transform%23Center_Map_in_Drawing_Area
https://www.ocad.com/wiki/ocad/en/index.php?title=Map%23Convert_Imported_Layers_to_Symbols
https://www.ocad.com/wiki/ocad/en/index.php?title=Map%23Convert_Area_or_Line_Objects_to_Point_Objects
https://www.ocad.com/wiki/ocad/en/index.php?title=Map%23Convert_Text_Objects_to_Point_Objects
https://www.ocad.com/wiki/ocad/en/index.php?title=Map%23Convert_Text_Objects_from_OEM_to_Unicode
https://www.ocad.com/wiki/ocad/en/index.php?title=Map%23Export_Objects_by_Selected_Symbols
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Export Selected Objects

Delete Objects by Selected Symbols

Export Part of Map With this function you can export a part of the current map to a new OCAD-File.
Colors: Define or edit the colors of the current map.
Define Spot Colors: Define the spot colors of the current map.
Load Colors From: Load a color table from another map.
Load Colors and Symbols From: Load the symbol set from another map.
Compare Symbols and Colours: Compare two symbol sets.
Load Symbol Descriptions From

Save Symbol Descriptions To

Symbol Set Report creates an Excel-file with a detailed description of all symbols in your file.
Symbol Set Conversion

Renumber Symbols and objects with a crt file.
Check Legibility: Check minimum distances between objects, minimum length of line objects or minimum
size of area objects according to ISOM 2017.
Routing: Import kml file with route from Google Maps API.
Map Information: Show map information.

Layout Menu
Edit Layout Objects: Draw and edit the layout objects.
Import Layout

Save Layout

Delete Layout

Hide

Add North Arrow or Scale Bar

Add Map Legend

Add Trim and Bleed Marks

Create Graticule Name Index

Create Name Index

Multiple Representation Menu
Manager: The multiple representation manager serves for the activation and management of the
representations.
Disable Multiple Representation: Disable multiple representation and the contents of the representations get
lost.

Database Menu
Manage Database Connections: Create and edit datasets.
Create and Update Databse Records: Create OCAD objects out of the database.
Update Special Fields from Database Records

Create Objects from Database Records: Create OCAD objects from database records.

https://www.ocad.com/wiki/ocad/en/index.php?title=Map%23Export_Selected_Objects
https://www.ocad.com/wiki/ocad/en/index.php?title=Map%23Delete_Objects_by_Selected_Symbols
https://www.ocad.com/wiki/ocad/en/index.php?title=Map%23Export_Part_of_Map
https://www.ocad.com/wiki/ocad/en/index.php?title=Colors%23Spot_Colors
https://www.ocad.com/wiki/ocad/en/index.php?title=Colors%23Load_Colors_From
https://www.ocad.com/wiki/ocad/en/index.php?title=Colors%23Load_Colors_and_Symbols_From
https://www.ocad.com/wiki/ocad/en/index.php?title=Map%23Compare_Symbols_and_Colors
https://www.ocad.com/wiki/ocad/en/index.php?title=Map%23Load_Symbol_Descriptions_From
https://www.ocad.com/wiki/ocad/en/index.php?title=Map%23Save_Symbol_Descriptions_To
https://www.ocad.com/wiki/ocad/en/index.php?title=Map%23Symbol_Set_Report
https://www.ocad.com/wiki/ocad/en/index.php?title=Map%23Renumber_Symbols
https://www.ocad.com/wiki/ocad/en/index.php?title=Map%23Check_Legibility
https://www.ocad.com/wiki/ocad/en/index.php?title=Map%23Map_Information
https://www.ocad.com/wiki/ocad/en/index.php?title=Layout%23Edit_Layout_Objects
https://www.ocad.com/wiki/ocad/en/index.php?title=Layout%23Import_Layout
https://www.ocad.com/wiki/ocad/en/index.php?title=Layout%23Save_Layout
https://www.ocad.com/wiki/ocad/en/index.php?title=Layout%23Delete_Layout
https://www.ocad.com/wiki/ocad/en/index.php?title=Layout%23Hide
https://www.ocad.com/wiki/ocad/en/index.php?title=Layout%23Add_North_Arrow_or_Scale_Bar
https://www.ocad.com/wiki/ocad/en/index.php?title=Layout%23Add_Map_Legend
https://www.ocad.com/wiki/ocad/en/index.php?title=Layout%23Add_Trim_and_Bleed_Marks
https://www.ocad.com/wiki/ocad/en/index.php?title=Layout%23Create_Graticule_Name_Index
https://www.ocad.com/wiki/ocad/en/index.php?title=Layout%23Create_Name_Index
https://www.ocad.com/wiki/ocad/en/index.php?title=Multiple_Representation%23Multiple_Representation_Manager
https://www.ocad.com/wiki/ocad/en/index.php?title=Multiple_Representation%23Disable_multiple_representation
https://www.ocad.com/wiki/ocad/en/index.php?title=Database%23Manage_Database_Connections
https://www.ocad.com/wiki/ocad/en/index.php?title=Database%23Create_and_Update_Database_Records
https://www.ocad.com/wiki/ocad/en/index.php?title=Database%23Update_Special_Fields_from_Database_Records
https://www.ocad.com/wiki/ocad/en/index.php?title=Database%23Create_Objects_from_Database_Records
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Assign Symbols from Database Records: With this command you can use the information in the database
table to assign OCAD symbols to the objects.
Add Texts from Records With this function it is possible to add a text which is written in a field of a record
to an OCAD object.
Set Object Directions by Records: Assign angle information from the open dataset(s) to the objects.
Merge Objects from Database Records With this function, objects with the same value on a specified
database field are merged.
Select Objects with Good Database Record Links

Select Objects with Broken Database Record Links

Select Objects without Database Record Link from Selected Symbbols

Select Objects Linked to the same Database Records

Delete Database Records without Linked Object: Use this function to delete unused database records for
example after using the Part of Map function.
Options

-Create Database Record when Cutting Object

-Delete Database Record when Deleting Object: If the option is turned on and an OCAD object with a
linked database record is deleted, the database record is deleted, too.

Database Information Allows you to see all the information about each dataset.

Thematic Map Menu
Create a Thematic Map with Wizard

Delete Themes

Background Map Menu
Scan: Scan a background map using a TWAIN interface.
Open: Open a scanned background map stored in a file.
Adjust: Adjust the background maps in horizontal and vertical directions.
Hide All: Hide the background maps temporarily.
Manage: Set options for displaying and printing the background maps.
WMS - Web Map Service: Add background map from WMS
Online Map Services: Choose this command from the Background Map menu to load temporary a screenshot
from Google Maps as background map.

https://www.ocad.com/wiki/ocad/en/index.php?title=Database%23Assign_Symbols_from_Database_Records
https://www.ocad.com/wiki/ocad/en/index.php?title=Database%23Add_Texts_from_Database_Records
https://www.ocad.com/wiki/ocad/en/index.php?title=Database%23Set_Object_Direction_from_Database_Records
https://www.ocad.com/wiki/ocad/en/index.php?title=Database%23Merge_Objects_from_Database_Records
https://www.ocad.com/wiki/ocad/en/index.php?title=Database%23Select_Objects_with_Good_Database_Record_Links
https://www.ocad.com/wiki/ocad/en/index.php?title=Database%23Select_Objects_with_Broken_Database_Record_Links
https://www.ocad.com/wiki/ocad/en/index.php?title=Database%23Select_Objects_without_Database_Record_Link_from_Selected_Symbols
https://www.ocad.com/wiki/ocad/en/index.php?title=Database%23Select_Objects_Linked_to_the_same_Database_Records
https://www.ocad.com/wiki/ocad/en/index.php?title=Database%23Delete_Database_Records_without_Linked_Object
https://www.ocad.com/wiki/ocad/en/index.php?title=Database%23Options
https://www.ocad.com/wiki/ocad/en/index.php?title=Database%23Create_Database_Record_when_Cutting_Object
https://www.ocad.com/wiki/ocad/en/index.php?title=Database%23Delete_Database_Record_when_Deleting_Object
https://www.ocad.com/wiki/ocad/en/index.php?title=Database%23Database_Information
https://www.ocad.com/wiki/ocad/en/index.php?title=Thematic_Map%23Create_a_Thematic_Map
https://www.ocad.com/wiki/ocad/en/index.php?title=Background_Map%23Scanning_a_Background_Map
https://www.ocad.com/wiki/ocad/en/index.php?title=Background_Map%23Open_a_Background_Map
https://www.ocad.com/wiki/ocad/en/index.php?title=Background_Map%23Adjust_a_Background_Map
https://www.ocad.com/wiki/ocad/en/index.php?title=Background_Map%23Hide_all_Background_Maps
https://www.ocad.com/wiki/ocad/en/index.php?title=Background_Map%23Manage_Background_Maps
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DEM Menu
DEM Import Wizzard: With this DEM Import Wizard you can import DEM data and create several output
formats.
Open: Open an OCAD DEM file (*ocdDem).
Show Frame: Shows blue rectangle with the extent of loaded DEM.
Resize: Resize OCAD DEM file (make a subset) and save it as a new OCAD DEM file.
Info: Shows information about OCAD DEM file.
Close: Close OCAD DEM file.
Merge DEM: Merges two parts of a DEM together.
Calculate DEM Difference Calculates the difference between a surface and a terrain model.
Create Contour Lines: Calculates contour lines based on the loaded DEM.
Create Hypsometric Map: Calculates a grayscale or colored hypsometric map
Create Hill Shading: Calculates a shaded relief picture.
Calculate Slope Gradient Calculates a grayscale picture with slope gradient.
Classify Vegetation Height Calculates picture with vegetation height classes.
Merge Contour Lines By Selected Symbols This is an obsolete function. It is still in the latest OCAD version
due to compability issues. OCAD merges the contour lines automatically.
Create Profile: Creates a profile for the selected line object.
Export: Save loaded OCAD DEM file as ESRI ASCII Grid or as ASCII Grid XYZ.
Lidar Point Cloud Manager: The LiDAR Point Cloud Manager analyzes the vegetation within the forest and
creates a vegetation raster map.

-Load:This function loads an OCAD LAS file (*.ocdLas) and opens the LiDAR Point Cloud Manager.
-Info: This function shows information about the ocdLas file.
-Show Frame: This function shows a red rectangle with the extent of the loaded ocdLas file.
-Close: This function closes ocdLas file.
-Manage: This function reopens the LiDAR Point Cloud Manager with the already loaded ocdLas file.

GPS Menu
Real Time GPS

Import Data from GPS Device

Import from File

Connect to Laser Rangefinder

Options Menu
OCAD Preferences: Options for your individual working methods.
Shortcuts: Define or change keyboard shortcuts for menu commands.
Backup and Restore Options Choose this command to save or restore the OCAD Options.
Language: Choose a language.

https://www.ocad.com/wiki/ocad/en/index.php?title=DEM%23Open
https://www.ocad.com/wiki/ocad/en/index.php?title=DEM%23Show_Frame
https://www.ocad.com/wiki/ocad/en/index.php?title=DEM%23Resize
https://www.ocad.com/wiki/ocad/en/index.php?title=DEM%23Info
https://www.ocad.com/wiki/ocad/en/index.php?title=DEM%23Close
https://www.ocad.com/wiki/ocad/en/index.php?title=DEM%23Merge_DEM
https://www.ocad.com/wiki/ocad/en/index.php?title=DEM%23Calculate_DEM_Difference
https://www.ocad.com/wiki/ocad/en/index.php?title=DEM%23Create_Contour_Lines
https://www.ocad.com/wiki/ocad/en/index.php?title=DEM%23Create_Hypsometric_Map
https://www.ocad.com/wiki/ocad/en/index.php?title=DEM%23Create_Hill_Shading
https://www.ocad.com/wiki/ocad/en/index.php?title=DEM%23Calculate_Slope_Gradient
https://www.ocad.com/wiki/ocad/en/index.php?title=DEM%23Classify_Vegetation_Height
https://www.ocad.com/wiki/ocad/en/index.php?title=DEM%23Merge_Contour_Lines_By_Selected_Symbols
https://www.ocad.com/wiki/ocad/en/index.php?title=DEM%23Create_Profile
https://www.ocad.com/wiki/ocad/en/index.php?title=DEM%23Export
https://www.ocad.com/wiki/ocad/en/index.php?title=LiDAR_Point_Cloud_Manager%23Load
https://www.ocad.com/wiki/ocad/en/index.php?title=LiDAR_Point_Cloud_Manager%23Info
https://www.ocad.com/wiki/ocad/en/index.php?title=LiDAR_Point_Cloud_Manager%23Show_Frame
https://www.ocad.com/wiki/ocad/en/index.php?title=LiDAR_Point_Cloud_Manager%23Close
https://www.ocad.com/wiki/ocad/en/index.php?title=LiDAR_Point_Cloud_Manager%23Manage
https://www.ocad.com/wiki/ocad/en/index.php?title=GPS%23Real_Time_GPS
https://www.ocad.com/wiki/ocad/en/index.php?title=GPS%23Import_Data_from_GPS_Device
https://www.ocad.com/wiki/ocad/en/index.php?title=GPS%23Import_from_File
https://www.ocad.com/wiki/ocad/en/index.php?title=Options%23Shortcuts
https://www.ocad.com/wiki/ocad/en/index.php?title=Options%23Backup_and_Restore_Options
https://www.ocad.com/wiki/ocad/en/index.php?title=Options%23Language


Graphical User Interface 37

Window Menu
Tile: Arrange all open maps horizontally or vertically on the screen.
Cascade: Arrange all open maps in a way that the title of each map is visible.

Help Menu
Contents: The contents of this help file.
Menu: Help for menu commands.
Toolbar: Help for toolbar buttons.
Tutorials: Link to the OCAD Tutorials.
What is New: Click on this menu item to open the What is New page.
OCAD Home page [1]: Connect to the OCAD homepage on the Internet.
OCAD Service Update: Download the current Service Update from the OCAD website.
OCAD Youtube Channel [2]: OCAD Youtube Channel
Getting Started with OCAD: Open the pdf file 'Getting Started with OCAD'. For different languages see
here [3] .
OCAD Blog [4]: Show the newest posts from OCAD Blog.
License Transfer Utility: Deactivate this license and transfer it to a new user.
License Manager: Overview about the licenses from your organization.
About OCAD: General Information about OCAD.

Using the Keyboard with the Mouse
You find an overview of options for using the keyboard and the mouse together on the Tips with Keyboard and
Mouse page.

Status Bar
In the Status Bar at the bottom of the window you can find useful information:

 Currently
Selected Object: The symbol number and the name of the currently selected symbol is displayed in this part. If
multiple objects are selected, the number of selected objects is shown. In addition, if you retrieve a Bookmark, the
saved comment is displayed here.

 If the selected object is an area object or line object, it's length (paper and real-world) will be shown as well.
Coordinates from Mouse: The coordinates of the current position of the mouse pointer is displayed in this part. You
can change the format of the coordinates shown here in the Graphical User Interface category of OCAD
Preferences in the Options menu. If a DEM is loaded, the elevation in meters is given in brackets after the
coordinates.
Mode: The current View Mode is displayed in this part of the status bar. The view mode can be changed either here
or in the View menu.
Current Zoom Factor: This field shows the current Zoom Factor.

Visibility:  
There are seven eye icons which indicate wheter a certain map feature is visible or not. These features are (from left 
to right): Layout, Map, Background Map, Symbols, Unsymbolized Objects, Graphic Objects and Image Objects.
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If the eye icon is black, the feature is visible. 
If the eye icon is grey, no corresponding features exist. 
If the eye icon is crossed off with a red cross, the feature is not visible. 
If the eye icon is crossed off with an orange cross, the feature is only partially visible.
Currently Selected Symbol: The currently selected symbol is shown in this part of the status bar.

Docking    
It is possible to dock/undock some panels, which where located on the right side.

Back to Main Page

References
[1] https:/ / www. ocad. com/ en/
[2] https:/ / www. youtube. com/ user/ ocadcom/
[3] https:/ / www. ocad. com/ en/ getting-started/
[4] https:/ / ocad. com/ blog/

Drawing an Object

Draw a Point Object      
1.1. Choose a point symbol.
2.2. Select any drawing mode. The cursor appears as a crosshair with a point in the lower right-hand corner.
3.3. Click a position in the drawing window.
4.4. The point object appears.

 -To define a specific direction of for the object, click and hold the left mouse button on desired position;
then drag to the direction you wish the object to be oriented to.

-The object can be adjusted retrospectively. To do this, select the point object and align it using the
Indicate direction of area pattern, point or text object function.
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Draw a Line or Area Object      
You must select one of the eight drawing modes to draw a line or area object.
•• The cursor appears as a crosshair with the symbol for the selected drawing mode in the lower right-hand corner.
•• In the lower left-hand corner will be shown the total line length.

 If you draw an area the finishing line is shown dashed, whilst the left mouse button is pressed.

Draw a Straight Line      

1. To draw straight lines such as streets, power lines or sidewalks, select Straight line mode.
2.2. Select a line or area symbol from the symbol box.
3. Select Straight line mode.
4.4. Position the cursor at the point where you want to start the line, then click and hold the left mouse button and

drag the cursor in the desired direction. The help line provides a preview of the line that has just been drawn.
5.5. To add a vertex to the straight line, release the left mouse button. Now press and hold the left mouse button once

more and drag the cursor in the desired direction. Repeat this process as often as necessary.
6.6. Click the left mouse button when you have finished drawing and the help line is transformed into the selected line

or area symbol.

Draw a Curve      

Select Bézier Curve mode to draw flowing or curved lines such as contours or shore lines. Drawing Bézier Curves
requires some practice as you need to get a feeling for where the radius or curvature of a flowing or curved line
changes. The turning point is where the vertex and its tangents need setting. Once you have mastered this technique,
you will be able to draw curved lines and area objects efficiently and precisely.
Beside the Bézier Curve mode, you can change in the OCAD Preferences to the Adobe Illustrator mode.

 Download this exercise [1] to draw Bézier curves.

1.1. Select a line or area symbol from the symbol box.
2. Select Bézier-Curve mode.
3.3. Position the cursor at the point where you want to start the line, click and hold the left mouse button and drag the

cursor to form the radius you want and release the left mouse button.
4.4. Position the cursor at the next inflection, click and hold the left mouse button and drag the cursor to form the

radius you want and release the left mouse button. The help line provides a preview of the curved line that has just
been drawn. Repeat this process for each inflection point.
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5.5. Click the left mouse button when you have finished drawing and the help line is transformed into the selected line
or area symbol.

 -If you are unhappy with the tangent, simply click the Backspace  button. The last tangent will be
deleted and you can try again. You can delete as many tangents as you like up to the beginning of the line.
This is not possible once the object has been completed.

-Sinuous lines can be managed easily by placing tangents at the outermost points.

 You can force a corner vertex by dragging two tangents from the same vertex point. Curve: Tangents 2
and 3 start at the same point but move in different directions. A corner vertex is created.
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Change Drawing Mode

You can draw parts of a line or area object using different drawing modes. Select the appropriate symbol and draw
the first part of your object using a drawing mode. Now press the Tab button until the desired drawing mode
appears and then continue drawing.
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Continuing existing objects

You can lengthen existing line objects or expand area objects. Simply select the appropriate symbol, press and hold
the Shift  button and start drawing at the beginning or end of the existing object. Release the Shift  button
once the line or area has been added.

This can be used instead of the  Merge function.
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Draw Horizontal Lines

To draw horizontal or vertical lines, press and hold the Alt button. The line snaps in a vertical or horizontal direction.
This can be useful when drawing a border or north lines.
The Shift  and Alt button functions can be combined.

Change to Straight Line Mode

This function makes it easier to combine curves and straight lines.
First activate this option Curve mode: Change to straight line mode when clicking in drawing area in the
Preferences -> Drawing and Editing tab.
Start drawing the curve. To draw a straight line click in the drawing area and release the left mouse button. So you
can easy switch between straight line mode and curve mode. Double click the left mouse button to finish drawing.
To finish the object with the right mouse button change the corresponding setting in Right click in drawing area
opens context menu

Draw a Freehand Line     

Freehand drawing mode plots the movement of the cursor and converts it into a line. Tracing flowing or curved lines
using this mode is not very efficient or precise. Depending on the drawing speed and selected smoothing factor (1, 2
or 3), the line may appear somewhat angular because the vertices are connected using straight lines.
1.1. Select a line or area symbol from the symbol box.
2. Select Freehand mode.
3.3. Position the cursor at the beginning of the line, press the left mouse button briefly and trace the line you want

using the mouse.
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4.4. Click the left mouse button when you have finished drawing and the help line is transformed into the selected line
or area symbol.

If you draw in freehand mode the same way as in straight mode, normal points will be placed at the corners. Unlike
corner points, normal points do not affect dashed lines.

Draw a Rectangular Area     

Select Rectangular mode if you want to draw rectangular areas or objects such as buildings or squares. This
drawing mode creates a right-angle in every corner and ensures the start and end points of the outline are identical.
1.1. Select a line or area symbol from the symbol box.
2. Select Rectangular mode.
3.3. Position the cursor on one of the corners of the longest side of the rectangular area. Press and hold the left mouse

button and drag the cursor along the longest side to the next corner.
4.4. When the cursor reaches the corner, release the left mouse button and then press it again. Hold the left mouse

button and drag the cursor towards the next corner. The help line provides you with a preview of the straight line
that has just been drawn. A broken line shows you what the rectangular object will look like when you have
finished. Repeat the above process to draw a line to the third corner.

5.5. Click the left mouse button to finish the drawing; the help line is then transformed into the selected line or area
symbol.

You should always draw the longest side of a rectangular area first since it is easier to define the rectangular
orientation of an area from the longer side.

Draw a Rectangular Line    

Select Rectangular line mode if you want to draw rectangular line objects such as sidewalks or stairs. This drawing
mode creates a right-angle in every corner. The only difference between Rectangular line mode and Rectangular
mode is that the start and end points are not identical when using rectangular line mode.
1.1. Select a line symbol from the symbol box.
2. Select Rectangular line mode.
3.3. Position the cursor at the beginning of the rectangular line. Press and hold the left mouse button and drag the

cursor along the longest side to the next corner.
4.4. When the cursor reaches the corner, release the left mouse button and then press it again. Hold the left mouse

button and drag the cursor towards the next corner. The help line provides a preview of the line that has just been
drawn. Repeat this process until you reach the end of the rectangular line.

5.5. Click the left mouse button when you have finished drawing and the help line is then transformed into the
selected line symbol.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:Space.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Mas40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Ori40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Sta40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_RectangularMode.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:DrawARectangularAreaOrLine.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Space.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Mas40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Ori40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_RectangularLineMode.PNG


Drawing an Object 45

You should always draw the longest side of a rectangular line first since it is easier to define the rectangular
orientation of a line from the longer side.

Draw a Stairway    

Select Stairway drawing mode if you want to draw a rectangular stairway.
1.1. Select a line symbol from the symbol box.
2. Select Stairway mode.
3.3. Position the cursor at the beginning of the stairway. Press and hold the left mouse button and drag the cursor

along the longest side to the next corner.
4.4. When the cursor reaches the corner, release the left mouse button and then press it again. Hold the left mouse

button and drag the cursor towards the next corner. The help line provides a preview of the line that has just been
drawn.

5.5. Hold the left mouse button and drag the cursor to the first step. The step help lines provide a preview of the
stairway. Release the left mouse button.
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Draw a Circular Object     

Select Circle mode if you want to draw circular objects such as roundabouts or silos.
1.1. Select a line or area symbol from the symbol box.
2. Select Circle mode.
3.3. Position the cursor at the edge of the object, then press and hold the left mouse button and drag the cursor to the

opposite edge. Release the mouse button. The help line is transformed into the selected line or area symbol.

 -The outline or circular line is drawn as a Bézier curve.

-You can also drag the circle from the center point. Simply press and hold the Shift  button and drag
a radius.
-Clicking the center of the circle with the right mouse button without dragging displays the Draw Circle
dialog box. Here you can enter the radius of the circle in mm or m.

Draw an Elliptical Object     

Select Ellipse mode if you want to draw oval objects such as hills or dips.
1.1. Select a line or area symbol from the symbol box.
2. Select Ellipse mode.
3.3. Position the cursor at the beginning of the longer ellipse axis, then press and hold the left mouse button and drag

the cursor towards the end of the axis.
4.4. Position the cursor at the beginning of the shorter ellipse axis, then press and hold the left mouse button and drag

the cursor towards the end of the axis. Release the mouse button. The help line is transformed into the selected
line or area symbol.
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 The outline or ellipse line is drawn as a Bézier curve.

Draw Multiple Point Objects    

This drawing tool is used to draw several point objects that are placed on a line with a constant interval.
1.1. Choose a point symbol in the symbol box.
2.2. Choose the drawing tool Drawing multiple point objects from the Edit and Drawing toolbar.
3.3. Draw a line from the position of the first to the position of the last feature.
4.4. The Dialog Draw Multiple Point Objects appears:

Enter the number of objects and click the OK button.
The defined number of objects are drawn:

 If the number of objects is 1, the objects position will be in the center of the drawn line.

Laser Rangefinder Drawing Mode    

Laser rangefinder drawing tool.

Numerical Drawing Mode    

Select Numeric mode if you have measurement values or coordinate pairs for specific objects.
Construct a point object using distance or azimuth measurements.
1.1. Select a point symbol from the symbol box.
2. Select Numeric mode.
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3. Enter the coordinates of your location in the Easting and Northing fields. A small cross highlights the position in
the drawing window.

4. Enter the length in mm or m in the Length field and the Angle in a clockwise or counterclockwise direction.
5. Click End.
6.6. The angle and distance measurements are used to position the point object.

 -You can change the direction from clockwise to counterclockwise, or vice-versa, by clicking the
Counterclockwise or Clockwise buttons.

-You can change the unit of measurement from millimeter to meter, or vice-versa, by clicking the
Millimeter or Meter button.

Construct a line or area object using coordinate pairs.
1.1. Select a line or area symbol from the symbol box.
2. Select Numeric mode.
3. Enter the coordinates of your first coordinate pair in the Easting and Northing fields. A small gray cross

highlights the position of the first coordinate pair in the drawing window.

4. Select the construction mode  Enter positions.
5. Enter the coordinates of the second coordinate pair in mm or m and click Next. A help line appears between the

first and second coordinate pair. Repeat this process as often as necessary; the help line is extended each time.
Click End once you have entered the final coordinate pair.

6.6. The sections are then transformed into the selected line or area symbol.
Construct a line or area object using distance or azimuth measurements.
1.1. Select a line or area symbol from the symbol box.
2. Select Numeric mode.
3. Enter the coordinates of your starting point in the Easting and Northing fields. A small cross highlights the

position of the starting point in the drawing window

4. Select the construction mode  Enter length and angle.
5. Enter the length in mm or m in the Length field and enter the Angle in a clockwise or counterclockwise

direction. A help line appears that displays the distance and azimuth from the starting point. Repeat this process as
often as necessary; the help line is extended each time. Click End once you have entered the final distance and
azimuth values.

6.6. The sections are then transformed into the selected line or area symbol.

Place a Text Object      
Text and line text symbols are available for placing text. Text symbols are generally aligned horizontally. Line text
symbols follow the flow of rivers or streets.
Place a text object

You can choose text frames or anchor points for placing text objects.
Define a text frame

1.1. Select a text symbol from the symbol box.
2.2. Select a drawing mode.
3.3. Position the cursor on the upper left-hand corner of the desired text frame, then click and hold the left mouse

button and drag the cursor to the lower right-hand corner. Release the mouse button. The text cursor for inputting
text appears.

4. Enter the desired text. The line break is added automatically Press Enter to start a new paragraph.
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 You can't draw a text frame with a text symbol whose Drawing Mode is set to Rotated Text.
Define a text anchor point

1.1. Select a text symbol from the symbol box.
2.2. Select a drawing mode.
3.3. Position the cursor at the point where the text is to be anchored. Release the mouse button. The text cursor for

inputting text appears.
4. Enter the desired text. Press Enter to start a new paragraph.

 The text objects line length gets enlarged while writing.
Place a Line Text Object

Select a Line Text symbol if you want your text to follow the flow of a curve.
1.1. Select a Line Text symbol from the symbol box.
2. Select Bézier Curve mode.
3.3. Draw a curve

1.1. Once you have finished drawing the line, a help line appears as well as the text cursor for inputting text.
4.4. Enter the desired text.

 Line text object's line length is enlarged while writing text if the line text symbol alignment is left aligned.
 Video: Writing Text [2]

Following Existing Objects     
Ctrl button: Following existing objects

Area objects are often limited by line objects. You can trace existing line or area objects without having to redraw
them.
1.1. Select a line or area symbol from the symbol box.
2.2. Select a drawing mode.
3. Press and hold the Ctrl button, then position the cursor at the point from which you want to trace the line. This

does not have to be the start or end point of the line. The help line will appear with its vertices.
4.4. Click and hold the left mouse button and drag the cursor to the desired point. This does not have to be the start or

end point of the line.
5.5. Release the mouse button. The traced line is transformed into the selected line or area symbol.
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 -With double lines (e.g. streets), you can trace the middle line as well as both side lines. If you do not
require this option, you can deactivate it under Preferences, Drawing in the Options menu.

-Line tracing is only possible in straight, Bézier and freehand mode.
-It is possible to trace the outline of existing area objects. However, it is only possible to trace up to one
half of the outline, otherwise the trace would be in the opposite direction. The point, up to which the
object can be traced, is represented by a large square  .

Snapping
Please look at the Snapping page.

Live Preview
The live preview can be turned on in the OCAD Preferences in the menu Options and check Enable Live Preview
in the category Drawing and Editing.

Edit a Vertex      

To edit a vertex, select the Select Object and Edit Vertex editing mode  . You will then be able to move, delete
or change the type of vertex.
For point objects, the middle of the symbol is represented by a large square  . For line and area objects, the first
point of the object is represented by a large square  , vertices by small squares  , and the last point of the object
by a cross X. With Bézier curves, circle symbols  are used to represent the ends of the tangents.
For more and detailed information, please visit the Select Object and Edit Vertex page.
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Edit an Object      

To edit an object, you must select the Select and Edit  object mode. As soon as you have selected the object, the
object frame appears with anchor points  .

 You can now move, rotate, cut, stretch or reduce the size of the object. You find all
functions in the Toolbars or in the Object Menu.

For more and detailed information, please visit the Edit Object page.

Tips with Keyboard and Mouse
Please visit the Tips with Keyboard and Mouse page for more information.

Back to Main Page
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Vertices
Vertices are specified by a pair of coordinates (x/y values). Vertices are used to define the position of points, lines
and areas.
There are 3 types of vertices:
•• Normal Vertex
•• Corner Vertex
•• Dash Vertex

Add Vertex
The commands for adding new vertices can be found in the Editing and Drawing Toolbar.

 Add normal vertex
 Add corner vertex
 Add dash vertex

Add Normal Vertex      

The  Add normal vertex function is enabled when a line, line text or area object is selected. Click this button to
change the cursor to the Add normal vertex mode. When this mode is selected, you can insert additional normal
vertices or change existing vertices to normal vertices.
Hold the Alt key to switch temporary to  Select Object and Edit Vertex mode, in order to select other objects.

Insert Normal Vertices

Select a line, line text or area object, change to the Add normal vertex mode and move the mouse pointer to the
desired position on the line object or on the border of the area object. Then, click the left mouse button. A new
normal vertex is inserted.
You can also insert normal vertices in  Select and Edit Object or  Select Object and Edit Vertex mode
when holding down both the  and the Ctrl key.
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Change a Vertex to a Normal Vertex

Select a line, line text or area object, change to the Add normal vertex mode and move the mouse pointer to the
vertex to be converted. Then, click the left mouse button. The vertex is changed to a normal vertex.

 If you want to change all vertices of an object to normal vertices use the Change Vertex Types to function.

Add Corner Vertex      

A  Corner Vertex is a special vertex of line, line text and area objects. You can use this function if a line, line
text or area object is selected.
Corner vertices have 3 effects:
•• they influence how line objects are drawn
•• they influence the editing of a Bézier curves
•• when smoothing (automatically or manually) they remain in the same position
When an object is selected, corner vertices are marked with an empty rectangle (  ).
Corner vertices are automatically created when drawing in the  Straight Line mode.

Hold the Alt key to switch temporary to  Select Object and Edit Vertex mode, in order to select other objects.
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Insert Corner Vertices

Select a line, line text or area object, change to the Add corner vertex mode and move the mouse pointer to the
desired position on the line object or on the border of the area object. Then, click the left mouse button. A new
corner vertex is inserted.

Change a Vertex to a Corner Vertex

Select a line, line text or area object, change to the Add corner vertex mode and move the mouse pointer to the
vertex to be converted. Then, click the left mouse button. The vertex is changed to a corner vertex.

 If you want to change all vertices of an object to corner vertices use the Change Vertex Types to function.

Influence on line objects

Corner vertices influence structured line objects such as dashed lines. When OCAD renders a dashed line it
distributes dashes of equal length on that line. Corner vertices divide a line into several line sections. OCAD
distributes the dashes on each section as if they are individual objects.
In the Comparison part of this page some examples can be found.

Influence on Bézier curves

Corner vertices allow you to create corners in Bézier curves. The Bezier vertex before and after a corner vertex can
be moved individually without influencing each other. This allows you to create sharp corners.

Add Dash Vertex     

A  Dash Vertex is a special vertex of line or area objects. Dash vertices influence how line objects are rendered.
When an object is selected, dash vertices are marked with a diamond (  ). You can use this function if a line, line
text or area object is selected.
Hold the Alt key to switch temporary to  Select Object and Edit Vertex mode, in order to select other objects.

Insert Dash Vertices

Select a line, line text or area object, change to the Add dash vertex mode and move the mouse pointer to the
desired position on the line object or on the border of the area object. Then, click the left mouse button. A new dash
vertex is inserted.

Change a Vertex to a Dash Vertex

Select a line, line text or area object, change to the Add dash vertex mode and move the mouse pointer to the vertex
to be converted. Then, click the left mouse button. The vertex is changed to a dash vertex.

 If you want to change all vertices of an object to dash vertices use the Change Vertex Types to function.

Influence on line objects

Dash vertexes influence structured line objects such as dashed lines. When OCAD renders a dashed line it distributes
dashes of equal length on that line. Insert a dash vertex to force a dash to a certain position.
In the Comparison part of this page some examples can be found.
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Comparison and Examples

Dotted Line

Dotted line with normal vertex (1) and corner
vertex (2) at the corner.

Dashed Line

Dashed line with normal vertex (1), dash vertex
(2) and corner vertex (3) at the corner.

Dashed Line with Intersection

Remove Vertex      

Click the  Remove Vertex button in the Editing and Drawing Toolbar to remove a vertex.
This function is enabled when a line or area object is selected. When you use this function, the cursor changes to the
Remove Vertex mode.
Remove a vertex from a line or area object by clicking the desired vertex on the selected object with the left mouse
button.

 Remove multiple vertices by clicking the  Remove Vertex button and holding down the Ctrl key and the
left mouse key while moving over the vertices. The mouse movement works like an eraser for the vertices of the
selected object.

 You can also remove vertices in  Select and Edit Object or  Select Object and Edit Vertex mode when
holding down the Ctrl key and clicking on a vertex.

 Hold the Alt key to switch temporary to  Select Object and Edit Vertex mode, in order to select other
objects.
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Change Vertex Types to    
You can find this function in the Object menu and is enabled if at least one line, line text or area object is selected.
1.1. Select at least one line, line text or area object.
2. Select the Change Vertex Types to submenu in the Object menu and choose the desired vertex type (normal

vertex, corner vertex or dash vertex).
3. The Change Vertex Types to dialog appears.
4. In the From field, choose which vertex types you want to convert.
5. If you do not want to change the first and last vertex, check the Do not change first and last vertex option.
6. Click the OK button.
Note: Virtual gap vertices can only be converted to normal vertices (Learn how to make a virtual gap here: Cut
Line).

To the Edit Object page.
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Tips with Keyboard and Mouse
This page summarises Tipps and Tricks with Keyboard and Mouse to optimize your drawing and editing skills in
OCAD.
Click on the links for each function to learn more and see an animation.

Navigation

Space + Mouse Drag Move the view. See also:  Pan Tool

Mouse Wheel Down Pan while holding the mouse wheel down.

Mouse Wheel + Ctrl
Zoom in/Zoom out. See also:   Zoom Tools

Mouse Wheel Move the view vertically.

Mouse Wheel + Shift Move the view horizontally.

F5 Redraw

Window > Tile Fit all opened OCAD projects horizontally or vertically in the OCAD window

There are some Shortcuts by default corresponding to view and navigation functions.

Drawing

Shift + Continue an existing line or expand areas objects. Press the Shift key and click the start or end point of line or area object to be
continued.

Shift + Drawing circular objects from the center point.

Ctrl + 
Following Existing Objects.

Alt + 
Draw horizontal or vertical lines. Press the Alt key while drawing. The line snaps in a vertical or horizontal direction.

Tab Change drawing mode during drawing and editing. Press the Tab key until the desired drawing mode appears to change the drawing
mode.

P Press the P key to change to the last used drawing mode.

Backspace Delete last vertex.

Visit the Drawing and Editing Section in the OCAD Preferences to choose your favourite settings.

Editing
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Move Segments

Shift +  or 
Object not selected: add to the selected objects. As an alternative, drag an area with the Left Mouse
Button.
Selected object: remove from selected objects.
Keep right angle when moving a corner (e.g. building).

Ctrl + 
Remove Vertex

Ctrl +  + Mouse
Remove Vertex with Mouse Over.

Shift + Ctrl + 
Add Vertex

Alt + 
Select an object under a already selected object.

Alt +  or 
Select next object for editing

Arrow Keys Move selected objects (fine tuning)

Arrow Keys Double Click on Vertex and Move Vertex With Arrow Keys.

Tab + 
Move neighboring Segments and congruent Vertices in one single step.

Shift + Arrow Keys Move selected objects (fast)

P Get latest used drawing tool

A Change to the Select Object and Edit Vertex mode.

V Change to the Select and Edit Object mode.

Cutting

Ctrl + 
Insert a virtual gap.

Shift + 
Dashed line: Insert a gap at the cutting point

Background Map

F9 Adjust a Background Map

F10 Hide all Background Maps

Varia
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F2 Normal (Visible and Selectable)

F3 Protect Objects

F4 Hide Objects

File > Open Recently Exported Documents Shortcut to open exported OCAD Files, PDFs, PNG, ...

File > Open Recently Used OCAD Files Shortcut to open an OCAD file which you recently opened.

https://www.ocad.com/wiki/ocad/en/index.php?title=Symbol%23Normal_.28Visible_and_Selectable.29
https://www.ocad.com/wiki/ocad/en/index.php?title=Symbol%23Protect_Objects
https://www.ocad.com/wiki/ocad/en/index.php?title=Symbol%23Hide_Objects
https://www.ocad.com/wiki/ocad/en/index.php?title=File%23Open_Recently_Exported_Documents
https://www.ocad.com/wiki/ocad/en/index.php?title=File%23Open_Recently_Used_OCAD_Files


60

Menu File

File

New      

Choose this command from the File menu or click the  New button in the Standard toolbar to create a new,
empty map. The New File dialog box is displayed. For further information visit the Create a New Map page.

New Map Wizard     
Choose this command from the File menu to create a new map using the wizard. The New Map Wizard dialog box
appears. For further information visit the New Map Wizard page.

New Course Setting Project Wizard      
Choose this command from the File menu to create a new course setting project using the wizard. The New Course
Setting Project Wizard dialog box appears. For further information visit the New Course Setting Project Wizard
page.

Open       

Choose this command from the File menu or click the  Open button in the Standard toolbar to open an existing
map. The Open Map dialog box is displayed. Browse the map to be opened and click the Open button.
If the map was created with an earlier OCAD version, you will be asked if you want to convert it into the OCAD
2019 format. If you answer by clicking the No button, the map will not be opened.
OCAD 2019 can open maps vom OCAD 6 to 2019. OCAD 2019 doesn't support earlier OCAD file formats.

 - Do not use this command to restore a backup copy from a floppy disk created with the Create Backup
command. Use the Restore Backup command instead.

- The error message "This OCAD version is not yet supported" appears if the file is an OCAD file from a
higher OCAD version.
- The error message "Format not correct" appears if the file is either damaged or not an OCAD file.
- The Fonts Not Found dialog box appears if the map contains one or more fonts that are not installed on the
computer. Probably the map was created on another computer. You must install the missing fonts in Windows
or select other fonts. Otherwise a standard font is used for the missing ones.
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Open Sample Map       
This command chosen from the File menu opens the Open Sample Map dialog. There you can choose a sample file.
The sample files are saved in the OCAD program subfolder Samples (usually C:\Program Files\OCAD\OCAD
20xx\Samples).

Close       
Choose this command from the File menu to close the current map. If changes were made to the current map, then
you will be asked if you want to save the changes.

Save       

Choose this command in the File menu or click the  Save button in the Standard toolbar to save all changes in
the current map on volume. If the current map has no name (untitled) the Save As dialog box will be displayed,
where a name for the map can be entered.

Save As       
Choose this command from the File menu to save the current map under a new name. The Save As file dialog box is
displayed.
You can use this command to save the map in a previous OCAD version (10, 11 or 12). Choose the format in the
Save as type list.
To create a backup file use the Create Backup command in the File menu.

 OCAD 2019 Course Setting files can be saved in an previous OCAD version if the file passes the
Compatibility Check.

 All changes made since the old map was saved the last time are not written to the old map. They are only written
to the new map.

 OCAD TRIAL can't save the ocd files in an earlier OCAD version.

Undo       

Click on the Undo icon  in the standard toolbar, press Ctrl+Z or select Undo in the File menu to undo the last
draw or edit operation.

Redo       

Click on the Redo icon  in the standard toolbar, press Ctrl+Y or select Redo in the File menu to reverse the effect
of the Undo operation.

Print
Print out the desired area of your map. Visit the Printing Maps page to read all about printing.
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Import
Choose this command to import an external file to the current map. Visit the Import Files page for more
information.

Export
Export the map in different file formats. See the Export page for more informations.

Export OCAD Internet Map
Export the map as an OCAD Internet Map. Read more about it on the Export OCAD Internet Map page.

Export Encrypted File
Export the map to encrypted OCAD file format. An encrypted OCAD map can only be loaded as a Background Map
and cannot be edited. See the Export Encrypted File page for more informations.

Send File by Email
Choose the Send File by Email command to send an OCAD map, including the loaded DEM, Databases,
Background Maps and Layout Objects, by E-Mail. Please find more information on the Send File by Email page.

Execute XML Script
Choose this command to execute functions whose settings are defined in a XML file. Please find more information
on the Execute XML Script page.

Create Backup       
To create a backup of the currently opened file:
1. Choose the Create Backup command in the File menu.
2. The Backup dialog appears.
3. OCAD creates a new folder called Backup and suggests a name for the backup file, which consists of the current

date and time and the file name. Alternatively, you can enter an own name.
4. Click the Save button to save the backup.
This function has not the same effect as the Save As function. After saving the backup you are still working on the
old file.

Open Recently Exported Documents       
Choose Open Recently Exported Documents in the File menu to open a recently exported document from the
opened OCAD file. The infomation about the recently exported documents are saved in the OCAD file that you have
open. This function is not available if you do not have a file open.
Click on the Delete List command to clear the list.
Not existing files are disabled and cannot be opened.
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Open Recently Used OCAD Files       
Choose Open Recently Used OCAD Files in the File menu to open an OCAD file which you recently opened.
Not existing files are disabled and cannot be opened.

Exit OCAD
Click on to exit OCAD.

Back to Main Page

Create a New Map
OCAD provides predefined symbol sets to help you begin drawing your map immediately.
If you want to import Open Street Map (OSM) data, have a look at the New Map Wizard Page

Create a New Map      
To create a new map:
1. Select New in the File menu. The New File dialog box appears.

2. Choose a map type. You can now choose a predefined symbol set which fits to your intended map from the
selection box. If you want an empty symbol set, choose the Empty symbol set option. Click the Other file button
to start with symbols from a different map than those listed. The box lists all symbol files in the \symbol\ sub
directory.

 - To add your own set of symbols to the list of predefined symbol sets, simply copy the ocd file to the
OCAD sub directory Symbol (usually C:\Program Files\OCAD\OCAD 20xx\Symbol). Symbol files are just
normal OCAD maps, usually without any objects. The Map notes box shows information about the
specifications of the map.

- Map notes can be edited in the template file itself. For this purpose choose Map Information in the
Map menu.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:Space.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Mas40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Ori40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Sta40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:View40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:CS40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=Main_Page
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Space.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Mas40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Ori40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Sta40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:CS40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:NewFile.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=Map%23Map_Information


Create a New Map 64

- Edit the file OrienteeringMapList.User.txt in the OCAD sub directory Symbol if you want that user
defined symbol sets are listed as map type Orienteering map.

 - Do not edit the symbol sets provided by OCAD. When installing a Service Update, OCAD overwrites
these symbol sets. So, your changes will be lost. If you want to modify symbols in the symbol set then first
save the symbol set with another file name and edit this symbol file.

 - You can add, change or delete symbols in the symbol box at any time.
3. Deside in which scale the map shall be drawn. If you change the scale, you can choose also to scale the symbols.
4.4. Choose the language of the symbol set (only at ISOM 2017 available).
5. By clicking the OK button, OCAD creates a new map and copies the chosen symbol set to it. You are ready to

start!

Set Scale and Coordinate System      
Select the Set Scale and Coordinate System item from the Map menu. The Set Scale and Coordinate System
dialog box appears.
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Map Scale
Enter a scale and click the OK button or adjust the Coordinates settings.

 Do not use this dialog to change the scale after entering the initial values. To increase or decrease the size of the
map subsequently, use the Change Scale function in the Map menu. Setting the current scale does not enlarge or
reduce the map. It only changes a number in the map file and georeferencing will be lost.

Georeference the Map
Before loading a georeferenced Background Map, work with GPS data or import Spatial Base Data, we
recommend that you first georeference the map. You should contact your data supplier, national surveying office or
cartographic institute to find out which coordinate system will best suit your needs.

Coordinates

1. Choose wheter you want define Paper coordinates (in mm) or Real world coordinates. Click the corresponding
radio button.

2. In the Easting offset and Northing offset fields, enter the coordinate values for the center of your map.
3. The coordinate system can be rotated by entering a value in the Angle field.

Click on Magnetic Declination to see the current Declination for your position. You can only Apply the
Angle, if no objects have been drawn yet. If you have already drawn objects, use the Rotate Map to Magnetic
North function instead.

4. In the Grid distance field, enter the desired distance for the Coordinate Grid lines.

 Enter the coordinate values for the center of your map in the horizontal and vertical offset fields. This is
important since the drawing area of OCAD is limited to 4 x 4 m in the  Orienteering edition, in the 
Starter edition as well as in the  Course Setting edition and 80 x 80 m in the  OCAD Mapping
Solution. This option is used to ensure that imported Spatial Base Data, georeferenced Background Maps and
GPS measurements do not lie outside the drawing area.
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Coordinate System

Click the Choose button to define a coordinate system. The Coordinate System dialog appears.

Choose the desired coordinate system. OCAD supports a lot of coordinate systems. The most common one is the
UTM [1] (Universal Transverse Mercator) system which is divided into 60 zones limited by meridians and defined
worldwide.
• Zone: Depending on the selected coordinate system you must select a zone. If the coordinate system UTM is

selected, you can click the Find button to find the correct UTM zone. This function is described in the next
paragraph.

• Map datum: This field displays the map datum for the desired coordinate system ( Map Datum [2]).
• Ellipsoid: The field displays the ellipsoid from the map datum ( Reference Ellipsoid [3]).
• Location: The field displays the location, where the coordinate system can be used.
• EPSG: The field displays the EPSG-Code (European Petroleum Survey Group Geodesy) of the coordinate

system. An external link is provided on the right side of the dialog box. This link refers to spatialreference.org
[4], where you can get more information about the chosen coordinate system and zone.

• ID: The field displays the internal grid ID for this coordinate system. This grid ID is used in the [[XML Script]].
Click the Remove button to reset the coordinate system to Grid undefined.
If you are finished, click the OK button.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:CoordinateSystemDialog.PNG
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Find UTM Zone

If UTM [1] is chosen as a coordinate system, the local zone can be found with this tool. Click the Find button next to
the Zone dropdown list. The Find UTM Zone dialog appears.

Enter the geographical coordinate (degree of longitude and degree of latitude) of your map.
• Latitude: Enter in this field the degrees of latitude.

N (North): Click this button if the position is northern of the equator.
S (South): Click this button if the position is southern of the equator.

• Longitude: Enter in this field the degrees of longitude.
W (West): Click this button if the position is western of Prime Meridian (London Greenwich).
E (East): Click this button if the position is eastern of Prime Meridian (London Greenwich).

Click the button OK to calculate the UTM zone. The UTM zone appears in the Coordinate system dialog box.
Example: Coordinate from Baar (Switzerland): 47° 12 North (Latitude), 8° 31' East (Longitude). Enter 47 in the
Latitude and 8 in the Longitude field. You will find out that this place is in the UTM zone 32 North.

http://en.wikipedia.org/wiki/Universal_Transverse_Mercator_coordinate_system
https://www.ocad.com/wiki/ocad/en/index.php?title=File:FindUTMZone.PNG
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User Defined Grid

In the Coordinate System dialog you have the option to choose a User Defined Grid in the dropdown list. If you
choose it, the dialog box is extended with the Coordinate system parameter part.

You can load the coordinate system from a PRJ-File by clicking the corresponding button. A PRJ-File is a projection
format containing coordinate system and projection information. The coordinate system parameter are updated after
loading a PRJ-File. Alternatively, the required values can be typed manually but this requires a little experience.

Additional local offset

It is possible to give an additional local offset to the chosen coordinate system. Enter a value for the horizontal and
vertical offset in the corresponing fields. This is especially useful if you have to work with GPS very precisely. A
tectonic plate can move but the coordinate system stays the same. If you enter a local offset, this problem can be
cleared.
Click the OK button to save changes and quit the Set Scale and Coordinate System dialog.

 Do not use this dialog to change the real world coordinate offset if the map is georeferenced. To move a
georeferenced map, use Transform -> Center Map to Drawing Area in the Map menu and enter the new offset.

Next Steps
Now as you created a new map, you are ready for the next steps.
• Learn how to Draw Objects.
• Learn how to Edit Objects.
• Use Existing Spatial Data: Import Files, Database, WMS, Background Maps.
• Processing of LiDAR data and Digital Elevation Models: DEM Import Wizard, Lidar Point Cloud Manager.
• Capture and derive own Data: GPS, Laser Rangefinder.

 Check out our tutorials about Mapping with OCAD.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:UserDefinedCoordinateSystem.PNG
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Back to Main Page
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New Map Wizard
Choose this command from the File menu to create a new map.
This wizard helps you to set the geo-reference and import optionally Open Street Map [1] data.
See also the Create a New Map Page if you do not want to import OSM data.

Choose Symbol Set     

The New Map Wizard dialog shows only OCAD symbol sets. If the Load symbol set from field is empty, then
change the Default Symbol Folder in the Preferences to the OCAD symbol folder.
• Map Scale: Set the Map Scale.
• File Name: Click the button to change the default temporary file name and the file location.
• Language: Choose the language.
Click the Next button.
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Choose Location

Choose the location of the map. Enter the location (e.g. Baar) in the search field and click Go. Choose the location in
the list or move the Open Street Map to the map location. OCAD show the correct UTM coordiantes system for the
map location (e.g. UTM/WGS 84 Zone 32 North). Click the Change button to change to another coordinate system.
OCAD also calculates the correct declination for your position and fills in the correct angle in the box Rotate map
to magnetic north. Check this option to have considered the declination from start.
Click the Next button.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:NewMapWizard_Location.png
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Import Data

Import OSM Data
You can import Open Street Map [1] data for this location. Check this option to import OSM data.
OSM are free and available all over the globe. However, in some places they are more accurate and in other places
less accurate.

Choose Cross Reference Table
Choose the CRT file to change automatically the objects into the symbols. Note: OSM data consists of many layers
and not all of them are listed in the CRT File. This data will appears in red color (Objects without Symbol). Select
these layers and convert them manually.
1.1. Click on one of these unsymbolised red object.
2. Go to Select>Select by Symbol>All objects in layer. The layer with the red object you selected before should

appear.
3. Click OK. Now you have selected all objects of this layer.
4. Click on a symbol in the Symbol Box and go to Objects>Change Symbol (Selected Objects)

https://www.ocad.com/wiki/ocad/en/index.php?title=File:NewMapWizard_OsmImport.png
https://www.openstreetmap.org
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Create DTM from Google Maps API
This option is only activated if a Google API key is entered in the OCAD Preferences. With this option you can
create contour lines, based on a DEM from Google Maps data. You shouldn't trust these data too much, so we
recommend to use this function only if no other precise DTM is available. Nevertheless, it can give you an
impression how the terrain looks like.
Click the Next button.
This step will take some time, as all the data will be downloaded and proceeded.
Click the Close button.

Example
The following maps have been created automatically with the New Map Wizard.

 
Map of Baar, Switzerland

https://www.ocad.com/wiki/ocad/en/index.php?title=OCAD_Preferences%23Google_API_Key
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Map of Cruz Grande, Gran Canaria

 Video: Start a New Map [2]

References
[1] https:/ / www. openstreetmap. org
[2] https:/ / www. youtube. com/ watch?v=iWERDnjMyO4& t=2s
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New Course Setting Project Wizard
Choose this command from the File menu to create a new course setting project.
This wizard guides you through the first steps like setting an event title and loading a map file in the background
layer.

Event Information
• Enter the Event Title
• Choose the Discipline

https://www.ocad.com/wiki/ocad/en/index.php?title=Course_Setting_Options%23Event_Title
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Map file, symbol set and language
• Choose the Map File. The scale of the map will appear automatically.
• Choose which Symbol Set you want to load. You can browse to any folder.
• If available, choose the Language of the Symbol Set
• Enter the Name of the Course Setting Project and browse to the location where you want to save the file.

Options
• Check the option Load courses and classes from another from another course setting file.

Browse to a already existing Course Setting Project, from which you want to import Courses and Classes. This
can be the case, if you organise an orienteering competition regulary.

• Check Load also course setting option from this file if all Course Setting Options from this file should be
adopted.

• Specify the Distance from circle to connection line.
• Activate White Outline on Control Number, if wanted.
• Click on Create to set up the Course Setting Project and to close the Wizard.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:NewCourseSettingProjectWizardSample2.png
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Undo and Redo

Undo      

Click on the Undo icon  in the standard toolbar, press Ctrl+Z or select Undo in the File menu to undo the last
draw or edit operation.

Redo      

Click on the Redo icon  in the standard toolbar, press Ctrl+Y or select Redo in the File menu to reverse the effect
of the Undo operation.

Back to the File page.
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Printing Maps
    

Print a map

1. Select Print in the File menu, press Ctrl+P or click on the Print icon  in the standard toolbar. The Print
dialog appears on the right hand side of the window.

2. Select the printer to print the map. In the box you can select one of the installed Windows printer drivers. Click
the Properties button  to change printing options.

3. In the Page handling box you can set the page orientation (Portrait or Landscape) and the number of copies
you would like to print.

4. Decide between Color printing or Spot color separations (Black & White printing) in the next box. Select the
second option to print black and withe spot color separations. Choose Define Spot Colors from the Map menu to
define spot colors. When this radio button is activated and spot colors are defined, you can select one or more of
the defined spot colors in the Spot colors list box.

5. Define the print scale in the Scale box. You can enter the scale on the keyboard, or choose one of the predefined
scales. If the print scale is different from the map scale, the map and the symbols are enlarged/reduced according
to the ratio of the map and print scales.

6. In the Print map size box you have the following options:
• Entire map: The entire map will be printed. Gray frames show a print preview on the basis of the defined

paper size in the printer settings. If the map is too large for one page, it will be printed on several pages. Click
on the Setup icon  to make more adjustments.

• Part of map: Print a part of the map. If you choose this option a thin black and a grey frame appear. The thin
black frame shows the area which is to be printed, the grey frame shows the paper size. Adjust the thin black
frame to your desired map part. More information about setting up Part of the Map can be found further down
on this page.

• One page: Select this option to print one page of paper of the map. Click the Setup  button to define the
region to be printed. More information about setting up One Page can be found further down on this page.

• If you cannot see the frame, click Zoom out in the View menu until the frame becomes visible.
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•• Move the mouse pointer inside the rectangle to drag the entire rectangle. Drag a corner or one side to resize the
rectangle.
7. In the Options box you can make the following adjustments:

• Intensity: For older ink jet printers you can reduce the color intensity here. This reduces the amount of ink
applied.

• Line width: For older ink jet printers you can reduce the line width here. This reduces the amount of ink
applied.

• Print screen grid: Check this box to print a grid on the map. Choose the color of the grid in the drop-down
list.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:PrintIntensity.PNG
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8. Click Print to print out the respective area.
Click Save XML to save an XML file with the print settings (Same filename and path as OCAD map). Use
Execute XML Script command in File menu to print the map with the settings saved in the XML file.

Hide the background map before printing the map, if you do not want this to be printed out as well. If you are still in
Draft mode, select Normal Mode in the View menu.

 The error message: "Paper size is not defined" appears if a paper size is defined that is not available for the
selected printer.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:PrintGrid.PNG
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Setup Part of Map

Choose the Part of map option as the print map size and click the  Setup button to define the printing area. The
Setup Part of Map (Printing) dialog appears.

Coordinates
Choose between Paper or Real World Coordinates.

Export map size
Reference point, width and height:

Choose the point of the map which you want to define as the reference point (e.g. upper left corner). Click one
of the nine squares.
Enter the coordinate of the chosen point.
Enter the dimension (Width and Height) of the map to be printed in m (real world coordinates) or mm (paper
coordinates).

Rectangle

Enter the coordinate of the bottom left and the top right corner of the rectangle to be exported in m (real world
coordinates) or mm (paper coordinates).

Overlap

If the map does not fit to one page, the given vertical and horizontal overlap is printed on both pages,
therefore the maps are overlapping.

 The overlap values can be negative. This can be useful when printing the courses for relays in orienteering.
Place the start number and or advertisement to be printed on the back side beside the map. With a negativ
overlap a gap between the two pages is created.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:Properties.PNG
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Save

You can name the adjustments/rectangles and save them by clicking the Save button.
Load

If there are saved settings, you can load them using the Load button or delete them using the Delete button.
Set to entire map

Click the Set to map to set the values given in the Export map size part of the dialog to the entire map
Import

You can import export-rectangles from another ocd file.
Set from selected objects

Click this option and the rectangle will be adapted to the selected objects.

Setup One Page

Choose the One page option as the print map size and click the  Setup button to define the printing area. The
Setup One Page dialog appears.

In this dialog you have to set the bottom left corner of the page to be printed in mm (paper coorinates) or m (when
you have Set a Coordinate System). Click the OK button when finished.

 A preview is given in the drawing area.

Color Display
Due to color display, we recommend you to always create a PDF first out of OCAD and print this PDF afterwards.
OCAD works with CMYK Colors and they will only be displayed correctly this way. What you see on your screen
are RGB-Colors from the Windows Graphics Device Interface (GDI). When you print maps directly out of OCAD,
the Windows GDI converts the CMYK values first in RGB values and your printer driver back to CMYK values.
This way it may come to changes in the color values.
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Back to Main Page

Import Files
Choose this command in the File menu to import an external file to the current map. The Import dialog box is
displayed. Initially all importable files are listed. The following file types can be imported:
•• OCAD map files (*.ocd)
•• Adobe Illustrator files (*.ai) (only vector data)
•• CSV files (*.csv)
•• DXF files (*.dxf)
•• Enhanced Meta files (*.emf) (only vector data)
•• GML files (*.gml)
•• GPX files (*.gpx)
•• KML files (*.kml)
•• OpenStreetMap files (*.osm)
•• NMEA files (*.nmea)
•• PDF files (*.pdf) (only vector data)
•• Freehand XML files (*.rcw)
•• Shape files (*.shp)
•• SVG files (*.svg)
•• Windows Meta files (*.wmf) (only vector data)
•• xyz files (*.xyz)

 It is possible to select and import multiple dxf, gpx, nmea, shp and xyz files in this dialog box.
 OCAD opens the File Dialog in the folder of the last imported file. Press the Shift key to open a file from the

Templates folder. The Templates folder is a subfolder of OCAD program folder (e.g. C:\Program
Files\OCAD\OCAD 20xx Mapping Solution\Templates).

https://www.ocad.com/wiki/ocad/en/index.php?title=File:ColorDisplay.png
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Import OCAD Map     
Choose an OCAD-File (*.ocd) in the Import dialog box and click the open button. The Import OCAD Map dialog
appears with the following options:
Position

• Place using the mouse: Choose this option to import for example a logo. The imported map is displayed in the
center of the screen and all objects are selected. Thus, you can drag it with the mouse to the desired position.

• Place with offset: Choose this option when combining different parts of a map. Enter the offset in mm where the
origin (0, 0) of the imported map should be placed.

• Use real world coordinates: Choose this option to import a georeferenced map. The map is automatically placed
at the correct position.

Symbols

• Do not import any symbols and colors: Choose this option to not import any symbols and colors.
• Import symbols only if symbol number does not exist yet: Choose this option to import symbols only if the

symbol number does not exist yet. The symbol signature will not be compared. OCAD will not produce a new
symbol if there is a symbol with an equal symbol number but a different signature. Colors will not be imported.

• Import symbols that do not exist. If the imported symbol number exists then a new symbol number is
applied: Choose this option to import symbols if they do not exist. OCAD will produce a new symbol if there is a
symbol with an equal number but a different signature. The new symbol number gets the next unused decimal
(e.g. 102.001 becomes 102.002). Colors will not be imported. This option accords with the data import function
of OCAD 8.

• Import all symbols and colors: Choose this option to import all symbols and colors from the imported map(for
example to print 2 maps with different symbol sets and color tables). There are two options to import the Colors
either at the top or at the bottom of the color table.

• Change symbol status from Normal to Protect: Check this option to change to symbol status off the imported
symbols from Normal to Protect. This option is recommanded for importing an ocd map into a course setting
project.

• Rotate objects with symbols orientated to north: This option is only available if the Real world coordinates
options are turned on in the current and the imported map file and if the real world angle property is different in
both maps. Select this option if the imported objects with north oriented symbols shall be rotated by this angle
difference.

• Use CRT file: Activate this button to use a CRT converting table. This table consists of two columns, which are
separated by a blank. In the first column there is the symbol number of the OCAD symbol in the map which is to
be imported. In the second column there is the symbol number of the opened OCAD file. Visit the Cross
Reference Table page to get more information about CRT-Files.

Example:

526.0 813.1

That means that all objects with the symbol number 526.000 will get the number 813.001 after the import.
• Load: Click this button to load a CRT file.
Database

• Database, Import existing database connections: This option is enabled if the import file contains database
connections. When this option is choosen then OCAD creates a new database connection to the existing database
if there is not already a database connection with the same name and file path in the OCAD file. Please note that
OCAD creates a new connection with a new name if a dataset with the same name but another file path exists.
Otherwise OCAD uses the existing dataset. OCAD does not merge databases.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:Space.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Mas40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Ori40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Sta40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=Map%23Colors
https://www.ocad.com/wiki/ocad/en/index.php?title=Symbol%23Normal
https://www.ocad.com/wiki/ocad/en/index.php?title=Symbol%23Protect
https://www.ocad.com/wiki/ocad/en/index.php?title=Create_a_New_Map%23Set_Scale_and_Coordinate_System
https://www.ocad.com/wiki/ocad/en/index.php?title=Cross_Reference_Table
https://www.ocad.com/wiki/ocad/en/index.php?title=Cross_Reference_Table


Import Files 84

 Please note that this CRT file is not compatible with the CRT files created in Convert Layers dialog! A list of
all CRT-Files which can be used with OCAD can be found on the Cross Reference Table page.

 The error message: "Cannot import symbol" appears if OCAD could not import a symbol. The import is aborted.

Import Adobe Illustrator File    
Choose an Adobe Illustrator file (*.ai) in the Import dialog and click the open button. Files from Illustrator version 4
and later can be imported.
The objects from an Adobe Illustrator file are imported into OCAD as image objects. The layer names are imported
with the objects. The layer name is displayed in the left part of the status bar if an image object is selected.

 Use Convert Imported Layers to Symbol from the Map menu to convert the imported objects from image
objects to symbolized OCAD objects.

Import DXF File     
DXF stands for Drawing Exchange Format and is a CAD data file format developed by Autodesk made for data
exchange between AutoCAD and other programs (Read more in the Wikipedia Article [1]).
Choose a DXF-File (*.dxf) in the Import dialog and click the open button.

The Import DXF-File dialog appears with the following options and information:
• DXF size: This box shows the range of the coordinates in the DXF file.
• Offset: Choose here whether you want to change the OCAD real world coordinates or to keep the existing ones.

• New offset: Choose this option if no real world coordinates are defined for the map. If you leave the proposed
offset unchanged, the imported objects will be placed in the center of the OCAD drawing area. In addition, you
can set the desired scale of the OCAD map here.

• Existing offset and angle: Choose this option if the map already has real world coordinates and you want to
fit the imported DXF file to the existing coordinates.
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• Coordinates: Define here how the coordinates of the DXF file should be interpreted. OCAD does not support
WGS 84 coordinates.
• GIS (1 meter/unit): Choose this option when importing DXF files from Geographic Information Systems

(GIS), where 1 unit in the DXF-File corresponds to 1 meter in the real world. The map scale is used for the
transformation. Choose Scale and Coordinate System from the Map menu to set the map scale.

• GIS (1 millimeter/unit): Choose this option when importing DXF files from Geographic Information Systems
(GIS), where 1 unit in the DXF-File corresponds to 1 millimeter in the real world. Usually GIS data uses the
unit meter. Please check the unit of the dxf data before importing the data into OCAD.

This example is from British Ordnance Survey data. The dxf size and the proposed new offset is in millimeter.

• Other: Choose this option when importing DXF files from graphic programs. Enter the size in millimeters of
one DXF unit on the map (e.g. if the DXF units are inches, enter 25.4).

• Convert text Objects from OEM to Unicode: Activate this box if the text in the DXF file is encoded in the
OEM character set. OEM character set is used by old DOS programs and concerns only accented characters (ä, à,
å etc.). Windows programs normally produce text in the ANSI character set. If accented characters are not
imported correctly, try this option.

• Import INSERT as point object: Activate this option to import INSERT objects in the DXF file as point objects
in OCAD. Otherwise the definition of INSERT objects is imported.

• CRT: Click this button if you have converted a similar DXF file before using Convert layers. A file dialog box
appears. Choose the CRT file created with the Convert layers command. Read more about CRT-Files on the
Cross Reference Table page. You will find examples there, too.

 If you do not use a CRT-File for importing a DXF-File, the DXF objects are imported as Unsymbolized
Objects. Use the Convert Imported Layers to Symbol function in the Map menu to assign the objects to a symbol
later on.
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Import EMF File    
Choose this function to import Windows Enhanced Metafile.
This import file format is obsolete.

Import GML Files   
Choose this function to import Normbasierte Austauschschnittstelle (NAS) [2] data.
OCAD cannot import other GML files.

Import GPX File    
Choose the .gpx file format in the Import File dialog. Read more about importing GPX files in the GPS - Import
from File article.

This function is also available for the  OCAD Starter and the  OCAD Course Setting Edition. For this
purpose, choose the Import from File command in the GPS menu.

Import KML File   
Choose the *.kml format in the file import dialog to import Keyhole Markup Language (KML) [3] files.
The line color, line width and fill color of the objects is also imported.

Import OSM Files     
A description of this function with an example can be found on the Import Open Street Map Files page.

Import NMEA Files    
Choose the .nmea file format in the Import File dialog. Read more about importing NMEA files in the GPS -
Import from File article.

This function is also available for the  OCAD Starter Edition. For this purpose, choose the Import from File
command in the GPS menu.

Import PDF Files    
Choose a PDF-File in the Import dialog and click the Open button. The Save Cross Reference Table dialog
appears. If you want to save a CRT-File, click the Save button. If you want to continue without saving a CRT-File,
click the Cancel button. Learn more about CRT-Files on the Cross Reference Table page.
The PDF-File is displayed in the middle of the current view of the map. All objects are selected, hence, it can be
easily moved to the desired position.
Please note, that it is only possible to import vector PDF-Files. If the PDF-File contains raster images, they are
displayed as a grey area on the map.

 Vector objects in PDF-Files are imported as Image Objects and can be converted to symbols using the Convert
Imported Layers to Symbols function. Learn how to make a point symbol out of a vector graphic by reading the
Create a Point Symbol out of Vector Data article.

 If you import a PDF-File, it should not be open in Acrobat Reader the same time. This will cause an error
message.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:Space.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Mas40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Ori40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Space.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Mas40px.PNG
https://de.wikipedia.org/wiki/Normbasierte_Austauschschnittstelle
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Space.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Mas40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Ori40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=GPS%23Import_from_File
https://www.ocad.com/wiki/ocad/en/index.php?title=GPS%23Import_from_File
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Sta40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:CS40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=GPS%23Import_from_File
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Space.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Mas40px.PNG
https://de.wikipedia.org/wiki/Keyhole_Markup_Language
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Space.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Mas40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Ori40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Sta40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=Import_Open_Street_Map_Files
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Space.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Mas40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Ori40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=GPS%23Import_from_File
https://www.ocad.com/wiki/ocad/en/index.php?title=GPS%23Import_from_File
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Sta40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=GPS%23Import_from_File
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Space.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Mas40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Ori40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=Cross_Reference_Table
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=Image_Objects
https://www.ocad.com/wiki/ocad/en/index.php?title=Map%23Convert_Imported_Layers_to_Symbols
https://www.ocad.com/wiki/ocad/en/index.php?title=Map%23Convert_Imported_Layers_to_Symbols
https://www.ocad.com/wiki/ocad/en/index.php?title=Create_a_New_Point_Symbol%23Create_a_Point_Symbol_out_of_Vector_Data
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg


Import Files 87

Import Freehand XML Files   

Choose a Freehand XML File (*.rcw) in the Import dialog and click the open button. The Import Freehand XML
dialog appears with the following options:
Font name translation:

• Select the load font name translation table option if the Macintosh font names used in the Freehand XML file
should be translated to the Windows font names. This translation is defined in a cross reference table (*.crt).

Example:

NicV-Normal;NicV

That means the font of all objects that used the NicV-Normal in Freehand will be changed to NicV after the
import.

• Load: Click this button to load a CRT file.
• File name: The file name of the loaded CRT file is shown here.
Geo-referenceing layer:

• Imported layer: OCAD offers a coarse georeferecing for Freehand XML files if the Freehand XML file contains
a layer with coordinate values. This layer must be entered in the imported layer text box.

Convert imported layers to symbols:

• Select this option if the imported layers should be converted to OCAD symbols. This step can be done also after
the import by using Convert Imported Layers to Symbol from the Map menu.
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Import Shape Files   
Get some information about Shape Files on Wikipedia [4].
If you choose an ESRI Shape File in the Import dialog, the Import Shape File dialog appears.

The import dialog offers the following options:
Shape size:

•• This box shows the dimension of the data in the shape file using its coordinates.
Coordinate System:

• This box allows you to transform the imported Shape file data to the maps coordinate system. Click the Choose
button to choose the Shape file's coordinate system if it is different to the map coordinate system.

Offset:

• New offset: Choose this option when importing the first shape file to the actual map and if the map is not
georeferenced yet. OCAD proposes reasonable easting and northing offset values. OCAD also proposes a map
scale that the entire map in the shape file fits into the drawing area of OCAD.

• Existing offset and angle: Select this option when importing the second and the following shape file to the actual
map or if the map is already georeferenced. The new shape file will then fit to the already imported shape files.

New database type:

• When importing Shape files, OCAD creates a new database for each Shape file. You can choose between the
database types dBase, Microsoft Access 2007 accdb and Microsoft Access 2003/2010 mdb.

•• Microsoft Access databases are much faster than dBase and support Unicode. dBase is more compatible with
Shape export.

• If one of the Microsoft Access options is chosen then the code page of the imported Shape file's dBase file should
be declared. This is important to ensure a correct text conversion from dBase (Ansi) to Microsoft Access
(Unicode) conversion.
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• Choose Do not create a database when you do not need the attribute data. Then OCAD imports only the
geometry from the Shape file. You can add one attribute as layer name when choosing the option Use layer
information from field.

Key field in database: OCAD creates a copy of the Shape file's dBase file during the import process. OCAD can
optionally add an additional key field to the copied dBase file.
• Create new key field: Select this option, if the dBase file does not contain a key field with a unique key for each

object or if you are not sure if such a key field exists.
• Use existing key field: Select this option, if the dBase file already contains a key field and you are sure that it

contains a unique key for each object. Select the key field.
• View table: Click on this button to see the dBase table. The View Table dialog opens. This table helps to decide

which key field can be used. It is not possible to edit this table.
Import layer information:

• Do not import any layer information: Select this option if no layer information should be imported. Symbols
must be assigned with Assign Symbols by Records command in Database menu. This may takes a lot of time.

• Use layer information from field: Select this option if you want to import layer information (ex. lake, forest
etc.) from a specified dBase field. This allows you to choose Convert Imported Layers to Symbol from the
Map menu to assign symbols to the imported data.

• Field 2:Check the Field 2 box to choose a 2nd database field. In that case the imported layer information will be
both field values, concatenated by an underscore: FieldValue1_FieldValue2.

• View table: Click on this button to see the dBase table. The View Table dialog opens. This table helps to decide
which field contains the layer information. It is not possible to edit this table.

Smooth objects Additional option whether objects imported from shape file should be smoothed with a tolerance.

Import Text or Line Text Objects
There are no text objects in Shape files. The texts like city names or river names are stored as attributes of the objects
in the Shape file's dBase file. You can create text objects from imported point objects or line text objects from
imported line objects by using Add Texts by Records... in the Database menu.

Example

After importing the Shape file the objects appear in OCAD as unsymbolized objects. The label of the selected object
is stored in the according database record ('Baar' in the field 'TEXT').
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Click Add Texts by Records... in Database menu to create the text objects. The Add Texts by Records dialog
appears.

Choose the option Replace existing objects and click OK to create the text objects.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:ImportShapeText1.png
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Import Shape Files in Orienteering Edition   
Geodata are often provided in the Shape file format. Get some information about Shape Files on Wikipedia [4].
If you choose an ESRI Shape File in the Import dialog, the Import Shape File dialog appears.

The import dialog offers the following options:
Shape size:

•• This box shows the dimension of the data in the shape file using its coordinates.
Coordinate System:
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• This box allows you to transform the imported Shape file data to the maps coordinate system. Click the Choose
button to choose the Shape file's coordinate system if it is different to the map coordinate system.

Offset:

• New offset: Choose this option when importing the first shape file to the actual map and if the map is not
georeferenced yet. OCAD proposes reasonable easting and northing offset values. OCAD also proposes a map
scale that the entire map in the shape file fits into the drawing area of OCAD.

• Existing offset and angle: Select this option when importing the second and the following shape file to the actual
map or if the map is already georeferenced. The new shape file will then fit to the already imported shape files.

Import layer information:

• Use layer information from field: Select this option if you want to import layer information (ex. lake, forest,
street classes etc.) from a specified dBase field. This allows you to choose Convert Imported Layers to Symbol
from the Map menu to assign symbols to the imported data.

• Field 2: Check the Field 2 box to choose a 2nd database field. In that case the imported layer information will be
both field values, concatenated by an underscore: FieldValue1_FieldValue2.

• View table: Click on this  button to see the dBase table. The View Table dialog opens. This table helps to
decide which field contains the layer information. It is not possible to edit this table.

Example:

This Shape file contains roads. In the database field OBJECTVAL is the road classification. So choose this field to
import for each street object the classification.
Smooth objects Additional option whether objects imported from shape file should be smoothed with a tolerance.

Import SOSI Files    
Choose this function import SOSI files. SOSI [5] is a much used geospatial vector data format predominantly used
for exchange of geographical information in Norway.
The Norwegian Mapping Authority Kartverket [6] released its map data in SOSI file format for free use [7] in
September 2013.
This example shows the import of the N50 Kartdata, UTM 32 data of Oslo. Each community consists of 8 SOSI
files.
Choose Import from the File menu. Select all sos-files except the uft8 text file. Otherwise you will import every text
label twice.
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Click Open. The Import SOSI File dialog appears.

OCAD has already two predefined crt tables for Orienteering maps which assigns the imported layers to symbols.
Both crt files are in the OCAD program subfolder crt\.
•• SOSI_2_ISSOM.crt: Convert the objects from SOSI layers to the symbols of sprint orienteering maps (ISSOM in

the scale 1:4000 or 1:5000).

https://www.ocad.com/wiki/ocad/en/index.php?title=File:SOSI_import.png
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•• SOSI_N50_2_ISOM.crt: Convert the objects from SOSI layers to the symbols of orienteering maps (ISOM in the
scale 1:10000 or 1:15000)

Click Choose to choose another crt file or X if you do not want to use a crt file.
Read more about crt-files in the Cross Reference Table article.
Click OK to import the files.

 OCAD imports only vector objects. OCAD doesn't support the RASTER object.

Import SVG Files   
[SVG [8]] stands for Scalable Vector Graphics, an XML-based file format for two-dimensional vector graphics.
Choose an SVG file (*.svg) in the Import dialog and click the open button.
The objects from the SVG file are imported into OCAD as image objects. The layer names are imported with the
objects. The layer name is displayed in the left part of the status bar if an image object is selected.

 Use Convert Imported Layers to Symbol from the Map menu to convert the imported objects from image
objects to symbolized OCAD objects.
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Import WMF Files    
Choose this function to import Windows Metafile.
This import file format is obsolete.

Import CSV and XYZ Files    
Choose this function to import csv and xyz files.
csv (Comma-separated values) files contain coordinates and other information like text label. Read more about CSV
[9] in Wikipedia [10].
xyz files contain 3d coordinate values.

 Real world coordinates must be chosen in Scale and Coordinate System dialog from the Map menu and
map offset must be set that the imported points are within the drawing area.

Specify the Northing, Easting and optionally the Height field. Specify the unit of measure and choose a point or text
symbol that should be assigned to the imported objects. OCAD will create point and text objects with x/y
coordinates. Height values are assigned to the objects' height property. Select an object and show Object
Information to see height value of the selected object.
After the import OCAD shows a summery about the imported points.
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CSV File Example with Comma as Separator
W13,457538.286,287921.422,105.426,A

W14,457530.267,287906.700,105.351,A

W15,457513.024,287892.899,105.736,B

W16,457509.835,287889.936,105.788,D

W17,457495.739,287896.681,106.758,C

XYZ-File Example Space as Separator and File Header
EASTING NORTHING HEIGHT

579609.39 335648.46 701.00 

579609.40 335627.71 698.79 

579609.40 335659.36 702.60 

579609.40 335729.36 711.52 

579609.40 335766.15 715.91 

579609.41 335674.01 704.39

Example
The following example shows the result of DTM xyz file import.

OCAD created for each data point a point object which are assigned to a point symbol (black dot).

https://www.ocad.com/wiki/ocad/en/index.php?title=File:XyzFileImport.png
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Converting a Layer Manually
When importing a file which is not an OCAD file, Unsymbolized Objects are created. They appear in the color
specified in OCAD Preferences.

When you select such an object, a layer name will appear on the left side of the Status Bar. To get a real map, the
layers have to be converted to OCAD symbols.
Normally you convert layers using the Convert Imported Layers to Symbols command from the Map menu. You
can also convert a layer manually:
1. Select an imported unsymbolized object. On the left side of the Status Bar the layer name is shown.
2.2. Select the corresponding OCAD symbol in the symbol box.

3. Choose the Change symbol for all objects with this symbol function in the Object menu or the  button in
the Edit Functions Toolbar.

4. Leave the preset values unchanged and click the OK button.

Back to Main Page
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Export Files
To print out a map or use it in another desktop publishing program, export it in for example PDF format.
1. Select Export in the File menu.
2. Select the area to print (Entire Map, Part of Map or One page) in the Setup field. Now place the gray frame in

the drawing window over the area you want to print out. If you cannot see the frame, click Zoom out in the View
menu until the frame becomes visible.

3. Click OK to export the map.

 If you want to export the raster background map as well, enter a resolution for it.
 File Export Information

Export AI   
(This function is not available in Draft mode. Change to Normal mode to export AI file.)

Choose this command to export the map to an AI (Adobe Illustrator) file.
After clicking OK, a file dialog box is displayed where you can enter a file name for the exported map.
The AI format is the preferred format if you want to process the map further in a graphics program. It preserves the
full graphics quality of the map. The exported file contains layers corresponding to the OCAD symbols appearing on
the map. The format is Adobe Illustrator version 7.
Part of Map Activate this check box to export a part of the map. The map section will be shown with a rectangle on
the drawing window. You can alter the rectangle with the mouse.

Click the button Setup  to define the part of map to be exported by coordinates. The dialog box Setup
Part of Map (Export) appears.

Click the button Entire map  to export the entire map.

Click the button To current view  to export the currently on the screen displayed map.
If this check box is not active the entire map will be exported.
Export scale Enter the scale for the exported map. You can enter the scale on the keyboard, or choose one of the
predefined scales.
Colors CMYK (process) colors: Select this radio button if you want to print the map using process colors. Spot
colors: Select this radio button if you want to print the map using spot colors Mode. If you choose this option, the
appearance must be specified for each spot color. Choose Spot color Mode from the Map menu to define the
appearance for the different spot colors. Activate Combine to export all selected spot colors in the same file. This is
for very special cases. Normally you should not use this option.
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Export BMP       
Choose this command to export the map to a BMP file. The Export BMP File dialog box is displayed. After
clicking OK, a file dialog box is displayed where you can enter a file name for the exported bitmap.
• Resolution: Enter here the desired resolution for the exported BMP file.
• Pixel size: Enter here the size of a pixel in the real world.
• Create World file (*.bpw): Choose this option if you want to use the exported file in a GIS (Geographical

Information System). A World file with the georeference information is created.
• Anti-Aliasing: Anti-Aliasing is method to make the edges of lines and texts appear soft. Normally you should

activate this option.
• Color correction: Activate this option to apply the same color correction as for the screen. Set up the color

correction in the OCAD Preferences from the Options menu (Category: View)
•• Part of map

Activate this check box to export a part of the map. The map section will be shown with a rectangle on the
drawing window. You can alter the rectangle with the mouse.

Click the button Setup  to define the part of map to be exported by coordinates. The dialog box Setup
Part of Map (Export) appears.

Click the button Entire map  to export the entire map.

Click the button To current view  to export the currently on the screen displayed map.
If this check box is not active the entire map will be exported.

•• Tiles

Activate this check box to export the map in tiles instead of one single file. Click the button Setup  to
define the tiles. The dialog box Setup tiles appears.
Pixel size and Create World file option are only available if Real world coordinate mode in Scale and
Coordinate System from the Map menu is activated

 The error message: "Not enough memory for exporting" appears if Windows cannot provide the memory needed.
Choose a lower raster resolution.

 The size of the exported BMP is limited to 32000 x 32000 pixels.

Export DXF    
(This function is not available in Draft mode. Change to Normal mode to export DXF file.)

(This function is not available if the map is hidden.)

Choose this command to export the entire map to a *.dxf file. After clicking OK, a file dialog box is displayed where
you can enter a filename for the exported map. The exported DXF contains only layers (corresponding to the
symbols) and coordinates, but no graphics. (That is, the appearance of the symbols is lost.) If you want to process a
map further in a graphics program, the PDF format is the preferred format. There all graphics are exported.
Export Scale

Enter the scale for the exported map. You can enter the scale on the keyboard, or choose one of the predefined
scales.

Convert text from ANSI to Unicode: Activate this option if text should be converted to the Unicode character set.
Only objects with a selected symbol: Activate this option to export only objects with a selected symbol.
CRT
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• Use CRT file: Choose this option and click the button to load a cross reference table. In a cross reference table
you can define how the OCAD symbols are translated to DXF layers. If you do not use a cross :reference table,
then the symbol numbers without decimal point are used as DXF layers (e.g. symbol 101.0 is translated to 1010).
The Load Cross Reference Table file dialog box is displayed.

• Write CRT file from symbols: Choose this option to create a CRT file from the symbol set in the same folder as
the dxf file.

Export OCAD curves as DXF splines

Activate this option if OCAD Bézier curves should be converted to DXF splines. Otherwise they are converted
to polylines.

• GIS (m): Select this radio button if you want to use the *.dxf file in a Geographic Information System (GIS). 1
unit corresponds to 1 meter in the real world. The map scale is used for the transformation.

• Paper (mm): Select this radio button if you want to use the *.dxf file in a graphics program. 1 unit corresponds to
1 mm on the map.

Export EPS       
(This function is not available in Draft mode. Change to Normal mode to export EPS file.)

Choose this command to export the map (or part of it) in the EPS format. After clicking OK, a file dialog box is
displayed where you can enter a filename for the exported map. *.eps files are mainly used to print maps on a color
copier or to make the printing films for offset printing. EPS files can be opened in Adobe Illustrator.
Part of map

Activate this check box to export a part of the map. The map section will be shown with a rectangle on the
drawing window. You can alter the rectangle with the mouse.

• Click the button Setup  to define the part of map to be exported by coordinates. The dialog box Setup Part
of Map (Export) appears.

• Click the button Entire map  to export the entire map.

• Click the button To current view  to export the currently on the screen displayed map.
If this check box is not active the entire map will be exported.

Export scale

Enter the scale for the exported map. You can enter the scale on the keyboard, or choose one of the predefined
scales. If the export scale is different from the map scale, the map and the symbols are enlarged/reduced
according to the ratio of the map and export scales.

Colors

• Color EPS (CMYK): Select this radio button to export a colored map. The color EPS contains CMYK colors. At
the service bureau color copies or films for CMYK printing can be made.

• Spot color separations: Select this option to export spot color separations. Choose Spot color Mode from the
View menu to define spot colors. When this radio button is activated and spot colors are defined, you can select
one or more of the defined spot colors in the Spot colors list box. Normally you export an EPS file for each of
these spot colors.
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Export GIF       
Choose this command to export the map as a GIF file. After clicking OK, a file dialog box is displayed where you
can enter a filename for the exported map. GIF files are used to publish small maps in the Internet. For large maps
the OIM (OCAD Internet) file format is recommended. For maps GIF offers the better compression than JPEG and
therefore gives smaller files.
• Resolution: Enter here the desired resolution for the exported GIF file.
• Pixel size: Enter here the size of a pixel in the real world.
• Create World file (*.gfw): Choose this option if you want to use the exported file in a GIS (Geographical

Information System). A World file with the georeference information is created.
Anti-Aliasing Anti-Aliasing is method to make the edges of lines and texts appear soft. Normally you should
activate this option.
Color correction Activate this option to apply the same color correction as for the screen.
Part of map Activate this check box to export a part of the map. The map section will be shown with a rectangle on
the drawing window. You can alter the rectangle with the mouse.

• Click the button Setup  to define the part of map to be exported by coordinates. The dialog box Setup Part of
Map (Export) appears.

• Click the button Entire map  to export the entire map.

• Click the button To current view  to export the currently on the screen displayed map.
If this check box is not active the entire map will be exported.

Tiles Activate this check box to export the map in tiles instead of one single file. Click the button Setup  to
define the tiles.

 Pixel size and Create World file option are only available if Real world coordinate mode in Scale and
Coordinate System from the Map menu is activated.

 The error message: "Not enough memory for exporting" appears if Windows cannot provide the memory needed.
Choose a lower raster resolution.

 The size of the exported GIF is limited to 65535 x 65535 pixels.

Export GPX      
(This function is not available if the map is hidden.)

(This function is not available for course setting projects. Use the Export Courses GPX function to export the
courses and the course setting objects in a gpx file).

Choose GPX file format to export OCAD objects as waypoints, tracks or routes that can be loaded to GPS devices.

 -Only the selected map objects are exported.
-Only point, line, text and line text objects are exported. Area objects cannot be exported to GPX.
-Export elevation of waypoints and track points if DEM is loaded.

Metadata

• Description: A description of the contents of the GPX file.
• Author: The person or organization who created the GPX file.
• Keywords: Keywords associated with the file. Search engines or databases can use this information.
Export line objects as

• Routes: Line objects are exported as routes: <rte>. A route is an ordered list of waypoints leading to a
destination.
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• Tracks: Line objects are exported as tracks: <trk>. A track is an ordered list of points describing a path.
After clicking OK, the file dialog box is displayed where you can enter a filename.

Export JPEG       
Choose this command to export the map as a JPEG file. After clicking OK, a file dialog box is displayed where you
can enter a file name for the exported map. JPEG files are used to publish small maps in the Internet. For large maps
the OIM (OCAD Internet) file format is recommended. For maps GIF offers the better compression than JPEG and
therefore gives smaller files.
• Resolution: Enter here the desired resolution for the exported JPEG file.
• Pixel size: Enter here the size of a pixel in the real world.
• Create World file (*.jgw): Choose this option if you want to use the exported file in a GIS (Geographical

Information System). A World file with the georeference information is created.
Anti-Aliasing: Anti-Aliasing is method to make the edges of lines and texts appear soft. Normally you should
activate this option. Color correction: Activate this option to apply the same color correction as for the screen.
Choose Color correction from the Options menu to setup the color correction.
Part of map: Activate this check box to export a part of the map. The map section will be shown with a rectangle on
the drawing window. You can alter the rectangle with the mouse.

Click the button Setup to define the part of map to be exported by coordinates. The dialog box Setup Part of
Map (Export) appears.
Click the button Entire map to export the entire map.
Click the button To current view to export the currently on the screen displayed map.

If this check box is not active the entire map will be exported.
Tiles: Activate this check box to export the map in tiles instead of one single file. Click the button Setup to define
the tiles. The dialog box Setup tiles appears.

 Pixel size and Create World file option are only available if Real world coordinate mode in Scale and
Coordinate System from the Map menu is activated.

 The error message: "Not enough memory for exporting" appears if Windows cannot provide the memory needed.
Choose a lower raster resolution.

 The size of the exported JPEG is limited to 65535 x 65535 pixels.

Export PNG       
Choose this command to export the map to a PNG file. The Export PNG File dialog box is displayed. After clicking
OK, a file dialog box is displayed where you can enter a file name for the exported PNG.
• Resolution: Enter here the desired resolution for the exported PNG file.
• Pixel size: Enter here the size of a pixel in the real world.
• Create World file (*.pgw): Choose this option if you want to use the exported file in a GIS (Geographical

Information System). A World file with the georeference information is created.
• Anti-Aliasing: Anti-Aliasing is method to make the edges of lines and texts appear soft. Normally you should

activate this option.
• Color correction: Activate this option to apply the same color correction as for the screen. Set up the color

correction in the OCAD Preferences from the Options menu (Category: View)
•• Part of map

Activate this check box to export a part of the map. The map section will be shown with a rectangle on the
drawing window. You can alter the rectangle with the mouse.
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Click the button Setup  to define the part of map to be exported by coordinates. The dialog box Setup
Part of Map (Export) appears.

Click the button Entire map  to export the entire map.

Click the button To current view  to export the currently on the screen displayed map.
If this check box is not active the entire map will be exported.

•• Tiles

Activate this check box to export the map in tiles instead of one single file. Click the button Setup  to
define the tiles. The dialog box Setup tiles appears.
Pixel size and Create World file option are only available if Real world coordinate mode in Scale and
Coordinate System from the Map menu is activated

 The error message: "Not enough memory for exporting" appears if Windows cannot provide the memory needed.
Choose a lower raster resolution.

 The size of the exported PNG is limited to 32000 x 32000 pixels.

Export KML    
(This function is not available if the map is hidden.)

Choose KML Google Earth (Vector) file format if you want to view the export map objects in a Earth Viewer.

 -Only the selected map objects are exported.
-Only point, line and area objects are exported. Text object cannot be exported to KML.

• Name: This is the name of the place folder in the places panel of Google Earth.
• Screen overlay: Define what an icon should be shown in top left corner of the Earth Viewer window when the

KML file is opened. This icon is not included in the KML file. An URL must be entered. The screen overlay
name is the name shown in the places panel of Google Earth

• Look at (longitude, latitude and range): Geographical coordinates and height above sea level where the viewer
should start navigating by opening Google Earth.

• Height for area objects: Set a height value for area objects to make them looking three-dimensional.
• Placemark default name: Set a default name that is shown in the places panel of Google Earth.
• Default icon for point objects: Point objects are converted to placemarks. A placemark needs an icon (small

picture). This icon is not included in the KML file. An URL must be entered. Google Earth loads the icon
dynamically when the KML file is opened.

• Compress file: Compress the file and change the extension to kmz.
After clicking OK, a file dialog box is displayed where you can enter a filename.

Export KMZ    
Choose KMZ Google Earth (Raster) to export the map as a raster KMZ file. It is possible to open the exported
KMZ file in Google Earth [1]. Like this, you can check if the scale of a map is correct.
• Opacity: Choose here the desired opacity for the exported KMZ file.
• Resolution: Enter here the desired resolution for the exported KMZ file.
• Pixel size: Enter here the size of a pixel in the real world.
• Anti-Aliasing: Anti-Aliasing is method to make the edges of lines and texts appear soft. Normally you should

activate this option.
• Color correction: Activate this option to apply the same color correction as for the screen. Set up the color

correction in the OCAD Preferences from the Options menu (Category: View)
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•• Part of map

Activate this check box to export a part of the map. The map section will be shown with a rectangle on the
drawing window. You can alter the rectangle with the mouse.

Click the button Setup  to define the part of map to be exported by coordinates. The dialog box Setup
Part of Map (Export) appears.

Click the button Entire map  to export the entire map.

Click the button To current view  to export the currently on the screen displayed map.
If this check box is not active the entire map will be exported.

•• Tiles

Activate this check box to export the map in tiles instead of one single file. Click the button Setup  to
define the tiles. The dialog box Setup tiles appears.

Garmin Custom Maps
Another possibility is to upload this kmz file on a Garmin GPS which supports 'Garmin Custom Maps'.

More about Garmin Custom Maps [2]

Tiles: Choose here between no tiles, 'Garmin Custom Maps' optimized tiles (max 1024x1024 pixels) or user-defined
tiles.
Some Garmin GPS support only a limited number of tiles in kmz file. OCAD shows the number of tiles for the
choosen export rectangle in the status bar.

After clicking OK, a file dialog box is displayed where you can enter a filename.
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Export OCAD Internet Map   
Read more about this topic on the OCAD Internet Map page.

Export PDF       
(This function is not available in Draft mode. Change to Normal mode to export PDF file.)

Choose this command to export the map to a PDF-file. After clicking OK, a file dialog box is displayed where you
can enter a filename for the exported map. You can open and print PDF files with Adobe Acrobat Reader.
Part of map Activate this check box to export a part of the map. The map section will be shown with a rectangle on
the drawing window. You can alter the rectangle with the mouse.

• Click the button Setup  to define the part of map to be exported by coordinates. The dialog box Setup Part
of Map (Export) appears.

• Click the button Entire map  to export the entire map.

• Click the button To current view  to export the currently on the screen displayed map.
If this check box is not active the entire map will be exported.
Export scale Enter the scale for the exported map. You can enter the scale on the keyboard, or choose one of the
predefined scales. If the export scale is different from the map scale, the map and the symbols are enlarged/reduced
according to the ratio of the map and export scales.
Colors

CMYK (process) solors: Select this radio button to export a color map. The color PDF contains CMYK
colors. At the service bureau color copies or films for CMYK printing can be made.
Spot color separations: Select this option to export spot color separations. Choose Spot color mode from the
View menu to define spot colors. When this radio button is activated and spot colors are defined, you can
select one or more of the defined spot colors in the Spot colors list box. Normally you export a PDF file for
each of these spot colors. Activate Combine to export all selected spot colors in the same file. This is for very
special cases. Normally you should not use this option.

Compress file: Activate this box to compress the export file. The compression does not influence the print quality.

Export Example
This is an example of an Orienteering map in the Normal View. The small watercourse is blue.

All 5 used colors (Black, Blue, Gray, Olive, Yellow) are defined as CMYK values and Spot color values in the Color
table.
The color Olive consists 50% of the spot color Green_PMS361 and 100% of Yellow_PMS136.
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The value '0' in the spot colors column means 'Knocking out'. For example the color Gray knockouts the three spot
colors Blue_PMS299, Green_PMS361, Yellow_PMS136. But the color Blue doesn't knock out the spot color
Yellow_PMS136.

In Spot color view mode OCAD simulates the spot color printing. Spot colors appear transparent to get a simulation
of the final printing result. The overlapping watercourse doesn't knockout the Yellow color bellow and appears
green.

When exporting the file as pdf and choosing the CMYK (process) colors option then OCAD ignores the spot colors.
The pdf appears in Adobe Reader as in OCAD Normal View.

When choosing the not combinded Spot colors then OCAD creates for each spot color a pdf file in grayscale. That
are the four sport colors:
•• Black_Spot
•• Blue_PMS299
•• Green_PMS361
•• Yellow_PMS136
The color Olive consists of 50% Green_PMS361 and 100% Yellow_PMS136. The gray building knockouts the other
three spot colors.
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When choosing the combinded Spot colors then OCAD creates one pdf file with the four selected spot colors. The
four single spot plates are visible in the Separations list in Adobe Acrobat Pro. Please check that the option Simulate
Overprinting is activated.

With the default settings Adobe Reader doesn't simalute the spot color printing. The yellow part of the Olive area
overlays the green part and isn't transparent.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:ExportPdfExampleSpotColorsBlack.png
https://www.ocad.com/wiki/ocad/en/index.php?title=File:ExportPdfExampleSpotColorsBlue.png
https://www.ocad.com/wiki/ocad/en/index.php?title=File:ExportPdfExampleSpotColorsGreen.png
https://www.ocad.com/wiki/ocad/en/index.php?title=File:ExportPdfExampleSpotColorsYellow.png
https://www.ocad.com/wiki/ocad/en/index.php?title=File:ExportPdfExampleSpotColorsCombinded.png


Export Files 108

Click Preferences in Edit menu. The Preferences opens. Choose the Page Display page and change the Use
Overprint Preview value from Only For PDF/X Files to Automatic.

Then Adobe Acrobat simalutes the spot color printing also for this combinded spot color pdf file.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:ExportPdfExampleSpotColorsCombindedAcrobatReader1.png
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Export Shape   
(This function is not available in Draft mode. Change to Normal mode to export Shape file.)

(This function is not available if the map is hidden.)

Choose this command to export the map in the shape format.
The shape format consists of 3 files
•• *.shp: the shape file
•• *.shx: the shape index
•• *.dbf: a dBase file
Point, line, area and texts objects must be exported separately. If you export all types totally 12 files will be
produced.
Objects In this box you select which object types should be exported. You can select one or more types by using the

 and Ctrl keys. Initially all types are selected.
Dataset Select here if all objects should be exported or only objects linked to a specified dataset.
If you select All objects the dBase file will contain an ID, the symbol number, the angle and for texts the text.
OCAD exports also elevation of line objects in TEXT1 field, if available.

 OCAD exports also the objects from visible ocd background maps.
 The text length is limited to ANSI 128 characters.

If you select Objects in dataset the dBase file will contain the information of the corresponding table.

 The text length is limited to ANSI 256 characters.
 OCAD exports the line text objects as lines. The text is in exported database.
 OCAD does not export unsymbolized objects.
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 OCAD cannot export excel tables that contain fields with user defined formats like hh:mm:ss because dBase
does no support them. Please define such columns as text fields.

Export SVG       
(This function is not available in Draft mode. Change to Normal mode to export SVG file.)

Choose this command to export the map to a SVG (Scalable Vector Graphics) file. After clicking OK, a file dialog
box is displayed where you can enter a filename for the exported map. Part of map Activate this check box to export
a part of the map. The map section will be shown with a rectangle on the drawing window. You can alter the
rectangle with the mouse.

• Click the button Setup  to define the part of map to be exported by coordinates. The dialog box Setup Part
of Map (Export) appears.

• Click the button Entire map  to export the entire map.

• Click the button To current view  to export the currently on the screen displayed map.
If this check box is not active the entire map will be exported.
Export scale Enter the scale for the exported map. You can enter the scale on the keyboard, or choose one of the
predefined scales.
Compress file Activate this box to compress the export file.

Export TIFF       
Choose this command to export the map as a TIFF file After clicking OK, a file dialog box is displayed where you
can enter a filename for the exported map.
• Resolution: Enter here the desired resolution for the exported TIFF file.
• Pixel size: Enter here the size of a pixel in the real world.
• Create World file (*.tfw): Choose this option if you want to use the exported file in a GIS (Geographical

Information System). A World file with the georeference information is created. This option is only available if
the map is georeferenced. Additional OCAD writes the georeference (map projection, coordinate systems) in the
tiff file (geotiff).

Anti-Aliasing Anti-Aliasing is method to make the edges of lines and text appear soft. Normally you should activate
this option.
Color correction Activate this option to apply the same color correction as for the screen.
Part of map Activate this check box to export a part of the map. The map section will be shown with a rectangle on
the drawing window. You can alter the rectangle with the mouse.

• Click the button Setup  to define the part of map to be exported by coordinates. The dialog box Setup Part
of Map (Export) appears.

• Click the button Entire map  to export the entire map.

• Click the button To current view  to export the currently on the screen displayed map.
If this check box is not active the entire map will be exported.

Tiles Activate this check box to export the map in tiles instead of one single file. Click the button Setup  to
define the tiles. The dialog box Setup tiles appears.
Setup Tiles This dialog box appears if you click the Setup button for Tiles in the Export panel. If you choose the 
Tiles option, the map is divided into small rectangular fields (tiles) and one file is exported for each tile. The tiles 
start from the lower left corner. To number the files, the number of the column and the number of the row are
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appended to the file name.
"filename_0_0.tif" is the tile in the lower left corner.
"filename_1_0.tif" is the tile to the right of the first tile.

All tiles have the same size, even if they extend beyond the map size or the part of map defined.
Tile size: Enter here the size of a tile.

Color

Color TIFF (RGB): Select this option to export a color map.
Compression: Choose LZW to compress the export file.
Spot color separations: Select this option to export spot color separations. Choose Spot colors Mode from the
View menu to define spot colors. When this radio button is activated and spot colors are defined, you can
select one or more of the defined spot colors in the Spot colors list box. Normally you export a TIFF file for
each of these spot colors. Activate Combine to export all selected spot colors in the same file. This is for very
special cases. Normally you should not use this option.

Color depth: Select the color depth (number of different colors to export):

CMYK (32 Bits): 4295 million colors.

RGB (24 Bits): 16 million colors.

256 colors: 8 bits with 256 colors.

Grayscale: 8 bits with 256 gray scales

Black/White: 1 bit with black or white.

Halftone screen: 1 bit with black or white.

 Pixel size and Create World file option are only available if Real world coordinate mode in Scale and Coordinate
System from the Map menu is activated.

 The error message: "Not enough memory for exporting" appears if Windows cannot provide the memory needed.
Choose a lower raster resolution.
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Export Encrypted File    
Learn more about this topic on the Encrypted OCAD File page.

Setup Part of Map
When exporting in certain file formats, you will have the option to export only a part of the map. By clicking the

 Setup button, the export area can be defined. The Setup Part of Map (Export) dialog appears.

Coordinates
Choose between Paper or Real World Coordinates.

Export map size
Reference point, width and height:

Choose the point of the map which you want to define as the reference point (e.g. upper left corner). Click one
of the nine squares.
Enter the coordinate of the chosen point.
Enter the dimension (Width and Height) of the map to be printed in m (real world coordinates) or mm (paper
coordinates).

Rectangle:
Enter the coordinate of the bottom left and the top right corner of the rectangle to be exported in m (real world
coordinates) or mm (paper coordinates).

Save

You can name the adjustments/rectangles and save them by clicking the Save button.
Load
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If there are saved settings, you can load them using the Load button or delete them using the Delete button.
Set to entire map

Click the Set to map to set the values given in the Export map size part of the dialog to the entire map
Import

You can import export-rectangles from another ocd file.
Set from selected objects

Click this option and the rectangle will be adapted to the selected objects.

Back to Main Page

References
[1] https:/ / www. google. com/ earth/
[2] http:/ / www. garmin. com/ us/ products/ onthetrail/ custommaps

OCAD Internet Map

Export OIM   

Choose Export OCAD Internet Map from File menu to export the map as OIM (OCAD Internet Map). With OIM
you can publish big OCAD maps on internet. Additionally, it is possible to display and query Points of Interest
(POI). You can insert the OCAD Internet Map to a HTML file.
• Resolution: Enter here the resolution for the map tiles (GIF).
• Part of map: Activate this check box to export a part of the map. The map section will be shown with a rectangle

on the drawing window. You can alter the rectangle with the mouse.

Click the Setup button  to define the part of map to be exported by coordinates. The dialog box Setup Part
of Map (Export) appears.

Click the Entire map button  to export the entire map.

Click the To current view button  to export the currently on the screen displayed map.
If this check box is not active the entire map will be exported.

 It is also possible to choose a defined format like A4 landscape.
-> Click Export. The Export OCAD Internet Map dialog box appears.
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OCAD Internet Map (OIM) Export Wizard

General Project Settings

•• Map title - heading of the map
•• Map subtitle - may be a copyright statement or similar
•• Choose the favoured postition of the Map tile/ Map subtitle by clicking on the corresponding button.
Base map layout:

•• Base layer name - name of the map (e.g. St. Moritz - OCAD Internet Map Example)
•• Edit layer enable - enables the users the ability to draw on the map
•• Search with selection - search only in one POI category, for example streets
•• Classic layout - use default layout for export
•• Global searchbox - search for POI's (works only with PHP support)
•• OCAD Slogan - displays OCAD slogan on your exported map

POI selection hint - change default label for POI selection hint
Search with selection heading - change default heading for Search with selection
Global search box heading - change default heading for Global search box
Search button (Global search box) - change default label for Search button

•• Create tiles - need to be selected if the map tiles should be created, otherwise only the meta files are created
-> Click Next

General project settings Zoomlevel settings

https://www.ocad.com/wiki/ocad/en/index.php?title=File%3AOIMExportAssistant1.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File%3AOIMExportAssistantZoomLevels.PNG


OCAD Internet Map 115

Zoom Level Settings

Select Zoom from and Zoom to levels which are created. Be aware that the overview map need a zoom level 0.
Generated levels are highlighted green, not created levels are grayed out. If the file is not found it is highlighted in
red.
• Relink - change the folder of all maps
• Change - change the map for the selected zoom level
• Reset all to current file - currently opened file is taken for all zoom levels
-> Click Next

Layout and Functionality Settings

Control Options:

•• Show layer selector - enables the user to select different POI groups
•• Show overview map - enables the overview map feature

Maximize overview map - shows the map maximized by default
•• Show coordinates - show coordinates in the lower right corner
•• Show permalink - enables the user the ability to link to a specific zoom, map view and layers
•• Map legend - if activated, you can select a file to display a map legend (jpg, png, gif)
•• Advertisement - if activated, you can select a file for an advertisement (jpg, png, gif)
Color and Size Settings:

•• Header text color - color of the map title
•• Header background color - background of the map title
•• Subheader font color - color of the map subtitle
•• Subheader background color - background of the map subtitle
•• Border color - border color of the map
•• Site background color - general site background
•• Font size - font size of the map title
•• Subheader font size - font size of the map subtitle (e.g. copyright)
•• Border width - thickness of the border
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Layout and settings of the OCAD Internet Map

-> Click Next

Points of Interest (POI)

Overview about all POI's exported

 Points of Interest (POI), like
Restaurants, Hotels or train stations
can only displayed in the web map, if
they have been added to the OCAD
map before.
Choose Add to add a POI layer. The
POI Selector dialog box appears:

•• Title - name of the layer
•• Dataset - dataset to choose from
•• Condition - with an SQL expression

the result set can be limited.
e.g.:
TYPE LIKE “Hotel” or
symbolnumber = 521.000

•• Location field - Name. It's the main
name of the POIs, which is shown
in the search

•• Hover title on mouseover - a tooltip will be provided if the mouse moves over the POI
•• Highlight POI through search result - an arrow will blink three times when the POI is selected from the search

box
•• Visible from zoom level - shows the entire overlay starting from the given zoom level. e.g.: show from zoom

level 3 on
•• Points of Interest type:

-Point (vector) - POIs are drawn as vector points on the map
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-Icon (information bubbles) - POIs are represented by the provided icon file
-> Click Next

POI Selector: Icon Settings (if choosen)

Icon settings (only if icon is chosen in the previous step):
• Icon - click the select button and choose a file (red background if file not found)
•• Icon offset - offset from the anchor point
•• Icon size - size of the icon (only in html, image will not be resized)
-> Click Next

POI Selector: Vector Settings (if chosen)

Vector settings (only if vector is chosen in the previous step):
•• Point fill color - represents the main color (fill color) of the vector point.
•• Point stroke color - represents the outline color
•• Point radius - size of the vector point
•• Point fill opacity - applies to the main color
•• Point stroke opacity - applies to the stroke color

 If you set both opacity values to 0, the vector points are transparent to the web map user. However,the points will
still provide information for queries and mouseover events. -> Click Next

POI Selector: General settings (if previously chosen Vecor Settings)

•• Short description - database field containing short description (important for search)
•• Description - database field containing description for the info bubble or the right info box
•• URL field - database field containing the URL
•• Link name - database field containing a link name

 If the URL should be shown select the same field as for the URL
•• Link target - link target for the browser

_blank - opens the linked target in a new window or tab
_parent - opens the linked target in the parent frame
_self - opens the linked target in the same window/tab as it was clicked
_top - opens the linked target in the full body of the window

URL, Link name and target are not mandatory fields.
-> Click Finish

POI Selector POI Icon settings (if chosen) POI Vector settings (if
chosen)

POI General settings

Choose a directory and Save the file. To see the exported internet map, open the *.html file in the browser.
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The search functionality only works on a server with PHP support otherwise the error message AJAX error: 0
occurs.

On the site HTML Entities the supported and convertable HTML characters can be seen.

 If you have stored your web map files locally, the POI will be displayed correctly only in Firefox at the moment.
However, as soon as the web map files have been uploaded on your web server, the POI are also displayed correctly
in other common browsers.

 Let’s assume you check your OIM in your browser after the export. The map tiles have been exported properly,
but there’s something wrong with your POI. So, if you re-export your map, just skip the option Create tiles in the
General project settings. The export will thereby run much faster, especially if you have big maps.

OCAD Internet Map Example St.Moritz
Example of an OCAD Internet Map export: Internet Map St. Moritz [1]

Extend OIM Functionality with Scripting
More advanced functions can be scripted. Examples can be found under OIM scripting

How To Add Second Base Map Layer to the OCAD Internet Map
•• Export two OCAD Internet Map exports with a different base map (ex. one with a topographic map and the other

with an aerial image). Save them to different folders.
• Navigate to the folder of the 2nd export and rename the sub folder map_tiles to map_tiles2.
• Copy map_tiles2 to the folder of the 1st OIM export. There should be now two sub folders map_tiles and

map_tiles2.

• Navigate from the 1st OIM export folder to the sub folder scripts and open the file BasisFunctions.js in a text
editor. Duplicate the function overlay_getTileURL and rename the 2nd to overlay_getTileURL2. Within this
''overlay_getTileURL2 function rename map_tiles to map_tiles2.
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• Open the OIM main html file from the OIM export folder in an editor and duplicate the basemap section and add
them as basemap1 and basemap2. Change the layer name for basemap2 to Orthophoto (or something else...) and
call the overlay_getTileURL2. Duplicate also map.addLayer(basemap) add it as map.addLayer(basemap1) and
map.addLayer(basemap2).

Back to Main Page

References
[1] http:/ / ocad. com/ demo/ OIM_StMoritz/ StMoritz. html
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Encrypted OCAD File
When a map is sold for example for Course Setting for Orienteering or drawing an overlay, it is possible to
encrypt the map. An encrypted OCAD map can only be loaded as a Background Map and cannot be edited. The
owner of the map can make more limitations which are described on this page.

Export an Encrypted OCAD File    
Choose the Export Encrypted File command in the File menu. The Export Encrypted File dialog appears.

• Document open password: In this field you can set a password, which is needed to load the encrypted file as a
background map. The password must have minimum four characters.

• Allow to Print and Export: Check this option to allow to print and export the map.
• Only valid for license numbers: Check this option to allow only the listed license numbers to load the map. Add

license numbers by clicking a field and typing them. You can give the permission to load your map as a
background map to maximum 16 licenses.

• Map owner name: Enter the map owner's name. This name is displayed when the encrypted file is opened.
Click the OK button to continue. The Save dialog appears. Browse a location, enter a name and click the Save
button. The Export Encrypted File dialog appears with a summary of the settings made. You can select and copy
this information and send it to the map receiver.

Load an Encrypted OCAD File      
In the OCAD Starter Edition, encrypted OCAD files can only be loaded in course setting projects.

Encrypted OCAD Files can only be loaded as Background Maps. For this purpose, choose the Open command in
the Background Map menu. The Open Background Map dialog appears. Choose the .eocd file and click the Open
button.
The following dialog appears:

https://www.ocad.com/wiki/ocad/en/index.php?title=File:Space.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Mas40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Ori40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:ExportEncryptedFile.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Space.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Mas40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Ori40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Sta40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:CS40px.PNG
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Enter the password you received from the map owner and click the OK button.
You get more information about the encrypted file by clicking the Document info button.

This dialog can also be displayed by clicking the Document info icon in the Manage Background Map dialog.

 OCAD 2019 can load only encrypted OCAD files exported from OCAD 2019. Encrypted OCAD 10, OCAD 11
or OCAD 12 files are not compatible with OCAD 2019.

Back to the Export Files page.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:EncryptedOCADFilePassword.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:EOCDDocumentInfo.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=Background_Map%23Manage_Background_Maps
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
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Send File by Email
 

Choose the Send File by Email command in the File menu to send an OCAD map, including the loaded DEM,
Databases, Background Maps and Layout Objects, by E-Mail. The Send File by Email command appears.

Enter the E-Mail address of the recipient in the To field and enter a subject. You can check all loaded DEM,
Databases, Background Maps and Layout Objects you want to add to the E-Mail. The Uncompressed file size
value shows the size of the attachment.
When you are finished, click the Open email in email client button to continue. OCAD opens the predefined E-Mail
in the standard client (e.g. Outlook, Thunderbird, etc.).

https://www.ocad.com/wiki/ocad/en/index.php?title=File:Pro40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Std40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:SendFileByEmail.PNG
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You can add text and send it.

 - Windows XP opens the email in Outlook (if installed) and not in the standard email client.
- OCAD uses the Messaging Application Programming Interface (MAPI) [1] to send the emails. Your installed
email client must support the MAPI.
- OCAD does not send the used fonts.

References
[1] http:/ / en. wikipedia. org/ wiki/ Messaging_Application_Programming_Interface

https://www.ocad.com/wiki/ocad/en/index.php?title=File:StandardClientEmail.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
http://en.wikipedia.org/wiki/Messaging_Application_Programming_Interface
http://en.wikipedia.org/wiki/Messaging_Application_Programming_Interface
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XML Script

Choose this command to execute functions whose settings are defined in a XML file.

Introduction
Select Execute XML Script from File menu or drag-and-drop then xml file to the OCAD window.
OCAD creates a log file in the temporary folder (C:\Users\USERNAME\AppData\Roaming\OCAD\OCAD
20xx\Tmp).

XML Script General

File

Node <OcadScript> Parameter Data
type

Values / Description

File.New File
MapScale
Easting
Northing
Angle

String
Integer
Integer
Integer
Double

file name of existing symbol set
10000
obsolete, use Map.ScaleAndCoordinateSystem
obsolete, use Map.ScaleAndCoordinateSystem
obsolete, use Map.ScaleAndCoordinateSystem

File.Open File
IgnoreMissingBackgroundMaps

String
Boolean

ocd file name
true, false (default: false)

File.Close Enabled Boolean true, false

File.Save Enabled Boolean true, false

File.SaveAs File String ocd file name

File.Import.Ocd File
SymbolOption
ColorOption

String
Integer
Integer

File name
[0..3]
[0, 1]

File.Import.DXF Directory
NewOffset
HorizontalOffset
VerticalOffset
Angle
MapScale

String
Boolean
Integer
Integer
Double
Integer

Directory name
ignored if NewOffset = false
ignored if NewOffset = false
ignored if NewOffset = false
ignored if NewOffset = false

File.MultipleFileImport Directory
CoordinateSystem
NewOffset
Horizontally
Vertically
Angle
MapScale
GridDistance
DatabaseType
Codepage
KeyField
LayerField
LayerField2

String
Integer
Boolean
Integer
Integer
Double
Integer
Double
Integer
Integer
String
String
String

Directory of import files
-1 = WGS 84, 1000 = existing grid of OCAD file
0 = dBase, 1 = Access 2007, 2 = Access 2003/2010, 3 = Do not create a
database
0 = Default, Codepage number
' ' = Create new key field, field name
' ' = do not import layer information, field name
' ' = do not import 2nd layer information, field name, LayerField and
LayerField2 content are concatenated by '_'

File.Exit Enabled Boolean true, false

https://www.ocad.com/wiki/ocad/en/index.php?title=File:Mas40px.png
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View

Node <OcadScript> Parameter Data type Values / Description

View.Mode Enum types normalMode, spotColorMode, draftMode

View.EntireMap Enabled Boolean true, false

View.MoveTo X
Y

Double
Double

View.Zoom Double

Map

Node <OcadScript> Parameter Data type Values / Description

Map.OptimizeRepair Enabled Boolean true, false

Map.ChangeScale NewScale
EnlargeReduceSymbols

Integer
Boolean

e. g. 10000
true, false

Map.ConvertLayer CrtFile String crt file name

Map.DeleteObjectsBySymbol SymbolNumber Double e.g. 526.002

Map.LoadSymbolsFrom File String ocd file name (with symbols to be loaded)
The option replace existing colors and symbols is used

Map.ScaleAndCoordinateSystem MapScale
Easting
Northing
Angle
CoordinateSystem

Integer
Integer
Integer
Double
Integer

e.g. 10000
e.g. 600000
e.g. 200000
e.g. 4.5
internal grid id

Map.Transform.ChangeCoordinateSystem CoordinateSystem
EastingOffset
NorthingOffset
ScaleSymbols

Integer
Integer
Integer
Boolean

internal grid id
true, false

Database

Node <OcadScript> Parameter Data type Values / Description

Database.Dataset.New DatasetName
DBaseFile
OdbcDataSource
Table
KeyField
SymbolField
TextField
SizeField
LengthUnit
AreaUnit
Decimals
HorizontalCoordinate
VerticalCoordinate
Username
Passwort

String
String
String
String
String
String
String
String
String
String
Integer
String
String
String
String

mandatory
mandatory
mandatory
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Database.Dataset.Remove Dataset String
Integer

all for all databases
3, 2, 1, ... for only one or several

Database.Assign.Symbols Dataset
CntFile

String
or Integer
String

all for all databases, dataset name
or 1, 2, 3... for only one database
Condition table file

Database.Assign.Texts Dataset
TextField
Condition
Symbol
ReplaceExistingObjects

String
or Integer
String
String
String
Boolean

all for all databases, dataset name
or 1, 2, 3... for only one database
ex. 101.0
true, false (Default)

Database.SetObjectDirection Dataset
AngleField
MathematicalFunction

String
or Integer
String
String

all for all databases, dataset name
or 1, 2, 3... for only one database
eg.: *180/3.14159

Database.CreateObjects Dataset
SelectSymbol
Condition
HorizontalCoordinate
VerticalCoordinate
Unit
TextField
HorizontalOffset
VerticalOffset

Integer
Double
String
String
String
Enum
types
String
Double
Double

1, 2, 3, ... Number of dataset
Symbol numer. ex. 207.0
SQL String (ex. SYMBOL LIKE
207.0)
Database fieldname
Database fieldname
m, km
Database fieldname

Background Map

Node <OcadScript> Parameter Data type Values / Description

BackgroundMap.Open FileName
Visible
VisibleInFavorites
Dimm
Transparent
SpotColor
Blockout
Infrared

String
Boolean
Boolean
Integer
Boolean
String
Boolean
Integer

true, false; Default = true
true, false; Default = true
[0..100]; Default = 0 [only works if Blockout is false]
true, false; Default = false [only works if Blockout is
false]
spot color name
true, false; Default = false
0=undefined, 1=32bit-infrared, 2=32bit RGB

BackgroundMap.Remove String all or filename

BackgroundMap.Reload a) String all or filename

a): Limited functionality. Not avaiable for all users.

Example
<?xml version="1.0" encoding="ISO-8859-1"?>

<!-- OCAD XML Script for multiple Shape import and assigning symbols from database -->

<OcadScript>

  <File.New>

    <!-- This path has to be adjusted before using the script! Choose a template file. -->

    <File>C:\Export\Chlosterwald.ocd</File>
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  </File.New>

  <File.MultipleFileImport>

    <!-- This path has to be adjusted before using the script! -->

    <Directory>C:\Export\Files</Directory>

    <CoordinateSystem>1000</CoordinateSystem>

    <NewOffset>true</NewOffset>

    <Horizontally>600000</Horizontally>

    <Vertically>200000</Vertically>

    <Angle>0</Angle>

    <MapScale>10000</MapScale>

    <GridDistance>500</GridDistance>

    <LayerField>OBJECTVAL</LayerField>

  </File.MultipleFileImport>

  <Database.Assign.Texts>

    <Dataset>all</Dataset>

    <Condition/>    

    <TextField>TEXT</TextField>

    <Symbol>902.000</Symbol>

    <ReplaceExistingObjects>false</ReplaceExistingObjects>

  </Database.Assign.Texts>

  <Database.Assign.Angles>

    <Dataset>all</Dataset>  

    <AngleField>ANGLE</AngleField>

  </Database.Assign.Angles>

  <Database.Assign.Symbols>

    <Dataset>all</Dataset>

    <CntFile>C:\Export\Chlosterwald.cnt</CntFile>

  </Database.Assign.Symbols>

  <Database.Dataset.Remove>

    <Dataset>all</Dataset>

  </Database.Dataset.Remove>

  <Map.OptimizeRepair>

    <Enabled>true</Enabled>

  </Map.OptimizeRepair>

  <View.EntireMap>

    <Enabled>true</Enabled>

  </View.EntireMap>

  <File.Save>

    <Enabled>false</Enabled>
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  </File.Save>

  <File.SaveAs>

    <File>C:\Export\Chlosterwald_Example.ocd</File>

  </File.SaveAs>

  <File.Close>

    <Enabled>true</Enabled>

  </File.Close>

  <File.Exit>

    <Enabled>false</Enabled>

  </File.Exit>

</OcadScript>

XML Script Thematic Maps    

Node <OcadScript> Parameter Data type Values / Description

https://www.ocad.com/wiki/ocad/en/index.php?title=File:Space.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Mas40px.png
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Thm40px.png
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File.CreateThematicMap <MapTheme>
Name
StatDataPath
StatDataTable
StatDataCommonField
VisualizeAttributes
AttributesValuesType
Classify
RepresentationFeature
GeometryDataPath
GeometryDataCommonField
JoinType
VisualizationMethod
VisualizationType
<VisualizationProperties>
ScalingMode
MaxSize
MinSize
FillColor
StrokeColor
StrokeMaxWidth
StrokeMinWidth
DecreaseStroke
ShowZeroValue
ShowNoData
Opacity
ThemeLegendTitle
</VisualizationProperties>
</MapTheme>
<MapTitleStyle>
Color
Opacity
Font
Size
isBold
isItalic
Alignment
</MapTitleStyle>
<LegendTitleStyle>
see MapTitleStyle...
</LegendTitleStyle>
<LegendTextStyle>
see MapTitleStyle...
</LegendTextStyle>
AddScaleBar
AddScaleText
AdditionalInformationText

string
string
string
string
string
ValueType
ClassifyType
RepresentationFeatureType
string
string
JoinType
VisualizationMethodType
VisualizationTypeType
ScalingModeType
double
double
FillColor
StrokeColor
double
double
boolean
boolean
boolean
integer
string
ColorType
integer
string
double
boolean
boolean
AlignmentType
...
...
boolean
boolean
string

Theme name
statistic data file path
Sheet or table for Excel or Access files
Common Id field
Attribute(s) to visualize: Ex. 2004 or
2009|2011
absolute, relative
yes, no
point, line, area
Geometry data file path
Common Id field
see Thematic Map Data Types table
see Thematic Map Data Types table
see Thematic Map Data Types table
see Thematic Map Data Types table
max. size in mm
min. size in mm
fill color: ex. C=84 M=0 Y=128 K=0
stroke color: ex. C=0 M=0 Y=0 K=255
max. stroke width in mm
min. stroke width in mm
true, false
true, false
true, false
%
ThemeLegendTitle
font color: ex. C=0 M=0 Y=0 K=255
opacity in %
font name

font size
true, false
true, false
0=align bottom left
...
...
true, false
true, false
Ex. Coordinate system: Pseudo-Mercator



XML Script 130

Thematic Map Data Types

Data type Values

ValueType absolute, relative

ClassifyType yes, no

RepresentationFeatureType point, line, area

JoinType 0=KeepAllRecords, 1=KeepOnlyMatchingRecords

VisualizationMethodType mProportionalSymbols, vmProportionalLines, vmProportionalArrows, vmGraduatedSymbols, vmGraduatedLines,
vmGraduatedArrows, vmChoropleths, vmCharts

VisualizationTypeType vtProportionalBar, vtProportionalCircle, vtProportionalSquare, vtProportionalLine, vtProportionalArrow,
vtGraduatedBar, vtGraduatedCircle, vtGraduatedSquare, vtGraduatedLine, vtGraduatedArrow, vtChoropleth,
vtPieChart, vtWingChart, vtBarChart, vtDividedPieChart, vtDividedWingChart, vtDividedBarChart,
vtStackedBarChart, vtPercentageStackedBarChart

ScalingModeType 0=scaling by representation ratio, 1=scaling by max. size

DataClassificationMethodType cmManual, cmNaturalBreaks, cmEqualIntervals, cmQuantiles

ColorType CMYK color definition [0..255]: C=84 M=0 Y=128 K=0

Thematic Map Script Examples
The following example creates a thematic map with proportional squares about the population in europe 2011.

<?xml version="1.0" encoding="UTF-8"?>

<OcadScript>

  <OcadVersion>OCAD 2018 - Mapping Solution 32-bit</OcadVersion>

 

  <File.New>

    <File>Thematic Map.ocd</File>

    <MapScale>25000000</MapScale>

  </File.New>

  <File.SaveAs>

    <File>Thematic Map Population Europe ProportionalSquare.ocd</File>

  </File.SaveAs>

  <File.CreateThematicMap>

    <MapTheme>

      <Name>Population 2011</Name>

      <StatDataPath>C:\import\population.xls</StatDataPath>

      <StatDataTable>Sheet0$</StatDataTable>

      <StatDataCommonField>id</StatDataCommonField>

      <VisualizeAttributes>2011</VisualizeAttributes>

      <AttributesValuesType>absolute</AttributesValuesType>

      <Classify>no</Classify>

      <RepresentationFeature>point</RepresentationFeature>

      <GeometryDataPath>C:\import\europe.shp</GeometryDataPath>

      <GeometryDataCommonField>ne_10m_adm</GeometryDataCommonField>

      <JoinType>0</JoinType>
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      <VisualizationMethod>vmProportionalSymbols</VisualizationMethod>

      <VisualizationType>vtProportionalSquare</VisualizationType>

      <VisualizationProperties>

        <ScalingMode>1</ScalingMode>

        <MaxSize>30.00</MaxSize>

        <MinSize>1.00</MinSize>

        <FillColor>C=84 M=0 Y=128 K=0</FillColor>

        <StrokeColor>C=0 M=0 Y=0 K=181</StrokeColor>

        <StrokeMaxWidth>0.40</StrokeMaxWidth>

        <StrokeMinWidth>0.08</StrokeMinWidth>

        <DecreaseStroke>true</DecreaseStroke>

        <ShowZeroValue>true</ShowZeroValue>

        <ShowNoData>true</ShowNoData>

        <Opacity>80</Opacity>

        <ThemeLegendTitle>Population</ThemeLegendTitle>

      </VisualizationProperties>

    </MapTheme>

    <MapTitle>Population in Europe 2011</MapTitle>

    <DefaultTextStyle>

      <Color>C=0 M=0 Y=0 K=150</Color>

      <Opacity>100</Opacity>

      <Font>Arial</Font>

      <Size>9.0</Size>

      <isBold>0</isBold>

      <isItalic>0</isItalic>

      <Alignment>0</Alignment>

    </DefaultTextStyle>

    <MapTitleStyle>

      <Opacity>80</Opacity>

      <Size>24.00</Size>

      <Alignment>1</Alignment>

    </MapTitleStyle>

    <AddThemeLegend>true</AddThemeLegend>

    <AddBasemapLegend>true</AddBasemapLegend>

    <LegendTitleStyle>

      <Size>12.0</Size>

    </LegendTitleStyle>

    <LegendTextStyle>

      <Size>9.0</Size>

    </LegendTextStyle>

    <AddScaleBar>true</AddScaleBar>

    <AddScaleText>true</AddScaleText>

    <AdditionalInformationText>OCAD ThematicMapper sample map</AdditionalInformationText>

  </File.CreateThematicMap>

  <File.Save>

    <Enabled>true</Enabled>
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  </File.Save> 

</OcadScript>

XML Script Partial Map

Node <OcadScript> Parameter Data type Values / Description

Export File
coordSystem
L, R, B, T

String
Enum
types
Float

eg.: ‚ c:\export\PartialMap1.ocd ‘
OCAD creates files
PartialMap1_#verticalPages_#horizontalPages.ocd
mm (paper, m (real world)
left, right, bottom, top

Export.loop Enabled
HorizontalPages
VerticalPages
HorizontalOverlap
VerticalOverlap

Bool
Integer
Integer
Float
Float

true, false
number of pages in horizontal direction
number of pages in vertical direction
horizontal overlap in [mm] or [m]
vertical overlap in [mm] or [m]

Example
The following example exports parts of an ocad map.
 <ocadScript>                                              // comment   

   <partialMapScript><br>

     <export id="0">                                       // first export section

       <file>c:\export\PartialMap1.ocd</file>              // export file

       <coordSystem>mm</coordSystem>                       // paper oder real world coordinates

       <T>100</T>                                          // export rectangle with Top Left point and Bottom Right point 

       <L>0</L>

       <B>50</B>

       <R>50</R>

       <loop>                                              // the loop export several ocd files. For this example 21 files.

         <enabled>true</enabled>

         <horizontalPages>7</horizontalPages>              

         <verticalPages>3</verticalPages>

         <horizontalOverlap>10</horizontalOverlap>         // horizontal and vertical overlap. 

         <verticalOverlap>10</verticalOverlap>

       </loop>

     </export>

                                              

     <export id="1">                                       // second export section

       <file>c:\export\PartialMap2.ocd</file>

       <coordSystem>mm</coordSystem>

       <L>0</L>

       <R>50</R>

       <B>50</B>

       <T>100</T>

       <loop>                                             // export only one ocd file

         <enabled>false</enabled>

       </loop>                                             
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     </export><br>

   </partialMapScript>

 </ocadScript>

XML Script Print
Print parameters can be saved in a XML script.

Node <OcadScript> Parameter Data
type

Values / Description

File.Print.Printer Name
DmPaperSize
DmDefaultSource
DmPrintQuality
DmColor
DmMediaType

String
Integer
Integer
Integer
Integer
Integer

Eg. ,HP Color LaserJet 2840 PCL'
File->Print->Save XML Script->Open the Script and depending on which printer
was choosen, the informations are there.

File.Print.Portrait Enabled Bool true, false

File.Print.SpotColor Enabled
Colors

Bool
String

true, false
Name of the spot color(s)

File.Print.PartOfMap Range
Coordinates
L, R, B, T

Integer
Enum
types
Float

1
mm (page), m (real world)
Left, Right, Bottom, Top

File.Print.HorizontalOverlap Float

File.Print.VerticalOverlap Float

File.Print.PrintScale Integer Eg. 25000

File.Print.Copies Integer Number of copies

File.Print.Intensity Integer

File.Print.LineWidth Integer

File.Print.PrintScreenGrid Enabled
PrintScreenGridColor

Bool
Integer

true, false
Ocad color number

XML Script Export
Watch out for the file endings.
Resolution is only used if File.Export.GeoRef -> Enabled = false

AI (Adobe Illustrator), PDF
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Node <OcadScript> Parameter Data type Values / Description

File.Export File
Format
Resolution
ExportScale

String
Enum types
Integer
Integer

eg.: ,c::\Export\Chlosterwald.ai‘
AI, PDF
in dpi [40..2540] (only if the map has raster background
maps)
eg. '10000' for the scale 1:10'000

File.Export.PartOfMap Enabled
Coordinates
L, R, B, T

Bool
Enum types
Float

true, false
mm (page), m (real world)
left, right, bottom, top

File.Export Colors Enum types normal, spotColors

File.Export.SpotColors Combine
Enabled

Bool
String

true, false [only if Colors = spotColors]
Spotcolor name [only if Colors = spotColors]

BMP, GIF, JPEG, PNG

Node <OcadScript> Parameter Data type Values / Description

File.Export File
Format
Quality
Resolution
Anti-Aliasing
ColorCorrection

String
Enum
types
Integer
Integer
Boolean
Boolean

eg.: ‚c:\Export\Chlosterwald.bmp‘
BMP, GIF, JPEG, PNG
only for JPEG, [0..100]
in dpi [40..2540]
true, false
true, false

File.Export.PartOfMap Enabled
Coordinates
L, R, B, T

Bool
Enum
types
Float

true, false
mm (page), m (real world)
left, right, bottom, top
for rotated maps use here the coordinate of the upper left und lower right corner

File.Export.Tiles Enabled
Width
Height

Boolean
Integer
Integer

true, false
[only if Enabled = true]
[only if Enabled = true]

File.Export.GeoRef Enabled
PixelSize
CreateWorldFile

Bool
Float
Bool

true, false
in meter [only if Enabled = true]
true, false [only if Enabled = true]

EPS

Node <OcadScript> Parameter Data type Values / Description

File.Export File
Format
ExportScale

String
Enum types
Integer

eg.: ‚c:\Export\Chlosterwald.eps ‘
EPS
e.g. '10000' for the scale 1:10'000

File.Export.PartOfMap Enabled
Coordinates
L, R, B, T

Bool
Enum types
Float

true, false
mm (page), m (real world)
left, right, bottom, top

File.Export Colors Enum types normal, spotColors

File.Export.SpotColors Enabled Spotcolor name [only if Colors = spotColors]
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SVG (Scalable Vector Graphics)

Node <OcadScript> Parameter Data type Values / Description

File.Export File
Format
ExportScale
CompressFile

String
Enum
types
Integer
Boolean

eg.: ‚c:\Export\Chlosterwald.svg
‘
SVG
e.g. '10000' for the scale
1:10'000
true, false

File.Export.PartOfMap Enabled
Coordinates
L, R, B, T

Bool
Enum
types
Float

true, false
mm (page), m (real world)
left, right, bottom, top

TIFF

Node <OcadScript> Parameter Data type Values / Description

File.Export File
Format
Resolution
Anti-Aliasing
ColorCorrection

String
Enum types
Integer
Boolean
Boolean

eg.: ‚c:\Export\Chlosterwald.tif‘
TIFF
in dpi [40..2540]
true, false
true, false

File.Export.PartOfMap Enabled
Coordinates
L, R, B, T

Bool
Enum types
Float

true, false
mm (page), m (real world)
left, right, bottom, top

File.Export.Tiles Enabled
Width
Height

Bool
Integer
Integer

true, false
[only if Enabled = true]
[only if Enabled = true]

File.Export.GeoRef Enabled
PixelSize
CreateWorldFile

Bool
Float
Bool

true, false
in meter [only if Enabled = true]
true, false [only if Enabled = true]

File.Export Colors Enum types normal, spotColors

File.Export.SpotColors Combine
Enabled

Bool
Spotcolor name

true, false [only if Colors = spotColors]
[only if Colors = spotColors]

File.Export ColorMode Integer 0 = 32 bit CMYK
1 = 24 bit RGB
2 = 256 colors
3 = grayscale
4 = 8 bit CMYK
5 = 1 bit black/white
6 = halftone screen [only if spotColor = true]

File.Export Compression Integer 1 = no compression
2 = CCITT [only used with ColorMode 5/6]
4 = FaxG4 [only used with ColorMode 5/6]
5 = LZW
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DXF

Node <OcadScript> Parameter Data type Values / Description

File.Export File
Format
ExportScale
ConvertAnsiToOem
ConvertOemToUnicode
ObjectsSelectedSymbols
AddSymbolDescription
UseCrtFileName
ExportAsSplines
Coordinates

String
Enum types
Integer
Boolean
Boolean
Boolean
Boolean
String
Boolean
Enum types

eg.: ‚c:\Export\Chlosterwald.dxf
‘
DXF
e.g. '10000' for the scale
1:10'000
true, false
true, false
true, false
true, false
eg.: ‚c:\CRT\Chlosterwald.crt‘
true, false
m, mm

Shape

Node <OcadScript> Parameter Data type Values / Description

File.Export ExportPath
File
Format
PointObjects
LineObjects
AreaObjects
TextObjects
Dataset
WordWrap
ProjectionFile
Utf8Encoding

String
String
Enum
types
Boolean
Boolean
Boolean
Boolean
String
Integer
Boolean
Boolean
Boolean

eg.: ‚c:\Export‘ (only path name)
eg.: ‚c:\Export\test.shp‘ (using ExportPath OR File, not
both)
SHAPE
true, false
true, false
true, false
true, false
all for all databases
1, 2, 3, ... for only one database
true, false
true, false
true, false

Example
The following example exports two pdf files in spot colors and two Shape files. Each OcadScript node can contain
many children.

 <?xml version="1.0" encoding="ISO-8859-1"?>

 <OcadScript>

   <File.Open>

     <File>M:\OCAD2018\Changes\11-06xx\11-0663\Chlosterwald.ocd</File>

   </File.Open>

   <File.Export>                                                                    //PDF export

     <File>M:\OCAD2018\Changes\11-06xx\11-0663\output\Chlosterwald.pdf</File>

     <Format>PDF</Format> 

     <PartOfMap>      

       <Enabled>true</Enabled>

       <Coordinates>mm</Coordinates>

       <L>0</L>
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       <R>50</R>

       <B>50</B>

       <T>100</T>

     </PartOfMap>      

     <ExportScale>10000</ExportScale>

     <Colors>spotColors</Colors> 

     <SpotColors> 

       <Combine>false</Combine>

       <Enabled>Blau</Enabled>

       <Enabled>Gelb</Enabled>

     </SpotColors> 

   </File.Export>

   <File.Export>                                                                   //Shape export

     <ExportPath>M:\OCAD2018\Changes\11-06xx\11-0663\output\</ExportPath>

     <Format>SHAPE</Format>

     <PointObjects>false</PointObjects>

     <LineObjects>true</LineObjects>

     <AreaObjects>true</AreaObjects>

     <TextObjects>false</TextObjects>

     <Dataset>all</Dataset>

     <WordWrap>true</WordWrap>

     <ProjectionFile>false</ProjectionFile>

   </File.Export>

   <File.Save>

     <Enabled>true</Enabled>

   </File.Save>

   <File.Close>

     <Enabled>true</Enabled>

   </File.Close>

 </OcadScript>

Run XML Script from the Command Line
It is possible to execute a XML script file from the command line or from batch file.
Open the Windows command and enter the OCAD program name and the xml script file. For example: "C:\Program
Files\OCAD\OCAD 2018\Ocad2018.exe" "C:\Data\ExportScriptExample_PDF.xml"
Do not forget to use the parameter <File.Open> to open the file, <File.Close> to close it and <File.Exit> to close
OCAD.
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Open ocd File from the Command Line
It is possible to open an ocd file from the command line with optional view parameters.
Open the Windows command and enter the OCAD program name and the ocd file name.
For example:

 "C:\Program Files\OCAD\OCAD 2018\Ocad2018.exe" "M:\Data\Map.ocd"

Additional OCAD supports the following optional view parameters to open an map at desired postion and view
scale.

 -c: center for view 

 -s: view scale

For example:

 "C:\Program Files\OCAD\OCAD 2018\Ocad2018.exe" -c 710000,231000 -s 2500 "M:\Data\Map.ocd" 

Back to Main Page

Create Backup

Create Backup      
To create a backup of the currently opened file:
1. Choose the Create Backup command in the File menu.
2. The Backup dialog appears.
3. OCAD creates a new folder called Backup and suggests a name for the backup file, which consists of the current

date and time and the file name. Alternatively, you can enter an own name.
4. Click the Save button to save the backup.
This function has not the same effect as the Save As function. After saving the backup you are still working on the
old file.

Back to the File page.
To the Main Page.
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Menu View

View

View Mode

There are four different view modes:

Normal Mode
In the Normal Mode the map objects appear absolutely intransparent and lie over the Background Map.

Spot Color Mode
This command gets a simulation of the spot color printing. It's enabled if at least one spot color has been defined.

Draft Mode
In the draft mode the map is displayed transparent and the background maps are visible.

Draft Mode (Only Background Map Favorites)
This view mode has the same characteristics as the Draft Mode, with the exception that only background maps
marked as favorites are displayed.
Visit the View Mode page to get more information about the view modes.

Keyline   

Visit the Keyline page to get some information about the Keyline mode.

Hatch Areas      

Visit the Hatch Areas page to get some information about the Hatch Areas mode.
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Anti-Aliasing       
Visit the Anti-Aliasing page to get some information about Anti-Aliasing.

Line Objects Appearance as in OCAD 10       
This option sets the appearance of dashed lines as it was in former OCAD versions (OCAD 10 and earlier).
This option is unchecked by default. If it is checked then dashed lines appear as in OCAD 10. If the option is
unchecked, then dashed lines' appearance is based on the new more precise calculation introduced in OCAD 11.
Please make sure that other OCAD users, who use this file with OCAD 11, have installed the latest service update.
The Line Objects Appearance as in OCAD 10 option is ignored up to and including OCAD 11.5.3. For this reason a
warning appears if this option is changed:

Example
Line Appearance in OCAD 11 and later (left image) and OCAD 10 and earlier(right image). Path and form line
dashes can be different.

 Please note that you can avoid unwanted gaps by placing dash vertices at critical places like bifurcations or tight
curves.
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Redraw       
Choose this command from the View or press the F5 key (Shortcut by default) to redraw the map on the screen.
This is especially useful when the displayed map is out of date due to editing operations (like deleting area objects).
By default, the map is redrawn automatically after editing it. If you want to disable the automatic redrawing, uncheck
the Redraw background automatically option in the View category of OCAD Preferences.

 For Windows Vista and 7 users: We recommend to use an Windows Aero Theme. You can change the theme in
Control Panel\All Control Panel Items\Personalization. The Themes Windows Basic and Windows Classic lead to
many unnecessary screen redrawings in OCAD.

Pan       

Choose Pan in the View menu, press the F6 key (Shortcut by default) or click the  Pan icon in the View
Toolbar to activate the Pan tool. With this tool you can move to another part of the map. Drag the map to the
desired location. After you dragged once the cursor changes to the previous mode (e.g. Select Object and Edit
Vertex mode). If you want to use the Pan mode several times, use the  Pan locked tool.

 You can also hold the Space key or the mouse wheel to change to Pan mode.
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Pan Locked    

Click the  Pan Locked icon in the View Toolbar to activate the Pan Locked tool. With this tool you can use the
Pan mode several times. Press the Esc key or another toolbar button to exit the Pan mode.

 You can also hold the Space key to change to Pan mode.

Move To    
Choose this command in the View menu to move the view to a desired position. The Move View To dialog appears.

Enter the Horizontal and Vertical position in real world coordinates (or paper coordinates, if no real world
coordinates are set up) and click the OK button. To set up the real world coordinates choose Scale and Coordinate
System from the Map menu.
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Find Selected Objects    

If you have objects on the map selected, choose this command in the View menu or click the  Find Selected
Objects icon in the Edit Functions Toolbar to move the view to those selected objects. The selected objects are
displayed in the middle of the drawing area.
If multiple objects are selected, you can use this function to center the view to all selected objects in sequence.

Zoom

Zoom In       

Choose the Zoom In command in the View menu, click the  Zoom In button in the View toolbar or press the F7
key (Shortcut by default) to display the map with a higher magnification. There are two options to zoom into the
map:
•• Drag a rectangle with the mouse pointer around a desired area to see this area magnified.
•• Click on the drawing area to get the double magnification of the current map view at the point you clicked.
After zooming in once, the cursor changes to the previous mode (e.g. Select Object and Edit Vertex mode).

 Alternatively, hold the Ctrl key and use the mouse wheel to zoom in and out.
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Zoom In Locked    

Click  Zoom In Locked button in the View Toolbar to use the Zoom In mode several times. Press the Esc key
or another toolbar button to exit the Zoom In mode.

Zoom Out       

Choose the Zoom Out command in the View menu, click the  Zoom Out button in the View toolbar or press the
F8 Key (Shortcut by default) to see a larger area of the map. The view is always reduced by half.

 Alternatively, hold the Ctrl key and use the mouse wheel to zoom in and out.

Zoom Out to Previous View    

Click the  Zoom Out to Previous View button in the View toolbar to reduce the view of the map to the previous
view. If there is no previous view which is smaller than the current one, this function has the same effect as the
Zoom Out function.

Zoom to Selected Objects    

If you have some objects selected, choose this command  in the View menu to zoom the view to them.

Show Entire Map       

Choose the Show Entire Map command in the View menu or click the  Show Entire Map button in the View
Toolbar to see the entire map on the screen. The scroll bars will be adjusted to the entire map.

Zoom to Previous View       

Click the  Zoom to Previous View button in the View Toolbar to change the view to the previous one. This
function is similar to the Undo function, but applies only for the view.

Zoom to Next View       

Click the  Zoom to Next View button in the View Toolbar to change the view to the next one. This function is
similar to the Redo function, but applies only for the view.

Zoom       
Choose the Zoom command in the View menu to change to one of the following zoom levels. The Shortcuts by
default are indicated in brackets.
•• 0.1x
•• 0.25x (Shift+F5)
•• 0.5x (Shift+F6)
•• 1x (Shift+F7)
•• 2x (Shift+F8)
•• 4x (Shift+F9)
•• 8x (Shift+F10)
•• 16x (Shift+F11)
•• 32x (Shift+F12)
•• 64x (Shift+Ctrl+F12)

 The current zoom level is displayed in the Status Bar.
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User Defined    
Choose the User Defined command in the View menu to change the magnification of the map to a user defined
factor. This factor can be defined in the View category of OCAD Preferences in the Options menu.

Bookmarks    
Choose the Bookmarks command in the View menu to create and manage bookmarks.
Bookmarks are stored views of the map, which can be easily retrieved. In addition, you can add a name and a
description to the bookmark.
Create a Bookmark

1.1. Zoom to the view you want to store, i.e. you want to create a bookmark.
2. Choose Bookmarks and then Create in the View menu.
3. The Create Bookmark dialog box appears.

4.4. Enter a name and a description for the bookmark.
5. Click the OK button.
Retrieve a Bookmark

1. Select Bookmarks in the View menu.
2.2. In the submenu you can see your bookmarks listed. Choose a bookmark to display the stored view of the map.

 If you have saved a comment, it is displayed in the Status Bar.
Manage Bookmarks

1. Select Bookmarks and then Manage in the View menu to manage bookmarks.
2. The Manage Bookmarks dialog appears.
3. Select a bookmark in the Name box. You have the following options now:

•• You can edit the description.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:Space.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Mas40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Ori40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=OCAD_Preferences%23View
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Space.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Mas40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Ori40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Bookmarks.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=Graphical_User_Interface%23Status_Bar


View 146

• You can delete the bookmark by clicking the Delete button.
• You can change the stored view by clicking the Update window button. The current view is overwritten with

the previous one.
4. Click the OK button to save the changes or click the Cancel button to quit the dialog without saving any
changes.

 The number of bookmarks is limited by 64.
 Bookmarks [1]

Show Screen Grid       

Enable the Show Screen Grid command in the View menu or click the  Show Screen Grid button in the View
Toolbar to show a grey grid in the drawing window.

Choose Scale and Coordinate System from the Map menu to define the screen grid distance. The color and style of
the screen grid can be changed in the OCAD Preferences.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Camera.jpg
http://ocad.com/howtos/124.htm
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Space.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Mas40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Ori40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Sta40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:View40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:CS40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_ShowGrid.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:ScreenGrid.png
https://www.ocad.com/wiki/ocad/en/index.php?title=Create_a_New_Map%23Set_Scale_and_Coordinate_System
https://www.ocad.com/wiki/ocad/en/index.php?title=OCAD_Preferences%23Screen_Grid


View 147

Show Rulers    
Click on this funktion and rulers are shown around the drawing area. Visit the Show Rulers page to get more
information.

Ruler Guides    
Add and manage vertical or horizontal ruler guides. Visit Ruler Guides for more information.

Back to Main Page

References
[1] http:/ / ocad. com/ howtos/ 124. htm

View Mode

Normal Mode       
In the Normal Mode the map objects appear absolutely intransparent and lie over the Background Map which
looks as follows:
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Spot Color Mode       
This command is enabled if at least one spot color has been defined (Define Spot Colors).
Choose this command to get a simulation of the spot color printing. Choose the Spot Colors command from the
Map menu to define how the spot colors appear on the screen.
Raster Background Maps are only visible if these are assigned to a spot color in the Background Map dialog.
OCAD Background Maps are always hidden.
Spot colors appear transparent to get a simulation of the final printing result.

Draft Mode       
Choose this command in the View menu to display the map and the Background Maps in the draft mode. The draft
mode slider  appears in the View Toolbar.
In the draft mode the map is display transparent and the background maps are visible.
With the draft mode slider you can set the transparency for the map and the background maps.
Use the upper slider (M stands for Map) for the Map and the lower slider (B stands for Background Maps) for the
Background Maps.
- 0 (slider left) means that the map is invisible.
- 100 (slider right) means full transparency.

 The draft mode replaces the Transparent Mode from OCAD 8. To set a color opacity choose the Colors
command from the Map menu. Set the opacity for each color.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:Space.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Mas40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Ori40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Sta40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:View40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:CS40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:View_SpotColorMode.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Space.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Mas40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Ori40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Sta40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:View40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:CS40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:DraftMode.JPG
https://www.ocad.com/wiki/ocad/en/index.php?title=Graphical_User_Interface%23View_Toolbar
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg


View Mode 149

Draft Mode Only Background Map Favorites    
Choose the Draft Mode (Only Background Favorites) command in the View menu to change to this view mode.
This view mode has the same characteristics as the Draft Mode, with the exception that only background maps
marked as favorites are displayed. Visit the Visibility Features article of the Background Map page to learn how to
set a background map to the favorites.

View Mode Loop    

Define View Mode Loop
With the View Mode Loop you can switch between different view modes using a Shortcut.
In the View category of the OCAD Preferences found in the Options menu you can declare which view modes
shall be included in the View Mode Loop. All four view modes are available: Normal Mode, Spot Color Mode,
Draft Mode and Draft Mode (Only Background Favorites).
Choose the Shortcuts command in the Options menu to assign a Shortcut. Search for the View - View mode loop
entry in the shortcut list. Select it and choose a shortcut from the Shortcut dropdown menu (e.g. F11). Click the
Close button to finish.
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Next View Mode in Loop
By using your defined shortcut (e.g. pressing the F11 key), you can switch between the view modes selected in
OCAD Preferences.

Back to the View page.

Keyline

Check Keyline in the View menu to change the view into Keyline mode.
This view mode reduces objects to the fundament.
•• Area objects: Only the border line is displayed in the main color of the object. White is converted to black.
•• Line objects: A thin line in the main color of the line object is displayed. White is converted to black.
•• Point objects: Instead of the point object, a cross is displayed in the main color of the symbol.
•• Text objects: Only the letter outlines appear.

 The topology of the map is shown (e.g. because of the thin lines you can distinguish if an area is completely
closed or not).

Back to the View page.

https://www.ocad.com/wiki/ocad/en/index.php?title=View%23View_Modes
https://www.ocad.com/wiki/ocad/en/index.php?title=File:KeylineExample.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Pro40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Keyline.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=View%23Keyline


Hatch Areas 151

Hatch Areas

   
Choose this mode in the View menu to hatch all area objects so that they become transparent. Other objects are
displayed normally.
This view mode is obsolete. We recommand to use the Draft mode or the Keyline mode.
Example:

 Please note that the hatched areas mode is not available for course setting projects.

Back to the View page.
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Anti-Aliasing
    

The Anti-Aliasing view option in the View menu removes the jaggies (aliasing) during the screen representation, as
the edges of the objects are smoothed.
The Anti-Aliasing mode makes the screen redraw slower.
The Anti-Aliasing mode is automatically switched off in the zoom levels higher than 16x.
The screen redrawing in Anti-Aliasing and Spot Colors mode is quite slow if the map has a lot of objects or big
raster background maps are loaded. In this case we recommend to switch off Anti-Aliasing.

Read more about Anti-Aliasing on Wikipedia [1].

Back to the View page.
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[1] http:/ / en. wikipedia. org/ wiki/ Antialiasing

https://www.ocad.com/wiki/ocad/en/index.php?title=File:Pro40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Std40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Sta40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:View40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:CS40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:AntiAliasingExample.PNG
http://en.wikipedia.org/wiki/Antialiasing
https://www.ocad.com/wiki/ocad/en/index.php?title=View%23Anti-Aliasing
http://en.wikipedia.org/wiki/Antialiasing


Show Rulers 153

Show Rulers
 

Check Show Rulers in the View menu to show rulers. They appear along the top and left side of the drawing area.
By default, the ruler's origin (0|0) is the same as the grid's point of origin. Disable Show Rulers in the View menu to
hide rulers again. Rulers are an assistance to create the map layout.

Change a ruler’s origin
1.1. Position the cursor over the intersection of the rulers in the upper-left corner of the window, and drag diagonally

down onto the image. Mark the new origin with the emerging cross hairs.

2. The dialog box Change the Ruler Origin appears.

You can also enter the position of the origin manually (in mm).
Check Move also ruler guides to move the Ruler Guides, too.
Click on Reset to global rulers to change the origin to default ((0mm|0mm), which is the center of the
map, hence the origin of the grid).

 -The rulers are not visible on exported or printed files.
-Changing the rulers does not influence the georeference.
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-The coordinates are shown in paper coordinates (mm).

To the Ruler Guides page.
Back to the View page.

Ruler Guides
 

Enable the Rulers in the View menu. Enable Show in the Ruler Guides submenu located in the View menu to
display all ruler guides in the drawing area.

Place a Ruler Guide
You have two options to place a ruler guide:
• Drag from the horizontal ruler to the drawing area to create a horizontal guide or drag from the vertical ruler to

the drawing area to create a vertical guide. The Show menu item in the Ruler Guides submenu located in the
View menu must be enabled to place ruler guides in this way.

• Choose Ruler Guides and then Manage in the View menu.
In both cases the Ruler Guides dialog appears.

'The Ruler Guides' Dialog
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'New ruler guide' Field

If you dragged the ruler guides to the drawing area the corresponding position (in mm) is shown in the New ruler
guide field. If you have chosen the second way to place ruler guides, enter there either a value (in mm) for a
horizontal or a value for a vertical ruler guide. In both ways, click the Add button in the New ruler guide field to
place the ruler guide.

'Default size' Field

In the Default size field of the Ruler Guides dialog you can place ruler guides with predefined dimensions (This is
helpful if you want for example draw and print a map in DIN A4 landscape size.) Select a size from the dropdown
list and click the Add button to place ruler guides in the chosen format. Note: The ruler's origin has to be set in the
upper left corner of the map.

'Existing ruler guides' Field

In the Existing ruler guides field in the Ruler Guides dialog you can see an overview of existing ruler guides.
Select one and click on the Delete button to delete the corresponding ruler guide.
Click on Load to to load Ruler Guides from another ocd file.
Click on Close to close the Ruler Guides dialog box and apply all changes.
Click on Cancel to close the Ruler Guides dialog without saving any changes.

 Read more about customizing the Rulers.

 Video: Rulers [1]

https://www.ocad.com/wiki/ocad/en/index.php?title=File:RulerGuideA4.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
https://www.youtube.com/watch?v=e0faGUOK6Ns


Ruler Guides 156

To the Show Rulers page.
Back to the View page.

References
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Menu Select

Select

Select and Edit Object      

Choose Select and Edit Object in the Select menu or click the Select and Edit Object icon  in the Editing and
Drawing Toolbar to select and edit an object. The cursor changes to a black arrow like on the icon  . You are
now in the Select and Edit Object mode.

•• Objects can be selected by either clicking on them or clicking outside and drawing a window over the object. You
can select multiple objects on the same time with this method.

•• While moving/stretching/rotating an object, it's new position is shown with a draft line.

Stretch an Area or Line Object

If you have Object Stretching in the Object category in OCAD Preferences activated, you can click and drag the
black squares  (stretching points) to stretch the object. If you want to keep the shape of the object drag one of the
corner points. If you drag one of the middle points, the object is distorted in the corresponding direction. If you hold
down the  key while dragging a stretching point  , the object is stretched relative to the center.
Stretching does not work for point and text objects. If you stretch line text objects, the line is stretched and not the
text.
If Object Stretching is not enabled, the stretching points  are not visible.
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Move an Object

Objects can be moved by clicking inside the object and moving the mouse after the object got selected. If the mouse
is in a correct spot, it changeds to a cross shaped cursor  .
Alternatively, click and drag one of the unfilled squares  (moving points) to move the object. Each square
represents a vertex. If a hole is selected, you can move it in the same way. Line, area and text objects don't need to be
picked by their moving points to be moved, a simple click and drag in the object is sufficent.
Objects can also be moved using the Arrow Keys. Additionally, press the Shift key to move the object faster.

Select Object and Edit Vertex      

Choose Select Object and Edit Vertex in the Select menu or click the Select Object and Edit Vertex icon  in
the Editing and Drawing Toolbar to select and edit vertices. The cursor changes to a transparent arrow like on the
icon  . You are now in the Select Object and Edit Vertex mode. Click on an object to select it.
For point objects, the middle of the symbol is represented by a large square  . For line and area objects, the first
point of the object is represented by a large square  , vertices by small squares  , and the last point of the object
by a cross X. With Bézier curves, circle symbols  are used to represent the ends of the tangents.

•• Objects can be selected by either clicking on them or clicking outside and drawing a window over the object. You
can select multiple objects on the same time with this method.

•• While moving vertices, a draft line shows the connection to the previous and next unmoved vertex.
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Move an Object

Objects can be moved by shifting vertices.
Objects can also be moved using the Arrow Keys. Additionally, press the Shift key to move the object faster.

Move Single Vertices

Once an object is selected you can move a single vertex of the selected object. Simply drag the desired point to the
new position.

 Right angles are kept by holding down SHIFT key while moving a single vertex.

Edit Vertices

Vertices are used to define the position of points, lines and areas. There are 3 types of vertices:

• Normal Vertex  Add normal vertex
• Corner Vertex  Add corner vertex
• Dash Vertex  Add dash vertex
Which type you choose Vertices is of importance, especially for dashed or dotted lines.
Read more on the Vertices page.

Edit a Bezier Vertex

Once an object containing Bezier vertices is selected you can edit those.

Drag a tangent endpoint O to edit the tangent.

Move Vertex With Arrow Keys

It is also possible to move a vertex with arrow keys. Double click on a vertex and move it then with the arrow keys.
The selected vertex gets shown a little bigger after double click.
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Move a Segment

A selected object can be changed by moving its segments. Just click on the segment and drag it.

 

 Move Line and Area Segements needs to be activated before in the OCAD Preferences.
 If a corner is rectangular, the angle will be kept and the segment can be move only along this/these straight/s.

Select and Edit Objects and Vertices - Varia

Settings for Select and Edit Objects and Vertices

If you have enabled the Auto select symbol when selecting object option in the Symbol category of OCAD
Preferences, the corresponding symbol is automatically selected when selecting an object. This does not work for a
selection of multiple objects.
Disable Context menu in drawing area in the GUI (Graphical User Interface) category of OCAD Preferences to
switch easily between the current Drawing mode and the Select Object and Edit Vertex mode by a simple click
with the right mouse button on the drawing area. If this option is enabled, the context menu appears by clicking on
the drawing area with the right mouse button. Read more about the context menu on the OCAD Preferences page.
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Select a Hole in an Area

It is possible to select a hole in an area object by clicking inside the desired hole. Only the hole and its vertices will
be selected. You can accomplish editing operations (e.g. Enlarge/Reduce, Fill, Rotate, Move or Delete) as for a
normal area object. Find more about cutting holes on the Edit Object page.

Move neighboring segments and congruent vertices    

If you have objects with congruent vertices and/or neighbouring segments, you can move their vertices and segments
together.
• For vertices, at least three congruent vertices in a row must have exactly the same position.
• For segments, at least two congruent vertices in a row must have exactly the same position.
First select the vertex or the segment to be shifted, then press the Tabulator key and move the vertex/segment.

 This function won't work if there's even a small offsett between the vertices. Use the Ctrl button for line tracing,
Snapping or the Fill function to be sure the vertices of the different objects are at exact the same place.

 Activate Move line and area segments to shift segments and Move closed start and end points of line and
area objects together in the OCAD Preferences to not get trouble if one of the three vertices is a start or end point
and.

Select and Edit Multiple Objects      

Drag an area in the  Select and Edit Object or  Select Object and Edit Vertex mode to select all objects
which are in it.
You can choose between two modes to select multiple objects in the Select category of OCAD Preferences in the
Options menu: Either all objects must be with at least one vertex in the selection or all objects must be completely in
the selection.
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Alternatively, you can select every object individually by holding the Shift key while clicking the objects (or remove
from selected objects, if already selected before).
In the  Select and Edit Object mode it is possible to enlarge or reduce a selection of objects. For that purpose,
drag one of the black squares  in the desired direction.
It is also possible to move a selection of objects in both modes. If you move the mouse over the selection the cursor
changes its appearance to  . By clicking and dragging the selection or using the arrow keys you can move it.

 Enable the Move multiple objects option in the Warnings category of OCAD Preferences to get a warning
message when you move multiple objects. Use this option in order to guard against moving multiple objects
accidentally.

Select Object with Lasso Tool    
1. Choose Select Object with Lasso Tool in the Select menu or click the Select Object with Lasso Tool icon 

in the Editing and Drawing Toolbar. The transparent arrow with a loop behind shows that you are now in the
Select Object with Lasso Tool mode.

2. Draw a Freehand line by holding down the left mouse button when moving the mouse cursor.
3.3. Finish the lasso line by leaving the left mouse key. The objects within the lasso line are selected.

 It depends from the Select Preferences if objects that are only partially within the lasso line are selected.
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Select Objects by Symbol     
Choose Select Objects by Symbol in the Select menu to select all objects with certain symbols or in a certain layer.
As an example you can select all roads. The Select By Symbol dialog box appears.

All objects with a selected symbol

Choose this option and click on the OK button to select all objects with the selected symbol(s). Select the symbol(s)
before you choose the Select Objects by Symbol command. For the example given above, select all road symbols.
All roads are selected and you can for example measure their total length or make a modification to them.

All objects in layer

If you import files like PDF, DXF, Adobe Illustrator or OpenStreetMap with layer information, the layer information
does not get lost, though OCAD does not support layers as they are known in Adobe Illustrator or similar
applications. Choose the All objects in a layer option to select all objects which are in the same layer. Choose a
layer in the dropdown list. If you have selected an object of this layer before choosing this command, the layer name
will already be filled in. For example, choose the layer which contains all the roads and click the OK button to select
all roads.

Objects without symbol

Choose this option and click on the OK button to select all Unsymbolized Objects.

Objects with unknown symbol

Choose this option and click on the OK button to select all Objects with Unknown Symbol.

Objects with invalid symbol type

Choose this option and click on the OK button to select all Objects with Invalid Symbol Type.

Graphic objects

Choose this option and click on the OK button to select all Graphic Objects.

Image objects

Choose this option and click on the OK button to select all Image Objects.
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Select Objects by Property    
Choose Select Objects by Property in the Select menu to select objects by particular properties. The Select by
Property dialog box appears.

In the Select field you can choose between different options:
• The All Objects option means that the selection is made out of all objects on the map.
• The Objects with a selected symbol option means that the selection is reduced to the objects with a symbol that

is selected in the symbol box.
• The All objects in Layer option means that the selection is made out of all objects which are in the same layer. .
• The Object without Symbol option means that the selection is made out of all Objects without Symbol.
• The Grafic Object option means that the selection is made out of all Grafic Objects.
• The Image Object option means that the selection is made out of all Image Objects.
In the Condition field you can impose conditions.
• Choose a property like Number of vertices, Elevation [m], Length [m], Area [m] or Object Type in the first

box.
• Choose an operator like < > = in the second box.
•• Enter a condition value in the third box.
Click the Select button to continue.
The Object Information table dialog box appears and the desired objects are selected. The number of selected
objects is shown in the header of the dialog. You have now different options:
• Click the Save Selection button to save the selection.
• Click the Report button to save a report in a Microsoft Excel (.xls), Text (.txt), Website (.htm) or Microsoft Word

(.doc) file.
• Click the Close button to close the dialog and return to the Select Objects by Property dialog.

 The Object Information and the Select Objects by Property dialog are non-modal dialogs. This means, that
you can edit the map without closing the dialogs. If the Object Information dialog box is opened, you can for
example select other objects on the map. The object information is refreshed automatically.
Example 1: Select all objects which are longer than 200m.
1. Choose the All objects option in the Select Objects by Property dialog.
2. In the Condition field choose Length [m] as the Property, > as an operator and enter the value 200.
3. Click on the Select button to continue. The Object Information table dialog box appears. All objects longer than

200m are selected and listed in the table dialog box.
Example 2: Select all lakes and ponds with an area smaller or equal than 3000m2.
1. Select the symbol for a lake and a pond in the symbol box. It is possible to do this even if the Select Objects by

Property dialog is opened because it is a non-modal dialog.
2. Choose the Objects with a selected symbol option in the Select Objects by Property dialog.
3. In the Condition field choose Area [m2] as the Property, <= as an operator and enter the value 3000.
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4. Click on the Select button to continue. The Object Information table dialog box appears. All lakes and ponds
with an area smaller or equal than 3000m2 are selected and listed in the table dialog box.

Select Objects by Date
With this function objects can be selected either by their Creation date or Modification date.It allso allows to differ
between All objects and All objects from selected symbols.

 All objects from selected symbols means to select only the previously selected symbol within the time frame.
1.1. Choose the Select Object by Date command from the Select menu.
2.2. A dialog appears where you can pick the date mode, enter the time frame and deside which symbols shall be

selected.

 By default, the actual date is picked.
3.3. Click the OK button to select the object(s).

The Object Information dialog appears.

 It's possible to sort the values by double clicking on the top row.
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Last Modified Objects
Click the Last modified button to select the last 100 changed objects. The Object Information dialog appears. The
objects are sorted by the Modification date.

Select Object by Object Index   
With this function objects can be selected by their object index. The object index is an internal index for each object
and cannot be changed. The object information is shown in the Object Information dialog which can be found in
the Select menu.
Choose the Select Object by Object Index command from the Select menu. A dialog appears where you can enter
the object index. Click the OK button to select the object.
The first drawn or imported object has the object index 1. The object index is a number and unique in a ocd file.

Select Duplicate Objects    
Choose this function from the Select menu.
With this function you can find all duplicate objects. The objects must be identical and on the same position that they
can be found. The selection can be saved with OCAD Mapping Solution right after carrying out the command (Save
a Selection).

 Objects with different symbols whose geometry is identical are not selected.

Select Self Intersected Objects    
Choose this function from the Select menu.
This function selects all line, area and line text objects with a self-intersecting geometry. The selection can be saved
right after carrying out the command (Save a Selection).

Select Objects with Invalid Geometry   
Choose this function from the Select menu to select all objects with invalid geometry.
The following objects are selected:
• Objects which start with a hole: OCAD selects all objects, whose first vertex has a hole flag. This can be a hole

with no exterior ring.
• Damaged Bezier curves: A Bezier curve is composed of minimum a start point, a first Bezier vertex, a second

Bezier vertex and an end point (see illustration).

If a Bezier curve has less than these vertices, it is selected.
• Line objects with invalid hole flag: A line object which contains a vertex with a hole flag is selected.
• Area object with invalid geometry: OCAD selects all area objects, whose vertices have the same coordinate.

This problem can occur when the scale is reduced.
• Line objects with the same start and end point: This problem can occur when the scale is reduced. In this case,

the start and end point of a really short line object can fall together.
• Area object with an invalid hole: A hole must have minimum three vertices. A hole with one or two vertices is

selected (see illustration).
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• Area object with an invalid exterior ring: An invalid exterior ring can be a ring with only one vertex (see
illustration).

• Graphic object with invalid object type: Graphic Objects are either areas or lines. OCAD selects all other
types.

• Object with invalid number of vertices: A line object must have minimum two vertices and an area object three.
If they have less vertices, they are selected. In addition, text and line text objects containing no text are selected.
To select line text objects with a too short line, use the Select Line Text Objects with too Short Line function.

It is difficult to get an object with invalid geometry. It can happen when you import files or change the scale.
After choosing the function, OCAD searches objects with invalid geometry, selects them and displays them in the
Object Information dialog. In addition, a text file opens with a report. This file is stored in a temporary folder.

The selected objects should be deleted, otherwise they can cause problems when exporting files like PDF or Shape.
The object index is indicated in the Object Information dialog as well as in the text file. Use the Select Object by
Object Index function to find the object later with help of the object index.
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Select Line Text Objects with Line too Short   
Choose this function from the Select menu.
This function selects all line text objects whose text is longer than the line length. This can happen when the font of a
text symbol has been increased. The selection can be saved right after carrying out the command (Save a Selection).

Select Group   
If you have Grouped objects on your map, you can select them easily by choosing the Select Group command in
the Select menu.

Select All    
Choose Select All in the Select menu to select all symbolized (also from protected and hidden symbols),
unsymbolized, graphic and image objects. Layout objects are not selected.

Clear Selection    
Choose Clear Selection in the Select menu or press the Esc key to deselect all objects.

Invert Selection    
Choose Invert Selection in the Select menu to deselect all selected objects and select all unselected object. Layout
objects are not selected.
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Select Next Object    

Select an object behind an object already selected
This menu item is only available if an object is already selected. Choose Select Next Object in the Select menu to
select an object which is behind an object that is already selected.

 To select an object behind an already selected object you can also keep the Alt or Alt Gr key pressed and click
on the already selected object.

Select next object for editing

Select a line object and choose the  Cut function. If you press the Alt key, the cursor changes to the  Select
Object and Edit Vertex mode. Keep the Alt key pressed and click the next object you want to cut. Release the Alt
key and continue with the cutting.
This works also with the Reshape function and with adding/removing Vertices.

Save Selection    
Choose Save Selection in the Select menu to save the current selection. The Save Selection dialog box appears.

Enter the name of the selection and click on the Save button.

 Choose Select Objects by Symbol in the Select menu to select all objects of the selected symbols.
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 Due to performance issues the number of objects in a selection is limited by 50'000 objects.

Reload Selection    
Choose Reload Selection in the Select menu to select all objects from a saved selection. Choose a saved selection
and the Reload Selection dialog appears.

The list of the selected objects with aditional information is shown in the dialog. The number of selected objects is
shown in the caption in brackets.
Select one object in the list and OCAD selects this object in the drawing area in the edit mode.

 The Reload Selection function selects also symbolized objects from symbols with the status Protect or Hide.

Edit Selection    
Choose Edit Selection in the Select menu to rename or delete saved selections.
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Delete a Selection

Select a selection in the Edit Selection dialog and click the Delete button to delete it. Click the Delete all button to
delete all selections.

Rename a Selection

Select a selection in the Edit Selection dialog. Then enter a new name for the selection in the Selection name field.
Click the Rename button to apply the new name.
Click the OK button to save and quit the Edit Selection dialog. Click the Cancel button to close the Edit Selection
dialog without saving any changes.

Back to Main Page
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Menu Object

Object

Cut      
Choose this command in the Object menu to cut the selected object(s). Optionally, you can press Ctrl+X. The cut
object(s) are stored in the clipboard and can be pasted again by choosing the Paste command in the Object menu or
pressing Ctrl+V.

Copy      
Choose this command in the Object menu or press Ctrl+C to copy the selected object(s) to the clipboard. A
maximum of 50 MB of data can be copied to the clipboard.

Paste      
This command is enabled in the Object menu when the clipboard contains OCAD objects or text and you are writing
text.
Choose this command to copy the object(s) in the clipboard to the current map. Alternatively, you can press Ctrl+V.
They are initially placed in the center of the screen.
Choose Cut (Ctrl+X) or Copy (Ctrl+C) from the Object menu to copy objects to the clipboard.

 When pasting an object from a different map, and the corresponding symbol does not exist in the current map,
the symbol will be added. However, if the color table is different, the object may appears in wrong colors. You will
have to adjust the colors of the newly added symbol.

Paste Text
When writing text, the text from the clipboard is inserted.
When the clipboard contains text, but you are not writing text, a dialogue window appears. In case your text contains
pairs of coordinates, you have three options:

• Move View To: Move the View so the first pair of pasted coordinates is in the center of the screen.
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• Create point objects: You need to select the desired point object beforehand in the Symbol Box. The objects will
be created at the coordinates.

• Create line or area objects: Only available if more than one pair of coordinates exists. You need to select the
desired point or area symbol beforehand in the Symbol Box. The Vertices of the line/area objects will be inserted
at the place of the coordinates.

 To use this function properly, a coordinate system has to be defined and the pasted coordinates need to fit to this
coordinate system.
Supported formats so far:

geo.admin.ch: 615'582.01, 256'284.55
geo.admin.ch: 47.45648, 7.64039
geo.admin.ch: 47°27′23.313″N 7°38′25.401″E
Google: 47.4563036,7.6405326
Google: -24.8512749,-59.8029067
OpenStreetMap: 47.45295/7.64673
OpenStreetMap: -37.762/-62.183
OpenStreetMap: 46.3103041, 4.8142705

 Video: Create Object With Pairs Of Coordinates [1]

Delete      

Choose this command in the Object menu or from the Edit Functions Toolbar  to delete the selected object(s).
Alternatively, press the Delete key on the keyboard.
When writing text, the next character or the selected text is deleted.

Back to the Edit Object page.

References
[1] https:/ / www. youtube. com/ watch?v=n-6zoQIBGMY& list=PLRHQMImiIeqFGEYQfdIRz07M6rlCX4EzS
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Edit Object

Basic Functions      

Copy and Paste

Visit the Copy and Paste page to get some information about copying and pasting objects.

Cut and Delete

Visit the Cut and Delete page to get some information about cutting and deleting objects.

Edit Vertices and Objects
Visit the Select an Object page to get all information about selecting an object.
Visit the Select and Edit Vertex page to get all information about editing vertices.

Edit Text

Choose the Select Object and Edit Vertex tool  to select the text object or the line text object. Click with the
mouse curser into the text at the position where you want to change it.

 Use double click to select a word.
 Click three times to select the whole text of an object.

Rotate

Rotate an Object      

Choose Rotate in the Rotate Object submenu of the Object menu or click the  Rotate Object icon in the
Editing and Drawing Toolbar to rotate an object. This function is only enabled when an object is selected.

The cursor changes to the anchor point symbol (  ) first. With this cursor you can define the center of the rotation
(anchor point). Click on the desired location. When the anchor point is defined, the cursor changes to the rotate

symbol (  ). Now you can rotate the object. Move the mouse pointer to a place distant from the anchor point,
press and hold the left mouse button. With the button pressed, rotate the object as desired. The object gets shown
with a draft line as "preview", until you release the mouse button to finish the rotation.
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Rotate an Object by Angle    
(This function is only enabled if one or several objects are selected)
Select Rotate (Enter Angle) in the Rotate Object submenu of the Object menu to rotate the selected object(s) by
angle. The Rotate (Enter Angle) dialog appears.
• Enter an angle in degrees.
•• Choose a rotation center option (this option is only visible if several objects are selected).

-Use selected objects centroid as common rotation center will use the selected objects centroid as one
common rotation center. This option is set by default if also line or area objects are selected.
-Use each object's centroid as rotation center will use each object's centroid as an individual rotation center.
This option is set by default if only point or text objects are selected.

• Click the OK button to finish the process.

Align Objects    

Visit the Align Objects page to find some information about the  Align Object: Horizontal Coordinate, 
Align Objects: Horizontal Coordinate Centered and the  Align Object: Vertical Coordinate function.

Distribute Objects
Theese functions distribute the selected objects with equal space between. The set borders are the upmost/leftmost
and the lowest/rightmost object.

 Distribute Objects: Horizontal Coordinate This function distributes the objects horizontally.

 Distribute Objects: Vertical Coordinate This function distributes the objects vertically.
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Indicate Direction of Area Pattern or Point or Text Object     

Choose this command either from the Objects menu or click the corresponding button  in the Editing and
Drawing Toolbar to indicate the direction of an area pattern, point or text object.
This function is only enabled if a point, area or text object is selected. Choose this function to change the direction of
a point object, of the pattern of an area object or of text. Indicate the new direction by dragging a line from the object
in the desired direction.

 
Note the difference to the Rotate button, where you first mark the anchor point and then rotate the object. In this
mode you just drag a long line for the new direction. The object remains in the same place.
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Cut a Hole or Area or Line

Visit the Cut page to get some information about the  Cut Hole,  Cut Area and the  Cut Line function.

Crop Objects     
Visit the Crop Objects page to find some information about the Crop Objects button.

Move Parallel

Visit the Move Parallel page to find some information about the  Move Parallel and the Move/Duplicate
Parallel by Specified Distance function.

Reshape    

Visit the Reshape page to find some information about the  Reshape function.

Interpolate Objects    

Visit the Interpolate Objects page to find some information about the  Interpolate Objects function.

Duplicate      

A description of the  Duplicate function can be found on the Duplicate page.

Move and Duplicate    

Visit the Move and Duplicate page to get some information about this function.

Mirror and Duplicate    

Visit the Mirror and Duplicate page to get some information about this function.

Stretch or Shrink
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You can select Objects and strech (enlarge / reduce) them. However, the objects will not stay at their original place.
To keep each object in place during the strech / shrink process, go to Stretch / Shrink in the Object menu. In the
following dialog, it's possible to define the new horizontal and vertical length (in %). By default, the Preserve
horizontal / vertical ratio option is selected.

Fill or Make Border or Duplicate Identically      

You can find this functions either in the Object menu or you can click the corresponding button  in the Edit
Functions Toolbar.
This function is enabled when an object is selected on the map and a symbol is selected in the symbol box which is
compatible with the selected object. For example, areas can be filled with other areas, or surrounded with line objects
but you cannot fill them with point objects. With this function it is possible to do several things:
•• If you use this function when you have selected an object with the same symbol as selected in the symbol box, an

identical copy of the object at the same position is made.
•• If you use this function when you have selected an object with the same symbol type as the symbol selected in the

symbol box (e.g both are area, line, text or point symbols), a copy of the object is made at the same position and
the selected symbol in the symbol box is assigned to this new object.

•• If you use this function when you have selected an area object in the drawing area and a line symbol in the
symbol box, a border line around the area object is created.

•• The other way round, if you use this function when you have selected a line object in the drawing area and an area
symbol in the symbol box, the line object is filled with the area symbol.

• If you use this function when you have selected a hole, the hole is filled if you have selected an area in the symbol
box or a border line is created if you have selected a line in the symbol box. Read more about holes here.

•• If you use this function when you have selected a line object in the drawing area and a line text object in the
symbol box, a line text symbol with the default text 'LTEXT' is created along the line object.

•• If you use this function when you have selected an text or point object, the bounding box is filled if you have
selected an area in the symbol box or a border line is created if you have selected a line in the symbol box.
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Merge      

You can find this function in the Object menu or by clicking the  Merge button in the Edit Functions Toolbar.
With this function you can merge the selected objects. It is enabled if two or more line, area or text objects with the
same symbol are selected.
Merge Line Objects
To merge line objects, the start respectively the end points of the selected lines must be close together. You can set
the merge tolerance in the Preferences. OCAD merges first objects with identically endpoints.
Merge Area Objects
To merge area objects, the selected area objects have to overlap.
Merge Text Objects
If you merge text objects, the text parts are positioned with a line break under the first text.

 When drawing line or area objects, you can continue existing line or area objects, instead of merging them
afterwards. To do this, keep the Shift key pressed and start drawing at the first or last vertex of the existing object.

 in you want line ends to coincide, but the objects shall remain independent, use the Topology#Join function.

Reverse Object Direction      

You can find this function in the Object menu or by clicking the  Reverse Object button in the Edit Functions
Toolbar.
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This function is enabled when a line, line text or area object is selected. It will reverse the direction of the object, the
first vertex becomes the last one and vice versa.
Reverse object direction function is useful for objects with asymmetrical line symbols. If a line or borderline has tags
to the right side, the tags will point to the left side after reversing. Line text appears on the other side of the line.

Change to Polyline or Bezier Curve
You can find some help about these functions on the Change to Polyline or Bezier Curve page.

Convert to

Graphic Object     

Visit the Convert into Graphic Object page to get some information about converting objects into graphic objects.

Image Object     

Visit the Convert into Image Object page to get some information about converting objects into image objects.

Layout Object    

Visit the Convert into Layout Object page to get some information about converting objects into layout objects.

Create Color Gradient    
With this function you can create a color gradient. Visit the Create Color Gradient page to get more information.

Vertices

Add Vertex

The commands for adding new vertices can be found in the Editing and Drawing Toolbar.
 Add normal vertex
 Add corner vertex
 Add dash vertex

You can find more information about adding vertices on the Vertices page.

Remove Vertex

Click the  Remove Vertex button in the Editing and Drawing Toolbar to remove a vertex.
You can find more information about removing vertices on the Vertices page.

Change Vertex Types to    

You can find this function in the Object menu. You can find more information about this function on the Vertices
page.

Change Symbol

Change Symbol of Object

 Change Symbol of Object: With this function you can change a selected object's symbol. This command is
enabled when at least one object is selected and the symbol selected in the symbol box is compatible with it.
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Change Symbol for all Objects with this Symbol

 Change Symbol for all Objects with this Symbol: This function changes all objects with a symbol A to
symbol B.
You can find more information about the  Change Symbol of Object and the  Change Symbol for all
Objects with this Symbol functions on the Change Symbol page.

Group and Ungroup    
Learn how to group and ungroup objects on the Group and Ungroup page.

Find and Replace Text   
Choose this command in the Object menu to find and replace text of objects. The Find and Replace Text dialog
box is displayed.
The texts are loaded in the text field if the map does not contain more than 50'000 objects. If you want to load the
text objects anyway then click the 'Auto fill' check box. To avoid long waiting time OCAD loads only the first 5'000
text objects in the combo box.
Find text
1.1. Enter a text you want to find.
2. If you choose the Case sensitive option, capitalization of letters is considered in the Find function.
3. Choose the Whole words only option if the Find function shall ignore parts of words.
4. Click the Find button. OCAD will select an object found. Click the Find button again to find the next object.
Click the Delete object to delete the last found, selected object.
Replace with
1. Enter a text that shall replace the word you looked for in the Find text part.
2. Click the Replace button to replace the text in the last found object. Click the Replace all button to replace every

text which matches with the Found text.
Click the Close button to quit the dialog.

 Press the Shift key when opening the dialog. Then OCAD does not load the texts in the combo box. If the map
contains several thousand text objects then the loading of the text objects needs some time (up to one minute).

 Regular expressions [1]: Please note that regular expressions use *, +, . or ? as wildcards. These charaters have
to be used with a backslash ex. \+ to find only the text objects with a + character.

 Enter #13#10 to replace some characters with a new line.

Insert Glyphs   
Visit the Insert Glyphs page to find information about glyphs in OCAD.

Measure      
Choose this command from the Object menu or click the Measure icon in the Edit Functions Toolbar. This
command is enabled when line or area objects or 2 point objects are selected.
Choose this command to measure the length of the selected line object(s), the area of the selected area object(s) or
the distance between 2 point objects. The result is displayed in the Measure Result dialog box.
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If you select multiple line or area objects (Select Multiple Objects), the displayed length respectively area is the
sum of all selected lines or areas.
The map scale is used for the calculation.
Click on the Copy button to copy the value to the Windows Clipboard.

Change Creation Date
Choose this command from the Object menu to change the creation date of the selected object(s).
1. Select the desired objects and open the Change Creation Date dialog.
2.2. Enter your desired creation date and time.

 For New date is automatically the current time and date.
3. Click OK to change the date.

This function does not change the modification date of the selected object(s).

Object Information      
Choose this command from the Object menu to get more information about the selected object(s). This command is
enabled if at least 1 object is selected.
The following information is shown in the Object Information dialog:
•• Object index (for internal use)
•• Server object index (for only internal use)
•• Object type
•• Symbol
•• Color
•• Creation date
•• Modification date
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•• Number of vertices
•• Elevation [m]
•• Length [m]
•• Area [m2]
•• Coordinates [mm] or [m] (only if 1 object is selected)

 - This is a non-modal dialog. You can always add or remove objects from a selection even if the dialog box is
opened. The information in the dialog gets updated instantly if you make any changes to the selection.

- It is possible to save a selection in the Object Information dialog when you select multiple objects (Select
Multiple Objects). Click the Save Selection button in the dialog. Learn more about saving selections on the
Save Selection page.
- Double click on a cell and press the Ctrl + C keys to copy a cell value to the Windows Clipboard.
- Click on the upper copy button to copy the object information or the lower copy button to copy coordinate
values to the clipboard.
- A double click on the top row of the collums allows to sort the values.

Back to Main Page

References
[1] http:/ / www. regular-expressions. info
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Align Objects
 

This command is only enabled if two or more objects are selected. There are three alignment options, which you can 
either choose from the Align Objects submenu of the Object menu or from the Edit Functions Toolbar. The 
allignement orientates itself on the bounding box of the objects. 

 Align Object: Horizontal Coordinate 
The selected objects are moved horizontally to the position of the first drawn object. 

  Align 
Object: Horizontal Coordinate Centered 
The selected objects are moved horizontally to the position of the first drawn object. The allignement orientates itself 
on the bounding box mass centre and not on its left side. 

  Align 
Object: Vertical Coordinate 
The selected objects are moved vertically to the position of the first drawn object.
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  For
line, area and text objects the alignment is related to the position of the objects' first vertex.

Back to the Edit Object page.

Cut
You can find the following functions in the Cut Object submenu of the Object menu or in the Editing and
Drawing Toolbar.

Cut Hole      

This function is enabled when an area object is selected.
Choose this function to cut a hole out of an area. Any drawing mode can be used (Curve, ellipse, circle etc.). This is
the procedure:
1.1. Select the object to cut a hole in.
2.2. Select a drawing mode (Curve, Ellipse, Circle etc.)

3. Choose the  Cut Hole function.
4.4. Draw the hole.

 Use Fill or Make Border to fill in the hole. 
 Change drawing mode with the Tab key before starting to cut.
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a: Cut a hole in an area object, b: Fill in a hole

Cut Area     

This function is enabled when an area object is selected.
Choose this function to split an area into two objects.
You can use the Curve, Straight line, Rectangular line or Freehand mode to split an area object into two objects.
1.1. Select the area object to cut.
2.2. Select a drawing mode (Curve, Straight line, Rectangular or Freehand).

3. Choose the  Cut Area function.
4.4. Draw the cut line. It must start at the border of the area, go across the area and end at the border of the area. The

last vertex of the cut line can be away from the border of the area.
The area is now split into two objects. Note that the cut line should not cross a hole. Otherwise the hole may not be
treated correctly for the 2 resulting objects.

 After cutting the area object always the smaller of the two new area objects is selected.
 Change drawing mode with the Tab key before starting to cut.
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Cut Line      

This function is enabled when a line or an area object with border line is selected.
Choose this function to divide a line into 2 objects or to cut a Virtual gap into a line object, i.e. the line object is not
divided, the gap concerns only graphic representation of the object.

Split a line object

Click on the desired position anywhere on the line. The line is then split into 2 objects. One of them is selected.
You can use this function to influence the dashes of a dashed line.

Split a line object with cut-out

Instead of just splitting you can create a cut-out (a gap) in the line.

1. Choose the  Cut function.
2.2. Place the mouse pointer at the start point of the cut.
3.3. Press and hold down the left mouse button.
4.4. Move the mouse pointer to the end of the cut.
5.5. Release the mouse button. The object is now divided into two and the cut-out portion is deleted.

 -If you press the Ctrl key when cutting a line, the line is not divided into 2 objects. A Virtual gap concerning
only the graphic representation of the object is inserted.

-If you press the Shift key when cutting a dashed line, you insert a gap with the same length, as the other gaps
in the dashed line.
-It is possible to cut a part of the individual sidelines of double line symbols (like major roads), without having
to cut the entire line itself.
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Cut Object      
If you are looking for help on the Cut Object function, visit the Cut Object page.

Back to the Edit Object page.

Crop Objects
  

Choose the Crop Objects command in the Object menu to crop objects. The Crop Objects dialog appears. This is a
non-modal dialog.
In the first field, choose between 3 different Objects to crop modes:

• All objects: All objects (symbolized, unsymbolized, graphic, image and layout objects) in a certain area are
cropped.

• All objects from selected symbols: All objects from selected symbols in the symbol box which are in a
certain area are cropped.

• Only chosen objects: All selected objects in the drawing area will be cropped. Click the Add selected objects
button to choose the objects.

Choose between 2 different Line or area cropping objects modes in the second field:
• Use cropping rectangle: All desired objects outside of a rectangle are cropped. Move and adjust the rectangle

to the desired position and size.
• Chosen line or area object All desired objects outside of a line or area object are cropped. Click the Choose

selected cropping object button to choose the cropping object. Check the option Delete cropping object to
delete the selected cropping template after cropping.

 The OCAD Starter edition has limited functionality. Only the Use cropping rectangle option is enabled.
Check the option Cut a hole to cut a hole instead of cropping, i.e. all desired objects inside a range are cropped.
Click the Crop button to finish.

 The number of vertices of the crop object has a big influence on the speed of this function.

Examples and Demonstrations

Create a desired sector

 Use this options from Crop Objects to crop a smaller part of the entire map.
1. Choose Crop Objects from the Object menu.
2. Choose All Objects at Objects to crop.
3.3. Draw an object which narrows the desired area or select an existing object.
4. Choose Chosen line or area object and click Choose selected cropping object.
5. Choose Delete cropping object if you want to delete the drawn cropping template afterwards.
6. Instead of using points 3 and 4 it is also possible to use the Use cropping rectangle option.
7. Click Crop and OCAD creates the area you selected.
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Create a hole
1. Choose Crop Objects from the Object menu.
2. Choose All Objects at Objects to crop.
3.3. Draw an object which narrows the desired area or select an existing object.
4. Choose Chosen line or area object and click the Choose selected cropping object button.
5. Choose Delete cropping object if you want to delete the drawn cropping template afterwards.
6. Instead of using points 3 and 4 it is also possible to use the Use cropping rectangle option.
7. Check Cut a hole.
8. Click Crop and OCAD creates a hole where you have drawn and selected the area.

Delete selected objects in a certain area
1. Choose Crop Objects from the Object menu.
2.2. Draw an object which narrows the desired area or select an existing object.
3. Choose Chosen line or area object and click the Choose selected cropping object button.
4. Instead of using point 2 and 3 it is also possible to use the Use cropping rectangle option.
5. Choose Delete cropping object if you want to delete the drawn cropping template afterwards.
6. Select All objects from selected symbols and mark the symbols in the symbol box which have to be cropped.
7. Click Crop and OCAD delete all selected symbols which you selected in the symbol box except the chosen area.

Back to the Edit Object page.
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Move Parallel and Move and Duplicate Parallel
by Specified Distance

Move Parallel     

Choose this function in the Object menu or click the  Move Parallel button in the Editing and Drawing
Toolbar. This mode is activated when a line, line text or area object is selected.
Choose this function to move a line (or the outline of an area) parallel to the original line.
1.1. Select a line, line text, or area object.

2. Choose the  Move Parallel function.
3.3. Drag a vertex of the selected object in the desired direction. A help line with vertices gives a preview of the

parallel moved object.
4.4. Drop the object to finish parallel moving.
• Hold the ALT key down to select a next object to move.
• While moving parallel, duplicate object using Shift+Ctrl key.
This mode is especially useful when writing street names on curved streets. To draw the line for the line text, follow
the center line of the street and enter the text. Then select this mode to move the text to the desired position. The line
of the text will stay parallel to the original line and follows curves so that a constant distance from the original line is
kept.
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Move and Duplicate Parallel by Specified Distance    

1. Choose the Move/Duplicate Parallel by Specified Distance function in the Object menu if you want to move a
line, line text or area object parallel with a certain distance. Point and text objects are moved according to their
direction.

2. The Move/Duplicate Parallel by Specified Distance dialog box appears.

3. Choose either the Paper (mm) or the Real world coordinates input option and enter a value in mm or in m.
4. Click the Move button to move the object, click the Duplicate button to duplicate and move the object.
5. Click the Close button to close the dialog.

 Positive values move the object to the right side, negative to the left.

Back to the Edit Object page.
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Reshape
 

With the Reshape function you can edit the shape of a line, line text or area object easily.

1. Choose the  Reshape function either in the Object menu or in the Editing and Drawing Toolbar. A line,
line text or area object must be selected.

2. Once you are in the Reshape mode, start drawing the new shape of the selected object. Reshape needs to start
and end on the shape of the selected object.

 You will be asked whether you want to continue if the end point is not placed on the shape of the selected object.

Back to the Edit Object page.

Interpolate Objects
 

This function is available if two point objects or two line objects are selected. Both line objects must have the same
number of vertices! The function can be found either in the Object menu or when you click the  Interpolate
Objects icon in the Edit Functions Toolbar.
You can either...

... interpolate line objects like contour lines or

... interpolate point objects e.g. when you want to draw an avenue.

Line objects
1.1. Create the upper line with a certain number of vertices.
2.2. Create the lowermost line with the same number of vertices like the upper line.
3. Select both lines (Select Multiple Objects).

4. Choose the  Interpolate Objects function.
5. The Interpolate Objects dialog opens.
6.6. Enter the number of objects you want to insert between the two lines.
7.7. Choose a symbol for the inserted lines.
8. Click the OK button to finish the interpolation.
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Point objects

1.1. Place two point objects in the drawing area.
2. Select both points (Select Multiple Objects).

3. Choose the  Interpolate Objects function.
4. The Interpolate Objects dialog opens.
5.5. Enter the number of objects you want to insert between the two point objects.
6.6. Choose a symbol for the inserted point objects.
7. Click the OK button to finish the interpolation.

 -Inspect the Symbol in the Interpolate Objects dialog box for correct interpolating.

-Instead of using the Interpolate Objects function for point objects it is also possible to use the  Drawing
multiple point objects tool.

Back to the Edit Object page.
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Duplicate and Move and Duplicate

Duplicate      

You can choose this function in the Object menu or by clicking the  Duplicate object icon in the Edit
Functions Toolbar.
Alternatively, press Ctrl + C and Ctrl + V.
This function is activated if at least one arbitrary object is selected.
Click this button to duplicate (create a copy of) the selected object(s). The cursor changes automatically to the Select
and Edit Object mode, which allows you to move the new objects to the desired place. Visit the Select and Edit
Object page to get some information about moving objects.

Move and Duplicate    
Choose this function in the Object menu to move and duplicate an object. This function is activated if at least one
arbitrary object is selected.
1.1. Select one or more object(s).
2. Choose the Move and Duplicate function.
3. The Move and Duplicate dialog box appears.
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4. Enter a position in Paper coordinates (mm) or Real world coordinates (m) for the moved or duplicated objects.
Alternatively, you can enter a distance (mm) and an angle.

5. Click the Move button if you want to move the objects without duplicating or click the Duplicate button if you
want to duplicate and then move the objects.

Back to the Edit Object page.
To the Mirror and Duplicate page.
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Mirror and Duplicate
 

Choose the Mirror and Duplicate function in the Object menu to mirror (and duplicate) an area or line object. The
function is available when at least one object is selected.
1. Select a line, an area object or multiple objects (Select and Edit Multiple Objects).
2. Choose the Mirror and Duplicate function.
3. The Mirror and Duplicate dialog appears.
4.4. Choose wheter the object(s) should be reflected horizontally or vertically.
5. Click the Mirror button to mirror the object(s) without duplicating them or click the Duplicate button to

duplicate and mirror the objects.
6. Click the Close button to quit the dialog.

 - Point and text objects cannot be reflected. Convert them to a Graphic Object before reflecting.

Back to the Edit Object page.
To the Duplicate page.

Convert into Graphic Object
  

Choose Convert into Graphic Object from the Object menu or click the  Convert into Graphic Object button
in the Edit Functions Toolbar to convert selected objects into graphic objects.

What is a Graphic Object?
A Graphic Object is an object which is not assigned to a symbol. It is either a line or area object with a color from 
the color table. Here are two examples:
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 Symbolized text objects are converted into
graphic area objects. A point object is taken apart in its fundamental components which are line or area objects, in
this case a blue line object (circle).
To convert a graphic object into a layout object choose the Convert into Layout Object function from the Object
menu.

Back to the Edit Object page.
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Convert into Image Object
  

Choose Convert into Image Object from the Object menu to convert selected objects into image objects.

What is a Image Object?
An Image Object is an object which is not assigned to a symbol. It is either a line or area object with a
corresponding CMYK color. Here are two examples (Symbolized objects left, image objects right):

 Symbolized text objects are
converted into image area objects. A point object is taken apart in its fundamental components which are line or area
objects, in this case a blue line object (circle).

To convert a image object into a layout object choose the Convert into Layout Object function from the
Object menu.

Back to the Edit Object page.
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Convert into Layout Object
 

Choose the Convert into Layout Object function from the Object menu to convert selected objects into layout
objects.

 Edit Layout Objects mode must be activated to be able to select and edit Layout Objects.
 Read more about Layout Objects on the Layout page.

To convert a layout object into a graphic object choose the Convert into Graphic Object function from the Object
menu.

Back to the Edit Object page.
To the Layout page.
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Change to Polyline and Change to Bezier Curve

Change to Polyline    

You can find this function in the Object menu or by clicking the  Change to Polyline button in the Edit
Functions Toolbar. This function is available when a line, area or line text object is selected.
Choose this function to change a line into a polyline. A polyline is an angular line, this means all Bezier vertices are
replaced with regular vertices.
Define the Smooth tolerance in the menu Options - OCAD Preferences - category Drawing and Editing.

Change to Bezier Curve     

You can find this function in the Object menu or by clicking the  Change to Bezier Curve button in the Edit
Functions Toolbar. This opens a dialog and is available when a line, area or line text object is selected.
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Choose this command to convert the selected polylines to Bezier curves. The quality of the Bezier curve depends on
the number of vertices of the original polylines and the tangent length factor. If the polyline has only a few vertices
the distance from the Bezier curve to the original polyline between the vertices can be much bigger than the
tolerance value. The closer the tangent length factor gets to zero, the more points are left and the curve looks more
like the polyline.

  
 The Convert polyline to curve dialog is not shown if the Shift key is pressed while clicking Change to

Bezier Curve button in the toolbar.
 If a hole inside an area object is selected, only the border of the hole is converted.

Define the Change to Bezier curve tolerance in the menu Options - OCAD Preferences - category Drawing and
Editing.

Back to the Edit Object page.
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Change Symbol

Change Symbol (Selected Objects)      

You can find this function either in the Object menu or by clicking the  Change symbol of object button in the
Edit Functions Toolbar. This command is enabled when at least one object is selected and the symbol selected in
the symbol box is compatible with it.
With this function you can change a selected object's symbol.
1.1. Select at least one object in the drawing area.
2.2. Select the new symbol in the symbol box.
3. Choose the Change Symbol (Selected Objects) function.
OCAD assigns all selected objects the new symbol.

Change Symbol (All Objects with Corresponding Symbol)     

Choose this command in the Object menu or click the  Change symbol for all objects with this symbol button
to change all objects with a symbol A to symbol B. The Change Symbol (All Objects with Corresponding
Symbol) dialog appears.
In the Change all objects with field you can choose wheter you want to change all objects with a specific symbol
number or all objects which are in an imported layer. Enter a symbol number or select an imported layer. The given
number in the box is the currently selected object.
Enter the symbol number of the new symbol. The given number in the box is the currently selected symbol in the
symbol box. Click the OK button to finish.

 This command is especially useful to translate the layers of an imported file to OCAD symbols.

Back to the Edit Object page.
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Group and Ungroup
Select this function in the Object menu to group and/or ungroup objects from the drawing area.

 -Grouped objects can be moved easily because they behave as a single object.
-In contrast to image objects the individual properties will always remain.

Group    
1. Select all objects which have to be added in one group (Select Multiple Objects).
2. Select Group in the Object menu.
3. Enter a Group name and click the Group button.

 -To select a group select Select Group in Select menu.
-If you want to edit a single object from a group, you have to ungroup first.

Ungroup     
1.1. Select the group which have to be ungrouped.
2. Select Ungroup in the Object menu.

 To add objects in an existing group, the group must be ungrouped and then grouped again.

Back to the Edit Object page.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Space.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Pro40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Ori40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=Select%23Select_and_Edit_Multiple_Objects
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Space.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Pro40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Std40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Sta40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=File:GroupUngroup.png
https://www.ocad.com/wiki/ocad/en/index.php?title=Edit_Object%23Group_and_Ungroup


Insert Glyphs 204

Insert Glyphs

The function Insert glyphs can be used to insert special characters like 2 for m2 into your text objects.
1. To insert glyphs change the Font in the Text Symbol dialog box into a font which supports the required glyphs.
2.2. Select an existing text object and set the cursor to the position you want to insert a glyph.
3. Choose the Insert Glyphs command from the Object menu.
4. The Insert Glyps dialog box appears:

5. Double click on a character to add it or select a character and click the Insert button.
6. Click the Close button to quit this dialog.

 -Only characters that are included in the character set can be added.
 -Add special characters on the right side of the dialog.
 -Glyphs can also be used in layout text objects.

Back to the Edit Object page.
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Menu Topology

Topology

Join     

Choose the  Join function in the Topology menu or in the Edit Functions Toolbar. This function is active if a
line object is selected.
Use this function to adjust adjoining line ends so that they coincide. Only line objects with the same symbol are
joined. This is especially useful when continuing a line object such as a contour. Note that the objects remain
independent objects, but the coordinates of the end vertices are equalized. If you want to merge objects, choose the
Merge command.

Automatic Joining

If you enable  Automatic Joining in the Edit Functions Toolbar, end points of lines or areas are joined
automatically when finishing drawing a line or area near another end. The Join when drawing lines tolerance can be
set in the Drawing and Editing category of the OCAD Preferences. To switch off the automatic joining temporary
during drawing, press the Shift key when terminating the line or area object.

Tolerance Value

Define how close two line end points have to be for joining them in the Drawing and Editing category of OCAD
Preferences.
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Smooth     

Visit the Smooth page to find some information about the  Smooth function.

Generalize Buildings    
Allows to simplify the building geometry or rectangle it.
1. Click on Generalize Buildings in the Topology menu. The Generalize Buildings dialog opens.
2. Choose between Geometry simplification and Rectangle option.

Geometry simplification:

• Define the angle change and the segment offset as thresholds if vertices should be deleted.
• There are also options to keep Corner vertices and Dash vertices.
Rectangle:

• Decide if each selected object will be replaced a rectangle, if all selected objects will be replaced with
one rectangle or if the selected object will be replaced with a series of rectangles. Enter the Number of
rectangles if you choose the last option.

• Enter a factor to scale the total area.

 The result of replacing three buildings with one rectangle may is better if the new area is more than
100% of the sum of the three areas because of the space between the original buildings. In such cases
often a factor of 130-140% is used.

3. Click OK
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Make Objects Rectangular    
This function allows to rectify line and area objects. Angles close to 90° are forced to be exactly 90°.

1.1. Select the object(s) that should be rectified.
2. Click on Make Objects Rectangular... in the Topology menu to open the non-modal Make Objects

Rectangular dialog.
3. Define the allowed angle tolerance as a difference from 90°. A tolerance of 10° means that all edges with an

angle change between 80 and 100° will be rectified.
4. Click on Add selected objects. This is necessary since this is a non-modal dialog.
5.5. Decide, if the selected objects shall also be orientated along a reference line.
6.6. Define the distance between the object(s) and the reference line.
7. Select the reference line object on the map and click Choose selected object as reference straight line
8. Click Execute button to execute the function.
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Close Area Objects   
Choose this function from the Topology menu.
This function closes the desired area(s).
1.1. Select the area objects to close either in the drawing area or in the symbol box. Do not select any area object if

you want to close all area objects on the map.
2. Choose the Close Area Objects command.
3. The Close Area Objects dialog appears.
4.4. Choose wheter you want to close all area objects, all area objects from the selected symbols or all selected are

objects on the map.
5. Click the OK button to finish. OCAD closes the desired areas (which means that the end and start point of an

area object have the same coordinate).

 OCAD is able to close area objects automatically when drawing. Enable the Close area objects when drawing
option in the Drawing and Editing category of OCAD Preferences to activate this function.

Change Area Objects to CCW    
Choose this function from the Topology menu.

This function changes the direction of area object to counterclockwise (CCW). You may use this funktion if you
need the border lines of many area objects being oriented to the same direction. In addition, it can be necessary if
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you export area objects to shape format, as in geodata formats area objects are defined counterclockwise. The holes
within the areas are defined clockwise.

The direction of an area object can be changed with the Reverse Object Direction function.

Lengthen Line Text Objects   
Choose this function from the Topology menu.
The function lengthens the selected line text objects by distance or a percent value of current length. The lenghtening
is always added at the end of the line text object. Choose the option Lengthen by distance or Lengthen by percent
of current length and enter the distance in mm or the percent value.

Remove Undershoots and Overshoots    
Undershoots and overshoots occur when the snap distance is either not set or is set too low for the scale being
digitized. Like this, the drawn line doesn’t connect exactly with the neighboring line it should intersect with.
You find the function Remove Overshoots and Undershoots in the Topology menu.
This function removes over- and undershoots of the selected lines. It is only enabled when at least two line objects
are selected.
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1. Select the line objects with over- and/or undershoots.
2. Choose the Remove Overshoots and Undershoots function.
3. The Remove Overshoots and Undershoots dialog box appears.
4.4. Decide wheter you want to remove overshoots, undershoots or both of them.
5.5. Define a tolerance value. This value determines how much a line must over- or undershoot so that it gets cut or

extended.
6. Click the OK button to finish.

 If you want to prevent from creating under- and overshoots, enable the Snapping function.
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Insert, Cut or Add at Intersections    
You can find this function in the Topology menu.

1. Select the line objects you want to work with. Please note that the function applies only to intersections and
self-intersections of the seleteced objects.

2. Choose the Insert, Cut or Add at Intersections function.
3. The Insert, Cut or Add at Intersections dialog appears.
4. Choose wheter you want to Insert vertex at intersections, to Cut line objects at intersections or to Add Point

object at intersections.
1. If you want a vertex at intersections, you have to choose between a Normal Vertex, a Corner Vertex or a

Dash Vertex (Read more about vertices on the Vertices page).
2.2. If you want a point object at intersections, you have to pick one.

5. If desiresd, check the Include touching objects option.

 If this option is checked, touching objects get the same reaction as intersected objects.
6. Click the OK button to finish.
This function can be useful if you want to improve the graphic appearance of dashed lines' intersections. For
example, if you insert a Dash Vertex, the intersection will be in the middle of a dash (Learn more about vertices on
the Vertices page).
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Remove Duplicate Vertices from selected Objects    
Choose the Remove Duplicate Vertices from selected Objects command in the Topology menu to remove the
duplicate (=consecutive with identical coordinates) vertices of selected objects.

Back to Main Page

Generalization
OCAD includes tools for Generalization.
Smoothing of line or area objects, using the Douglas-Peucker algorithm which removes unnecessary vertices.
Generalize Buildings: Simplify the building geometry or rectangle it.
Rectify line and area objects with the Make Objects Rectangular function.
Smooth and simplyfiy contour lines using Topographic Position Index.

Snapping
 

Click the  Snapping icon in the Edit Functions Toolbar to enable snapping.
The snapping works with unsymbolized, graphic and image objects and with objects from symbols with status
normal or protect. The snapping does not work with layout objects, objects from hiddens symbols and with
background maps.
Enter the snapping tolerance in screen pixel in OCAD Preferences in the menu Options and change Snapping
Tolerance in the category Drawing and Editing. The default value is 5 pixels.

 Press the Crtl + Alt keys to switch on the snapping temporary if the snapping mode is switched off.
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Smooth
  

Choose this command in the Topology menu or by clicking the  Smooth button in the Edit Functions Toolbar.
This command is activated when at least one line or area object is selected.
Choose this command to smooth ‘dithered’ line or area objects with the smoothing tolerance defined in the Drawing
and Editing category of OCAD Preferences (Smooth (generalization)). The Smooth function uses the
Douglas-Peucker algorithm and removes unnecessary vertices.

The Smooth function with different tolerance
levels.

1. Click Smooth to open the Smooth Objects dialog.
2.2. Enter the tolerance and decide if and under which conditions the verticles shall be kept.
3. Click OK

Back to the Topology page.
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Menu Symbol

Symbol
Symbols are used to define a map object’s graphic appearance (characteristic). For example, a tree is represented by a
green point on the map. Every map object drawn using the “tree” symbol will therefore have the same graphic
appearance. If the symbol is changed using the symbol editor, all map objects drawn using it are also changed.
OCAD provides four basic symbol types that correspond to the properties of the respective objects:

•• Point symbol
•• Line symbol
•• Area symbol
•• Text symbol

 You can get to the Symbol menu by clicking a symbol in the symbol box with the right mouse button, too.

New      
Choose this command to create a new symbol. The New Symbol dialog box is displayed. Check the desired symbol
type and click OK. A dialog box is shown where the parameters of the symbol can be defined, varying according to
the symbol type.
For basic principles see Create a New Symbol.
• Point symbol: Symbol for point objects.
• Line symbol: Symbol for line objects.
• Area symbol: Symbol for area objects.
• Text symbol: Symbol for text.

 For every text style, a separate symbol is required.
• Line text symbol: Line text symbols are used for text along curved lines.
• Rectangle symbols: Symbol for rectangular frames.

Edit      
Choose this command from the Symbol menu or click with the right mouse button on a symbol in the symbol box to
edit the currently selected symbol. According to the symbol type a dialog box is displayed where the symbol
properties can be modified:
•• Edit Point Symbols
•• Edit Line Symbols
•• Edit Area Symbols
•• Edit Text Symbols
•• Edit Line Text Symbols
•• Edit Rectangle Symbols

 If you edit a symbol, all objects on the map with this specific symbol are changed.
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Icon      
Choose this command from the Symbol menu or click with the right mouse button on a symbol in the symbol box to
draw or edit the icon for the selected symbol. The Edit Icon dialog box appears, which contains a simple paint
program to draw an icon.
Learn more about the Icon Editor on the Icon Editor page.

Enlarge Reduce      
Choose this command in the Symbol menu to enlarge or reduce the selected symbol(s) or all symbols. The Enlarge
Symbol dialog appears.
Factor

Enter here a percentage value to enlarge or reduce the symbol(s). A value of 100 means that the size of the symbol
remains the same. A value smaller than 100 means the size of the symbol is reduced, a value greater than 100 means
the size of the symbol is enlarged.
All symbols

If this check box is checked, all symbols are enlarged/reduced. If it is not checked, only the selected symbol(s) are
enlarged/reduced.
This function is disabled for course setting projects.

Copy      
Choose this command from the Symbol menu to copy the selected symbol(s) to the clipboard.
If a symbol has been copied to the clipboard, choose Paste from the Symbol menu to paste it either to the symbol
box of the original map or to the symbol box of a different map. Keep in mind that when you copy a symbol to a
different map, the colors are not copied.

Paste      
This command is activated if the clipboard contains one or more OCAD symbols.
Choose this command to paste a symbol or a group of symbols from the clipboard to the current map. If a symbol
number already exists, it is changed to the next free number. Use the Copy function from the Symbol menu to copy
symbols to the clipboard.

Delete      
Choose this command from the Symbol menu to delete the selected symbol(s). A confirmation message appears
before the symbols are removed from the symbol box.
If a deleted symbol is used in the map, the respective objects are not deleted, but appear gray as Unsymbolized
Objects.

Duplicate      
Choose this command from the Symbol menu to duplicate (create a copy of) the selected symbol(s). The duplicated
symbols get the next free symbol number.
If one symbol is selected, the duplicated symbol is inserted after the selected symbol; otherwise the duplicated
symbols are appended at the end of the symbol box.
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Sort Symbol Box    
You can sort the symbol box by various definition.
•• By Symbol Number
•• By Color
•• By Symbol Type
•• By Status (Normal, Protected or Hidden)
•• By Usage Frequency

Learn more about sorting the symbol box on the Symbol Box page.

Select
It's possible to select objects without specially clicking on them.
•• Used
•• Unused
•• Invert
•• All
•• By Symbol Number
•• By Symbol Type
•• By Status
•• By Color
•• By Fonts

Learn more about selecting symbols on the Symbol Box page.

Replace    

Replace Font in Symbols
Choose the Font function in the Replace submenu of the Symbol menu to replace a font in symbols. The Replace
Font in Symbols dialog opens.
The font can be replaced either in all symbols with a specified font (e.g. every text symbol with the font Arial gets a
new font) or in all selected symbols (All selected text objects no matter which font they have get a new font). Choose
the desired option. Afterwards, choose a new font in the New font dropdown menu and click the OK button to
finish.

Replace Color in Symbols
Choose the Color function in the Replace submenu of the Symbol menu to replace a color in symbols. The Replace
Color in Symbols dialog opens.
Choose wheter you want to replace the color in all symbols or only in the selected symbols of the symbol box. Then
select the old color in the Old color dropdown list as well as the new color in the New color dropdown list.
Click the OK button and the color is replaced.
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Symbol Status       
Each symbol has one of these four status:
•• normal (visible and selectable)
• protected (and visible). Protected means that it is not possible to select these objects by clicking on an object in

the drawing area. However you can selected these objects with other functions like Select Object by Symbol or
Select Object by Date.

•• hidden and protected
•• hidden and unprotected (former unprotected status is saved, but not selectable)

Normal (Visible and Selectable)
Choose this command in the Symbol menu to change the selected symbols to Normal. Normal symbols are neither
protected nor hidden, which means they are visible and can be selected (draw, edit, delete).

 Alternatively, you can press the F2 key (Shortcut by default) or right click into the symbolbox and select
Normal (Visible and Selectable) to set the symbol status of the selected symbols to Normal.

Protect Objects
Choose this command in the Symbol menu to protect the selected symbol(s). Objects with a protected symbol are
visible but cannot be edited.
Protected symbols appear with a gray diagonal in the symbol box.

 Alternatively, you can press the F3 key (Shortcut by default) or right click into the symbolbox and select
Protect Objects to protect the selected symbols.

Hide Objects
Choose this command in the Symbol menu to hide the selected symbols. Objects with a hidden symbol are not
visible, not printed and not exported.
Hidden symbols appear with a gray cross (x) in the symbol box.

 - There is an option in the category Warnings of the OCAD Preferences to turn on/off the warning that the map
contains hidden symbols.

- Alternatively, you can press the F4 key (Shortcut by default) or right click into the symbolbox and select
Hide Objects to hide the selected symbols.

Symbol Status Manager
Choose this command in the Symbol panel to save symbol status settings as .xml files. With the Symbol Status
Manager you can Load and Delete previously saved settings. It's even possible to Export and Import setting from
other ocad files.

Show Unsymbolized Objects      
With this menu item you can show or hide Unsymbolized Objects.

Show Graphic Objects      
With this menu item you can show or hide Graphic Objects.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:Space.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Mas40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Ori40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Sta40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:View40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:CS40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=Select%23Select_Objects_by_Symbol
https://www.ocad.com/wiki/ocad/en/index.php?title=Select%23Select_Objects_by_Date
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=Shortcuts
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=Shortcuts
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=OCAD_Preferences%23Warnings
https://www.ocad.com/wiki/ocad/en/index.php?title=Shortcuts
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Space.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Mas40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Ori40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Sta40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:View40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=Unsymbolized_Objects
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Space.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Mas40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Ori40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Sta40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:View40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=Convert_to_Graphic_Object


Symbol 218

Image Objects      
With this menu item you can show, protect or hide Image Objects.
Normal: The image objects are visible and can be edited, moved or deleted
Protect: The image objects are visible but cannot be selected, edited, moved or deleted.
Hide: The image objects are not visible.

Symbol Favorites    

Show Symbol Favorites

Display the symbol favorites in symbol box.

Add To Favorites

Add the selected symbol(s) to symbol favorites.

Remove from Symbol Favorites

Remove the selected symbol(s) from symbol favorites.
Learn more about the Symbol Favorites functions on the Symbol Box page.

Symbol Tree    

Show Symbol Tree

Display the symbol tree in symbol box.

Remove from Symbol Tree

Remove the selected symbol(s) from symbol tree.
Learn more about the Symbol Tree functions on the Symbol Box page.

Back to Main Page
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Symbol Box

Sort Symbol Box    
Choose this command from the Symbol menu to sort the symbols in the symbol box. The other way to access these
functions is to right click in the Symbol Box and the select this command.
This submenu provides multiple functions:
• By Symbol Number: The symbol box gets sorted by the symbol number, starting with the lowest number.
• By Color: The symbol box gets sorted by the order of the Map Colors. If an object uses multiple colors, the sort

uses the first to be found color.
• By Symbol Type: The symbol box gets sorted by the symbol type. Starting with point objects, then line objects,

area objects and as last text objects.
• By Status (Normal, Protected or Hidden): The symbol box gets sorted by the status of the symbols. Starting

with Normal, then Protected and finally Hidden.
• By Usage Frequency: The symbol box gets sorted by how many times a symbol got used in the map, starting

with the highest usage.

Select
Choose this command from the Symbol menu to select symbols in the symbol box. The other way to access these
functions is to right click in the Symbol Box and the select this command.
In the submenu you can find the following functions:

   
• Used: Select all symbols which are used in the map.
• Unused: Select all symbols which are not used in the map.
• Invert: Invert the selection. Selected symbols become unselected and unselected symbols become selected.
• All: Select all symbols.

 
• By Symbol Number: Select a symbol by symbol number. Choose a symbol number in the Select Symbol by

Symbol Number dialog box and click the OK button.
• By Symbol Type: Select a symbol by symbol type. Choose one or multiple symbol types in the Select Symbol by

Symbol Type dialog box and click the OK button.
• By Symbol Status: Select a symbol by its status. Choose one or multiple status in the Select Symbol by Status

dialog box and click the OK button.
• By Color: Select symbols by color. Choose a color in the Select by Color dialog box and click the OK button.

All symbols with the chosen color are selected.
• By Font: Select symbols by font. Choose a font in the Select by Font dialog box and click the OK button. All

text and line text symbols with the chosen font are selected.
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Symbol Favorites    

Show Symbol Favorites

Choose this command in the Symbol menu to display the symbol favorites
above the symbol box.

You can add often used symbols to the favorites. The Symbol Favorites
function makes the handling with large symbol sets easier.

Add to Symbol Favorites

Select the symbol(s) in the symbol box and choose the Add To Favorites
command in the Symbol menu. The Show Symbol Favorites function must
be enabled to choose this command.

 - It is also possible to add multiple objects.
- An easy way to add symbols to the favorites is to use the Symbol
menu which appears by clicking a symbol with the right mouse button.

Remove from Symbol Favorites

Select the symbol(s) in the symbol favorites or in the symbol box and choose
the Remove From Favorites command in the Symbol menu.

 - It is also possible to remove multiple objects.

- An easy way to remove symbols from the favorites is to use the
Symbol menu which appears by clicking a symbol with the right mouse
button.
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Symbol Tree    

Show Symbol Tree

Choose this command in the Symbol menu to display the symbol tree above the symbol box. You
can organize the symbols in groups (e.g. theme or colors). The symbol tree makes the handling of
large symbol sets easier.

New subgroup

Click a group in the symbol tree with the right mouse button. Choose the New subgroup
command from the popup menu. A new group is inserted as a subgroup of the selected group.
Click on the group name, wait a second, and click again to rename the group.

Insert group

Click a group in the symbol tree with the right mouse button. Choose the Insert group command
from the popup menu. A new group is inserted on the same level. Click on the group name, wait a
second, and click again to rename the group.

Delete group

Click a group in the symbol tree with the right mouse button. Choose the Delete group command
from the popup menu. The selected group is deleted and the symbols can be found in the group
Other.

Add selected symbol

Select a symbol in the symbol box. Click the group, you want to add the symbol to, with the right
mouse button and choose the Add selected symbol command from the popup menu. The selected symbol is added to
this group.

Remove selected symbol

Select a group in the symbol tree and then a symbol in symbol box. Click this group in the symbol tree with the right
mouse button. Choose the Remove selected symbol command from the popup menu. The removed symbol can be
found in the group Other again.
Alternatively, you can use the Remove from Symbol Tree function of the Symbol menu to move the selected
symbol to the group Other.

Move group

You can move a symbol tree group with drag and drop.

Change Symbol Status

You can change the symbol status of all symbols belonging to a group by choosing one of the following commands
in the Symbol Tree popup menu (right click on a symbol group).
• Normal: Set all symbols of a group to Normal status.
• Protect: Protect all symbols of a group.
• Hide: Hide all symbols of a group.
Learn more about hiding and protecting symbols on the Symbol Status page.
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 Use the small triangle before a group to expand or collapse all subgroups.

Remove from Symbol Tree
This function can be found in the Symbol menu and is an alternative to the Remove selected symbol function of the
Symbol Tree menu (right click on a symbol group). Select a symbol which is arranged in a group and choose this
function to remove the symbol from the symbol tree and move it to the group Other.

Selecting Symbols in the Symbol Box
To select one symbol, click the desired symbol.
To select a consecutive group of symbols:

1.1. Click the first symbol.
2.2. Press and hold down the Shift key on the keyboard and click the last symbol.
To select a non-consecutive group of symbols:

1.1. Click the first symbol.
2.2. Press and hold down the Ctrl key on the keyboard and click all the additional symbols.

Back to the Symbol page.

Create a New Symbol
New symbols can be created by choosing New in the Symbol menu. The New Symbol dialog box appears. Select
one of the six different symbol types.
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Create a New Point Symbol      

Visit the Create a New Point Symbol page to learn more about this function.

Create a New Line Symbol      

Visit the Create a New Line Symbol page to learn more about this function.

Create a New Area Symbol      

Visit the Create a New Area Symbol page to learn more about this function.

Create a New Text Symbol      

 
Visit the Create a New Text Symbol page to learn more about this function.
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Create a New Line Text Symbol      

Visit the Create a New Line Text Symbol page to learn more about this function.

Create a New Rectangle Symbol      

Visit the Create a New Rectangle Symbol page to learn more about this function.
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Icon Editor      
Choose the Icon command in the Symbol menu to edit the icon of the selected symbol. Alternatively, you can click
the symbol in the symbol box with the right mouse button and choose the Icon command. The Icon Editor dialog
box appears.

Draw the icon in the 22x22 matrix. You can use different drawing tools: 
 Pen: Draw single pixels 
 Line: Draw a straight line 
 Rectangle: Draw a rectangle 
 Filled Rectangle: Draw a filled rectangle 
 Ellipse: Draw an ellipse 
 Filled Circle: Draw a filled ellipse 
 Fill: Fill an area (bordering pixels with the same color) with the selected color. 

Before drawing choose one of the 26 colors. 
Alternatively, you can choose a predefined icon from the Symbol icon palette. Choose one of the colors from the 
color palette to change the color of the symbol icons. Select an icon and click the Use selected icon button or 
double-click to overwrite the current one. 
You can use the following editing tools: 

 Pick Color: Pick a color from the 22x22 drawing area 
 Select: With this tool you can select some pixels. After the selection you can move them or copy and paste 

them. 
 Rotate Counterclockwise: Rotate the whole icon counterclockwise 
 Rotate Clockwise: Rotate the whole icon clockwise 
 Copy: Copy a selection of pixels
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 Paste: Paste a selection of pixels 
 Open Paint: This button opens the Paint application of Windows. You can draw an icon in Paint. Make sure,

your Paint document has the dimensions 22x22 pixels to get a satisfying result. When you are finished with
drawing, select and copy the icon. Now you can paste it in the Icon Editor of OCAD.

 There is an easy way to get an icon for a point object. Simply use the Make screenshot for symbol icon
function in the Symbol Editor.

Define a New Color       
Learn more about colors on the Colors page of this wiki. This article shows you, how to create intersections and
overpasses for roads.
When displaying maps, OCAD uses the colors in the color table in a specific order; objects which use the lowest
colors in the table are drawn first, objects which use the colors at the top of the table are drawn last. The advantage
of this technique is that lines or areas can be omitted automatically. This is especially beneficial when drawing road
junctions (cf. below).
1. Select New in the File menu.
2.2. In the New Map dialog window, double-click empty Symbolset.ocd.
3. To edit the color table, select Colors in the Map menu.
4. To create a new color, select Add in the color table and enter the name (e.g. pictogram white foreground) and

CMYK value (e.g. blue 0/0/0/0) of the color.
5. You can change the position of the colors in the color table by clicking the Move up and Move down buttons.

 Roads are often displayed using two lines with a color filling between these lines. If two roads intersect, the side
lines in the area where the roads cross each other must be omitted.
If two roads intersect at an under or overpass, only the lines of the lower road should be omitted. By moving the
position of the color upwards or downwards, you will be able to influence these effects:
• Intersections: If the color of the filling is located above the color of the side lines in the color table, the side lines

in the area where the roads cross each other will be omitted automatically.
• Overpass: To ensure the side lines are not omitted automatically, a new color must be defined for the side lines

of the overpass. This color must be located above the filling color in the color table.

Learn more about colors on the Colors page.

 If you would like to assign a color which does not yet exist, to the new symbol, a New Color will need to be
defined.

 Each symbol must have a unique symbol number between 0.001 and 999999.999.
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Back to Main Page

Create a New Point Symbol

   
Select the New command in the Symbol menu. Choose the Point symbol option in the New Symbol dialog box to
create a new point symbol.

Point Symbol Dialog
The Point Symbol dialog appears.

 
Enter a number between 0.001 and 999999.999 in the Symbol number field.
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Enter a description of the new symbol in the Symbol description field. 
Check the Orientated to north when rotating the map option if you want that the symbol always stays orientated
to north when you use the Rotate function. 
Click the Edit button to edit the object. The Symbol Editor appears.

Symbol Editor
The main window changes to the symbol editor...
•• ... when you create or edit a point symbol.
•• ... when you create or edit a symbol for a structured line.
•• ... when you create or edit a symbol for a structured area.
When you change to the symbol editor, the magnification changes to 64x and the Anti-Aliasing is switched off. The
coordinate (0,0) is in the center of the screen. A number of menu functions are disabled when working in the symbol
editor. However, you can open and adjust a Background Map if you have a scanned image of the desired symbol.

Symbol Element Style

On the right side of the drawing area the Symbol Editor menu is
displayed. In the Symbol element style part of this menu you can
make drawing adjustments of symbol elements. 
Type 
You can choose between four symbol element types:  Line, 
Area,  Circle or  Dot (Filled Circles).. 
Color 
Choose a color from the Color dropdown menu. These colors are the
same colors as in the Colors dialog of the Map menu and have to be
defined before opening the Symbol Editor. Learn more about defining
and editing colors on the Colors page. If you draw a structure for an
area and this area has a background color, you must choose a color

https://www.ocad.com/wiki/ocad/en/index.php?title=Edit_Object%23Rotate
https://www.ocad.com/wiki/ocad/en/index.php?title=Create_a_New_Point_Symbol%23Symbol_Editor
https://www.ocad.com/wiki/ocad/en/index.php?title=File:NewPointSymbol.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File%3ASymbolElementStyle.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Linebtn.gif
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Areabtn.gif
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Circlebtn.gif
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Dotbtn.gif


Create a New Point Symbol 229

which is above the background color in the color table. Otherwise the element will be covered by it. 
 Click on the Open color dialog... button in the right of the color box to open the color dialog directly from the

symbol editor 
Line width 
If you have chosen a Line or a Circle as a symbol element type, enter a line width in mm in this field. Note that the
Line width is set to zero by default and with a Line width of zero the drawn symbol element is invisible! 
Line style 
If you have chosen a Line as a symbol element type, you can choose here how the corners and line ends of the line
symbol element shall appear. 
Diameter 
If you have chosen a Circle or a Dot as a symbol element type, enter here the diameter the symbol element is meant
to have. For circles, this diameter includes the line width of the circle line.

Draw a Symbol Element
When you made all those adjustments you can start drawing the symbol element. You can draw any number of
elements for one symbol. The number of vertices of all elements is limited by 32768.
Line: A line symbol element can be drawn with the regular drawing modes (curve, ellipse, circle etc.).
Area: An area symbol element can be drawn with the regular drawing modes (curve, ellipse, circle etc.) as well.
Circle: A circle symbol element have to be placed like a point object where the placement point is the middle of the
circle.
Dot: A dot symbol element have to be placed like a point object where the placement point is the middle of the filled
circle.
The center of the drawing area (0mm/0mm) is equal to the center of the point object.
You can change the drawn symbol elements by selecting them and making adjustments in the Symbol Editor menu.
Click the Change button at the bottom of the Symbol element style field to apply all changes to the symbol
elements. It is also possible to add or remove vertices (Vertices) or use nearly all editing functions (Edit Object).

Scale Selected Symbol Element

In the Scale selected symbol element part of the Symbol Editor menu
you can scale the selected symbol element(s):
Scale factor: Enter a scale factor in percentage.
Scale center: Use either the center of the symbol (center of the
drawing area (0/0)) or the center of the symbol element (x/y) as a scale
center.
Scale line width: Check this option to extend or reduce also the line
width.
Click the Scale up/down button to scale the selected symbol
element(s).

Select a symbol element and click the Center selected symbol
element button to move it to the center of the drawing area (equals
center of the symbol).
Click the Generate symbol icon button to make a screenshot and use it as symbol icon.
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Draw Symbols for Structured Lines
When drawing symbols for a line, imagine that the line goes from left to right on the x-axis. If you want a tag to
point to the right side of the line, draw it downwards from the origin (0, 0); if it should point to the left side, draw it
upwards.

Draw Symbols for Structured Areas
If the area symbol has a background color, this background color is also shown. Note that the background color must
be below the color of any elements in the color table, otherwise these elements are covered by the background color.
When you draw an element, it is also shown in gray in the neighboring fields to get a better impression of the
structure.
Click the Close button when you are finished with drawing the symbol. The Point Symbol dialog box appears again.
Click the Icon button to edit the icon manually in the Icon Editor. Click the OK button to save all changes and quit
the dialog. The new symbol appears in the symbol box.

Examples

Create a Point Symbol out of Vector Data
With OCAD it is possible to import a vector image (for example a logo or a pictogram) and convert it into a symbol.
In this example the US National Park Service Pictograms are imported.

 Video on YouTube how to Create a Point Symbol out of Vector Data [1].
1. Open a project.
2. First we import the vector image. Choose the Import command from the File menu.
3. Browse the vector image file and click the Open button.
4. The Save Cross Reference Table dialog appears. It is not neccessary to save one, therefore click the Cancel

button.
5.5. OCAD imports the file. In this example a PDF-File is imported which contains exclusively vector data.
6. The PDF-File appears in the drawing area. The vector objects are displayed as Image Objects, which looks like a

huge mess.
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7.7. Search the pictograph in this chaos you want to create a symbol of. If you have troubles finding the desired
pictograph, a look at the original PDF-File can probably help.

8.8. Select all pictopraphs you want to create symbols of and delete the other ones.
9.9. In this case the symbol for the airport was chosen, which looks still as follows:
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10. Now, it is time to define the Colors. Choose the Colors item from the Map menu and add two new colors: A
white color for the plane and a black color for the background. Make sure that the white color is above the black
one.

11. Click the Close button.
12. Area symbols have to be defined now. Click in the Symbol Box with the right mouse button and choose the

New command.
13. In the next dialog, choose the Area Symbol item and click the OK button.
14. The Area Symbol dialog appears. Adjust all parameters as desired. At least, the Fill option must be checked and

the in the Fill color list, White must be chosen. Then click the OK button.

15. Repeat the last three steps for the Black color.
16.16. Select the fill of the pictograph and the symbol for the white area in the symbol box.
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17. Click the  Change Symbol (Selected Object) icon in the Edit Functions toolbar.
18.18. Repeat this with the black color for the background.
19. Select the whole pictograph (Select Multiple Objects).
20.20. Copy the selection (Ctrl+C).
21. Create a New Point Symbol.
22. In the Symbol Editor paste the selection (Ctrl+V).
23. Scale the symbol, make a screenshot for the symbol icon and click the Close button.
24.24. Finished! The pictograph can be used as a point symbol now.

Back to the Create a New Symbol page.

References
[1] https:/ / youtu. be/ jPjEtQTPeOA
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Create a New Line Symbol

   
You can create very complex line symbols with OCAD. In addition, the symbol editor can make use of nearly all the
drawing modes and editing tools that are available for objects in the normal drawing window to make a line symbol
even more unique.
Choose the New command in the Symbol menu. Then, choose the Line Symbol option in the New Symbol dialog to
create a new line symbol.
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Line Symbol Dialog
The Line Symbol dialog appears. This dialog consists of six tabs:
• Main Line: Use this tab to define the color, line thickness and line type, generally the appearance of the main

line.
• Distances: Use this tab to define the length of dashed lines and the distance between the dashes.
• Symbols: Use this tab to define the start, main, corner and end points.
• Double Line: Use this tab to define the line width, filling color, line thickness and line type of a double line.
• Decrease: In this tab a decreasing line type can be defined.
• Framing: With this tab you can use framing to cover other map objects if you use complex line symbols.

Main Line

In the Main Line tab you can make the following adjustments:

Symbol Number

Type a symbol number between 0.001 and 999999.999 in this field.

Symbol Description

Enter a symbol description in this field (e.g. Railway).

Preferred Drawing Tool

Choose a preferred drawing tool in the corresponding dropdown list. When the symbol is selected in the Symbol
Box the drawing mode changes automatically to the chosen one. If None was chosen, the drawing mode remains the
same as it was before.
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Line Color

Choose a line color for the main line. The dropdown list contains all colors from the Color Table. If a main line is
not used, it is not necessary to define a line color.

Line Width

If the symbol has a main line (full or dashed), enter a line width here. Type in 0.00 if you do not want to use a main
line (e.g to create dotted lines).

Line Style

Choose between three line styles. The line ends and corners appear in each case differently.

Line Length

In this part of the dialog you can define two distances:
• Distance from start: This value defines the distance from the beginning of the line to the start of the main line

(the start of the visible line).
• Distance to the end: This value defines the distance from the end of the visible line (main line) to the actual line

end.
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If you activate the Pointed ends option, the line gets pointed ends over the above mentioned distances.
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Course Setting for Orienteering Options

There is an additional option in course setting projects to use the symbol as a marked route. Visit the Add a Marked
Route article for further information.

Examples

 Example Full Line

This is an example for a full line.

 Example Dashed Line with Background

This is an example for the Distances from start and Distances to the end asjustments.

 Example Motorway

This is an example for the Distances from start and Distances to the end asjustments.

 Example Pointed Line

This is an example for a line with Pointed ends.
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Distances

Use this tab to define the dashes for a dashed line.

Distances

Main length a
This length defines the length of the main dash (see figure at the top of the dialog, the main dash is indicated with the
letter a). For a dotted line, enter here the distance between the dots.
End length b
This length defines the length of the start and end dashes (see figure at the top of the dialog, the end dashes are
indicated with the letter b). For a dotted line, enter 0 in this field to make sure, that the line starts with a dot and not a
gap. For lines with dots on it, enter here the distance from the start of the line to the first dot on the line.

 The end length is also used before and after a corner of the line.
at least X Gap(s)/Symbol(s)
Here you can define a minimum number (max 2) of gaps or symbols (if a main symbol is defined) that a line should
contain. If you want a dashed line to always have a gap (regardless how short it is) then choose a 1 here.
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Gaps

Main gap C
The value entered here defines the length of the main gap (see figure at the top of the dialog, the main gaps are
indicated with the letter C).
Gap D
You can add an additional gap to the main dash. Define a length for it in this field (see also figure at the top of the
dialog, the Gap D is indicated with the letter D).
Gap E
You can add an additional gap to the end dashes. Define a length for it in this field (see also figure at the top of the
dialog, the Gap E is indicated with the letter E). This is used rarely.

Examples

 Example Dashed Line

This is an example for a dashed line with a main length of 2.0mm, an end length of 1.0mm and a main gap of
0.5mm.

 Example Dotted Line

This is an example of a dotted line with a main length of 1.0mm.

 Example Dashed Line with Dots

This is an example for a dashed line with a dot in the middle of each dash.

Symbols

Add point symbols to your line symbol to make your symbol unique. This point symbol can be a simple dot, but it is
also possible to add complex symbols.

Main Symbol

In the Main symbol A part of the dialog you can define a main symbol. The main symbol appears at every main gap
defined in the Distances tab of this dialog.
No. of symbols
The main symbol may consist of more than one symbol. It can be formed of up to five equal symbols.
Edit button 
To edit the symbols described in the paragraph above, click the Edit button. The Symbol Editor will appear, where 
you can draw a symbol with almost every drawing and editing function of OCAD. Visit the Symbol Editor article
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for more information. In this article, there is also a specific paragraph for drawing symbols of structured lines.
Distance
The value typed in the Distance field defines the distance between the individual symbols unless the number of
symbols is 0 or 1.

Other Symbols

Secondary symbol B
A secondary symbol appears at the position of the Gap D defined in the Distances tab of this dialog, therefore
exactly in the middle of two main symbols. A secondary symbol does not appear if the number of symbols of the
Main symbol A is 0. Click the Edit button to edit the symbol with help of the Symbol Editor.

Corner symbol 
A corner symbol appears at every Corner Vertex of the line. Click the Edit button to edit the symbol with help of
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the Symbol Editor.

Start symbol C
The Start symbol C appears at the start point of a line. Click the Edit button to edit the symbol with help of the
Symbol Editor.

End symbol D
The Start symbol C appears at the end point of a line. Click the Edit button to edit the symbol with help of the
Symbol Editor.

https://www.ocad.com/wiki/ocad/en/index.php?title=Create_a_New_Point_Symbol%23Symbol_Editor
https://www.ocad.com/wiki/ocad/en/index.php?title=File:CornerSymbol.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=Create_a_New_Point_Symbol%23Symbol_Editor
https://www.ocad.com/wiki/ocad/en/index.php?title=File:StartSymbol.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=Create_a_New_Point_Symbol%23Symbol_Editor
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Examples

 Example Power Line

This is an example for a line symbol with corner symbols.

 Example Cable Car

This is an example for a line symbol with a main, a start and an end symbol.

 Example Canton Boundary

This is an example for a line symbol with a special main symbol.

 Example Area Boundary

This is an example for a line symbol with a symbols between dashes.

 Example Geological Line Symbol

This is an example for a line symbol with a main and a secondary symbol.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:EndSymbol.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Example.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=Example_Power_Line
https://www.ocad.com/wiki/ocad/en/index.php?title=File:PowerLine.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Example.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=Example_Cable_Car
https://www.ocad.com/wiki/ocad/en/index.php?title=File:CableCar.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Example.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=Example_Canton_Boundary
https://www.ocad.com/wiki/ocad/en/index.php?title=File:CantonBoundary.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Example.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=Example_Area_Boundary
https://www.ocad.com/wiki/ocad/en/index.php?title=File:AreaBoundary.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Example.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=Example_Geological_Line_Symbol
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 Example Dashed Line with Dots

This is an example for a dashed line with a dot in the middle of each dash.

Double Line

Double lines are primarily used for streets, where you have a left and a right border line filled or not filled with
another color. If you need a center line (often used for highways) define a main line (note, that the color for the
center line must be above the color for the infill in the Color Table).

Mode

Select the mode of the double line. You have the following options for a double line:
• Off: No double line is shown.
• Full lines: The two lines which form a double line are continuous.
• Left line dashed: The left line is dashed.
• Both lines dashed: Both lines are dashed.
• All dashed: Both lines and the filling are dashed.

Width

Enter the distance between the two double lines in this field. If you use a fill color, this is the width of the filling
between the two border lines.

Fill Color

Check the On option, to activate the fill color. In the dropdown list a color of the Color Table can be chosen. The
border of the filling is formed by the sidelines. The filling does not exceed those border lines, therefore there are
often really small gaps between the sidelines and the filling. To avoid these gaps make use of the Framing which is
described later on this page. The advantage of a fill color is that for example street crossings are automatically
cleared. To get that effect you must choose a fill color which is above the color of the side lines in the Color Table.
Otherwise the infill cannot erase the side lines in the street crossings.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:GeologicalLine.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Example.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=Example_Dashed_Line_with_Dots
https://www.ocad.com/wiki/ocad/en/index.php?title=File:DashedLineWithDots.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=Create_a_New_Line_Symbol%23Framing
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Left and Right Line

Assign a color from the Color Table to the left respectively the right sideline. Those can be colored individually and
the Line width can be chosen distinctly as well. Choose 0 as a line width if you want to show the sideline for
example only on the left side.

Dashed

If you chose the Left line dashed, Both lines dashed or All dashed option as a double line mode, you can enter the
dash and gap lengths in this part of the dialog. The value entered in the Distance a field defines the dash length and
the value entered in the Gap field stands for the gap length.

Examples

 Example Minor Road

This is an example for a simple double lined symbol.

 Example Motorway

This is an example for a simple double lined symbol with activated, dashed main line.

 Example National Park Boundary

This is an example of a line symbol with activated double line in the Both lines dashed mode and the left line
set to 0.00.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:DoubleLineHint.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Example.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=Example_Minor_Road
https://www.ocad.com/wiki/ocad/en/index.php?title=File:MinorRoadNormal.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Example.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=Example_Motorway
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Motorway.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Example.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=Example_National_Park_Boundary
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 Example Dashed Minor Road

This is an example of a line symbol with dashed double line.

 Example Three Lanes

This is an example of a line symbol with a double line, which does not appear as a borderline.

 Example Three Lanes Dashed

This is an example of a quite complex line symbol with a dashed double line, which does not appear as a
borderline.

 Example Power Line

This is an example for a line symbol with a double line without filling.

Decrease

These features are primarily used for geological symbols with decreasing dots.
Decide if defined symbols shall only decrease at one end or at both ends in the Decrease part of the tab. In the Last
symbol field enter a value in percentage how much the symbols shall decrease towards the ends. The distance
between the symbols is also decreased. However, the dashes of dashed lines are not decreased. Therefore, you should
not use the Decrease function together with dashed lines.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:NationalPark.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Example.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=Example_Dashed_Minor_Road
https://www.ocad.com/wiki/ocad/en/index.php?title=File:MajorRoadMiddleLineFrameDashed.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Example.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=Example_Three_Lanes
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Highway.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Example.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=Example_Three_Lanes_Dashed
https://www.ocad.com/wiki/ocad/en/index.php?title=File:TwoDashed.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Example.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=Example_Power_Line
https://www.ocad.com/wiki/ocad/en/index.php?title=File:PowerLine.PNG
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Examples

 Example Geological Line Symbol

This is an example for a line symbol with decreasing ends on both ends.

 Example Stone Embankment Top Edge

This is an example for a line symbol with decreasing ends on both ends.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:Decrease.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Example.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=Example_Geological_Line_Symbol
https://www.ocad.com/wiki/ocad/en/index.php?title=File:GeologicalLine.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Example.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=Example_Stone_Embankment_Top_Edge
https://www.ocad.com/wiki/ocad/en/index.php?title=File:StoneEmbankmentTopEdge.PNG
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Framing

Framing lines are normally used as a background to line objects. Often a framing line is used to block out (or cover)
other objects. Note that the color of the framing line must be above the colors of the objects to be covered in the
color table.
• Line color: Select the line color.
• Line width: Enter here the line width. Enter 0 here if no framing line should be drawn.
• Line style: Select one of the 3 line styles with different line ends and line joins.
Choose a framing if you want to avoid small gaps between sidelines and filling. These occur, when using a Fill color
with double lines. The framing must have the same color than the filling but must be at a lower position in the Color
Table. In addition, they must be wider than the filling (for example width of filling plus half width of the sidelines).

Examples

 Example Railway

This is an example for a line symbol black framing under a white main line.

Icon
Click the Icon button in the dialog to create an icon for the symbol. The Icon Editor appears. Read more about this
editor in the Icon Editor article.

Back to the Create a New Symbol page.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:Example.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=Example_Railway
https://www.ocad.com/wiki/ocad/en/index.php?title=File:DashedFraming.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=Create_a_New_Symbol%23Icon_Editor
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Create a New Area Symbol

   
You can create quite complex area symbols with OCAD. In addition, the symbol editor can make use of nearly all
the drawing modes and editing tools that are available for objects in the normal drawing window to make an area
symbol even more unique.
Choose the New command in the Symbol menu. Then, choose the Area Symbol option in the New Symbol dialog
to create a new area symbol.

The Area Symbol dialog appears. This dialog provides the following three tabs:
• General: Used to define the color and the borderline.
• Hatch: Used to define the line thickness, distance and orientation of the hatching.
• Structure: Used to define the structure symbol as well as the distances and orientation of the structure.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:HatchExample.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Pro40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Std40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Sta40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:CS40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:NewAreaSymbolDialog.PNG
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General
In this tab you can make general adjustments like those for the fill and borderlines.

Symbol Number
Type a symbol number between 0.001 and 999999.999 in this field.

Symbol Description
Enter a symbol description in this field (e.g. Lake).

Preferred Drawing Tool
Choose a preferred drawing tool in the corresponding dropdown list. When the symbol is selected in the Symbol
Box the drawing mode changes automatically to the chosen one. If None was chosen, the drawing mode remains the
same as it was before.

Fill
Check the On field to activate the fill. Allocate a fill color from the dropdown list. All colors from the Color Table
appear in this dropdown list. If you use borderlines or a structure, make sure that the fill color is below the borderline
respectively the structure color in the Color Table. Otherwise, the fill covers the structure completely or the
borderline is only shown with half the width.

Border
Activate borderlines by checking the corresponding On checkbox. Then, select a line symbol in the dropdown list
below. All line symbols in the Symbol Box are listed there. Make sure that the color of the line symbol is above the
color of the fill in the Color Table, otherwise half of the line symbol will be covered by it.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:Border.PNG
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Orientation to North
Check the Hatch/Structure orientated to north when rotating the map option if you want to keep a hatch or
structure always orientated to north when rotating the map (Rotate).

Hatch

In this tab you can define the parameters for a simple hatch or a cross-hatch.

https://www.ocad.com/wiki/ocad/en/index.php?title=Edit_Object%23Rotate
https://www.ocad.com/wiki/ocad/en/index.php?title=File:OrientationToNorth.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:HatchExample.PNG
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Hatch
Choose between None if you do not want a hatch, simple hatch or a cross-hatch.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hatch.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:HatchTip.PNG
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Color
Choose a color for the hatch lines. Make sure that this color is above the background color of the area in the Color
Table.

Line Width
Enter a line width in mm for the hatch lines in this field.

Distance
Enter the distance between the hatch lines in this field.

Angles
• Angle 1: Enter the angle for the hatch lines. 0 means that the lines are horizontal. For angles greater than 0, the

lines are rotated counterclockwise.
• Angle 2: Enter the second angle for the hatch lines if you have defined a cross-hatch. Otherwise this value is

ignored. 0 means that the lines are horizontal. For angles greater than 0, the lines are rotated counterclockwise.

Structure
In this tab you can define the parameters for a structure.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:Structure.PNG
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Structure
Choose between None if you do not want a structure or one of the two layouts for structures.

Width
Enter the horizontal distance from one structure to the next (center to center). This distance is horizontal if the angle
is 0, otherwise it is measured in the corresponding angle.

Height
Enter the vertical distance from one structure line to the next (center to center). This distance is vertical if the angle
is 0, otherwise it is measured in the corresponding angle.

Angle
Enter here the angle of the structure. If this angle is 0 the structure is drawn as shown in the structure box. Otherwise
it is rotated counterclockwise for positive angles.

Edit
Click this button to draw one structure element in the Symbol Editor. In the Symbol Editor the symbol will also
appear (in gray) in the position of the neighboring structures in order to get an impression of the structured area. If
you enter an angle other than 0, the structure will be rotated, but not the symbol. Read more about the Symbol
Editor in the Symbol Editor article. This article contains also a paragraph for structured areas.

 It is possible to rotate the structure of individual objects drawn with that symbol with the Indicate Direction of
Area Pattern, Point or Text Object button. In this case the structure and the structure symbols will be rotated.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:StructureTip.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=Create_a_New_Point_Symbol%23Symbol_Editor
https://www.ocad.com/wiki/ocad/en/index.php?title=Create_a_New_Point_Symbol%23Symbol_Editor
https://www.ocad.com/wiki/ocad/en/index.php?title=Create_a_New_Point_Symbol%23Symbol_Editor
https://www.ocad.com/wiki/ocad/en/index.php?title=Create_a_New_Point_Symbol%23Symbol_Editor
https://www.ocad.com/wiki/ocad/en/index.php?title=Create_a_New_Point_Symbol%23Symbol_Editor
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
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Do not cut structure element at border
This option lets you decide how the elements get drawn, if the object would be cut off at border. You can pick either
Draw element if completly inside area, Draw element if center inside area or Draw element if partially inside
area.

Irregular Pattern
This function allows to define the horizontal and vertical variation of objects inside the area (in %). It's also possible
to push the elements inside the area apart with a defined minimum distance between symbols.

Examples

 Example Boulders with Shrubbery

This is an example for a structured area symbol.

 Example Dam

This is an example for a structured area symbol.

Icon
Click the Icon button in the dialog to create an icon for the symbol. The Icon Editor appears. Read more about this
editor in the Icon Editor article.

Back to the Create a New Symbol page.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:Example.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=Example_Boulders_with_Shrubbery
https://www.ocad.com/wiki/ocad/en/index.php?title=File:BolderWithShrubbery.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Example.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=Example_Dam
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Dam.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=Create_a_New_Symbol%23Icon_Editor
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Create a New Text Symbol

   
You can create quite complex text symbols with OCAD.
Choose the New command in the Symbol menu. Then, choose the Text Symbol option in the New Symbol dialog to
create a new Text symbol.

The Text Symbol dialog appears. This dialog provides the following five tabs:
• General: Used to define the font color, type and size.
• Paragraph: Used to define the paragraph attributes
• Tabulator: Used to define the tab attributes
• Line Below: Used to define the underscore attributes
• Framing: Used to define the framing and combination with point symbols

https://www.ocad.com/wiki/ocad/en/index.php?title=File:TextSymbols.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Pro40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Std40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Sta40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:CS40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:NewTextSymbolDialog.PNG


Create a New Text Symbol 257

General
The General tab provides adjustment options for the font, color, size etc. of text symbols. At the bottom of the
dialog a preview of the text is shown.

 For every text style, a separate symbol is required. If you modify the text symbol, then all text written with that
symbol will change.  The error message: "Font not found" appears if a font is chosen that is not installed on the
PC. The font needs to be installed on the PC or another font must be chosen. Otherwise the font Arial is used.

Symbol Number
Type a symbol number between 0.001 and 999999.999 in this field.

Symbol Description
Enter a symbol description in this field (e.g. Hiking Track Label).

Font
Choose a font for the text symbol. All TrueType fonts installed in Windows are listed in the dropdown box. You
cannot use raster fonts or Adobe Type Manager fonts.

- The error message: "Font not found" appears if a text object is linked to a font that is not installed on the PC.
The font needs to be installed on the PC (restart OCAD after you installed the font) or another font must be
chosen. Otherwise the font Arial is used.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:TextSymbolGeneral.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
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Color
Choose the color for the text. All colors from the Color Table are listed in the dropdown list.

Size
Choose the size in points for the text. As an alternative you can enter the character height in millimeters in the
Character height field.

Character Height
Enter here the height of the character 'B' in millimeters. Alternatively, you can enter the size of the font in points in
the Size field.

Emphasis
• Bold: Check this box for bold text.
• Italic: Check this box for italic text.

Drawing Mode
This setting is used if you drag the mouse in a specified direction when drawing or editing a text object or if you
rotate the map with the Rotate Map command in the menu Map.

Horizontal text: Choose this option if the text shall be rendered horizontal after a rotation of the map.
Rotated text: Choose this option if the text shall rotate with the map after a rotation of the map.

https://www.ocad.com/wiki/ocad/en/index.php?title=Map_Transform%23Rotate_Map
https://www.ocad.com/wiki/ocad/en/index.php?title=File:DrawingModeHint.PNG
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Course Setting for Orienteering Options
In Course Setting for Orienteering projects you have additional options for text symbols. Check the Course
setting symbol box if you want to use this text symbol for the course title, code for variant or start numbers for relay
courses. Read more about this topic on the Add Course Setting Objects page.

Paragraph
Choose this page to define parameters for text paragraphs. At the bottom of the dialog a preview of the text is shown.

Character Spacing
Enter here a distance to be inserted between characters. If you enter 100%, a space character is inserted between
characters. The default value is 0%. Negative values can be inserted, too.

https://www.ocad.com/wiki/ocad/en/index.php?title=Add_Course_Setting_Objects%23Add_a_Course_Title
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Paragraph.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:CharacterSpacing.PNG
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Word Spacing
Enter here the distance between words. 100% means that a normal space character is used between words. The
default value is 100%.

Alignment
Choose an alignment of the text. You have 10 options (from Bottom to Top and Left to Right, or select the Bottom
justified option for left-aligned text which is Fully Justified). This last option only influences text draw as a text
frame.

Line Spacing
Enter the distance from one line to the next within a paragraph in relation to the font size. The standard value is
120%.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:WordSpacing.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=Drawing_an_Object%23Place_a_Text_Object
https://www.ocad.com/wiki/ocad/en/index.php?title=Drawing_an_Object%23Place_a_Text_Object
https://www.ocad.com/wiki/ocad/en/index.php?title=File:LineSpacing.PNG


Create a New Text Symbol 261

Space after Paragraph
Enter the additional space after each paragraph.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:SpaceAfterParagraph.PNG
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Indent First Line
Enter the indent of the first line of each paragraph.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:IndentFirstLine.PNG
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Indent Other Lines
Enter the indent of the other lines of each paragraph.

Tab
Choose this page to set the tabs for the text symbol. The tabs are left adjusted. A maximum of 32 tabs can be
defined. If a text contains more tab characters than defined in the list, the distance to the last tab is repeated.
To add a new tab enter the position and click the Add button. The tab is added to the list.
To remove a tab select the tab to be deleted in the list. Then click the Delete button.

Line Below
On this page a line which is drawn below each paragraph can be defined. A paragraph is terminated by a hard return
- the Enter key.

On
Check this box to get a line below the paragraphs.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:IndentOtherLines.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:On.PNG
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Line Color
Choose a color for the line. The colors from the Color Table appear in this list.

Line Width
Enter a line width.

Distance from Text
Enter a distance from the baseline of the text to the upper edge of the line.

Framing
Choose this page to set the parameters for text framing. Text framing is a method to make text more readable on
maps. If - for instance - you have black text on a map, it may interfere with black line objects. Text framing can also
be used for decorative effects - giving the text a shadow, for instance.

 
For text framing you need to understand the Color Table and you should have some experience in creating new
colors and new symbols.

Off
Activate this box if you don't want to use text framing.

Line
Enter here the Width (how much the framing extends outside the character) of the text framing as well as the Line
style (how corners and line ends appear) and the Color at the bottom of the Mode part of the dialog (all colors from
the Color Table are listed here). To get text framing, this color must be below the color of the main font in the
Color Table, but above the colors of any objects which you wish to cover.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:TxtWithout.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:TxtFrame.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:FramingModeOff.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:FramingModeLine.PNG
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Shadow
Choose this option if a shadow to the text shall be rendered. Enter the Horizontal and Vertical offset of the shadow.
Choose a Color at the bottom of the Mode part of the dialog (all colors from the Color Table are listed here). To get
text framing, this color must be below the color of the main font in the Color Table, but above the colors of any
objects which you wish to cover.

Rectangle
Choose this option to add a rectangular background. Enter the values Left, Right, Bottom and Top if the rectangle
shall overlap the text. Choose a Color at the bottom of the Mode part of the dialog (all colors from the Color Table
are listed here). To get text framing, this color must be below the color of the main font in the Color Table, but
above the colors of any objects which you wish to cover.

Point Symbol
Check the On option if you want to attach a point symbol to the text symbol. Then, choose a point symbol, which are
those from the Symbol Box.

Examples
Download-Links: Example_Textframing.ocd [1] Example_TextPointsymbol.ocd [2]

Creating a Line Text Frame

 
For text framing you need to understand the Color Table and you should have some experience in creating new
colors and new symbols.
First you need two additional colors which are above the black color for symbols:

https://www.ocad.com/wiki/ocad/en/index.php?title=File:FramingModeShadow.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:TextSymbolWithAllocatedPointSymbol.PNG
http://www.ocad.com/download/samples/Example_Textframing.ocd
http://www.ocad.com/download/samples/Example_TextPointsymbol.ocd
https://www.ocad.com/wiki/ocad/en/index.php?title=File:TxtWithout.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:TxtFrame.PNG
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Then you can add the text framing to an existing text symbol:
1. Right click the text symbol and choose Edit from the context menu.
2. Choose the General page. Choose the Black for text item for the text color.
3. Choose the Framing page. Activate the Line option.
4.4. Enter the desired framing width.
5. Choose the White for text frames item in the Color dropdown list.

Selective Text Framing

Often text framing erases only the black color, but the other colors still come through. OCAD allows selective text
framing for printing the map with spot colors (PMS or Pantone colors), by defining the appropriate spot colors.
However, on the screen all colors below the framing color are erased. So beware: the appearance of the map on the
screen and the printed map will be different. Selective text framing is also possible for CMYK printing. In this case
you have to define your own Spot Color for CMYK. You cannot use the automatic CMYK color separations.

Icon
Click the Icon button in the dialog to create an icon for the symbol. The Icon Editor appears. Read more about this
editor in the Icon Editor article.

Back to the Create a New Symbol page.

References
[1] http:/ / www. ocad. com/ download/ samples/ Example_Textframing. ocd
[2] http:/ / www. ocad. com/ download/ samples/ Example_TextPointsymbol. ocd
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Create a New Line Text Symbol

   
You can create different line text symbols with OCAD.
Choose the New command in the Symbol menu. Then, choose the Line Text Symbol option in the New Symbol
dialog to create a new line text symbol.

The Line Text Symbol dialog appears. The following options are available:
• General: Used to define the font color, type and size.
• Spacing: Used to define the letters, word spacing and text positioning.
• Framing: Used to define the framing
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General
The General tab provides adjustment options for the font, color, size etc. of line text symbols. At the bottom of the
dialog a preview of the text is shown.

 For every text style, a separate symbol is required. If you modify the line text symbol, then all text written with
that symbol will change.  The error message: "Font not found" appears if a font is chosen that is not installed on
the PC. The font needs to be installed on the PC or another font must be chosen. Otherwise the font Arial is used.

Symbol Number
Type a symbol number between 0.001 and 999999.999 in this field.

Symbol Description
Enter a symbol description in this field (e.g. River Name).

Font
Choose a font for the text symbol. All TrueType fonts installed in Windows are listed in the dropdown box. You
cannot use raster fonts or Adobe Type Manager fonts.

- The error message: "Font not found" appears if a line text object is linked to a font that is not installed on the
PC. The font needs to be installed on the PC (restart OCAD after you installed the font) or another font must
be chosen. Otherwise the font Arial is used.
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Color
Choose the color for the text. All colors from the Color Table are listed in the dropdown list.

Size
Choose the size in points for the text. As an alternative you can enter the character height in millimeters in the
Character height field.

Character Height
Enter here the height of the character 'B' in millimeters. Alternatively, you can enter the size of the font in points in
the Size field.

Emphasis
• Bold: Check this box for bold text.
• Italic: Check this box for italic text.

Spacing
Choose this page to define spacing and alignment for a line text symbol.

Character Spacing
Enter here a distance to be inserted between characters. If you enter 100%, a space character is inserted between
characters. The default value is 0%. Negative values can be inserted, too.

Word Spacing
Enter here the distance between words. 100% means that a normal space character is used between words. The
default value is 100%.
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Alignment
Choose here how the text is aligned along the line. The All line options (Those three on the right side) mean that the
text is distributed along the entire line. With this option the letter-spacing will be adapted to the length of the line
text object. Choose the options from Bottom to Top and Left to Right for a normal alignment (not justified).

Framing
Choose this page to set the parameters for text framing. Text framing is a method to make text more readable on
maps. If - for instance - you have black text on a map, it may interfere with black line objects. Text framing can also
be used for decorative effects - giving the text a shadow, for instance.

 
For text framing you need to understand the Color Table and you should have some experience in creating new
colors and new symbols.

Off
Activate this box if you don't want to use text framing.

Line
Enter here the Width (how much the framing extends outside the character) of the text framing as well as the Line
style (how corners and line ends appear) and the Color at the bottom of the Mode part of the dialog (all colors from
the Color Table are listed here). To get text framing, this color must be below the color of the main font in the
Color Table, but above the colors of any objects which you wish to cover.
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Shadow
Choose this option if a shadow to the text shall be rendered. Enter the Horizontal and Vertical offset of the shadow.
Choose a Color at the bottom of the Mode part of the dialog (all colors from the Color Table are listed here). To get
text framing, this color must be below the color of the main font in the Color Table, but above the colors of any
objects which you wish to cover.

Drawing a Line Text Symbol
Line text symbols are used for text along curved lines. Line text can be written along any line, including curved
lines. To draw a line text object you must define a line text symbol and do the following steps:
1.1. Select the line text symbol.
2.2. Draw a line in any drawing mode (curve, ellipse, circle etc.).
3.3. After terminating the line, an insertion line appears and you can directly type the text on the keyboard.

4. If the text goes in the wrong direction, click the  Reverse Object icon in the Edit Functions toolbar.

Icon
Click the Icon button in the dialog to create an icon for the symbol. The Icon Editor appears. Read more about this
editor in the Icon Editor article.

Back to the Create a New Symbol page.
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Create a New Rectangle Symbol

   
You can create rectangle symbols with OCAD.
Choose the New command in the Symbol menu. Then, choose the Rectangle Symbol option in the New Symbol
dialog to create a new rectangle symbol.

The Rectangle Symbol dialog appears.
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Rectangle symbols are used to draw rectangular frames (around the entire map or around parts of the map). A special
use for Rectangle symbols are punch boxes for orienteering maps.

Symbol Number
Type a symbol number between 0.001 and 999999.999 in this field.

Symbol Description
Enter a symbol description in this field (e.g. Punch Box).

Line Color
Choose the color for the frame. All colors from the Color Table are listed in the dropdown list.

Line Width
Enter a line width for the frame.

Corner Radius
If you want the frame to have round corners, enter the corner radius here (measured to the center of the line),
otherwise enter 0 here.
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Line Style

The Line Style option is only available, if the Corner Radius is set to 0. In this case you can choose between the
three common line styles to define the appearance of corners and line ends.
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Drawing Mode
• Horizontal rectangle: Activate this option if you want to draw only horizontal rectangles.
• Rotated rectangle: Activate this option if you want to draw rotated rectangles.

Grid
The grid linie width is not alterable. So this option is obsolete.
• On: Activate this field if you want to add a grid into the rectangle.
• Cell width / Cell height: Enter the desired width and height for the cells.

 The effective cell width and cell height are always a divider of the drawn rectangle's total size.

Numbering

On

Activate this field if you want to add numbers to the grid.

Numbered from the Bottom

Normally, the cells are numbered starting from the top row. Check this box to start numbering from the bottom row.

Text Size

Choose the size in points for the text.

Unnumbered Cells

Number: Enter here the number of cells used as reserved fields, if you want to create punch boxes. If you
want all cells numbered enter here 0.
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Text: Enter here up to 3 characters which appear instead of the number in the reserved fields.

Icon
Click the Icon button in the dialog to create an icon for the symbol. The Icon Editor appears. Read more about this
editor in the Icon Editor article.

Back to the Create a New Symbol page.

Symbol Status Manager
 

The Symbol Status Manager allows to easily get access to various status settings.
While the Symbol Status Manager dialog is open, the map can still be edited.

 --> See a short video on Youtube [1], which explains you the basics.

Save current symbol status
1. Select Symbol Status Manager item in the Standard Toolbar or in the Symbol menu.
2. The Symbol Status Manager dialog opens.

3. Set the status of the symbols in the Symbol Box to normal, protected or hidden to get the map view you want.

 This can be done already before opening the dialog.
4. Enter a name and save the current symbol status settings by clicking on the Save button.
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Load Symbol Status
1. Select a status in the Symbol Status box.
2. Either double click on the name or click on Load to activate this symbol status settings.

 Only one symbol status setting can be active.
 If multiple status are selected then only the one who's name is shown in the name box will be loaded.

Delete Status
1. Select a status in the Symbol Status box.
2. Click on the Delete button to delete this symbol status.

Export Symbol Status
1.1. Select a saved symbol status setting.
2. Click on the Export button.
3. Choose the destination folder and save the .xml file.

 If multiple settings are selected to be exported, they are saved in one .xml file.

Import Symbol Status
1. Click on the Import button.
2. Pick and load an symbol status setting(s) .xml file.
3. The loaded symbol status are shown in the Symbol Status box.

Examples
•• normal map

•• no tracks
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•• height map

Back to Symbol

References
[1] https:/ / www. youtube. com/ watch?v=vflwkqPiCH0
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Menu Map

Map

Optimize and Repair       
Choose this command in the Map menu to optimize (reduce) the size of the map file and repair damaged objects.
With edit operations such as deleting objects, empty space is created in the map file. This function removes this
empty space and therefore reduces the size of the map file.
When OCAD encounters damaged objects it tries to repair them. If this is not possible, they are deleted.
After the optimization the Optimization Result dialog box is displayed with the following information:

• File size before optimization in bytes.
• File size after optimization in bytes.
•• Objects repaired
•• Damaged objects deleted
• Spurious objects deleted: Spurious objects are objects which are not visible. These may be text objects with no

text and no line, line objects with only one point, or area objects with only 2 points.
•• Unsymbolized Objects
•• Objects with Unknown Symbol
•• Objects with Invalid Symbol Type
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Set Scale and Coordinate System      
Visit the Set Scale and Coordinate System page to get some information about this function.

Change Scale      
Choose this command in the Map menu to change the scale of the map. The map is enlarged/reduced according to
the new scale. The Change Scale dialog box is displayed, where the new scale can be entered.

Actual scale
This line shows the current scale of the map. Choose the Set Scale and Coordinate System command from the
Map menu to set the current scale.

 Setting the current scale with the Set Scale and Coordinate System function does not enlarge or reduce the
map. It only changes a number in the map file.
New scale
Enter here the desired new scale of the map. You may choose one of the predefined scales or enter the scale on the
keyboard.
Enlarge/reduce symbols
Check this box to enlarge/reduce the symbols with the same factor as the map. When the box is checked, the map is
enlarged/reduced like a photographic enlargement. When this box is not checked, the map is enlarged/reduced, but
the symbols are kept in the same dimension.

 Course Setting project: OCAD does not enlarge and reduce symbols with symbol numbers 0-100. That are
usually the symbols for the control description.
Click the OK button to finish.
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Create Map Grid     
Choose this command from the Map menu to create grid lines on the map (e.g. it can be used to draw Magnetic
North lines or the grid for a Name Index.). The Create Map Grid dialog box is displayed.

Now, you have to make the following adjustments:
• Easting offset: Enter the easting offset to the defined map grid for the vertical grid lines.
• Northing offset: Enter the northing offset to the defined map grid for the horizontal grid lines.
• Create vertical grid lines: Check this option to create vertical grid lines and enter the distance .
• Create horizontal grid lines: Check this option to create horizontal grid lines and enter the distance .
• Angle: OCAD uses the real world angle.
• Create vertices at grid junctions: Check this option to create a vertex at every grid junction.
• Symbols:

• Grid lines: Select a line symbol for the grid lines (map grid).
• Grid labels: Select a text symbol for the grid labels.

Click the OK button when finished. The grid is drawn over the whole map. Therefore, remove background maps
which are larger than the map before creating a grid.

 Create Name Index is the corresponding function to create a name index based on a rectangular map grid.
 The minimum and maximum grid line distance depends on the map grid distance. You can change this grid

distance in Set Scale and Coordinate System dialog.
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Create WGS84 Grid   
Read more about this topic on the Create WGS84 Grid page.

Hide     
Choose this command in the Map menu to hide the map on the screen.

Transform
Information about the transforming functions, which are Move, Stretch/Shrink, Mirror, Rotate Map, Change
Coordinate System, Affine, Rubbersheeting, Local Transformation and Center Map to Drawing Area, can be
found on the Map Transform page.

Convert Imported Layers to Symbols     
Choose this command from the Map menu to convert the layers of an imported DXF, Shape or AI file to symbolized
objects. The Convert Imported Layers to Symbols dialog box appears.
In this dialog box you can create a list of references. A reference consists of a layer and the corresponding OCAD
symbol. You can save the list to a cross reference (.crt) file for later use. You can load an existing cross reference file
to modify or execute it.

Visit the Cross Reference Table page to get some information about CRT-Files and the CRT-File part in the dialog.
Click the Execute button when you are finished with editing the CRT-File. The conversion gets executed.
Click Add all to add all imported layers to the table.

 - Please note that this CRT file does not work to Import OCD Files!
An imported layer can be converted manually. Visit the Convert a Layer Manually page to get more
information.
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Convert Area or Line Objects to Point Objects   
Choose this function in the Map menu to convert area or line objects to point objects. This command is enabled if an
area or line object is selected.
1.1. Select a line or an area object.
2. The Convert Area or Line Objects to Point Objects dialog appears.

3. Choose a point symbol. You may have to create a Symbol first that looks like the old one. Read here how to
create a Point Symbol out of vector data.

4. Click the Execute button. The selected area or line object is converted to a point symbol and the chosen symbol
is assigned to it.

5. You may need to shift the point symbol until it is at the right place.

 The point symbol appears in the middle of the area or the line.

Examples
•• Import PDF and convert to symbol

A typical example for this function would be the import of a PDF. Vector objects in PDF-Files are imported as
Image Objects and can be converted to symbols.
In the image below, you see a symbol for a post office and a car park. However, each of these symbols consists of
one or several area objects. Because of that, editing and moving around these symbols can get tedious. That's why it
is an option to create a new Point Symbol out of the Vector Data and later convert the area objects to this new
Point Symbol.
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•• Convert a Line or Area Object to a Point Object

In the next example the map contains a symbol for coniferous and deciduous forest and a symbol for heather. The
animation shows how to convert them to point symbols.
•• Convert multiple Line Objects to a Point Object

Here's the problem: We have a symbol consisting of 6 line objects, in our example the symbol for 'Heather, which
appears 5 times. Now, if we select all six objects of these 5 symbols, we will get 30 Point Symbols, but only want to
have 5. That's why we try to find an unique property of the objects we want to convert to identify only one specific
object per symbol.
So, we first select all 30 objects and select them by property in a next step.
Now we only have one selected object for every symbol, which we can convert to a Point Object.
Shift the Symbols until they are at the right place.

Convert Text Objects to Point Objects   
Choose this command from the Map menu to convert text to point objects. The Convert Text Objects to Point
Objects dialog appears.
This function is used after import map drawn in DTP program. In a DTP program point symbols are often drawn
with a character and a special symbol fonts. OCAD can convert this characters to a point symbol.
In the first part of the dialog you can decide wheter you want to convert the objects from all text symbols or only
objects from a selected symbol.
In the second part of the dialog box you can create a list of references. A reference consists of a layer and the
corresponding OCAD symbol. You can save the list to a cross reference (.crt) file for later use. You can load an
existing cross reference file to modify or execute it.
Visit the Cross Reference Table page to get some information about CRT-Files and the CRT-File part in the dialog.
Example of crt file:

 312.000 A

 313.000 B

 314.000 C 

The same data in the dialog:
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Click the Execute button when you are finished with editing the CRT-File. The conversion gets executed.

Convert Text Objects from OEM to Unicode   
Choose this command from the Map menu to convert text objects from OEM to Unicode.
This function can be used after importing geodata from non-Unicode compatible programs or open ocd files from
older OCAD versions. OCAD 2019 is Unicode compatible.
In the first part of the dialog you can decide wheter you want to convert the text from all text symbols or only objects
from a selected symbol.
In the second part of the dialog box you can create a list of references. A reference consists of a layer and the
corresponding OCAD symbol. You can save the list to a cross reference (.crt) file for later use. You can load an
existing cross reference file to modify or execute it.
Visit the Cross Reference Table page to get some information about CRT-Files and the CRT-File part in the dialog.
Click the Execute button when you are finished with editing the CRT-File. The conversion gets executed.
Example: After opening OCAD 7 file in OCAD 2019 file some characters are invisible (e.g. the character Ť from
codepage Windows-1250 [1] to represent texts in Central European and Eastern European languages). Use this
function to convert this character from OEM code '141' to the Unicode '356'.
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Export Objects by Selected Symbols     
With this function you can export objects with the selected symbol(s) in a new OCAD-Map. Select the desired
symbol(s) before choosing this function (e.g. you can export all roads).
Choose this function from the Map menu. The Export Objects by Selected Symbols dialog opens. Browse a
location and enter a name for the new file. Then, click the Save button to finish.

Export Selected Objects    
With this function you can export the selected object(s) in a new OCAD-Map. Select the desired object(s) before
choosing this function.
Choose this function from the Map menu. The Export Selected Objects dialog opens. Browse a location and enter a
name for the new file. Then, click the Save button to finish.

Delete Objects by Selected Symbols   
Choose Delete Objects by Selected Symbols in the Map menu to select all objects with certain symbols or in a
certain layer. As an example you can select all roads. The Delete Objects by Selected Symbols dialog box appears.

All objects with a selected symbol

Choose this option and click on the OK button to delete all objects with the selected symbol(s). Select the symbol(s)
before you choose the Delete Objects by Selected Symbols command.

All objects in layer

If you import files like PDF, DXF, Adobe Illustrator or OpenStreetMap with layer information, the layer information
does not get lost, though OCAD does not support layers as they are known in Adobe Illustrator or similar
applications. Choose the All objects in a layer option to delete all objects which are in the same layer. Choose a
layer in the dropdown list.

Unsymbolized objects

Choose this option and click on the OK button to delete all Unsymbolized Objects.

Objects with unknown symbol

Choose this option and click on the OK button to delete all Objects with Unknown Symbol.

Objects with invalid symbol type

Choose this option and click on the OK button to delete all Objects with Invalid Symbol Type.

Graphic objects

Choose this option and click on the OK button to delete all Graphic Objects.

Image objects

Choose this option and click on the OK button to delete all Image Objects.
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Export Part of Map    
With this function you can export a part of the current map in a new OCAD-Map.
Choose this function from the Map menu. The Export Part of Map dialog opens on the right side of the screen. The
following adjustments can be made:
Boundaries

• Rectangular boundaries: Choose this option to export a rectangular part of the map. You can modify or move
the boundaries using the mouse.

Click  Setup button to define the region to be exported with coordinates. The Setup Part of Map
(Export) dialog box appears.

Click the  Entire Map button to export the entire map. The boundary rectangle adjusts to the entire map.

Click the  To Current View button to export the map which is currently displayed on the screen. The
boundary rectangle adjusts to the current view.

• Use selected object for boundaries: Choose this option to export an irregularly shaped part of the map. Before
choosing the Export Part of Map command, you must draw the shape with a line or area object.
• Export with selected object: If you check this option the object which defines the boundary is exported as

well.

 To make this function faster convert this cutting object from a curve to a polyline (Change to Polyline).
 The number of vertices of the cutting object has a big influence on the speed of this function.
 This option may produces inverted area objects or other artefats. Namely if the cutting object has

self-intersections or if the cutting object crosses a hole of an area object.
 We recommend to use the Rectangular boundaries option to export a rectangular part of the map.

• Export database links: This option is checked by default. If you do not want to export the database links, then
uncheck this option. This will speed up the export significantally if the map has a lot of linked objects.

Click the OK button when finished. The Export Part of Map dialog opens. Browse a location and enter a name for
the new file. Then, click the Save button to finish.

Colors       
You can find all information about colors on the Colors page.

Define Spot Colors       
Visit the Define Spot Colors page to get some information about this function.

Load Colors From      
Information about this function can be found on the Colors page.

Load Colors and Symbols From    
Information about this function can be found on the Colors page.

Compare Symbols and Colors    
Select this command in the Map menu to compare the symbol set of the open file with a reference OCAD map. The
Reference map dialog appears. Choose a reference file and click the Open button. The Compare Symbols and
Colors dialog box appears. You have the following options:
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• Compare colors: Activate this check box if the color table shall be compared.
• Compare symbols: Activate this check box if the symbols shall be compared.
• Used symbols only: Activate this checkbox if only used symbols shall be compared.
• List identical symbols: Activate this check box if the identical symbols shall be listed, too. If this check box is

deactivated, only the different symbols will be logged in the TXT-File.
Click the OK button to continue. OCAD saves a text file to the location of the currently opened OCAD-Map under
the name FILENAME.CompareResult.txt and opens it. Make sure that the directory of the current OCAD-Map is not
a read-only folder.
The Logfile shows the difference of the symbols and/or colors and if wanted also the identical symbols.

Load Symbol Descriptions From
Choose this command in the Map menu to load symbol descriptions from a text file. Choose the Load Symbol
Descriptions From... item from the Map menu. The Load dialog box is displayed. Choose a text file what contains
the symbol descriptions. Click the Open button to load the symbol descriptions. The text file needs to contain the
symbol number followed by a SPACE or TAB as separator and the symbol description, ex:

101.000 Contour
102.000 Index Contour

Save Symbol Descriptions To
Choose this command in the Map menu to save the symbol descriptions to a text file. Select the Save Symbol
Descriptions From... item from the Map menu. The Save dialog box is displayed. Choose a path and file name.
Click the Save button to save the symbol descriptions. The text file contains the symbol number followed by a TAB
as separator and the symbol description, ex:

101.000 Contour
102.000 Index Contour
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Symbol Set Report    
Choose this command to save an Excel-file with a detailed description of all symbols in your file.

Symbol Set Conversion    
Visit the Symbol Set Conversion page to get some information about this function.

Update Symbol Set    
Use this function to update maps drawn with ISOM 2017 to the new ISOM 2017-2 standart.
Visit the Update Symbol Set page to get some information.

Renumber Symbols   
Use this function to renumber symbols and objects with a crt file.
Example of a crt file: The first value is the old symbol number, the second the new one.

 101 10101

 102 10102

The new symbol number can't be any old symbol number, even if you change this number later on.

101 102

102 101

The result is shown in a info message.
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Use the function Save Symbol Descriptions To to get all symbol numbers as a text file.

Check Legibility    
Use this function to check minimum distances between objects, minimum length of line objects or minimum size of
area objects according to ISOM 2017. This function will help map makers to find the right degree of generalisation.
Furthremore, Event Advisers and Map Consultants have a tool to check the maps.

 --> See a short video on YouTube [2], which explains you the basics.

• Ckeck for objects: Choose if you want to check all objects or only the objects with a selected symbol (they need
to be selected before).

• Extend: Check entire map or only current view.
• Check distance between objects: Default value is 0.15 mm for map scale 1:15'000. The default value is adapted

automatically for larger scales like 1:10’000 (0.23 mm).
• Check distance only between object from the same color group (black, brown, blue, green, yellow): It is

recommended to check this option for orienteering maps, as many objects of differnt colors overlap (e.g.
brown contour line through green vegetation).

• Check minimum line length: Minimum length values from ISOM 2017 are checked.
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• Check minimum area size: Minimum area size and width values from ISOM 2017 are checked.
Click the OK button. Three different selections will be stored (minimum distance conflict, minimum line length
conflict, minimum area size conflict). Reload the selections under Reload Selection in the Select menu. The latest
selections are at the bottom of the list. Once you have opened a selection, go through the conflics by clicking on the
corresponding objects in the table.
Minimum distance conflics will not only be stored in a selection, but also shown with red dots or lines. Therefore,
two new symbols will be added at the bottom of your symbol box.

 If you want to delete these red conflict dots and lines, select them by using Reload Selection in the Select menu
or by right-clicking the symbol(s) in the symbol box and Select objects by symbol....

If you uncheck the option Check distance only between object from the same color group (black, brown, blue,
green, yellow), you will get more conflicts and the result will look like this.
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Selection for minimum line length.

For the option minimum area size, OCAD compares the area size of an object with its minimum dimension
according ISOM 2017. However, please be aware that most symbols do not only have minimum area sizes, but also
a minimum width. OCAD does not check the minimum width.
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Minimum area size dimension according ISOM 2017.
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Show Impassable Features     
Visit the Show Impassable Features page to get some information about this function.

Routing   
Visit the Routing page to get some information about this function.

Map Information       
Choose this command from the Map menu to get some information about the current map and about the Windows
system. The Map Information dialog box is displayed.

The dialog box provides the following information:
• Total objects: The total number of objects on the map.
• Objects with symbol: The total number of symbolized objects on the map.
• Objects without symbol: The total number of Unsymbolized Objects on the map.
• Objects with unknown symbol: The total number of Objects with Unknown Symbol on the map.
• Layout objects: The total number of Layout Objects on the map.
• Graphic objects: The total number of Graphic Objects on the map.
• Image objects: The total number of Image Objects on the map.
• Objects with invalid symbol type: The total number of Objects with Invalid Symbol Type on the map.
• Colors: The total number of Colors.
• Spot Colors: The total number of Spot Colors.
• Symbols: The total number of Symbols.
• File size: The size of the map file on the disk in Bytes.
• Undo file size: The size of the undo file in the temporary OCAD folder in Bytes. The undo file is used for

Undo/Redo.
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In addition, you can choose between six tabs with detailed information:
• Notes: Enter information about the map here. This feature was called File information until OCAD 9. The text

you type in here will show up in the New File dialog under Map notes if you use the map as a symbol template.
• Symbols: This tab shows a tree view of all Symbols in the Symbol Box.
• Colors: This tab shows a tree view of all Colors in the color table and in which symbols they are used.
• Fonts: This tab shows a tree view of all used fonts and in which symbols they are used.
• Background Maps: This tab shows a tree view of all Background Maps loaded.
• Database: This tab shows a tree view of all connected Databases in the map.
Click the Report button to save a report of the selected tab as a XLS or TXT File.
The right part of the dialog is the System information part with the following information:
• Screen resolution: Number of dots in horizontal and vertical direction on the screen. The resolution is

determined by the currently installed screen driver. In addition, the Pixels per Inch are given.
• Physical memory: Size of the physical memory (RAM).
• Disk space: Available disk space on the drive where OCAD is installed in Megabytes.
• ADO Version: The current version of the ActiveX Data Objects (ADO) [3] is displayed here.
• Access Database Engine: The Access Database Engine (32-bit) [4] is displayed here.
• Borland Database Engine: Shows if Borland Database Engine [5] is installed or not.
Click the OK button to save and quit.

Back to Main Page

References
[1] http:/ / en. wikipedia. org/ wiki/ Windows-1250
[2] https:/ / youtu. be/ s0oOPl8Wrw8
[3] http:/ / en. wikipedia. org/ wiki/ ActiveX_Data_Objects
[4] http:/ / www. microsoft. com/ download/ en/ details. aspx?id=13255
[5] http:/ / en. wikipedia. org/ wiki/ Borland_Database_Engine
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Map Transform

Move     
Select the Transform item in the Map menu and choose Move.
The Move Map dialog appears. Depending on wheter you are using paper coordinates or real world coordinates (Set
Scale and Coordinate System) you can enter different values.

With set paper coordinates enter a X and a Y value in mm. By clicking the OK button the map is moved in the
desired direction.
With set real world coordinates enter a value in m for easting and northing. By clicking the OK button the map is
moved in the desired direction.
Check the corresponding option to move also Background Maps, Layout Objects and Bookmarks.

 Do not use this dialog to change the real world coordinate offset if the map is georeferenced. To move a
georeferenced map, use the Center Map to Drawing Area function in the Transform submenu of the Map menu
and enter the new offset.

Stretch or Shrink      

Select the Transform item in the Map menu and choose Stretch/Shrink.
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The Stretch/Shrink Map dialog opens.

Enter a percentage value for the horizontal strech/shrink and the vertical stretch/shrink. If both values are the same,
the proportions of the map are kept.
Check the corresponding boxes if you want to reflect the map horizontally or vertically.
Click the OK button when you are finished.

Mirror      

Select the Transform item in the Map menu and choose Mirror.
The Mirror Map dialog opens, which is the same as the Stretch/Shrink Map dialog.

Enter a percentage value for the horizontal strech/shrink and the vertical stretch/shrink. If both values are the same,
the proportions of the map are kept.
Check the corresponding boxes if you want to reflect the map horizontally or vertically.
Click the OK button when you are finished.
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Rotate Map      

Select the Transform item in the Map menu and choose Rotate Map.
The Rotate Map dialog opens.

Enter an angle in degrees and check the option Rotate objects with symbols orientated to north if yout want the
symbols stay orientated to north when you use the Rotate function.

 To consider the declination and rotate map to magnetic north, use the function Rotate Map to Magnetic North,
which is more sophisticated than the function Rotate Map.

 Select a Point or Line Symbol and go to the symbol diaglog (Symbol>Edit) and see that the option Orientated
to north when rotating the map is checked for that particular symbol.
Check Rotate layout objects and your layout objects will be rotated as well.
Layout images will not be rotated.
Click the OK button to finish.

Rotate Map to Magnetic North     
This function opens Open Street Map at your current position. It takes two values into consideration:
• Magnetic declination: The angle between the direction of the magnetic meridians and the direction to the

geographic North Pole at the observation site.
• Grid convergence: The angle at the observation site between true north and grid north.
• Grid magnetic angle: The sum of the two values above, by how much the map should be rotated.
• Current angle: The current angle of your map.
• Rotate by: By default, it is the value from the Grid magnetic angle field. You can adjust it manually if you wish.

Example: Current angle of your map is 0°, Grid magnetic angle is 2.1° and is supposed to change +0.12° per
year. It would be an option to rotate the map by 2.6°. In this case, the deviation of your map would not be
more than 0.5° for the next 8 years.
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Options
• Do not rotate objects from selected symbols: You may not want to rotate certain objects, e.g. texts or symbols

you use for the layout. Select these symbols beforehand in the Symbol box. Hold the Shift and/or Ctrl key for
multiple selection.

• Do not rotate image objects: Set this option active, if you do not want to rotate image objects.
• Do not rotate layout objects: Set this option active, if you do not want to rotate layout objects.

 Your map has to be georeferenced and a Coordinate System has to been set to use this function.
 In the Map Menu, there are two more functions where you could rotate your map:

• Set Scale and Coordinate System: Do not edit the Angle in the function Set Scale and Coordinate System.
Only change the angle there, if you start a new map and haven't drawn any objects yet.

• Rotate Map: The function Rotate Map is basically the same as Rotate Map to Magnetic North, but not that
sophisticated.
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Change Coordinate System    
Select the Transform item in the Map menu and choose Change Coordinate System.
The Change Coordinate System dialog opens.

The current coordinate system is displayed in the Change map from part of the dialog.
Click the Choose button in the Into part to choose a new coordinate system. Select the system in the Coordinate
System dialog and click the OK button.
The new offset is displayed in the Horizontal offset and Vertical offset fields and can be edited there, too.
The option Scale symbols is only enabled when Google Mercator [1] coordinate system is choosen. If this option is
checked then OCAD scales all symbols according to the new scale in the center of the map. The map looks similar as
before the transformation.
Click the OK button when finished. OCAD converts every vertex' coordinate to UTM and then (if necessary) to the
desired coordinate system. Due to different origins of the coordinate systems the map gets transformed
(stretched/shrinked and rotated).

Affine    
Select the Transform item in the Map menu and choose Affine to adjust the whole map on background map or on
grid. With this function you can geo-reference the map. The grid button must be pressed to see the grid. You can
use 1 to 12 points for the adjustment. For each point you do the following:
1.1. Mark a point on map.
2.2. Mark the same grid point on reference (background map or grid).
When you have adjusted enough points, press the Enter key on the keyboard. The map is rotated and stretched
(Affine transformation) to get the best fit for the adjustment points. You can achieve a precise adjustment with 4
adjustment points arranged in a rectangle. In this way you can compensate rotation and distortion. The horizontal and
vertical scales will be adjusted individually.

 This function works in the same way as the Adjust a Background Map function, but it is for the map.
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Rubbersheeting    
Select the Transform item in the Map menu and choose Rubbersheeting to adjust the map or a part of the map to a
geo-referenced background map. The Rubbersheeting Transformation dialog appears.

Rubbersheeting perimeter
The Rubbersheeting perimeter is an area in which the Rubbersheeting Transformation is carried out. Objects
outside of the rubbersheeting perimeter are not transformed.
Click the Define button and define the perimeter by drawing a polyline on the map (one corner per click). To define
a new rubbersheeting perimeter click the Remove button to remove the actual one. Click the Load button to load an
exported rubbersheeting perimeter (txt-File). Click the Save button to save the current perimeter.

Rubbersheeting settings
Check the corresponding boxes if you want to transform objects with protected symbols, transform layout objects or
decrease rubbersheeting towards the border of the perimeter.

Rubbersheeting points
Click the Add button and do the following steps:
•• Click a point on the map.
•• Click the same point on the reference map (grid or background map). The rubbersheeting points are shown on the

map by a red and a green cross and a connection line.
•• Do the same procedure for other points.
• Click the Transform button to transform the map. Click the Save button to save the rubbersheeting points. Click

the Remove button to remove the selected rubbersheeting point. Click the Remove all button to remove all
rubbersheeting points. Click the Load button to load a saved selection of rubbersheeting points.
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Click the Close button when finished.

 -Click the Undo button in the Standard Toolbar if you are not satisfied with the rubbersheeting transformation.
-Uncheck rubbersheeting points in the Used column if they should not be included in the transformation.
Unchecked rubbersheeting points appear in gray color on the map.
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-The rubbersheeting perimeter defines that only objects or vertices of objects within this perimeter are
transformed. But it is possible that objects or vertices of objects are moved out of the perimeter by the
transformation! Place rubbersheeting point pairs with the same position on the perimeter border to avoid this.
-The Affine function is much easier to handle and gives more or less the same result.

Local Transformation
Local Transformation is an interactive tool to eliminate local distortions. This tool makes the adjustment of existing
maps to geo-referenced base maps (hillshading, orthophotos etc.) easier and more accurate too.
Select the Transform item in the Map menu and choose Local Transformation to open the Local Transformation
dialog.

1. Define the Radius of transformation.
2. Choose if objects with protected symbol and layout objects shall be transformed as well.
3. Click on the Start the interactive transformation button.
4.4. Press the left mouse button at the transformation center and move the mouse meanwhile to transform. The mouse

up needs to be within the circle.

 While pressing the left mouse button, the beforehand defined transformation radius will be shown
with a blue circle.

 Each vertex inside the circle will be transformed. Thus the transformation doesn't stop exactly at the
border of the circle for line and area objects that are partially within the circle. They get transformed
until their first vertex out of the circle.

 It is possible to edit the map while having opened the non-modal Local Transformation dialog.
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Center Map in Drawing Area    
Select the Transform item in the Map menu and choose Center Map in Drawing Area. The Center Map in
Drawing Area dialog appears.

This function is often used to center a map drawn in OCAD Mapping Solution edition into the smaller drawing area
from OCAD Orienteering, Starter or CS edition. OCAD moves the map offset, all objects, all background maps and
all bookmarks. After this function the map is still geo-referenced. In the dialog the extent with the existing map
offset is shown in grey, the extent with the new offset in blue. The green rectangle shows the drawing area of OCAD
Mapping Solution edition (80x80m), the orange the drawing area from Orienteering, Starter and CS edition (4x4m).
If a map should be visible in all OCAD editions then the entire map must fit in the 4x4m drawing area.
The proposed new map offset is displayed in the New map offset fields and can be edited there. This new map offset
is calculated from the map and his visible background maps. If the background maps are hidden then OCAD
calculates the new map offset only from the map.
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Click the Center map button to move the map to the center of the drawing area.
The geo-reference of the map is not changed.

Back to the Map page.

References
[1] http:/ / en. wikipedia. org/ wiki/ Mercator_projection

Colors

Colors       
This function has limitations in the OCAD Viewer

Choose this command in the Map menu to define the colors and spot colors of the map. The Colors dialog box is
displayed. In this dialog all colors which you can use for the map are listed, can be edited, created or deleted.

 In the top right corner is a color search field.

The colors are rendered on the screen and on the printer from the bottom up. The color on the bottom is rendered
first and the color on the top is rendered last. Therefore, an object A with a color, which is below the color of another
object B, appears behind object B on the map.
The table contains 18 columns:
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Number and Name
The first column provides you with a preview of the color defined in the corresponding row. The second and the
third column are defined as follows:
• No.: In this column the color number is displayed. Each color must have a number between 0 and 32000. This

number can be changed by clicking on it.
• Name: In this column a name with up to 45 characters must be given to each color. This name can be changed by

clicking on it.

CMYK (process) colors
The CMYK (Cyan, Magenta, Yellow, Key (Black)) values of the color are displayed in those 4 columns. These
values can be changed by clicking on it. The color preview will be updated immediately.

Overprint
In the Ov. column you can check the Overprint option. When overprinting is chosen for a color, the CMYK
separations are not omitted (i.e. the CMYK seperations are printed/rendered under the color you overprint). This
makes this color appearing darker when it is printed on another color. The following example should illustrate this:

In the figure on the left side, overprinting for brown and black colors is active. In contrast, on the right side,
overprinting is disabled for those colors. You can see that the brown contour lines appear darker in the green areas.
Furthermore, there is a similar effect when the black path crosses the contour lines.
It is noticeable that the contour lines do not appear darker when crossing the yellow area. This is due to the fact that
the brown color as well as the yellow color have a cyan value of 0. Overprinting has therefore only an effect, if the
upper color has at least one CMYK value which is 0 and, at the same time, this value is greater than 0 in the lower
color.
In OCAD the overprinting effect is not shown. Overprinting affects only Color AI, EPS and PDF files as well as
CMYK separations. Overprinting is also supported by some PostScript printers.

 To show overprinting effect when printing PDF files from Adobe Acrobat Reader: Activate the Simulate
overprint option in the Advanced Printer Settings .
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Opacity
In this column the opacity of the color in percentage can be entered by clicking the value.
An opacity value of 0 means that the color is not visible.
An opacity value from 1 to 99 means that the color is transparent with the corresponding intensity.
An opacity value of 100 means that the color is opaque.

Black with 100%, 50% and 0% opacity.

Usage
If the Symbol column is checked, the color is used in at least one symbol.
If the Map column is checked, the color is used in at least one map object, including Image and Graphic Objects.

Spot Colors
Spot colors are used if the map is printed with PMS (Pantone) colors. If the map is printed with 4 colors (CMYK),
spot colors needn't be defined.
You can define a spot color value for each color. Click in the corresponding field and enter a value in percentage.
•• A value of 100 means that the color appears black on the separation.
•• A value of 0 means that the color appears white on the separation and erases any black color.
•• An empty field means that the color has no effect on the separation.

 The colors are rendered on the separation from the bottom up. The lowest color in the list is drawn first and the
color on top of the list is drawn last. Therefore if you put 0 in one row, only colors below this row are erased.

 Putting a 0 is especially important for streets in order to enable automatic cleaning up of crossings. The color of
the street infill must be above the color of the street sidelines. And in the row of the infill there must be a 0 for the
spot color of the sidelines.
To create, edit and delete spot colors choose the Define Spot Colors item in the Map menu.

Functions
• Redraw screen when changing a color: OCAD redraws the map after changing a color. If the map has a lot of

objects this takes some seconds. Uncheck this option to avoid the automatical redrawing of the screen.
• Move Up: Click the Move Up icon to move the selected color one row upwards in the color table.
• Move Down: Click the Move Down icon to move the selected color one row downwards in the color table.
• Add: Click this button to add a new color.
• Duplicate: Click this button to duplicate the selected color. The duplicated color is inserted below the selected

color.
• Delete unused: Click this button to delete all colors that are neither used in any symbol nor any map object.
• Delete: Click this button to delete the selected color.
• Report: Click this button to save a report of the colors as a Word, Excel, Html or Text file. Open the report with

the Open Recently Exported Documents command from the File menu.

 If you have a map with a lot of objects, it may take some seconds until the Color dialog appears. OCAD is 
checking through all objects to find all colors used in the symbols and in the map. If you want OCAD to display the 
Colors dialog immediately, press the Shift key when choosing Colors in the Map menu. OCAD opens the dialog
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instantly and hides the Symbol and Map columns as well as the Delete unused button. This dialog looks as follows:

Choose Color from Color Picker
Click the Choose color from color picker button to edit the selected color in the Color Picker dialog.

Select Color Swatch
Click the Select color swatch to compare the colors from the current opened OCAD file with a color swatch from a
reference file in the Color Swatch dialog.

Blend Mode
Click the Blend Mode button to set the blend mode for each color in PDF export in Blend Mode dialog.

Load Colors From      
Choose this command in the Map menu to load a color table from a different OCAD-File. The Load Colors From
dialog box is displayed. Choose a map file which the color table shall be loaded from. Click the Open button to
continue. Another Load Colors From dialog box appears. You have two options:
• Replace existing colors: Choose this option to overwrite the existing color table of the current map with the new

one.
• Add to existing colors: Choose this option to add the new colors to the existing color table.
Click the OK button to finish.
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Load Colors and Symbols From    
Choose this command in the Map menu to load a symbol set from a different OCAD-File. The Load Colors and
Symbols From dialog box is displayed. Choose a map file which the symbol set shall be loaded from. Click the
Open button to continue. Another Load Colors and Symbols From dialog box appears. You have two options:
• Replace existing colors and symbols: Choose this option to overwrite the existing symbol set and color table of

the current map with the new ones.
• Add to existing colors and symbols: Choose this option to add the new symbols and colors to the existing ones.
Language: If available, choose the language for the symbol description.
You have the option to use a CRT-File to import the symbol set. In the first column of the cross reference table the
symbol numbers of the current map are listed. In the second column symbol numbers of the other OCAD-File are
listed, namely those numbers of symbols, which the current symbol has to be replaced with. As an example, a CRT
row which is defined as 526.000 813.001, means that the symbols of all objects with the symbol number 526.000
will get the symbol of the other OCAD-File with the number 813.001.
Visit the Cross Reference Table page to get detailed information about using CRT-Files. Click the Load button to
load a CRT-File.
Click the OK button to finish.

 OCAD opens the File Dialog in the folder of the last imported file. Press the Shift key to open a file from the
Symbol folder. The Symbol folder is a subfolder of OCAD program folder (e.g. C:\Program Files\OCAD\OCAD
20xx Mapping Solution\Symbol).

 The error message "Cannot import symbol" appears if OCAD was not able to load a symbol. The Load Colors
and Symbols From process is aborted.

Example

Back to Main Page
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Blend Mode
Click the Blend mode button in the Colors dialog to open the Blend Mode dialog.
The blend mode affects only the pdf export. The blend mode controls how the underlying color of an object interacts
with the blend color of the overlaying object.
OCAD supports the blend modes Darken und Multiply. The blend mode is only visible in the exported pdf file, not
in OCAD!
More about blend modes in Wikipedia [1].
For digital printed Orienteering maps we recommand to set the Purple and Green over Brown to the blend mode
Darken.

Example
The Darken blend mode is set for the colors Purple and Green over Brown.

The blend mode is not visible in OCAD.

After exporting pdf file the blend mode is visible when opening this pdf file in Adobe Reader. The colors Purple and
Green over Brown are transparent.
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References
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Color Swatch
 

Click the Open color swatch dialog button in the Colors dialog to open the Color Swatch dialog.

Functionality
Use this function to compare the color values from the currently opened OCAD file with a color swatch from a
reference file.
Additionally, it is possible to replace colors by those from the color swatch.

On the left part of this dialog the color table of the currently opened OCAD file is displayed. On the right side, a
color table of your choice is shown. Click the Load color swatch button to load a different color swatch.
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Compare Colors
Colors with identical CMYK values in the color table of the currently opened file and in the loaded color swatch are
highlighted green.
It is not possible to compare Spot Colors with the help of this dialog.

Replace Colors
To replace a color in the color list click on the corresponding color in the color swatch and drag and drop it to the
color which is supposed to be replaced in the color table.

 if you want to add, remove or move the color up/down in the color table, you need to do so in the Colors dialog
box.

OCAD overwites always the CMYK values, but not changing the color number. Optionally OCAD overwrites also
the Color name, the Overprint flag and the Opacity. Check the corresponding options at the bottom of the dialog.

Replace All Colors
Click the Replace all button to replace all colors from the list by the colors from the color swatch if they have the
same color number.

Color Swatch File
The data of the color swatch are saved in a semicolon or tab separated text file with the extension .txt.
To create a color swatch file from an existing OCAD file click the Report button in the Colors dialog and choose
Text as a file type. Save the file in the OCAD program subfolder Color Swatch.
The last used color swatch file name is saved in the Windows Registry. When reopening this Color Swatch dialog
OCAD reloads the last used color swatch.
Move the mouse cursor over the file name to see the full file name with file path.

Back to the Colors page.
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Create Color Gradient
 

There are two types of gradients:

•• Linear gradient

To create a linear gradient select an area object from your drawing area which is drawn in the straight line or
rectangular mode.

•• Circular gradient

To create a circular gradient select a circle object from your drawing area.

1. Select an area symbol.
2. Choose the straight line or circle drawing mode.
3. Draw an object. OCAD uses only the first four vertices to create a linear gradient.
4. Select the Create Gradient function from the Object menu.
5. Choose the first color:
•• Linear gradient means the left color is the first color.
•• Circular gradient means the color in the middle of the circle is the first color.
6. Choose the second color.
7. Choose a one of the following options:
• Do not add the new image objects to a selection: The image objects are selected but the selection is not saved.
• Add the new image objects to an existing selection: The selection of the image objects is saved in an existing

selection. Choose the existing selection in the dropdown menu. Visit the Select page to get more information
about saving selections.

• Add the new image objects to a new selection: The selection of the image objects is saved in a new selection.
Enter a name for the new selection in the field on the right. Visit the Select page to get more information about
saving selections.

8. When clicking OK OCAD generates 100 Image Objects in different colors.

 -Choose an new selection for the gradient to select and move it easily with Reload Selection in the Select menu.
-The recently created gradient is always on top of the image objects.

Use the Crop function in Object menu to cut the image objects to a new shape:
1.1. Create an object with required gradient.
2.2. Draw an object on it with the desired shape.
3. Choose Crop Objects from the Object menu.
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4. Select the gradient (100 image objects) and choose in the Objects to crop field the Only chosen objects option.
Then click the Add selected objects button.

5. Select the drawn object with the desired shape and choose the Chosen line or area object option in the Line or
area crop object field. Then click the Choose selected crop object button.

6. Click OK to finish.

Back to the Edit Object page.

Define Spot Colors
    

Choose this command from the Map menu to create, edit and delete spot colors. Read the Wikipedia Article [1] to
get an impression what spot colors are.
High quality maps are often printed with spot colors. Spot colors are also referred as PMS (Pantone matching
system) [2] colors.
Choose the Spot Colors command in the View menu to get a preview of the spot color print.
If you choose the Define Spot Colors command in the Map menu, you will get to the Define Spot Colors dialog:
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A table shows all currently defined spot colors. The columns provide the following information:
• V (Visible): If you click the eye icon in this column you can hide or display a spot color.
• No. (Number): Enter here a number for the spot color.
• Name: Enter here a name for the spot color.
• Halftone Frequency: This column determines how fine the typesetter will present halftone screens. The standard

value is 150 lines per inch (lpi). Read more about this topic in the Wikipedia Article [3].
• Halftone Angle: This determines the angle of halftone screens. The standard value is 45°. Read more about this

topic in the Wikipedia Article [3].

 If dotted areas are rendered as a halftone screen, then the halftone screen angle should be different from the
angle of the dots to avoid Moiré effects on the printed map.

• Appearance: These values are used for the spot color view (the spot color view is a simulation of the map printed
with spot colors). They are also used when exporting the map in the AI and PDF format with spot colors.

In addition, you have the following functions:
• Move up: Click the Move up button to move up the selected spot color.
• Move down: Click the Move down button to move down the selected spot color.
• Add: Click this button to create a new spot color.
• Delete: Click this button to delete the currently selected spot color.
Click the Report button to save the table as a XLS, TXT, HTM or DOC-File.
Click the OK button to save all changes and quit the dialog.
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Back to the Map page.
To the Colors page.

References
[1] http:/ / en. wikipedia. org/ wiki/ Spot_color
[2] http:/ / en. wikipedia. org/ wiki/ Pantone_Matching_System#Pantone_Color_Matching_System
[3] http:/ / en. wikipedia. org/ wiki/ Halftone

Color Picker

The Color Picker dialog helps to find a suitable color (e.g. if you want to define a new Color).
1. Choose the Colors command in the Map menu to open the Colors dialog.
2. Select a color or add a new one, then click the Choose color from color picker button to open the Color
Picker dialog.
3. The Color Picker dialog appears. You can either choose...
•• ...a color from the color hexagon. Adjust the brightness of the colors with the slider on the right of the color

hexagon.
•• ...a grey level from right below the color hexagon.
• ...a color defined in the CMYK color model if you enable the CMYK option.
• ...a color defined in the RGB color model if you enable the RGB option.

The chosen color is displayed on the bottom right side of the dialog.
If you choose a color in the color hexagon, either the CMYK or RGB values are updated depending on
wheter color model is enabled.

4. Click the OK button to accept the color, click the Cancel button to quit the Color Picker dialog without
saving any changes.
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Back to the Colors page.

Symbol Set Conversion
 

This function is not available in the TRIAL version of OCAD!
Choose this command from the Map menu to replace the symbol set by a new one.
This function was developed to convert easily orienteering maps in ISOM 2000 to the new map specifications ISOM
2017 [1] or sprint orienteering maps in ISSOM 2007 to ISSprOM 2019 [2].
Check out the Symbol Set Overview page to find out, which symbol set you are using.
But the function can also be used to convert all other types of maps. The advantage of this function is that you can
select which symbols (e.g. club logos, layout symbols) of your current symbol set should additionally converted to
the new symbol set. This function deletes also the unused colors of the current symbol set.
• File name: The New Symbol Set, to which you want to convert your current map.
• Language: For some Symbol Sets, you can choose the language.
• CRT File: Select a CRT table.
• ISOM 2000 to ISOM 2017 adjustments: Activate this checkbox to

- Change last vertex of objects with symbol 516.000 Power line to Corner vertex to keep the pylon
- Change last vertex of objects with symbol 517.000 Major power line to Corner vertex to keep the
carrying mast
- Rotate boulder field objects (208.000 and 208.001) because Boulder field symbol is rotated too

Example
The following example shows how to convert the ISOM 2000 OCAD sample map to ISOM 2017. You can find the
sample map (Bürenflue_ISOM_ENG.ocd) in the OCAD program subfolder Samples.

The map contains additional symbols for the club logo in the symbol tree group 'Text and Logo'.
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Click Symbol Set Conversion in the the Map menu to open the Symbol Set Conversion dialog form.

Choose the New symbol set. OCAD loads all files from the OCAD program subfolder Symbol. Because the sample
map is in the scale 1:10'000 OCAD loads the corresponding ISOM 2017 symbol set by default.
Choose the CRT file (Cross Reference Table). OCAD loads all files from the OCAD program subfolder crt.
When changing the New symbol set or the CRT file then OCAD updates the list.
The left side of the list shows the symbols from the current file, on the right the symbols from the chosen new
symbol set. A line in green color means that OCAD assign all objects of this symbol to the new one. OCAD has this
information from the CRT file. For example all objects form the current symbol 104.000 will be convert to the new
symbol 101.001.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:SymbolSetConversion_ClubLogo.png
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You can click on the symbol icon to choose another symbol. It is only possible to choose a symbol from the same
symbol type (e.g. line symbol to line symbol).

The three symbol for the club logos are not assigned to a new symbol in the CRT file. So check these three symbols.
The three lines appears in blue color. This means that OCAD copy these symbols with the used colors to the new
symbol set.

A white line means that OCAD deletes this symbol, but not the objects. So the objects will be Objects with unknown
symbol. You can click on the red rectangle to assign these objects to a new symbol. For example the brown filling
color for the north arrow (symbol number 529.007) will be changed to light brown (501.000).

Click OK to convert the map. OCAD replaces the symbols and colors.
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The three copied symbols are at the top in the symbol box.

Also the used color (101 Black) from these three symbols is at the top in the color table. All other unused colors
from the old symbol set are deleted.

Use the Replace Color function in Symbol menu to replace this black color in these symbols by another one (e.g. 2
Black 100%).
Choose the function Optimize/Repair in Map menu to verify the map. 6 Objects still have a unknown symbol. You
have to assign these objects to symbols manually.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:SymbolSetConversion_ConvertedMap.png
https://www.ocad.com/wiki/ocad/en/index.php?title=File:SymbolSetConversion_SymbolBox.png
https://www.ocad.com/wiki/ocad/en/index.php?title=File:SymbolSetConversion_ColorTable.png
https://www.ocad.com/wiki/ocad/en/index.php?title=Symbol%23Replace_Color_in_Symbols
https://www.ocad.com/wiki/ocad/en/index.php?title=Map%23Optimize_and_Repair


Symbol Set Conversion 321

Known Issues

Spot Colors
Spot colors have often different names in the current and new symbol set. In this case OCAD lose the spot color
values for the added colors. if you want to print the map in spot colors you have to enter it again.
In the example below the added color 101 Black has no spot color values. You have to enter 100 in the Process
Black column.

Reverse Object Direction
Line and point objects can be reversed after the conversion. It occurs if the symbol definition in the old and new one
are different.
Use the Reverse Object function function to reverse the direction of line objects.
Use the Rotate an Object by Angle function to rotate point objects by 180°.

References
[1] http:/ / orienteering. org/ resources/ mapping/ international-specification-for-orienteering-maps-isom-2017/
[2] https:/ / orienteering. sport/ iof/ resources/ mapping/
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Update Symbol Set
This function helps you to update your map to the latest ISOM 2017-2 [2] standart. There will be approximately 15
changes to your Symbol Set.
Check out the Symbol Set Overview page to find out, which symbol set you are using.

Update Symbol Set    
1. Choose Update Symbol Set in the Map menu. The Update Symbol Set dialog box appears.
2. Click on Update

Template Symbol Set
The template is called Orienteering Map ISOM 2017 15000.ocd
You can't edit this field.

Symbol Scaling
The template symbol set is in 15'000 scale.
If you update a 10'000 map, you need to scale the symbols by 150%.
If you update a 15'000 map, you leave the value at 100%.
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Language
not yet supported
That means, the updated symbols will be in English.

Changes
A list of changes will be shown after the update.

Dialog box after updating a 1:10’000 map from ISOM 2017 to ISOM 2017-2

https://www.ocad.com/wiki/ocad/en/index.php?title=File:ISOM_2017_Comparison.png
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Dialog box after updating a 1:15’000 map from ISOM 2017 to ISOM 2017-2
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Show Impassable Features
   

This function is available for orienteering maps or course setting projects according ISOM 2017, ISSOM 2007,
ISSprOM 2019, ISSkiOM 2019 and ISMTBOM 2010.
This function shows a black/white image with all impassable features (incl. course overprint out-of-bounds features).

Click the Save As... button to save a the image as TIFF file. The default path is your map's folder.
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Routing

This command is only available if the map is georeferenced and a Coordinate System is set.
This command can be used to find the fastest way by car between two arbitrary points by downloading and
importing the vector data from Google Maps.

Routing by Entering a Location
1. Select Routing in the Map menu to open the Routing dialog.
2. Enter the name of the start and end location.

Routing by Entering Coordinates
Instead of entering the name of the start and end point you can also simply click on these locations on the map.
1. Activate the Coordinate option in the Routing dialog.
2. Click on the Get Coordinate from Drawing Area button  , then click on the start location on your map.
OCAD displays the coordinate in the Routing dialog. Optionally you can enter the coordinate manually.
3. Do the same for the end location.
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 Please note that the function Get and import KML file does not work anymore.

Show Route in Google Maps
Click on the Open in Google Maps button to see the route on Google Maps.
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Template File
The symbols and colors used for routing are saved in a template file (usually C:\Program Files\OCAD\OCAD
20xx\Templates\Template Routing.ocd) and can be edited there, too.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:Routing9.png
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Menu Layout

Layout

Since Ocad 11, it's possible to add layout layers in the map. This layer may contain raster images and vector objects
like lines, areas or text. The vector layout objects color model is CMYK. The layout images' one is RGB. PNG
transparency is not supported. Spot colors are not supported by the OCAD layout layer.
Layout objects cannot be selected, moved, removed or changed unless you choose the Edit Layout Objects
command in the Layout menu.
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Edit Layout Objects    
Use this function in the Layout menu to add, remove or edit layout objects and define their properties. The Edit
Layout Objects dialog appears on the right side of the window. Now you can move, edit or remove layout objects in
the drawing area like normal objects.

Add a line, area or text layout object:
1. Click the Line, Area or Text icon in the Edit Layout Objects dialog as a Type.
2. Choose a Color. Click the color field to define the color with the Color Picker.
3. If you have chosen a line, define the Line width in the Line properties category in mm. If you have chosen a

text, choose a Font and a Text size in the Text properties category.
4. The Opacity can be defined for each object.
5.5. Draw the layout object with the regular drawing tools.

 To edit the drawn layout object select it and change the properties (color, line width etc.) in the Edit Layout
Objects dialog or use the editing functions of OCAD (Edit Object).

 The error message: "Font not found" appears if a layout object is linked to a font that is not installed on the PC.
The font needs to be installed on the PC (restart OCAD after you installed the font) or another font must be chosen.
Otherwise the font Arial is used.

Add an image:
1. Click the Add button in the Images category of the Edit Layout Objects dialog.
2. The Add Layout Image dialog opens and you can browse an image. The supported image files are .bmp, .gif,

.jpg, .png, .tiff. Click the Open button to add the image.
3. Move and resize the image objects by using the Select and Edit Object Tool. They can be moved with arrow

keys as well.
4. Remove a layout image by selecting it in the layout objects list and clicking the Remove button in the Images

category of the Edit Layout Objects dialog.

 If your map contains Layout images and your pass you file forward to another person, you need to send the
Layout images as well, as they are not part of the OCAD file.

Layout Objects List:
All Layout objects are listed in the layout objects list. It is possible to set them visible or hidden and to move
them by drag and drop or the arrow keys.
The error message "The maximum allowed entries of layout objects is reached" appears if the list contains the
maximum of 256 entries.
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Parameters

Object Type Parameter Properties

Line Object Color
Opacity
Line width

Color Picker
in [%]
in [mm]

Area Object Color
Opacity

Color Picker
in [%]

Text Object Color
Opacity
Text properties

in [%]
Font
Size in [pt]
Bold
Italic
Bottom left
Bottom
center
Bottom right
Fully justified

Images Add
Remove

Import Layout    
Choose this command in the Layout menu to import the layout objects from another OCAD map. The layout objects
are placed in the center of the actual drawing area. This command is only available if you are in the Edit Layout
Objects mode.

Save Layout    
Choose this command from the Layout menu to save the layout objects to a separate OCAD file. This command is
only available if you are in the Edit Layout Objects mode.

Delete Layout    
Choose this command from the Layout menu to delete all the layout objects. This command is only available if you
are in the Edit Layout Objects mode.

Hide    
Select Hide in the Layout menu to hide all layout objects.

Add North Arrow or Scale Bar    
You can add predefined north arrows or scale bars to the Layout.
1. Choose Edit Layout Objects in the Layout menu.
2. Choose Add North Arrow or Scale Bar in the Layout menu.
3. The Add North Arrow or Scale Bar dialog appears and you can choose between different north arrows and

scale bars from the Templates folder of the OCAD directory (Usually C:\Program Files\OCAD\OCAD 20xx
Edition\Templates).

4. Click the Open button to add the selected object to the layout objects.
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 - In the OCAD directory you can find a PDF-File with an overview of all predefined north arrows and scale bars
(Usually C:\Program Files\OCAD\OCAD 20xx Edition\Templates).

- North arrow and scale bar templates are black. You can change the color after adding them by choosing a
color from the color field in the Edit Layout Objects dialog.

Add Map Legend    
Choose the Add Map Legend function from the Layout menu to create a Map Legend. The Add Map Legend
dialog appears.
Legend Icon
Define values for the legend icon in this part of the dialog. You have to set a value for the Icon height, the Icon
width and the Line spacing. If you want that only used symbols are shown in the legend, check the corresponding
box. In the same way, you can decide wheter hidden symbols are shown in the legend or not.
Symbol type
Only the checked symbol types are taken into consideration for the map legend. Click the All button to check or
click the None button to uncheck all symbol types.
Legend Text
Choose a symbol for the legend text. This must be a text symbol of course. If you want that the symbol number is
shown in the legend text, check the corresponing option.
Click the OK button to add the map legend.

 This function creates symbolized map objects, not layout objects. Use the function Convert to Layout Object to
convert them into layout objects.

Add Trim and Bleed Marks    

This command adds trim and bleed marks as layout objects to the map.
1. The easiest way to add trim and bleed marks is when you set the ruler guides to the border of the map and the

map layout (e.g. A4 landscape format) first. Learn how to use the ruler guides on the Ruler Guides page. If you
do not want to use Ruler Guides skip this step.

2. Choose the Add Trim and Bleed Marks function in the Layout menu.
3. The Add Trim and Bleed Marks dialog opens.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Space.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Mas40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Ori40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=Convert_to_Layout_Object
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Space.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Mas40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Ori40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:TrimAndBleedMarks.PNG


Layout 333

4. If you are using Ruler Guides, click the Get ruler guides coordinates button in the Trim marks part of the
dialog, select a style (see below) and then click the Add button. Trim marks with the coordinates of the ruler
guides are added. If you are not using Ruler Guides, enter the paper coordinates for the trim marks manually
before clicking the Add button.

5. Enter the offset for the bleed marks in the Bleed marks part of the dialog if you want to add them and select a
style (see below). Then click the Add button.

6. Click the Close button to apply all adjustments and quit the dialog.
Trim and Bleed Marks are layout objects and can be edited and removed like other layout object.

 With adding trim and/or bleed marks, OCAD adds automatically a print and export rectangle with the
corresponding extent including the marks.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:TrimAndBleedMarksDialog.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:TrimAndBleedMarksDifferentStyles.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg


Layout 334

Create Graticule Name Index   
This command is only available if the map is georeferenced and a coordinate system is set. The command calculates
a name index based on the WGS84 graticule.
Select one or more symbols in the symbol box before choosing the command. All text objects and line text objects
with these symbol(s) are included to the index.

Create Graticule Name Index Dialog

• Index origin of longitude/latitude: Enter index origin coordinates.
• Horizontal/vertical distance: Enter the distance between the grid lines.
• Angle: Enter the angle of the grid. This angle is zero, if the grid is not rotated.
• Style: Choose a numbering style. One axis is always numbered "A, B, C..." and the other "1, 2, 3...".

Alternatively, you can choose the WGS84 style.
• Symbol: Choose a text symbol. It is used as a symbol for the name index text objects.
After clicking the OK button a text object with the index will be added in the center of the drawing area and can be
moved to the desired position.

 This function creates symbolized map objects, not layout objects. Use the function Convert to Layout Object to
convert the index to layout objects.

 Create WGS84 Grid is the corresponding function to create a graticule.
 Define a Tab in the name index text symbol therewith the indices are written in a column.
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Error Message Text is too long

Each text object in OCAD is limited by 32000 characters. This error message appears when the text has more
charcaters. OCAD copies the full text string in the Windows Clipboard. In this case we recommend you to split the
text string from Windows Clipboard in a Text editor and paste it into OCAD.

Create Name Index   
Make sure you have selected one or more text or line text symbols in the symbol box before choosing Create Name
Index in the Layout menu. The Create Name Index Dialog appears.

OCAD creates the name index from all objects from the selected text or line text symbols. For example, if you want
to list all street names, select all symbols for street names in the symbol box.
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• Name index range: Choose Entire map to create the index for the entire map or choose Part of map for a
desired part. OCAD uses the part of maps defined in the print and export dialogs.

• Horizontal/vertical offset: Enter the coordinate of the upper left or lower left corner where the numbering of the
grid starts (in this example the origin of the A1 square). The coordinate can be easily found out by reading them
in the Status Bar while hovering with the mouse over this point.

• Horizontal/vertical distance: Enter the distance between the grid lines (in this example the distance from A to B
square respectively from 1 to 2 square.

• Angle: Enter the angle of the grid if it is rotated. Usually, namely in the case of exactly horizontal and vertical
grid lines, the angle is zero.

• Style: Choose a numbering style. One axis is always numbered "A, B, C..." and the other "1, 2, 3..."
• Symbol: Choose a text symbol. It is used for the text objects, building the name index.
After clicking the OK button a text object with the index will be added in the center of the drawing area and can be
moved to a desired position.

 This function creates symbolized map objects, not layout objects. Use the function Convert to Layout Object to
convert the index to layout objects.

 Create Map Grid is the corresponding function to create a rectangular map grid. OCAD does not create a map
grid with the Create Name Index function.

 Define a Tab in the name index text symbol therewith the indices are written in a column.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:CreateNameIndex.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=Export_Files%23Setup_Part_of_Map
https://www.ocad.com/wiki/ocad/en/index.php?title=Graphical_User_Interface%23Status_Bar
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=Convert_to_Layout_Object
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=Map%23Create_Map_Grid
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg


Layout 337

Error Message Text is too long

Each text object in OCAD is limited by 32000 characters. This error message appears when the text has more
charcaters. OCAD copies the full text string in the Windows Clipboard. In this case we recommend you to split the
text string from Windows Clipboard in a Text editor and paste it into OCAD.

Convert to Layout Object
Visit the Convert to Layout Object page to get some information about this function.

Back to Main Page
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Menu Multiple Representation

Multiple Representation

What is Multiple Representation in OCAD?  
Multiple representation enables the ability to store different states of objects in one single OCAD file. To show
these different states of objects, you need to create multiple representations. After you created a new representation
and set it active, you start with the original map and can alter objects or add new ones. The original map won't be
changed, but just your representation. This can be helpful for example when you want to translate a city map to
another language. Just add a new representation where you translate the labels. If you need to change objects in the
original map, these changes are automatically assumed to the new representation. For more examples see Examples:
How OCAD Multiple Representation is meant to work.
The multiple representation is available in OCAD Mapping Solution. OCAD maps with an active multiple
representation can only be opened with this edition.

 Anleitung OCAD Multi-Repräsentation (deutsch) [1]

Multiple Representation Manager
Click on Multiple Representation -> Manager… to open the manager. The multiple representation manager serves
for the activation and management of the representations. You can only activate the multiple representation in the
multiple representation manager.

Click in the head of the dialog on Enable multiple representation to activate the multiple representation. The
multiple representation manager is a non-modal dialog, you can edit the map while the dialog is open.
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Representations
After the activation of the multiple representation and the creation of two representations "Sirnach_city_map" and
"Sirnach_athletic_field" in the Manage Representations tab, the dialog looks like this:
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Extent

In the section Extent, you have the possibility to define the border of a representation. Click on the Define button
and define the extent of the representation with the black rectangle in the map window. Click on Save and activate
Show extent area. The extent gets shown with a red frame in the map window. You can remove the extent, if you
click on Remove or you can overwrite it by defining and saving a new one.

 You don't need to define an extent, but it makes it easier for you to keep the overview. Furthermore, you can use
the defined extent as an input, when you like to export or print the representation.
If you have defined an extent for the currently showing representation, you can click on the button Zoom to extent
to zoom to the extent of this representation.

Representations

The currently showing representation is in this example the Sirnach_city_map. With a click on the favored
representation in the box, you can change between the representations. You see the Representation currently
showing in the top right of the dialog.

Original Map

If you click on the button Original Map, the original map is shown in the map window.

Show Changes

If a representation is shown, you can activate the option Show changes. All objects, that have been moved, changed
or deleted compared to the original map, are shown in the Keyline modus, like the label „Ortsplan“ in following
example:

 The red frame in
the map is the defined extent of the currently showing representation. The label “City map” would be missing in the
Sirnach_athletic_field if it wouldn’t have been moved to a new position within in the representation extent.
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Settings
You can manage the properties for deleting or updating objects of the original map in the Settings tab.

Delete Objects

Ask every object

If an object is deleted in the original map, a dialog appears and asks, if you also want to delete the object in the
representations or if you want to keep it there. This dialog appears once per object and representation.

Delete only original, keep in representations

If an object is deleted in the original map, it is kept in the representations.

Delete original and representations

If an object is deleted in the original map, it is also deleted in the representations.

 If an object is deleted in the representation, there are no effects to the original map and the other
representations. To delete an object in all representations, you have to delete it in the original map.

Update of original objects with representation(s)

Here you can define what will happen, if an object is changed in the original map, that has already been changed in a
representation before.

Ask every object

If an object is changed in the original map, a dialog appears to ask if the changes should be assumed to each
representation. This dialog appears once per object and representation.

Always update representation objects

If an object is changed in the original map, the changes are automatically assumed to all representations.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:MR_Settings.png
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Manage Representations

Add Representation

Enter the name of the representation in the field Representation name and click on the button Add. You see the
added representation in the list of the Representations tab.

Delete Representations

A representation can be deleted, if it isn’t the currently showing representation. Click (once, no double click) on the
representation in the list and click on the button Remove.

Rename Representations

A representation can be renamed. Chosse an existing representation from the dropdown-list, enter a new name and
click on Rename representation.
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Copy Objects from the Original Map to the Representation
If you have deleted (e.g. by mistake) one or several objects in a representation, you can undo this action. Go to the
original map, right-click on a selected object, click on Copy in representation and choose in which representation
you want to copy the object.

This message appears if the object is already in the representation:

This message appears if the object has already been changed in the representation:
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Disable multiple representation
The multiple representation can be disabled in an OCAD map by going to Multiple Representation -> Disable
multiple representation...
The contents of the representations get lost.

Print and Export
If you print or export the map, the currently showing representation/original map is printed or exported.

Restrictions
The function in the menu Thematic Map can’t be used, if the multiple representation is activated. Following
functions are only available, if the original map is shown:
•• Import files
• Functions in the menus Map, Database, DEM and GPS

Examples: How OCAD Multiple Representation is meant to work
The representation "Sirnach_city_map" is an Englisch translation of the original German map. Just the labels are
different, the content of the map ist the same.

For the representation "Sirnach_athletic_field" an approach plan was created. It contains additional labels and
arrows.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:MRM20.PNG
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Back to Main Page

References
[1] http:/ / www. ocad. com/ docs/ Anleitung_OCAD_Multirepraesentation. pdf
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Menu Database

Database

Introduction to Database Connection
In OCAD information which is stored in a database can be added to an object (e.g. position of the object, name of the
place, URL-Link, length of the object etc.). A database is structured as follows:

General Structure of a Database

Table

A database usually consists of several tables. There are different forms of databases: In a flat file database like dBase
[1], each table is a file and all tables in a folder form the database. In other databases like Microsoft Access [2] or in
spreadsheet programs like Microsoft Excel [3] all tables of the database are in the same file.

Record

A table consists of records. A record is a row in the table and contains the information about an OCAD object.

Field

A record consists of fields. Each field contains a single information of an OCAD object, which is described by the
corresponding record. Normally this information is a number, but can also be text. For example the x-coordinate of
the objects' position. Each record has a key field, which is used to identify the record. This is mostly a number.

Example

The following table contains three records. Each record describes an area object in OCAD which describes real
estate and consists of six fields: ID, SIZE, OWNER and XCOOR, YCOOR, TYPE. The ID is the key field, which
is used by OCAD to identify the record. The SIZE describes the magnitude of the area. In the OWNER field, there
is a number which links to a Secondary Table. The fourth and the fifth field contain the coordinate and in the last
field, the type of the area is indicated.

ID SIZE OWNER XCOOR YCOOR TYPE

1 724 29 754870 233386 Private Building Area

2 702 12 754900 233442 School

3 422 13 754815 233505 Private Building Area

In OCAD a record is displayed as follows when the corresponding object is selected:
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Dataset

To connect to a table OCAD uses a dataset. The dataset contains the link to the database, the name of the table, the
name of the key field and information about other special fields. You can have several datasets for the same OCAD
map.

Manage Database Connections   

Create a New Database Connection
You have to create a dataset, which can be done by following these steps:
1. Choose the Manage Database Connections command in the Database menu.
2. The Manage Database Connections dialog opens.

3. Click the New button.
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4. The New Dataset dialog appears. Choose the Create new database file option and select a Database type or
choose the Use existing datasource option. Note that the Access Database Engine has to be installed if one of
the Mircosoft Access or Mircosoft Excel database type options is chosen. See at Map Information in the Map
menu if the Access Database Engine is installed.

5. If a new database file is created, the Save Database File dialog appears. If an existing datasource is used, the
location of the datasource has to be specified by clicking the Browse button or connecting via ODBC in the
Manage Database Connections dialog.

6.6. The dataset is created. Your OCAD map is now connected to the database.
When a database connection is newly created, OCAD displays a dialog after closing the Manage Database
Connections dialog. You can check two options in this dialog:
•• Delete Database Record when Deleting Object
•• Create Database Record when Cutting Object

General Settings for the Selected Dataset
The first of the three tabs in the Manage Database Connections dialog is about general settings of the currently
selected dataset. In the first part the source of the database is given. It can be either a Database file or an ODBC
data source. Click the Edit Fields... button to edit the fields of the selected dataset (only available for dBase
format).
In the lower part of this tab, the Table which contains the desired information can be chosen. Define a Key field so
that OCAD can identify the record. This field is mostly named ID.
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dBase
When OCAD is connected with a dBase table there are additional functions available. In dBase each table is a file. It
is possible to edit field settings within OCAD. If a dBase table is loaded, the Edit fields button is enabled in the
General tab of the Manage Database Connections dialog. Click it to open the dBase Table dialog.

 OCAD can only link dBase files in the 32 bit version. In 64 bit version a warning appears when opening
the ocd file. The warning can be switched on/off in the Preferences in the submenu Warnings.

 You can convert these databases to Microsoft Access in the Manage Database Connections dialog with
convert or open this ocd file in OCAD in 32 bit version.
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This dialog box lists the fields of the dBase table. Each field is displayed in a line. There are several functions
available:
• Name: Enter here the name for the field. The name must start with a letter and may contain up to 10 letters and

numbers. Letters are converted to capital letters.
• Type: Choose either Character (C), Number (N) or Float (F) as a field type.
• Length: Enter here the number of characters for the field.
• Decimals: This filed is only active if the data type is Float. Enter the number of decimals.
• Move Up: Click this icon to move the selected field one line upwards.
• Move Down: Click this icon to move the selected field one line downwards.
• Insert: Click this button to add a field. After adding the new field, the dBase table is restructured. Existing

information is preserved.
• Delete: Click this button to delete the selected field.
• Character encoding: A character encoding type can be chosen in the corresponding dropdown list.

 If you do not have installed the Borland Database Engine (BDE), only filenames with less than 8 characters are
allowed (Example: 'test5678.dbf'). Click the Map Information command in the Map menu to see, if the Borland
Database Engine is installed or not. It can be downloaded from the internet for free.

Remove
With this function, you can remove the selected dataset.

Rename
This function allows you to change the selected dataset name.
1.1. Choose your dataset, which you want to rename.
2.2. Click on the "Rename..." Button.

3.3. Enter the new dataset name.
4.4. Click on the "OK" Button.
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Convert
It allows you to convert your datasets to Microsoft access either each as single file or all datasets in one file. This
works only if your datasets are in dBase (*.dbf).
1. Get to Manage Database Connections in Database.
2. Click on the "Convert" Button and the Convert dBase to Microsoft Access dialog opens.

3.3. Pick your datasets, which shall get converted and if each dataset shall be in a new file or all datasets in a single
file.

4.4. Click on "OK" to end the process.

Relink
This function allows you to change the directory of your datasets.

• All dataset pathes from the Old directory are relinked to the New directory.
• Dataset pathes that are different from the Old directory are not changed.

View and edit table
This function shows you the elements of the dataset and allows you to edit them.
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ODBC
You can access to databases via ODBC [4] (Open Manage Database Connection). This is an interface to connect to
all kind of databases.
Click the ODBC button in the Manage Database Connections dialog to create a new ODBC data source or to
modify an existing data source. The ODBC Data Source Administrator is started. This is a Microsoft program and
contains its own online help. Here are just some hints: Normally you create a new User DNS.

For a connection to an Excel file, you select the Excel driver and the Excel (*.xls) file.
For a connection to an Access database, you select the Access driver and the Access (*.mdb) file.
For a connection to a flat file database like dBase you do not select the dBase file. Instead you select the folder
where the dBase file is.

Create and Edit Secondary Tables
Secondary tables are tables which are linked to a field in the primary table. This is especially useful, when additional
information is added. For example, imagine a map with all real estates of a village. Then, each owner would get a
number, which is stored in the primary table. The secondary table would be linked to this number and would contain
all names, addresses and contact information of the owners. If an owner changed his contact information, you would
update the changes in the secondary table, which would have an effect on all his real estates.
In OCAD, secondary tables can be managed in the Secondary Tables tab of the Manage Database Connections
dialog. Click the Add button to add a new one. The Secondary Table dialog appears. First, you have to define the
Reference field in the primary table, which is the field, the secondary table is linked to. Then, choose the
secondary table which must be in the same dataset. Finally, define a Key field for the secondary table and click the
OK button.
Click the Edit button to change the settings of the secondary table.
Click the Remove button to remove the selected secondary table.
Fields which are linked to a secondary table are indicated with an asterisk (see below).

Click the asterisk to display the secondary table:
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Define Special Fields
Open this tab to define special fields. Special fields are automatically updated in the database when a modification to
the object in the map is made. However, it does not work in the other direction. If you change such a field in the
table, the object is not updated.
OCAD provides the following special fields:
• Symbol field: The symbol number of the object is automatically copied to the database field which you have

chosen in the dropdown list. It is possible to let new symbols get assigned, when the field value is changed.
• Assign new symbol when changing field value: When changing the symbol number in the database field then

OCAD change the symbol of the linked object.
•• Example:
•• Object is assigned to symbol number 900.002.

•• When changing the symbol number to 900.003 in the database box then OCAD changes the symbol.

• Text field: For text and line text objects, the text of the objects is automatically copied to the database field which
you have chosen in the dropdown list. For multiline text, only the first line is copied.

• Size field: The size of the object is automatically copied to the database field which you have chosen in the
dropdown list. For line objects the length and for area objects the area is taken. Adjust the units in the
corresponding fields as well as the number of decimals.

• Easting: For point objects the horizontal coordinate is copied to the chosen database field. For line, area and text
objects it is the horizontal coordinate of the start point.
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• Northing: For point objects the vertical coordinate is copied to the chosen database field. For line, area and text
objects it is the vertical coordinate of the start point.

• Angle: For point and text objects the angle is copied to the chosen database field.
• Date: The date of the object is automatically copied to the database field which you have chosen in the dropdown

list. It's value get's adjusted, whenever you change the object.

Database Box   

Link Object
When the map was connected to a database, the Database Box appears below the Symbol Box.

 The Database Box is shown right below the Symbol Box by default. Only one row of the Symbol Box is visible.
To move the Database Box down, simply click and drag the grey bar between symbol and database box down.
To link an object:
1.1. Select the object which you want to link to a record. (Note: To select an object, it must not be protected or

hidden.)
2. Click the Link button in the Database Box.
3. The Link Object dialog appears.

4.4. Select the dataset which contains the desired record.
5.5. Enter a key. This number is used for the key field. Unless you make any changes, OCAD takes always the next

free integer.
6. Check the Create new record option. If the object is to be linked to a record which already exists, uncheck this

option and enter the key of the record.
7. Click the OK button.
8. The Record is shown in the Database Box now.
To remove a link:
1.1. Select the object which the link is to be removed from.
2. Click the Link button in the Database Box.
3. The Link Object dialog appears.
4. Click the Remove button.
5.5. The link is removed from the object but the record is not deleted from the table.
Learn how to link multiple objects to records in the Create and Update Records article.
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Records in OCAD
This is how a record looks in the Database Box:

The Key field is indicated with a K behind the field name. A S means, that this is a Special Field. A link to a
Secondary Table is indicated with an asterisk. If no sign appears in this column, it is just a normal field.
It is possible to open an URL directly from the Database Box. Press the Ctrl key and click the field. OCAD opens
the URL in the web browser. This works for local files (for example a picture), too:

OCAD opens the file in the default program.

Find Object
Find an object with help of the key by clicking the Find button in the Database Box. The Find Object dialog
appears.

Select a dataset and enter the key. Click the OK button. OCAD will display the record in the Dialog Box and will
move the view to the corresponding object. Furthermore, the object will be selected.
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SQL Query
Click the SQL Query button to select database objects by a certain criteria. The Select Database Object dialog
appears.

In the SELECT FROM part of the dialog, choose a dataset.
In the WHERE part you can give a condition:

Field: Choose a field of the selected dataset. When you double-click a field name it is added to the SQL
statement box.
Operator: Select an operator. When you double-click an operator it is added to the SQL statement box.
Value: Select a Value. When you double-click a value it is added to the SQL statement box.

The SQL statement should always contain the components FIELD - OPERATOR - VALUE (example: Length >
430). An SQL statement can be cleared, saved or loaded by clicking the corresponding button to the right of the
SQL statement box.
Click the Select button to start the database query. The found objects are selected and the corresponding records are
displayed in a table.
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Create and Update Database Records   
With this function, new records can be created or updated for all objects with the selected symbol:
1. Choose the Create and Update Database Records command in the Database menu.
2. The Create and Update Database Records dialog appears.

3. Select the Dataset the records are to be created in and click the OK button.
4. New records are created and linked to all objects with the selected symbol(s). The next free integers are used for

the key fields. If they are already linked to records, the records are updated. Special Fields are updated
automatically.

As an example, assume that you want to create an OCAD Internet Map with a street find function. All street names
must be linked to the database. OCAD provides a simple way to create these links.
1. Make sure you have enabled the Special Fields for text.
2.2. Select all symbols which are used for street names.
3. Choose the Create and Update Records command from the Database menu.
4. Select the dataset and click OK.
Now all street names are linked to a record which contains the street name itself as a field.

Update Special Fields from Database Records   
Special Fields are only updated automatically when the linked object is edited. When objects are linked to a
database and the database is edited with another program, the Special Fields are not updated, until you use the
Update Special Fields from Database Records function in the Database menu. The same applies for fields which
were edited manually in OCAD.
1. Choose in the database pannel Update Special Fields from Database Records and the dialog opens.
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2. Select a dataset or choose the All datasets option.
3. Then, check all special fields you want to update and click the Update button.

Create Objects from Database Records   

With this option, objects can be created with location and text data from the database.
1.1. Select the symbol the new objects shall get. This must be a point or a text symbol.
2. Choose the Create Objects from Database Records command in the Database menu.
3. The Create Objects from Database Records dialog appears.
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4.4. Select the dataset which contains the information the object is to be created with.
5. Select the field for the Easting and Northing which determines the position of the new object.
If the dataset is a line text object with two points (P1,P2), P1 has the coordinates of the Easting and Northing fields.
The length of the line text is added to the P2 easting coordinate.
1. Choose between m, km and deg as a unit of measure.
2.2. If a text symbol was selected in the beginning, you have to select a text field. The content of the text field is used

as the text of the OCAD object.
3. Enter a condition. This condition must be an SQL statement: FIELDNAME OPERATOR VALUE (Examples:

SIZE > 500, City='Baar'). If this field is empty, all records in the table get an object on the map.
4.4. You can give a horizontal and vertical offset. This is useful for example when you want to import city names.

First create a point object for each city, then create a text object with the city name with an offset, so that the
name does not overlap with the point object.

5. Finally, click the OK button.
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Assign Symbols from Database Records   
After importing for example a Shape file the objects have no symbol assigned and appear as Unsymbolized Objects.
With this command you can use the information in the database table to assign OCAD symbols to the objects.
Choose the Assign Symbols from Database Records command in the Database menu. The Assign Symbols from
Database Records dialog appears.

In this dialog box you can create a list of conditions. You can save the list to a condition file (*.cnt) for later use.
You can load an existing condition file to modify or execute it. You have the following possibilities in the Assign
Symbols by Records dialog:
• Dataset: Select here the dataset which should be used to assign symbols. Check All to execute the condition for

all datasets.
• Load: Click this button to load an existing condition file (*.cnt).
• Save: Click this button to save the changes to a condition file (*.cnt).
• Save as: Click this button to save the changes to a different condition file (*.cnt).
• Symbol: Select here a symbol. For those objects the condition is true, the symbol number will be assigned.
• Condition: Enter the condition here. This must be a SQL statement: FIELDNAME OPERATOR VALUE

(Example: TYPE = 'BUILDING').
• Move up: Click this button to move up the selected condition.
• Move down: Click this button to move down the selected condition.
• Add: Click this button to add a condition to the list.
• Delete: Click this button to delete the selected condition.
• Execute: Click this button to execute the assignment.

 Assign Symbols from Database Records might make slow progress for big datasets. There is an alternative for
shape files by chosing the option Use layer information from field in the Import Shape File dialog and Convert
Imported Layers to Symbols... afterwards.

 If there is an apostrophe in the value then you have to add an addition apostrophe. For example: 'RIVERNAME
LIKE l' 'Avançon'
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Add Texts from Database Records   

With this function it is possible to add a text which is written in a field of a record to an OCAD object.
1. Choose the Add Texts from Database Records command in the Database menu.
2. The Add Texts from Database Records dialog appears.

3. Choose a Dataset or check the All option to take all datasets into consideration.
4. Choose the field which contains the Text to be added.

It's possible to assign a parameter condition for the text.
5. Assign a text or line text symbol. If no symbol is assigned, the text appears as Unsymbolized Objects.
6.6. You can either replace the existing objects or add new objects.
7. Enter an Object offset if you want to have the text slightly displaced from the existing object.
8. Click the OK button.
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Set Object Direction from Database Records   
With this function the object direction can be defined by an angle (in degrees) from a field of the database.
Choose the Define Object Directions from Database Records command from the Database menu. A dialog
appears. Choose a Dataset in the dropdown list or check the All option to take all datasets into consideration. The
define the Angle field.
Mathematical function: Optionally you can define a mathematical function. To convert Radians to Degrees enter
*180/3.14159.
Click the OK button when finished.
The following things are rotated according to the angle field:
•• Text objects
•• Point objects
•• The pattern of area objects
OCAD does not rotate line or line text objects!

Merge Objects from Database Records   
With this function, objects with the same value on a specified database field are merged. They also must have the
same symbol.
Choose the Merge Objects from Database Records command in the Database menu. A dialog appears. Choose a
Dataset or check the All option to take all datasets into consideration. Then choose the field with the value to be
used for merging the objects. Click the OK button when finished.
The merged objects have to be linked again to the database.
Example:

You have different river segments on a map. Each river segment have the same river name. With the Merge Objects
from Database Records function, they can easily be merged to one object.
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Select Linked Objects   

Select Objects with Good Database Record Links
Choose this function in the Database menu to select all objects with a link to an existing record.

Select Objects with Broken Database Record Links
Choose this function in the Database menu to select all objects which are linked to a record but the record was not
found.

Select Objects without Database Record Link from Selected Symbols
Choose this function in the Database menu to select all objects which are not linked to a record. OCAD checks only
if a record link exists. OCAD does not check if the record link is broken or not. To check if the record links are
broken choose Select Objects with Broken Database Record Links.

Select Objects Linked to the same Database Records
Choose this function in the Database menu. By choosing this function, multiple objects which link to the same
record are selected.

Delete Database Records without Linked Object   
Use this function to delete unused database records for example after using the Part of Map function.
Choose Delete Records without Linked Object in the Database menu. The Delete Records without Linked
Object dialog appears.

Select the dataset and click the Find button. OCAD checks for
•• records in the selected dataset
•• links to OCAD objects found. OCAD does not check if the objects also exists.
•• records in the selected dataset without a link to an OCAD object
The ids of the records without a link to an OCAD object are shown in the Records to delete field. Please note that
only the first 100 ids are shown. For the complete list of ids please use the Copy report to Clipboard function.
Click the Copy report to Clipboard icon to copy a list with the record ids to the Windows Clipboard. You can paste
this list into an text document.
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Example of this report:

*** Records found in dataset: (35982)

198

199

200 

...

*** Linked objects found: (818)

199

18421

202

...

*** Records without linked objects found: (35165)

49535

49536

49537

...

Click the Delete button to delete the records according the list from the Records to delete field. The number of the
deleted records are shown in the left status bar during the deleting process. Press the ESC key to abort this process.

 Please note that is not possible to undo this process. So please backup your database before starting the deleting
process.

Options   

Delete Database Record when Deleting Object
If this option is checked in the Database menu, the corresponding record is deleted when you delete a linked object
in OCAD.

Create Database Record when Cutting Object
If this option is checked in the Database menu, a second database record is created when a linked object is cut.

Database Information   
Allows you to see all the information about each dataset.
OCAD checks for invalid database links and shows these in the Report field when opening the dialog.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Space.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Mas40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Space.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Mas40px.PNG


Database 365

All linked objects from all datasets: Shows all objects with have link to a database records. OCAD does not check
if this record really exists (broken database record links).
Datasets: Shows all datasets. Click on a dataset to load the data for this dataset.
All keys in database: Shows all keys from the choosen dataset. This list shows also keys from database records
which are not linked with OCAD objects.
All linked objects: Shows all objects which are linked with the choosen dataset. OCAD does not check if this record
really exists (broken database record links).
Report: Shows a report about the choosen dataset.

Database Compatibility
OCAD checks the compatibility of the dataset. OCAD 2019 exists in a 32 bit and 64 bit version.

Mircosoft Excel/Access
OCAD 64 bit version cannot connect to Microsoft Excel/Access if the 32 bit version of Microsoft Access Database
Engine is installed. The same with 64 bit Microsoft Access Database Engine and OCAD 32 bit version.
In this case use the same OCAD version as installed Microsoft Access Database Engine.

 You can switch on/off this warning in the Preferences in the submenu Warnings.
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Back to Main Page
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Menu Thematic Map

Thematic Map
OCAD ThematicMapper has been developped in a joint project of the OCAD Inc. and the Institute of Cartography
and Geoinformation at ETH Zurich. As a core of the new application a step-by-step wizard guides - considering
established cartographic rules - through the process of creating thematic maps. The wizard supports the user
from the data analysis to the thematic symbolization and visualization. The OCAD ThematicMapper opens the
OCAD software for the broad scope of thematic statistical maps [1].
OCAD ThematicMapper supports numerous visualization methods for point-like, linear and area-based
representations like proportional symbols, lines and arrows as well as choropleths [2] or various types of charts such
as bar charts, pie charts [3] and wing charts. These can be divided into groups for example, to make comparable the
consumption of different energy sources of two years.

Create a Thematic Map   
You can get access to the Thematic Map Wizard by opening a New File with choosing Thematic Map as a map
type (this is done silently in the OCAD ThematicMapper edition) or by clicking Create with Wizard... in the
Thematic Map menu. It opens the Welcome page of the wizard with an overview of the six steps to create a
thematic map.

Requirements
OCAD ThematicMapper module requires the Borland Database Engine [4] and the Microsoft Access Database
Engine [4]. See also system requirements.

Welcome Page

Add a new theme

Choose the Add new theme to the map option and enter a name for the theme (ex. population change). It is possible
to load the wizard settings with the load settings from xml file option if you have already created thematic maps
with the Thematic Map Wizard. The xml file can be choosen with the ... button.

 A map can have more than one theme (ex. choropleths + proportional symbols).
 The next button is only active if a theme name is set.
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Modify an existing theme

Use the option Modify an existing theme to change the settings of an already existing theme in your map file.

Step 1 - Statistical Data
1.1. Load statistical data from a file (*.xls, *.csv, *.dbf or *.txt).

 The statistical data should be complete and accurate.
 Select a table (sheet) if an Excel file is loaded.
 It's possible to view the table with the  lense icon.
 The statistical data should have a common field with the attribute table of the geometry data, in order to be

joined later.
2. Select attributes to visualize either by double click, drag and drop or selecting them and pressing the [>]-button.

 Remove attributes from the selection by double click (in the box Selected attributes to visualize:), drag and
drop or selecting them and pressing the [<]-button.

3. Define if the attribute values are absolute or relative and if they shall be classified and choose the representation
feature to visualize the theme.

 The Classify and the representation feature option are disabled if more than one attribute is chosen.
4. Click the Next button to go on with Step 2.
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Step 2 - Geometry
1.1. Load the geometry data from shape (*.shp) file.

 It's possible get a data preview. The Geometry Data Viewer is opened by clicking on the  lense icon.
Switch between the Geometry and the 'attribute(s) tab to view the map or the attribute table.

2.2. Set map scale and map size.

 The map scale and the map size are linked by default. Click the Keep ratio between map scale and map
size  button to disable the ratio fixation.

3.3. Select a coordinate system.

 By default the coordinate system of the template file (loaded during the New File process ) is set.
The template file is loaded from: OCAD program path -> symbols\Thematic Map.ocd. Select another one by clicking
on the Choose button.
1. Click the Next button to go on with Step 3.
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Step 3 - Join Data
1.1. Choose a common field in both tables.

 Click on the  lense icons to view the tables, if you are not sure which fields have common values.
2. Decide betweeon the options Keep all records (Left outer join) or Keep matching records (inner join).
3. Click the Next button to go on with step 4.

Step 4 - Visualization of map's theme

Step 4.1: Choose a Visualization Method
1. Choose a visualization method that is suitable for the chosen data. The wizard suggests the most appropriate

method(s) according to the choices done in Step 1.
2. Click the Next button to go on with step 4.

Step 4.1.1: Select the Chart Properties (Only for charts)
1. Grouping: Choose if the attributes shall be divided into groups.

 The grouping option is only enabled if the number of selected attributes allows to create groups with a
constant number of attributes.
Select the Divide attributes to several groups option if they attributes should be divided to several groups.
Click on the ... button to open the Define groups with drag and drop window.
Select a number of groups and divide the attributes to the corresponding number of columns. Each column
represents one group. Keep attention that have the same order of attributes.
Enter the group names in the first row.
Click Close to hide the Define groups with drag and drop window.
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2.2. Proportionality

Choose if the chart size should be Linear (length) or Quadratic (area) proportional to the data values.
3.3. Amount emphasis

Choose between emphasizing the Total amount (total size) or the Sub values (sub value sizes).
4.4. Choose one of the available charts.
5. Click the Next button to go on.

Step 4.2: Visualization Properties

 The available visualization properties depend from the visualization method chosen in step 4.1.
 Click the  lense icon to show/hide the preview on the right side of the wizard.

Proportional Symbols

1. Choose a Visualization type like Proportional bar, Proportional circle or Proportional square.
2.2. Define the symbol color by double-clicking on the attribute(s). The color picker opens and allows to define the

color either with CMYK or RGB.
3. Scale the symbol size by a Representation ratio or a Maximum size (height, radius, side length etc.). Define

also a minimum size (height, radius etc.)
1. Define a Bar width for the visualization type Proportional bar.

4. Define the Stroke color and Stroke width and if the stroke width shall decrease for smaller symbols.
5. Define the Opacity in a value range between 0 and 100%.
6. Decide if 0 values and no data shall be shown.
7. Click the Next button to go on.
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Step 5 - Visualization of Basemap
The different layers are listed in the table.

Additional basemap layers can be added  and layers can also be removed  . Make sure that the basemap
features are suitable for this scale.
The layer order can be changed by clicking the  and  button.
Define the visualization properties (fill color, stroke color and width) for the geometry layer and the basemap
layer(s).
Click the Next button to go on.
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Step 6 - Additional Map Elements
Additional map elements help the user to read the map. The elements can be moved and edited directly on the map.
1. Enter a Map title and define it's style.
2. Choose if a Legend for the theme shall be added, define it's title and the style.
3. Choose if a Basemap legend shall be added.
4. Choose if a Scale bar and/ or a Scale text shall be added.
5. Decide if you want to add any Additional text information by typing the text into the box.
6. Click on the Finish button to create the final map.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:ThematicMapStep5.png


Thematic Map 375

Create Thematic Maps with XML Script
OCAD XML scripts functionality does also support to create thematic maps with xml script

Thematic Map Samples
There are several sample maps available in the OCAD program subfolder Samples\ThematicMapper (usually
C:\Program Files\OCAD\OCAD 20xx\Samples\ThematicMapper) as well as statistic data samples, geometry data
samples and XML script samples.

 Open the sample maps by using Open Sample Map... in the File menu.
 Execute the XML scripts by using Execute XML Script in the File menu.

Thematic Map Tutorials
• Visualisierung von Einwohnerdaten mit proportionalen Symbolen: Download as a PDF file [5]. (Visualization of

population data with proportional symbols)
• Visualisierung von Migrationsdaten mit proportionalen Pfeilen: Download as a PDF file [6]. (Visualization of

migration data with proportional arrows)
• Visualisierung von Daten zur Produktion erneuerbarer Energie mit unterteilten Flügeldiagrammen: Download as a

PDF file [7]. (Visualization of renewable energy production data with divided wing charts)
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Thematic Map Videos
Link to Youtube Video Playlist [8]

Back to Main Page
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Menu Background Map

Background Map
Background map refers to a raster map or OCAD file used as a background. It serves as a drawing template or
background image. Examples include scanned draft maps, satellite pictures, orthophotos or relief shadings. OCAD
cannot be used to edit background maps.

Scanning a Background Map     
It is recommendable to keep with the following two things:
• Use a grid: In most cases you cannot scan the entire draft map (the background map). You are either limited by

Windows (which limits the maximum size of background maps), by the available memory, or by the size of the
scanner (A4). In these cases, it is strongly recommended that you should draw a grid on the draft map. In many
cases there is already a kilometer grid which can be used. If this does not exist, you should draw a precise grid of
vertical and horizontal lines (perhaps at a distance of 10 cm). Then the scanned pieces can be easily joined
together in OCAD.

• Resolution: It is recommendable to scan the map with 300 dpi.
OCAD supports only WIA compatible scanners. Click Scan in the Background map menu. The Scan dialog opens.
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Choose the extent and click Scan. You have the option to save file file in jpg, bmp or png file format. Then the
scanned background map is opened.

Open a Background Map      
Choose this command from the Background Map menu to open a background map which is displayed as a
background picture on the screen. OCAD can open BMP, GIF, PDF, PNG, TIFF, JPEG, JPG2000 and TIFF files. In
addition, OCAD maps (*.ocd) or Encrypted OCAD maps (*.eocd) can be loaded as a background map, too. The
Open Background map dialog appears. Choose a file and click the Open button.
Note: In the OCAD Starter Edition, OCAD (.ocd) and Encrypted OCAD Maps (.eocd) are only available to use
as a background map in course setting projects.

 OCAD 2019 can load only encrypted OCAD files exported from OCAD 2019. Encrypted OCAD 10, OCAD 11
or OCAD 12 files are not compatible with OCAD 2019.

 OCAD loads the background map hidden when pressing the Shift key while clicking the Open menu item.

Use a Georeferenced Raster Map as Background Map
If your map is georeferenced and you want to use a georeferenced map as background map:
1. Select the Open command in the Background Map menu. The Background Map dialog box opens.
2. Select a file and click the Open button.
3. The Background Map (Georeferenced) dialog appears and shows the georeferencing of the selected map.

• Select the New Offset option to create a new map offset. The center of the map will be moved to the offset you
typed in the Easting and Northing Offset fields and rotated with the angle entered in the Angle field. In
addition, the scale can be changed.

• Select the Existing Offset and Angle option to leave the map as it is. The background map will be placed at 
the correct position with reference to the existing map offset and angle. If you choose this option, the
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background map may be placed outside the map range. In this case, an error message will appear.
• Select the Transform from other coordinate system option to transform the background map from another

coordinate system when opening the aerial image.

4. Click the OK button to finish.

 - Click the Entire Map button to display the entire background map.
- The Draft Mode option in the View menu can be used to dim map objects and the background map itself.
- Ocad files can also be loaded as background maps.

Use a Non Georeferenced Raster Map as Background Map
If your map is georeferenced and you want to load a non-georeferenced map:
1. Select the Open command in the Background Map menu. The Background Map dialog box opens.
2. Select a file and click the Open button.
3. Enter a resolution for the background map (if a raster map is loaded) and click the OK button.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:BackgroundMapDialogGeoreferenced.PNG
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The background map is displayed at the center of the current drawing area. The raster map (background map) now
needs to be adjusted with the map (Adjust a Background Map). In other words, it needs to be referenced with the
map coordinate system.

 You can scan a raster map to use it as a background map directly in Ocad: Select Scan in the Background Map
menu and then choose the Acquire submenu. Your scanner's dialog box will open (Scanning a Background Map).

Infrared Images
OCAD supports 32-bit infrared tiff images. When opening an infrared image Ocad shows the following message
box:

Click Yes to show the background map as false-color image using the infrared, red and green spectral bands mapped
to RGB.

Click No to show the background map as true-color image.

https://www.ocad.com/wiki/ocad/en/index.php?title=Background_Map%23Adjust_a_Background_Map
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Error or Warning Messages

Error Message Not enough memory for the background map

This error message appears if Windows cannot provide the memory needed to load the whole background map. For
uncompressed background map files the size of memory needed is about the file size. Compressed background map
files have to be expanded in memory and therefore need more memory than their file size.

 If Ocad 64-bit version is used, background map files bigger than 2.1GB can be loaded.

Error Message TIFF variant not supported

This error message appears if the TIFF variant is not supported by the current version of OCAD.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:InfraredImageTrueColors.png
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Error Message This TIFF file contains tiles. OCAD does not support TIFF files with tiles

This error message appears if the TIFF contains tiles which OCAD doe not support. Please convert this file into an
untiled TIFF format.

Error Message Compression type not supported

This error message appears if the compression in the opened TIFF file is not supported by the current version of
Ocad.

Warning The background map is geo-referenced in the scale 1:x but the open map is in the scale 1:y

This warning appears if the OCD background map is geo-referenced and has an other scale than the currently opened
map. Ocad opens the map but ignores the georeferencing (no scaling and no offset) and uses the paper coordinates.
To avoid this warning message, open the OCD-File you want to load as a background map and use the change the
map scale function.

Limitations for Georeferenced ocd Background Maps
OCAD supports different real world offsets and real world angles. The offset and angle can be set in the Set Scale
and Coordinate System dialog. In some cases, OCAD has a redrawing problem with different real world angles.

Open pdf as Background Map
OCAD cannot load pdf files as background maps. OCAD uses the software Ghostscript [1] to convert the pdf to jpg
and load this jpg file.
To open pdf files you have to install the software Ghostscript [1] and set the Ghostscript path in the OCAD
Preferences.
Example:
• Set Ghostscript file path in Ghostscript file path in the OCAD Preferences
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•• Open pdf as background map

• Ghostscript converts the file to a not georeferenced jpg. So you have to adjust this background map. The loaded
jpg images is in the list of the background maps.

Adjust a Background Map      
Choose this command in the Background Map menu or press the F9 button (Shortcut by default) to adjust the 
background map. This command is active when one or more raster background maps are loaded. 
If more than one background map is loaded, you will have to choose a map in a dialog box:

https://www.ocad.com/wiki/ocad/en/index.php?title=File:GhostscriptFilePath.png
https://www.ocad.com/wiki/ocad/en/index.php?title=File:BackgroundMapOpenPdf.png
https://www.ocad.com/wiki/ocad/en/index.php?title=Background_Map%23Adjust_a_Background_Map
https://www.ocad.com/wiki/ocad/en/index.php?title=File:BackgroundMapOpenPdfLoadedJpg.png
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Space.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Mas40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Ori40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Sta40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:CS40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=Shortcuts


Background Map 384

  Background
maps from online WMS are not shown in this dialog box.
A background map can be adjusted to the grid or to the map. A grid on the background map makes it easier to adjust
it. The grid crossing points can be used for the adjustment (however, any points can be used).
It is possible to use 1 to 12 points for the adjustment. After choosing the Adjust command the cursor changes to a
cross line with a black and white squared pattern. You are now in the Adjust mode. Do the following steps for each
adjustment point:
1.1. Mark a point on the background map (e.g. grid point or a surface reference point) by clicking it.
2.2. Mark the same point on the map by clicking it.
In the bottom left part of the Status Bar you can always see, which point you have to mark at the moment, when you
are in the Adjust mode.
When having adjusted enough points, execute the adjustment by pressing the Enter key. The background map is
rotated and stretched to get the best fit for the adjustment points.
If the adjustment is not good use the Undo function to cancel the new adjustment.

 - If the size of the raster map corresponds exactly with that of the map scale and has not been rotated, it is
possible to adjust it with the map using a single point pair. OCAD will correctly reposition the raster map without
changing the scale or angle.

- If the raster map is contorted, rescaled or rotated, you will need to use between 3 and 12 point pairs to adjust
the image with the map. OCAD repositions the raster map by transforming it (affine transformation) and
adjusts the scale and angle accordingly. The point pairs should be distributed equally across the map.
- If the adjustment point pairs lie outside of the drawing window, you can move the map section between the
adjustment point pairs during the adjustment process.

Error Adjustment points too close: When using several points for adjusting a background map, the outermost points
must be separated by at least 2 mm on the background map.
Note: OCAD Background Maps cannot be adjusted. The Georeferencing is used to place the map or, if the map is
not georeferenced, the origin of the background map (middle of the map, point (0/0)) is displayed on the origin of the
current map.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=Background_Map%23WMS
https://www.ocad.com/wiki/ocad/en/index.php?title=Background_Map%23WMS
https://www.ocad.com/wiki/ocad/en/index.php?title=Graphical_User_Interface%23Status_Bar
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=Create_a_New_Map%23Set_Scale_and_Coordinate_System


Background Map 385

Once you have completed the map adjustment, the raster map can be saved as a georeferenced raster map. The
advantage of this is that the raster map will be loaded in the correct position the next time it is opened.

Export Georeferenced Raster Map
To save the raster map as a georeferenced raster map:
1. Select the Export command in the File menu.
2.2. Select a desired raster format (TIF, JPG, GIF or BMP)
3. Select a Resolution (300 dpi is recommended for printing maps)
4. Select the Create World file option
5. Click the OK button.

Hide all Background Maps       
Choose the Hide All command in the Background Map menu or press the F10 key (Shortcut by default) to hide all
background maps temporarily or make them visible when they are hidden. This command is active if one or more
background maps are loaded.
If you want to hide only single background maps, choose the Manage command from the Background Map menu.

Manage Background Maps       
Choose the Manage command from the Background Map menu to set options for displaying and printing the
background maps. The Manage Background Map dialog box is displayed. This is a non-modal dialog box. It is
possible to switch between the dialog box and the map window without closing the dialog. Changes are directly
updated on the map.
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In the Manage Background Map dialog a table is displayed. In this table all loaded background maps are listed.
The table consists of the following columns:

Visibility options       

• V (Visible): You can make a background map visible or hide it by clicking the corresponding cell in this column.
An eye icon in this column means that the background map is visible.

 To hide all background maps temporary use the Hide All command in the Background Map menu.
• F (Visible in Background Favorites view mode): You can make a background map visible or hide it in the

Background Favorites by clicking the corresponding cell in this column. An eye icon in this column means that
the background map is visible in the Background Favorites.

• Dim: In this column you can enter a value in percentage to make the background map appear brighter, i.e. to dim
it. 0% means the background map is displayed in its original colors. 100% means the background map appears
completely white. Dimming is used to get a better distinction between the background map and the map.

• T (Transparent): If more than one background map is opened you can set them transparent so that both are
visible. Activate this option by clicking the corresponding cell in this column.

Assign to Spot Color     

This feature is used in a special production process, namely to update old hand drawn or scribed maps. The printing
plates for each spot color are scanned (black and white or gray-scale) and then used as background maps. When such
a background map is assigned to a spot color, it is displayed with this color. In addition, when the Spot Color View
is activated the background map is displayed together with the corresponding spot color.
Visit the Define Spot Colors page to learn more about spot colors.
Note: This feature is intended for black and white or gray-scale background maps. If a color background map is
assigned, the resulting colors are undefined.

Blockout     

This column is labeled with a B and is only available for raster background maps. Click a cell in the Blockout
column to use the corresponding background map as a block out mask.
If you have several black and white or gray-scale background maps which are transparent and assigned to a spot
color, you can use this function to hide some background maps in a certain area of a different background map.
In the following example, there are four black and white or grey-scale background maps loaded. Each background
map was assigned to a spot color. There are the purple, the black and the blue lines. The fourth background map was
assigned to the yellow color. The Manage Background Map dialog looks as follows:
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The yellow background map is used as a Blockout mask. The result looks as follows.

The black and the purple background maps are hidden behind the yellow areas when using Blockout. The blue
background map is drawn over the yellow areas because it is over the blockout mask in the order of the background
maps.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:ManageBackgroundMap.PNG
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File name       

The file name of the background map is displayed in the File name column.

I (Information)       

Click on the  information icon to get more information about the corresponding raster background map. The
Background Map Info dialog box appears with additional information. The given information varies depending on
the file type.
Info for raster background map:

Info for OCAD background map:

If an encrypted background map is load then a  lock icon is displayed in the information column.
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Click on the  lock icon to get more information about the encrypted background map.

WMS

Background maps from online WMS are displayed with light blue color.

Other Functions      

• Move Up: Click the Move Up icon to move the selected background map one line upwards. Background maps
which are listed in a upper position in the Manage Background Map table are diplayed in the foreground.

• Move Down: Click the Move Down icon to move the selected background map one line downwards.
Background maps which are listed in a lower position in the Manage Background Map table are diplayed in the
background.

 The selected background map can also be moved up and down with drag and drop on the file name
column.

• Open: Click this button to open a new background map (Open a new Background Map).

 OCAD loads the background map hidden when pressing the Shift key while clicking the Open butten or
menu item.

• Relink: Relink background maps to another directory.
• Remove all: Click this button to remove all background maps. This command does not delete the background

map files.
• Remove: Click this button to remove the selected background map. This command does not delete the

background map file.
• Close: Click the close button to quit the dialog.
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Web Map Service - WMS    
Visit the Web Map Service page to get some information about this function.

Online Map Services
Visit the Online Map Services page to get some information about this function.

Download Georeferenced Satellite Images
Visit the Download Georeferenced Satellite Images page to get some information about this function.

Back to Main Page

References
[1] http:/ / www. ghostscript. com/ download/ gsdnld. html

WMS
A Web Map Service (WMS) is a standard protocol for serving georeferenced map images over the Internet. The
images are generated by a map server using data from a GIS database. (taken from the Wikipedia Article [1].)

 WMS requires a georeferenced map. Choose the Scale and Coordinate System command from the Map menu
to set the map scale and a coordinate system. Real world coordinates do not have to be necessarily defined. They can
be left at (0/0) for example.
To set up a map from a WMS server choose the WMS - Web Map Service command from the Background Map
menu. The WMS - Web Map Service dialog appears.
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WMS Server    
The WMS servers are listed in the upper box of the WMS - Web Map Service dialog.

Add a WMS Server
1. Click the Add button.
2. The Add WMS Server dialog appears.
3. Enter the Name of the server, the URL, the Version and, if required, a Login with Password, the Token Server

URL and a Key.

4. Click the OK button when finished.
5.5. The WMS server appears in the WMS server box.
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Connect to a WMS Server
Select a WMS server from the list and click Connect. If the connection was successful, OCAD gets a list from the
server with the available layers. These layers are listed in the WMS layer table of the WMS - Web Map Service
dialog. Read the WMS Layer article to learn how to use layers as Background Maps.

Edit WMS Server Properties
Select a WMS server and click the Edit button to edit its properties. The Edit WMS Server Properties dialog
appears which is equal to the Add WMS Server dialog.
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Remove a WMS Server
Click the Remove button to remove the selected WMS server from the list.

WMS Layer
After connecting to a WMS server the available WMS layers are listed in the WMS layer box.

1. Select a WMS layer in the list and choose an Image format from dropdown list (those formats are provided by
the WMS server).

2.2. Choose an option how to add the selected layers:
•• Add Selected Layers as WMS Layers to Background Maps (Online)

This is an online Background Map . It is updated by the WMS Server by each change of the map view.
This can take a moment. Choose the online option only if you are using a fast WMS server and work
woth high speed internet connection. As an alternative, you can add the layer as an offline background
map.

•• Add current view of selected layers to background maps (Offline)
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• Define the Offline folder. The current map folder is set as default.
With this offline option an image of the chosen WMS layer of the current view is downloaded from the
WMS server and added as a custom background map to the map. It does not get updated when changing
the view.

•• Add User Defined Extent of Selected Layers to Background Maps (Offline)

• Define the Offline folder. The current map folder is set as default.
• Define the Resolution.
• Define the Extent (minimum easting, maximum easting, minimum northing, maximum northing). The

current view extent is set as a default when opening the WMS dialog but the entries are not updated
automatically by changing the view. The extent can be updated by clicking the Set extent to current
view button.
With this offline option an image of the chosen WMS layer of the defined extent is downloaded from
the WMS server and added as a custom background map to the map. It does not get updated when
changing the view.

3. Click the Add button.
The WMS layer appears in the table of the Manage Background Map dialog which can be displayed in
the Background Map menu.

 The Background map (Geo-Referenced) dialog appears if no real world coordinates offset is set.
Choose an offset and click the OK button.

 Web Map Services generally provide their images in multiple spatial reference systems. OCAD can only access 
to WMS if the OCAD maps' coordinate system (ex. Swiss Grid CH1903+/LV95) is supported by the WMS. Then the 
Spatial reference system is automatically set to the corresponding EPSG code. If the chosen coordinate system is 
not compatible with the WMS, the Spatial reference system caption in the WMS dialog remains empty. 
Click the Close button when finished. 

 Manage the view or remove the WMS maps by choosing the Manage command from the Background Map 
menu:

https://www.ocad.com/wiki/ocad/en/index.php?title=File:WmsAddCurrentViewOffline.png
https://www.ocad.com/wiki/ocad/en/index.php?title=File:WmsAddUserDefinedExtentOffline.png
https://www.ocad.com/wiki/ocad/en/index.php?title=Background_Map%23Manage_Background_Maps
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=Background_Map%23Manage_Background_Maps


WMS 395

WMS Examples:

 

Back to the Background Map page.

References
[1] http:/ / en. wikipedia. org/ wiki/ Web_Map_Service
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Online Map Services
Choose this command from the Background Map menu to load temporary a screenshot from Google Maps as
background map.

If the map is geo-referenced, OCAD opens Google Maps at the same location. Move and zoom in Google Maps to
the desired location. You can also enlarge the Online Map Services dialog by clicking and dragging a corner.
Click on the Update button to move Google Maps to the center of the drawing area.
Click Load as background map to make a screenshot and load this map as background map. The Background
Map dialog appears. The screenshot is not geo-referenced.

Click OK. OCAD loads this screenshot and change to Draft mode.
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Choose Adjust in the Background Map menu to adjust this screenshot.

 Please note that Google Street View doesn't work here.
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Open Google Street View

Open Google Street View    
1. Select the Open Google Street View icon in the toolbar. The cursor changes to an arrow.

 The toolbar icon is disabled if the map is not georeferenced.
2. Click into the drawing area and drag a direction.
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3. OCAD opens the web browser with Google Street View at the chosen position and direction.

Download Georeferenced Satellite Images
SAS.Planet is a free application used to view and download satellite maps submitted by such services as Google
Maps, Bing Maps, Yandex.maps, Yahoo! Maps and many more. The satellite maps can be downloaded and then
loaded into OCAD as georeferenced background maps.

We can recommend the following workaround:
1. Download SASPlanet from the web and open the application.
2. Zoom to your desired location and select an extend.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:GoogleStreetView.jpg
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3. Open the Selection Manager and edit the tab Stitch. Don’t forget to create a file for georeferencing. We’ve chosen
the settings as follows.

4. Start the download.
5. Open a map project in OCAD. Your map needs to be georeferenced.
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6. Go to Menu Background>Manage>Open.
7. Choose your downloaded satellite maps. As they most probably do not have the same coordinate system as your
map project, you need to transform the satellite maps. Choose Google Mercator as coordinate system.

8. Click OK and the satellite maps appear as georeferenced background maps.
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Menu DEM

DEM
A DEM (Digital Elevation Model) contains points with elevation data. DEM Data are based on LIDAR (Light
Detection and Ranging) technology measurement, also known as Airborne Laser Scanning. There are DEM with
point data arranged in a regular grid with a constant distance between the points. This distance is called cell size.
Other DEM contain data points arranged irregularly (cloud-model).

Read more about this topic: http:/ / en. wikipedia. org/ wiki/ Digital_elevation_model

A laser beam splits as it hits objects. The result are multiple returns. The difference between first and last return can
show object height. The last return doesn’t always reach the ground.

http://en.wikipedia.org/wiki/Digital_elevation_model
https://www.ocad.com/wiki/ocad/en/index.php?title=File:DEM.jpg
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Source: Lohani, Bharat. Airborne Altimetric LiDAR: Principle, Data Collection, Processing and Applications.

DEM Import Wizard    
Read more about importing DEM file on the page DEM Import Wizard.

Open      
Open an OCAD DEM file (*.ocdDem). OCAD 2019 can also open ocdDems created in OCAD 11 and OCAD 12.
The OCAD DEM file is a DEM grid in an OCAD internal file format created in the DEM Import Wizard. This file is
optimized for fast access to the height values.
For more information (e.g. cell size) about this file open the DEM Information dialog.
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Show Frame      
Shows blue rectangle with the extent of the loaded DEM.

When moving the mouse cursor inside the frame the height values is show in the status bar together with the
coordinate.
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Resize    
Resize the loaded OCAD DEM file (make a subset) and save it as a new OCAD DEM file or overwrite the existing
one.

Info      
Shows information about OCAD DEM file.

When moving the mouse cursor over the file name then the file name with path appears.
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Close      
This function closes OCAD DEM file.

Merge DEM    
Choose Merge from DEM menu to merge two different DEMs.

• DEM 1: Choose the first DEM.
• DEM 2: Choose the second DEM.
The two DEMs must have the same cell size.

Calculate DEM Difference    
Choose Calculate DEM Difference from DEM menu. The Calculate DEM Difference dialog box appears.

Usually it is the difference between a terrain model and a surface model.
• Add Upper DEM = DSM data file
• Add Lower DEM = DTM data file
• Click OK.
In the DEM Import Wizard it is possible to import DTM and DSM and create the DEM difference in one step.
To visualize the DEM difference choose Classify Vegetation Height

 The extent of the Upper DEM and Lower DEM can be different. OCAD takes the overlapping area for the new
DEM.
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 The cell size of Upper DEM and Lower DEM can be different. OCAD takes the cell size of Upper DEM for the
new DEM.

Example
This is an example to show what can result from the Calculate DEM Difference function.
This is a DTM (Digital Terrain Model) with a cell size of 5m shown as hypsometric map:

The next picture shows the DSM (Digital Surface Model) of the same area with a cell size of 2m as hypsometric
map. The buildings (northern part) and forest (south western part) are slightly visible.

The next picture shows a Difference DEM with a cell size of 2m shown as raster background map after calculating
the DEM Difference. In addition, heights were colored using the Classify Vegetation Height function.
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•• The area with no difference of the DTM and the DSM are displayed white.
•• A height difference up to 15m appears red.
•• The greater the difference, the greener an area appears.
When moving the mouse cursor over the map the difference is shown in the Status Bar.
Data source: Test data Wabern from swisstopo.

Create Contour Lines    
Choose Create Contour Lines from DEM menu. The Create Contour Lines dialog box appears.
Read more about this function on the page DEM Import Wizard.

Create Hypsometric Map    
Choose Create Hypsometric Map from DEM menu. The Create Hypsometric Map dialog box appears.
Read more about this function on the page DEM Import Wizard.

Create Hill Shading    
Choose Create Hill Shading from DEM menu. The Create Hill Shading dialog box appears.
Read more about this function on the page DEM Import Wizard.
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Calculate Slope Gradient    
Choose Calculate Slope Gradient from DEM menu. The Calculate Slope Gradient dialog box appears.
Read more about this function on the page DEM Import Wizard.

Classify Vegetation Height    
Choose Classify Vegetation Height from DEM menu. The Classify Vegetation Height dialog box appears.
Read more about this function on the page DEM Import Wizard.

Merge Contour Lines By Selected Symbols    
This is an obsolete function. It is still in the latest OCAD version due to compability issues. OCAD merges the
contour lines automatically.
•• Select the contour line symbols
• Choose Merge Contour Lines By Selected Symbols from DEM menu.
• The Merge Contour Lines By Selected Symbols dialog box appears.

Create Profile      

Find more information about this function on the DEM Profile page.
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Export    
• Choose Export from DEM menu.
• The DEM Export dialog box appears.

The function exports the loaded DEM file to the following formats:
•• ESRI ASCII Grid

Select Create tiles for large DEMs to create tiles from 1001x1001 points.
•• ASCII Grid XYZ

LiDAR Point Cloud Manager    
The LiDAR Point Cloud Manager analyzes the vegetation within the forest and creates a vegetation raster map.
Learn more on the LiDAR Point Cloud Manager page.

Back to Main Page

DEM Import Wizard
With the DEM Import Wizard you can import DEM data and create different outputs like Contour lines, a Hill
shading map or a Vegetation height map. The main purpose of the DEM Wizard is to create base maps for
orienteering map making.

 There is a tutorial which shows a possible way to proceed and use LiDAR data in OCAD for orienteering
sport.

DEM Import Data    
The DEM Import Wizard is able to import files with regular and irregular DEM data. Supported DEM data formats
are:
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https://www.ocad.com/wiki/ocad/en/index.php?title=File:Mas40px.png
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Ori40px.PNG
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las, laz and zLas Files

The LAS format (*.las) is a file format designed for the interchange and archiving of lidar point cloud data.
The *.laz and *.zLas files are compressed LAS file.
OCAD uses the laszip.exe [1] and LASliberator [2] tools form Martin Isenburg [3] to decompress the laz and zLas
files.

ASCII Grid XYZ file and Raw data ASCII XYZ file

File format *.xyz

ESRI ASCII Grid

File format *.asc

SRTM Files

This is a world wide available DEM data set from the Shuttle Radar Topography Mission (SRTM). SRTM data
(*.hgt) import requires that a coordinate system set in the OCAD map file.
Link: https:/ / lta. cr. usgs. gov/ SRTM1Arc

rar Files

Please note that OCAD can not handle file names with Non-ASCII character like Å.
File format *.rar

GML file

File Format *.gml or *.xml

TIFF file

File Format *.tif
Please not that normally a *.tif file is a raster image that is used as background map. However, some *.tif files can
store DEM data and can therfore be imported and processed in the DEM Import Wizard.

Start Import DEM Wizard
Open the DEM Import Wizard in the DEM Menu. The DEM Import Wizard appears. Otherwise you can also drag
and drop an DEM file from Windows File Explorer onto the OCAD drawing area.

http://www.cs.unc.edu/~isenburg/lastools/
http://rapidlasso.com/2015/04/20/new-lasliberator-frees-lidar-from-closed-format/
http://www.cs.unc.edu/~isenburg/
https://lta.cr.usgs.gov/SRTM1Arc
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Importable Files
First use Add button to add at least 1 DEM to the DEM Import Wizard dialog.
Alternatively, just drag&drop the files into the drawing area
You have three different options:
•• Choose a las files which often contain both DTM and DSM data
•• Choose only DTM data
•• Choose DTM and DSM data

https://www.ocad.com/wiki/ocad/en/index.php?title=File:DEMImportFilesEmpty.png
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Choose las Files

• After adding a las file you can select the item and click the LAS Info button. The LAS File Header dialog opens
wich shows the information from the file header like the Number of Points by Return or the Extent.

• Click on Show to see the tile in LasView.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:DEMLasFileHeader.png
https://www.ocad.com/wiki/ocad/en/index.php?title=File:ShowLasTile.png


DEM Import Wizard 415

Choose DTM Data

Add only the DTM file(s).
Please note that not all functions (e.g. vegetation height) are available if only DTM data are available.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:DemImportWizard3.png
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Choose DTM and DSM Data

Add the DTM file(s) on the left side and the DSM file(s) on the right.

If the DSM have an other extent than the DTM then OCAD cuts to the DSM to the extent of the DTM or the choosen
extent.

Coordinate System
Usually the DEM data are in the same coordinate system as the OCAD map. So no transformation is necessary.
OCAD supports the transformation during the DEM import. Click the Choose button to select the coordinate system
of the DEM data.

In this example OCAD transforms the DEM data from US State Plane (Feet) to the metric UTM Zone 18 North.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:DemImportWizard4.png
https://www.ocad.com/wiki/ocad/en/index.php?title=File:DemImportWizard5.png
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• Convert height values from Feet to Meters: Optional it is possible to convert also the height values from Feet to
Meters. Some DEM data in USA are provides in Feet.

• Convert height values from mm to Meters: Optional it is possible to convert also the height values from
Millimeters (mm) to Meters. Some DEM data in UK are provides in mm.

• Shift elevations below sea level: OCAD cannot work with elevations below the sea level. OCAD shifts them to
0m when importing the data. This option is a temporary workaround. If the option is checked then OCAD shifts
all elevations by 1000m. So check this option if you have terrain below the sea level.

Extent
DEM data are often big. So the calculation needs a lot of time and memory. If you do not need the whole extent of
DEM data you can enter here the used extent.

 The extent is in terms of the Map Coordinate System, not the Input Coordinate System.
Please note that when an object is selected in the drawing area and you open the DEM Import Wizard, OCAD uses
the extent of the selected object as default extent.

Click the Next button. OCAD imports the file(s). Depends on the file size of data this step can takes some minutes.
The Settings dialog appears.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=File:DemImportWizard6.png
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Settings
This dialog shows the information about the DEM data.

Analyze Files
OCAD shows here the information about the map extent and the average number of point per square meter.
If the source file is a regular grid (data type of import files = grid), the Cell size box is set to read only. OCAD sets
the same cell size for the imported DEM. For irregular DEM data source (data type of import files = raw) the cell
size can be set in the 'cell size' box. For these DEM's OCAD interpolates a regular grid with the specified cell size
during the import. The cell size depends on the import data and the further usage of the DEM.

 The Cell size range is between 0.01 and 650 m. A resolution of 1 m is appropriate for orienteering base maps.

File Name
During the import procedure the imported DEM must be saved in the OCAD DEM file format (*.ocdDem) and it is
loaded to the OCAD map.
Choose here the file name of this DEM file.
If only one import file is choosen OCAD uses by default the file name of the import file. Otherwise the filename of
the ocd map.
If the ocd file is untiteled OCAD exports the DEM files in the temporary user directory
(C:\Users\XXX\AppData\Roaming\OCAD\OCAD 20xx\Tmp).

https://www.ocad.com/wiki/ocad/en/index.php?title=File:DEMSettings.png
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
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Options
OCAD can create different outputs depending on the choosen import data type (DTM and DSM or only DTM).

Create Contour Lines
Create Hypsometric Map
Create Hill Shading
Calculate Slope Gradient
Classify Vegetation Height
Extract features
Create Raw Data Points Map
Create ocdLas File for LiDAR Point Cloud Manager
Create vegegetation base map

Check or uncheck these outputs. OCAD shows for each output a page with options later in the DEM Import
Wizard.

LAS Settings
The LAS Settings dialog is only visble when importing las/laz/zlas files.

On the left side OCAD shows the information about the DTM, on the right to the DSM. If is possible to create both
DEMs in one step or only one DEM.
Each point is classified. The value in the round brackets is the number of points for this classification.
• Click the Choose DTM button to reset the Classification ans Return Number option to the default values.
• Click the Choose DSM button to reset the Classification ans Return Number option to the default values.

https://www.ocad.com/wiki/ocad/en/index.php?title=DEM_Import_Wizard%23Create_Contour_Lines
https://www.ocad.com/wiki/ocad/en/index.php?title=DEM_Import_Wizard%23Create_Hypsometric_Map
https://www.ocad.com/wiki/ocad/en/index.php?title=DEM_Import_Wizard%23Create_Hill_Shading
https://www.ocad.com/wiki/ocad/en/index.php?title=DEM_Import_Wizard%23Calculate_Slope_Gradient
https://www.ocad.com/wiki/ocad/en/index.php?title=DEM_Import_Wizard%23Classify_Vegetation_Height
https://www.ocad.com/wiki/ocad/en/index.php?title=DEM_Import_Wizard%23Extract_Features
https://www.ocad.com/wiki/ocad/en/index.php?title=DEM_Import_Wizard%23Create_Raw_Data_Points_Map
https://www.ocad.com/wiki/ocad/en/index.php?title=DEM_Import_Wizard%23Create_ocdLas_File_for_LiDAR_Point_Cloud_Manager
https://www.ocad.com/wiki/ocad/en/index.php?title=DEM_Import_Wizard%23Create_vegegetation_base_map
https://www.ocad.com/wiki/ocad/en/index.php?title=File:DEMLasSettings.png
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Usually the default setting are right. But in some cases it makes sense to uncheck the overlap point for the DSM. It
depends on the used data. Change also this settings if the data are not classified.

Create Intensity and Classification Map
Check the option Create intensity and classification map to create these maps. If created OCAD loads these raster
maps as background maps.

Intensity Map

Each data point has an intensity of the returned laser beam. This intensity is shown in a grayscale map.
Example:

https://www.ocad.com/wiki/ocad/en/index.php?title=File:DemImportWizard9.png
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Classification Map

Each data point has a classification or is unclassified. This classification is shown in a colored map.
Example:

The classification tiff image has the following color index:
•• 0 Created, never classified (light gray)
•• 1 unclassified (red)
•• 2 Ground (yellow)
•• 3 Low Vegetation (light green)
•• 4 Medium Vegetation (green)
•• 5 High Vegetation (dark green)
•• 6 Building (Generic) (gray)
•• 7 Low point (noise) (gray)
•• 9 Water (blue)
•• 10 Bridge (brown)
•• 11 Road (brown)
•• 12 Overlap pointd (gray)

https://www.ocad.com/wiki/ocad/en/index.php?title=File:DemImportWizard10.png


DEM Import Wizard 422

Create Contour Lines    
Choose Create Contour Lines from DEM menu or from DEM Import Wizard. The Create Contour Lines dialog
box appears.

This function calculates contour lines based on the DEM.
• Choose between Custom contours and Smoothed contours.
Create custom contours (no smoothing): Creates custom contour lines as you are used from older OCAD versions.
There will be no smoothing. Use these contours for your fieldwork. You will see every terrain detail on it, provided
you chose contour interval small enough.
Create smoothed contours using TPI: TPI stands for Topographic Position Index, which is defined as the
difference between a central pixel and the mean of its surrounding cells. Choosing this option, OCAD first creates a
smoothed DEM using TPI and calculates contours afterwards. Some details may get lost, but results are very
satisfying in constant slopes. Use these contours, if you want to adopt the calculated contour lines directly to your
map.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:Space.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Mas40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Ori40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:DEMContourLines.png
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Custom contour lines in brown, smoothed contour lines using TPI in green.
•• Define 1-3 contour intervals (for example 1m, 5m, 25m) for custom and/or smoothed contour lines.

 Contour interval values can be entered manually or chosen from the list.
• Choose a line symbol for each type appears. By default, the first three line symbols in the settings are

pre-selected. Load symbols from template to get 12 line symbols at the bottom of your symbol box, which you
can use for the settings.

• Choose Use different symbols for depression to distinguish depressions from hills.
•• Specify the minimum (lowest) and maximum (highest) contour for the calculation.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:ContoursTPI.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=File:LoadSymbolsFromTemplate.PNG
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Create Hypsometric Map
Choose Create Hypsometric Map from DEM menu or from DEM Import Wizard. The Create Hypsometric
Map dialog box appears.
The progression is from highest at left to lowest at right.

This function calculates a grayscale or colored hypsometric map as GeoTIFF file. Choose one of the color ramps.
Optionally you can set white color for areas with no data.
Optionally the created raster file is directly loaded as background map.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:OcadTpiContourLinesBuerenflue.png
https://www.ocad.com/wiki/ocad/en/index.php?title=File:CreateHypsometricMap.PNG


DEM Import Wizard 425

https://www.ocad.com/wiki/ocad/en/index.php?title=File:HypsometricMap.PNG
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Create Hill Shading
Choose Create Hill Shading from DEM menu or from DEM Import Wizard. The Create Hill Shading dialog box
appears.
This function calculates a shaded relief picture (hill shading).

Shading method
There are two calculation methods available:
• Slope shading is optimized to see outlines of features like paths in a slope.
• Slope shading combined with oblique light shading is the recommended method if the hill shading should be

used as a background relief of a map.
Optionally the calculated hill shading is directly loaded as background map.

Resolution
Aside from the chosen method, there is to define the Resolution and the Interpolation mode if chosen. The default
interpolation mode is Bicubic, but there are 7 other algorithm.
Additionaly an Azimuth and a Declination of the light source has to be set. Standard settings are 315° (north-west)
and 45°.
An Exaggeration factor of 4 is pre-selected and can be altered.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:CreateHillShading.PNG
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Preview
The Preview... button allows you get a first impression of the current setting for your hillshading and can be use to
optimize it. Click and move with the left mouse button allows to pan the current view.
The Preview... button is only enabeld when importing a dem grid file or an ocddem is already loaded. This function
is disabled when importing las/laz files.

 To detect point and line objects like paths or watercourses from DEM we recommend using the same resolution
as the DEM. To create a relief and if the DEM cell size isn’t high then we recommend to set a smaller resolution.

 The default export file format is JPEG and creates an 8 bit JPEG with in grayscale and a world file with the geo
reference. If you decide to export the file in TIFF-format, only with resolution option ‘DEM cell size’ then OCAD
creates an 8 bit grayscale tiff with color palette. Otherwise a 24 bit RGB tiff.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:HillShadingPreview.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
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Hillshiding (slope shading)

Hillshiding (slope shading combined with oblique light shading)

https://www.ocad.com/wiki/ocad/en/index.php?title=File:HillShading.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:HillShading2.PNG
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Error Message Bitmap is too big

The size of the hill shading image is limited. If this error message appears please enter a bigger value for the
interpolation.

Calculate Slope Gradient
Choose Calculate Slope Gradient from DEM menu or from DEM Import Wizard. The Calculate Slope
Gradient dialog box appears.

Slope Gradient Method

Select one of two different methods:
• Continous (<x° = grayscale / >x° = black)
• Black/White (<x° = white / >x° = black)
Enter the slope gradient threshold. Slope gradinet values over this threshold will be displayed with black pixels.
The resulting picture can be used to identify cliffs an rock faces. The result can sometimes be significantly improved
with a slight adjustment of the gradient threshold (between 42-45 degrees).
Slope gradient also shows paths or relief features independent from a azimut like the Hill Shading.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:CalculateSlopeGradient.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=DEM%23Create_Hill_Shading
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Extract Cliff Features From Black Pixels

Choose this option to automatically convert cliffs into vector symbols. OCAD vectorizes the black pixels from the
slope gradient calculation. By adjusting the gradient threshold, you can influence the number of cliffs.
You can also adjust the Cliff minimum area and the Cliff minimum length in pixel. The higher this value is, the
more distinctiv your cliffs need to be before OCAD vectorizes them.
Three symbols will be added automatically to your Symbol Box when choosing this option: One area symbol for
bigger cliffs and two line symbols for smaller cliffs. Select the cliffs and change their Symbol if desired.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:SlopeGradient.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:ExtractCliffFeatures.png
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Classify Vegetation Height
Choose Classify Vegetation Height from DEM menu or from DEM Import Wizard. The Classify Vegetation
Height dialog box appears.

There are two different options to show vegetation height classification:
•• Gray scale classification with options: Linear, Quadratic negative, Quadratic positive
•• Colored classification: Define classes with a height and color range

https://www.ocad.com/wiki/ocad/en/index.php?title=File:ExtractCliffFeatures2.png
https://www.ocad.com/wiki/ocad/en/index.php?title=File:DEMVegetationHeight.png
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- Split a class into two classes by clicking the Split class button
- Remove a class by clicking the Remove class button
- Load the settings from a text file by clicking the Load button
- Save the settings to a text file by clicking the Save button
- Reset the classes and colors to the default settings by clicking the Reset classes to default button

Extract Features
Choose Extract features from DEM Import Wizard. The Extract features dialog box appears.
This function extracts automatically landform and vegetation features from your data. The function is
computationally intensive and may take a while.
• Extract landform features: Choose this option to extract landform features. Define symbols for knoll and small

depression.
• Extract vegetation features: Choose this option to extract vegetation features. Define the tree symbol.
For both landform and vegetation features, you can adjust the Minimum height.
The chosen symbols will be loaded directly to your map.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:VegetationHeightColor.PNG
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Note: This function is (1) very dependend on the quality of the data and (2) the results should be treated with
caution. In terms of LiDAR data, a small knoll looks very similar to a cluster of branches, a tree stump or a small fir
tree. However, the results can give you a hint, which places you should check carefully during fieldwork.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:DemWizardExtractFeatures.png
https://www.ocad.com/wiki/ocad/en/index.php?title=File:DEMResulatExtractFeatures.png
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Create Raw Data Points Map
The Raw Data Points Map shows you where there are data and not.
There is no further dialogue for this option.

Create ocdLas File for LiDAR Point Cloud Manager
There is no further dialogue for this option.
The output is an ocdLas file, which contains all poitns of the LiDAR point cloud and it is optimized for the use with
OCAD.
This file is used to analyze the vegetation. This file is often very big (> 1 GB).
Learn more about the ocdLas file functions on the LiDAR_Point_Cloud_Manager page.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:RawDataPointMap.png
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Create Vegetation Base Map
If you checked this option in the DEM Settings, a Vegetation Base Map will be calculated with default values.
To adjust the settings, you need to run the LiDAR Point Cloud Manager.

Summary
This dialog is only visible in DEM Import Wizard. It shows the progress of the different functions.

https://www.ocad.com/wiki/ocad/en/index.php?title=DEM_Import_Wizard%23Settings
https://www.ocad.com/wiki/ocad/en/index.php?title=File:DEMVegetationBaseMap.png
https://www.ocad.com/wiki/ocad/en/index.php?title=File:DemImportWizardSummary.png
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After finishing the process the dialog closes automatically.

References
[1] http:/ / www. cs. unc. edu/ ~isenburg/ lastools/
[2] http:/ / rapidlasso. com/ 2015/ 04/ 20/ new-lasliberator-frees-lidar-from-closed-format/
[3] http:/ / www. cs. unc. edu/ ~isenburg/

DEM Profile
To use this function a DEM has to be loaded.

Create a Profile      
To create a profile:
1. Select a line object within the DEM data. Add a Corner Vertex to the line to create a stopover. Stopovers are

visible in the profile after exporting an OCD-File or adding it to the map.

2. Choose the Create Profile command from the DEM menu.
3. The DEM Profile dialog appears and the profile is shown.

http://www.cs.unc.edu/~isenburg/lastools/
http://rapidlasso.com/2015/04/20/new-lasliberator-frees-lidar-from-closed-format/
http://www.cs.unc.edu/~isenburg/
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Space.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Mas40px.png
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Ori40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Sta40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:CS40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=Vertices%23Add_Corner_Vertex
https://www.ocad.com/wiki/ocad/en/index.php?title=File:ProfileRoute.PNG
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You have several options now:
• Auto scale: If this option is enabled, OCAD takes a scale which fits best to the dialog box.
• Scale: Choose the desired scale of the profile in the dropdown list.
• Show grid: If this box is activated, a grid is shown in the profile.
• Elevation factor: Choose an elevation factor in the dropdown list. This is the scale factor for the horizontal

profile axis (height).
• The Elevation resolution and the Length resolution are filters that influence the calculation of the total ascent

and total descent. These resolution values should not be more accurate than the elevation resolution and cell size
of the DEM.

 DEM Profile dialog is a non-modal dialog. The user can switch to the OCAD map window. It is possible to edit
the selected line object in the OCAD map. Click the Update button in the DEM Profile dialog to see the profile for
the edited or newly selected object.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:DEMProfile.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
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Export Profile   

Export OCD
Click the Export OCD button to export the profile to a new OCD-File. The DEM Profile Options dialog appears.

The Template DEM Profile.ocd file in the OCAD-directory is chosen as a template file (for the symbol set, colors
etc.) by default. You can choose an own template by clicking the Load template button.

Symbol
Number

Description Symbol
Type

Color(s)

10000.001 DEM: Elevation Text Text symbol 10000: UPPER BLACK DEM PROFILE

10000.002 DEM: Distance Text Text symbol 10000: UPPER BLACK DEM PROFILE

10000.003 DEM: Text Text symbol 10000: UPPER BLACK DEM PROFILE

10000.004 DEM: Horizontal Grid Line Line symbol 10006: LOWER BLACK DEM PROFILE

10000.005 DEM: Profile Frame Line symbol 10000: UPPER BLACK DEM PROFILE

10000.006 DEM: Profile Line Line symbol 10005: LOWER RED DEM PROFILE

10000.007 DEM: Profile Area Area symbol 10003: GREEN DEM PROFILE

10000.008 DEM: White Background Area symbol 10002: WHITE DEM PROFILE

10000.009 DEM: Horizontal Tag Point symbol 10000: UPPER BLACK DEM PROFILE

10000.010 DEM: Vertical Tag Point symbol 10000: UPPER BLACK DEM PROFILE

10000.011 DEM: Time Text Text symbol 10000: UPPER BLACK DEM PROFILE

10000.012 DEM: Label Text Stopover Text symbol 10000: UPPER BLACK DEM PROFILE

10000.014 DEM: Label Text Start- and
Endpoint

Text symbol 10000: UPPER BLACK DEM PROFILE

https://www.ocad.com/wiki/ocad/en/index.php?title=File:Space.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Mas40px.png
https://www.ocad.com/wiki/ocad/en/index.php?title=File:DEMProfileOptions.PNG
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10000.020 DEM: Profile Startpoint Point symbol 10001: UPPER RED DEM PROFILE, 10004: YELLOW DEM
PROFILE

10000.021 DEM: Profile Stopover Point symbol 10001: UPPER RED DEM PROFILE
10004: YELLOW DEM PROFILE

10000.022 DEM: Profile Endpoint Point symbol 10001: UPPER RED DEM PROFILE
10004: YELLOW DEM PROFILE

10000.041 DEM: Vertical Grid Line Line symbol 10006: LOWER BLACK DEM PROFILE

10000.051 DEM: Profile Restaurant Point symbol 10000: UPPER BLACK DEM PROFILE
10001: UPPER RED DEM PROFILE
10007: UPPER WHITE DEM PROFILE

In the Units and Formats category, you can choose, whether the distance is to be shown in km or in m. In addition,
you can set the time format (at the moment only h:mm is available) and the rounding (no rounding, 5 minutes, 10
minutes). Uncheck the Show text at the bottom of the profile option if you do not want any text under the profile.
In the Labels and Symbols category, labels and symbols can be allocated to the start- and endpoint or a stopover.
Enter a label in the corresponding field (for example the name of a place) and choose a symbol from the dropdown
list. These symbols are defined in the template file. Add a Corner Vertex to the line which defines the profile to
create a stopover.

 Click into one of the columns on the left or right after typing a label text to make OCAD saving this entry.
Click the OK button when finished. In the next dialog you have to save the profile at the desired location. To open
the document, use the Open Recently Exported Documents function in the File menu. The profile can be edited
(e.g. change colors or add objects) there.

Stopovers are marked with a dot on the profile line and a vertical line to the x-axis. At the start- and endpoints as
well as the stopovers the covered distance and the walking time are indicated.

https://www.ocad.com/wiki/ocad/en/index.php?title=Vertices%23Add_Corner_Vertex
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=File%23Open_Recently_Exported_Documents
https://www.ocad.com/wiki/ocad/en/index.php?title=File:ProfileExample.PNG
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Export PNG    
Click the Export PNG button to export the profile as a raster image. The Save Picture dialog box appears. Browse a
location and enter a name for the new file. Choose the file type in the Save as type drop down list. Click the Save
button to finish. The exported profile looks the same as the profile shown in the DEM Profile dialog.

Add to map   
Note: This function is similar to the Export OCD function. For more information and illustrations visit the
corresponding article.
Click the Add to map button to add the profile to the currently opened map. The DEM Profile Options dialog
appears.
The Template DEM Profile.ocd file in the OCAD-directory is chosen as a template file (for the symbol set, colors
etc.) by default. You can choose an own template by clicking the Load template button.
In the Units and Formats category, you can choose, wheter the distance is to be shown in km or in m. In addition,
you can set the time format (at the moment only h:mm is available) and the rounding (no rounding, 5 minutes, 10
minutes). Uncheck the Show text at the bottom of the profile option if you do not want any text under the profile.
In the Labels and Symbols category, labels and symbols can be allocated to the start- and endpoint or a stopover.
Enter a label in the corresponding field (for example the name of a place) and choose a symbol from the dropdown
list. These symbols are defined in the template file. Add a Corner Vertex to the line which defines the profile to
create a stopover.
Click the OK button when finished. The symbols and colors from the template file are added to the current symbol
set and the profile is displayed.

Print
Click the Print button to print the profile. The profile is printed exactly as it is diplayed in the dialog box.

Back to the DEM page.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:Space.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Mas40px.png
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Ori40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Space.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Mas40px.png
https://www.ocad.com/wiki/ocad/en/index.php?title=DEM_Profile%23Export_OCD
https://www.ocad.com/wiki/ocad/en/index.php?title=Vertices%23Add_Corner_Vertex
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LiDAR Point Cloud Manager
The LiDAR Point Cloud Manager analyzes the vegetation within the forest and creates a vegetation raster map. The
analys is based on a ocdLas file created when importing las files in the DEM Import Wizard.

Load
This function loads an OCAD LAS file (*.ocdLas) and opens the LiDAR Point Cloud Manager.
The OCAD LAS file is a LiDAR point cloud in an OCAD internal file format created in the DEM Import Wizard.
This file is optimized for fast access to the LiDAR points.
For more information about this file open the Information dialog.

Info
This function shows information about the ocdLas file.

When moving the mouse cursor over the file name then the full file path appears.

https://www.ocad.com/wiki/ocad/en/index.php?title=DEM_Import_Wizard%23Create_ocdLas
https://www.ocad.com/wiki/ocad/en/index.php?title=LiDAR_Point_Cloud_Manager%23Manage
https://www.ocad.com/wiki/ocad/en/index.php?title=DEM_Import_Wizard%23Create_ocdLas
https://www.ocad.com/wiki/ocad/en/index.php?title=LiDAR_Point_Cloud_Manager%23Info
https://www.ocad.com/wiki/ocad/en/index.php?title=File:LidarPointCloudManager_Information.png
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Show Frame
This function shows a red rectangle with the extent of the loaded ocdLas file.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:LidarPointCloudManager_ShowFrame.png
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Close
This function closes ocdLas file.

Manage
This function reopens the LiDAR Point Cloud Manager with the already loaded ocdLas file.

Filtering
This function shows the LiDAR point cloud as image according to the settings in filtering options.

It is the same extent as on the drawing area in the OCAD File. The pixel size depends on the zoom level in the
drawing area. When moving the cursor over the point cloud image the coordinate of the mouse cursor is shown in the
status bar.
In the Filtering tab there are four different display options: Classification, Intensity, Height over ground and
Vegetation density.

https://www.ocad.com/wiki/ocad/en/index.php?title=LiDAR_Point_Cloud_Manager%23Load
https://www.ocad.com/wiki/ocad/en/index.php?title=File:LidarPointCloudManager_PointCloud.png
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Display Option Classification

This option shows the classification of the LiDAR points. If more than one point is inside one cell then the point
with the higher priority is shown. For example, the class Building has higher priority than Vegetation and Ground
has the lowest priority.

Ground = Brown, Low Vegetation = Dark Green, Medium Vegetation = Light Green, High Vegetation = Green,
Buliding = Black, Low Point = Grey

https://www.ocad.com/wiki/ocad/en/index.php?title=File:LidarPointCloudManager_Classification.png
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Display Option Intensity

This option shows the intensity of the LiDAR points. Lower intensity is drawn with darker color. In this image the
different types of vegetation (deciduous and coniferous forest) and the vegetation boundaries are visible.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:LidarPointCloudManager_Intensity.png
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Display Option Height Over Ground

This option shows the maximum height above ground for each cell. In this image, high trees and vegetation
boundaries can be detected. The structure of the forest can be seen clearly.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:LidarPointCloudManager_HeightOverGround.png
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Display Option Vegetation Density

This option shows the number of LiDAR points for each cell. Cells with more points are shown in darker red. Open
areas have often less return points and appear therefore in lighter red.

Click the Save image button to create a geo-referenced png file from the current point cloud image and load it as
new background map. The file is automatically saved in the same folder as the ocd file.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:LidarPointCloudManager_VegetationDensity.png
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Classification
A list with the different classifications is shown. The value in parentheses is the number of points for this class. In
some cases it is recommended to uncheck the Overlap points. The overlapping points come from the different flight
lines.

Click the Low vegetation button to choose only the Low vegetation points and set the Height above ground filter to
0.1 - 1.0 m.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:LidarPointCloudManager_PointCloud_ClassificationOption.png
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Click the Medium vegetation button to choose only the Medium vegetation points and set the Height above ground
filter to 1.0 - 3.0 m.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:LidarPointCloudManager_PointCloud_ClassificationLowVegetions.png
https://www.ocad.com/wiki/ocad/en/index.php?title=File:LidarPointCloudManager_PointCloud_ClassificationMediumVegetions.png
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Return Type
Choose which return types are shown. By default 'All returns' is chosen.

Height Above Ground
This function filters the points with the height above ground. To show only near-ground vegetation points move the
left slider to 0.0 and the right to 3.0.

Vegetation Base Map
This function creates an Orienteering base map with user-defined information about the near-ground vegetation.
Near-ground means between ground and 3m above. When using this function the first time default values are set.
The default values are optimized for Steinhauserwald [1] in Switzerland and LiDAR data from Canton Zürich. The
settings depend on the forest type and the LiDAR data.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:LidarPointCloudManager_PointCloud_Classification_ReturnTypes.png
https://www.ocad.com/wiki/ocad/en/index.php?title=File:LidarPointCloudManager_PointCloud_Classification_HeightAboveGround.png
https://map.geo.admin.ch/?lang=en&topic=ech&bgLayer=ch.swisstopo.pixelkarte-farbe&layers=ch.swisstopo.zeitreihen,ch.bfs.gebaeude_wohnungs_register,ch.bav.haltestellen-oev,ch.swisstopo.swisstlm3d-wanderwege&layers_visibility=false,false,false,false&layers_timestamp=18641231,,,&X=229174&Y=680276&zoom=10&crosshair=marker
https://www.ocad.com/wiki/ocad/en/index.php?title=File:LidarPointCloudManager_RasterMap.png
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Cell size
Choose the cell size.

Undergroth and Vegetation

Range From

Choose the range in which points should be considered as Undergrowth and Vegetation.

Neighborhood kernel

Choose the amount of neighbouring cells for the calculation.

Thresholds

The calculation based on the NDVD (Normalized Difference Vegetation Density). The thresholds for the
undergrowth and the vegetation shall be between -1.0 and +1.0. The thresholds can be calculated with samples in the
Statistics function. The meaning of the thresholds is visible in the image below.

Overlap Points from
Overlap points is a classification type of LAS file format. These unclassified overlap points come from different
scans (flight lines). Choose the lower threshold in which points should be considered as Undergrowth and
Vegetation. If this as value is too low, ground points are used as undergrowth and vegetation points.

Use filter
Use filter to generalize the map.

Show area with no data in red color
Area with no data are shown in red color if the value is set to True. Otherwise the cells are white and not specifiable
from the forest cells. The filter option generalizes the raster map.
Click the Create button to calculate and show the Orienteering base map. The map is drawn with the following
colors:

https://www.ocad.com/wiki/ocad/en/index.php?title=LiDAR_Point_Cloud_Manager%23Statistics
https://www.ocad.com/wiki/ocad/en/index.php?title=File:LidarPointCloudManager_Thresholds.png
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Click the Save image button to create a geo-referenced png file and load it as new background map. The file is
automatically saved in the same folder as the ocd file.
The example below shows the Orienteering base map (left) and the map from field work (right).

Statistics
The statistics function can calculate the vegetation thresholds from samples.

OCAD uses Microsoft Excel for this function. If Excel is not installed the following error message appears.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:LidarPointCloudManager_OrienteeringBaseMapColors.png
https://www.ocad.com/wiki/ocad/en/index.php?title=File:LidarPointCloudManager_Example.png
https://www.ocad.com/wiki/ocad/en/index.php?title=File:LidarPointCloudManager_Statistics.png
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The following steps are to do:
1.1. Import Symbol from Template File
2.2. Draw Samples
3.3. Create Statistics

Import Symbol from Template File
Press the Shift key and click File -> Import. The file chooser opens in the Template subfolder of the OCAD
program folder. Choose the Template Vegetation Samples.ocd file and click Open. In the Import OCAD Map dialog
choose the option to Import all symbols and colors and at the top of the color table.

Click OK. The 6 imported symbols are in the symbol box.

The symbol are for the vegetation samples and have the following meaning:

https://www.ocad.com/wiki/ocad/en/index.php?title=File:LidarPointCloudManagerStatisticsExcelErrorMessage.png
https://www.ocad.com/wiki/ocad/en/index.php?title=File:LidarPointCloudManager_PointCloud_ImportOptions.png
https://www.ocad.com/wiki/ocad/en/index.php?title=File:LidarPointCloudManager_PointCloud_SymbolBox.png
https://www.ocad.com/wiki/ocad/en/index.php?title=File:LidarPointCloudManager_PointCloud_Symbols.png
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Draw Samples
Use these 6 symbols and draw samples for the expected vegetation. We recommend to draw totally more than 100
samples for the desired area.

Create Statistics
Click the Create statistics button to create an Excel file. The file opens automatically if Excel is installed.
The 5 thresholds (marked in yellow color in the images bellow) can be inserted in the Raster map settings.

Profile
The profile shows the vegetation structure.
In the OCAD window, choose any line symbol and draw a straight line inside the loaded ocdLas file and select the
line object afterwards.
In the LiDAR Point Cloud Manager window, choose the profile width and click the Show button. OCAD draws the
profile according to the filter settings in the Filtering tab.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:LidarPointCloudManager_PointCloud_Samples.png
https://www.ocad.com/wiki/ocad/en/index.php?title=LiDAR_Point_Cloud_Manager%23Raster_Map
https://www.ocad.com/wiki/ocad/en/index.php?title=File:LidarPointCloudManager_ThresholdsExcel.png
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Menu GPS

GPS

Real Time GPS    
Choose this command from the GPS menu for mobile mapping with GPS. The GPS device must be connected to the
computer via the COM interface with Bluetooth. If your GPS device is connected via an USB port, please install a
software like GpsGate Splitter [1] to transfer the data to a virtual COM port.

 It is important that the coordinate system on the GPS device is WGS84 or a UTM zone. Otherwise, OCAD
cannot analyze the data correctly and the position is wrong (some 100 meters)!
When you choose the Real Time GPS command from the GPS menu, the Real Time GPS Settings dialog appears.

Real Time GPS Settings

https://www.ocad.com/wiki/ocad/en/index.php?title=File:RealTimeGPS.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Space.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Mas40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Ori40px.PNG
https://gpsgate.com/products/gpsgate_client
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=File:RealTimeGpsSettings.png
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Connection Settings

There are three Connection Settings. The COM interface works only in OCAD 32-bit version!

COM

Choose this option to connect your GPS device with a COM port.
1. Port: Choose the COM port where the GPS device is connected. The GPS device must send the NMEA 0183

Format [2].
2. Baud rate: Choose the baud rate the serial port. NMEA 0183 defines 4800 bps but some devices may send data

at a different speed.
3. Test: Click the Test button to open the Test GPS dialog box. The NMEA messages received from the GPS

device are displayed there and you can verify the connection of the GPS device. Read more about this dialog in
the Test GPS article on this page.

Windows Location API

Internal or external GPS devices can be connected using the Windows Location API [3]. This options is
recommended if the Windows computer does not anymore support COM ports.
The Location service must be activated in the Windows settings. For Windows 10 you can find this option in the
Privacy settings -> Location. Switch on the Location service and switch on the app App connector.
Choose a sensor from the sensor list and click the Test button to test the connection settings. The real time GPS
works still in the habitual way.

 The GPS must be manually activated as a location sensor in the Windows settings.

HTTP (Smartphone)

Choose this option to connect your smartphone as a GPS device. Please note that the GPS must be activated on
your smartphone.
1. Port: Enter a port for the IP address. The default port is 8088 and does not necessarily have to be changed.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:COM.png
https://en.wikipedia.org/wiki/NMEA_0183
https://www.ocad.com/wiki/ocad/en/index.php?title=GPS%23Test_GPS
https://www.ocad.com/wiki/ocad/en/index.php?title=GPS%23Test_GPS
https://www.ocad.com/wiki/ocad/en/index.php?title=File:GpsInterfaceLocationApi.png
https://msdn.microsoft.com/en-us/library/windows/desktop/dd464636%28v=vs.85%29.aspx
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=File:HTTP.png


GPS 458

2. IP address: This is the IP address to connect your smartphone to your computer.
3. Activate the connection by clicking the Test or Connect button.
4. Enter the IP address with the port (seperated by a colon, ex. 192.168.1.37:8088) in a browser. It should look like

the image below. Click on the left button if it is called Enable (the button will change to Disable) to start sending
the GPS positions from your smartphone to your computer.

 Make sure that the address in your brower does not have a https:/ / '' prefix.

 Due to restrictions some Smartphones do not allow to access the ip address in their browser. In such cases
we recommend to use an app (ex. Share GPS) to map the GPS position to bluetooth and to set up the
connection via COM interface.

 OCAD does not show the GPS cursor if the accuracy is too bad (state: GPS: No fix).

Requirements

The following requirements can be given:
• DGPS, RTK, Float RTK: Check this option to use DGPS, RTK, Float RTK and define if the positions calculated

without DGPS [4], RTK [5], Float RTK are not saved or not saved and not shown.

 This option has only an effect if OCAD receives the GGA Message [6]. Click the Test button to see what
type of message is sent from the device.

• Min. 4 satellites: Check this option as a kind of precision requirement and define if the positions calculated from
less than 4 satellites are not saved or not saved and not shown..

• HDOP: Check this option to define an upper limit for the HDOP (Horizontal Dilution of Precision) [7] value
and define if the positions calculated with a higher HDOP are not saved or not saved and not shown..

Options

• Filter: Check this option to activate a filter and specify how many GPS positions are averaged. This results in a
more stable position, but the update is slower.

• Accuracy circle: This option is enabled when the Filter option is checked. Check this option to show the
accuracy circle. This shows the accuracy of the last 5 measurements with a circle around the GPS marker.

• Auto scroll (moving map): Check this option to move the map automatically with the GPS marker.
• Subtract antenna height from Z value: Check this option to define a correction for the Z value. The entered

value gets subtracted from the measured height value.
• GPS Connection tail: Chech this option to show GPS positions tail.
- You can also choose the length of the tail. 
- The tail color is the same as the mark color, which can be set in the OCAD Preferences.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:GpsViaSmartphone.png
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
https://''
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
https://en.wikipedia.org/wiki/DGPS
https://en.wikipedia.org/wiki/Real_Time_Kinematic
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
https://www.gpsinformation.org/dale/nmea.htm#GGA
https://www.ocad.com/wiki/ocad/en/index.php?title=GPS%23Test_GPS
https://en.wikipedia.org/wiki/Dilution_of_precision_%28GPS%29
https://www.ocad.com/wiki/ocad/en/index.php?title=OCAD_Preferences%23Mark
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Coordinate system

Click the Change button to change the coordinate system. The Coordinate System dialog box appears.
Click the Connect button to turn on the real time GPS mode. The GPS box is displayed in the lower right corner if
the connection to the GPS device was successful.
Close the Real Time GPS Settings dialog or click the Disconnect button to turn off real time GPS.

Test GPS
Click the Test button in the Real Time GPS Settings dialog to open the Test GPS dialog.

https://www.ocad.com/wiki/ocad/en/index.php?title=Create_a_New_Map%23Coordinate_System
https://www.ocad.com/wiki/ocad/en/index.php?title=File:TestGPS.PNG
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If OCAD receives GGA Messages [6], those messages are displayed in the Serial data field. Characters 4 to 6 show
the abbreviation GGA (e.g. $XXGGA...). RMC Messages [8] are displayed if OCAD does not receive any GGA
messages. RMC messages contain no information about DGPS and the number of satellites. However, the position
can still be used in OCAD. The serial data box remains empty, if the GPS device is sending neither of the two
messages or if there is a connection problem. Check that you have selected the right port in the Real Time GPS
Settings dialog box and that the GPS device is connected correctly to the PC.
GGA message example:

$GPGGA,092750.000,5321.6802,N,00630.3372,W,1,8,1.03,61.7,M,55.2,M,,*76

RMC message example:

$GPRMC,092750.000,A,5321.6802,N,00630.3372,W,0.02,31.66,280511,,,A*43

OCAD takes the serial data apart and displays it in a bit more user-friendly view below the Serial data box.

Mapping with Real Time GPS
The GPS box is displayed in the lower right corner if OCAD is successfully connected to a GPS device.

The following information is given in this box:
• Easting: In this field the easting value of the coordinate is displayed. If the Filter is activated, then it is the

averaged value.
• Northing: In this field the northing value of the coordinate is displayed. If the Filter is activated, then it is the

averaged value.
• Height: In this field the height is displayed. If the Filter is activated, then it is the averaged value.
• DGPS: A green or red dot shows if a DGPS [9] signal is received.
• Satellites: In this field the number of received satellites is displayed. A Red number means that the requirements

defined in the Real Time GPS Settings are not fulfilled.
• HDOP: The HDOP (Horizontal Dilution of Precision) [10] is displayed in this field. HDOP is a quality indicator

for the position of the useable satellites on the local sky. HDOP values less than 4 are very good, HDOP greater
than 8 are bad. A Red number means that the requirements defined in the Real Time GPS Settings are not
fulfilled.

• Precision (x Val): In this field the accuracy (root mean square) of specified number of the last measurements is
displayed. The Filter length can be specified in the Real Time GPS Settings dialog.

Below the information part of the box, there are several icons:

 Start GPS Measurement: Click this icon to create an OCAD object with the receiving GPS information.
A symbol must be selected. Choose a point symbol and click the Start GPS Measurement icon to create an
object at the position of the GPS marker. If a line or area symbol is selected, OCAD starts with the
measurement and draws a vertice for every recieved position. The object is represented with a thin black line.

 Pause GPS Measurement: Click this icon to interrupt the GPS measurement without finishing the object.
Click the icon again to continue with the measurement.

https://www.gpsinformation.org/dale/nmea.htm#GGA
https://www.gpsinformation.org/dale/nmea.htm#RMC
https://www.ocad.com/wiki/ocad/en/index.php?title=File:RealTimeGPSBox.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=GPS%23Options
https://www.ocad.com/wiki/ocad/en/index.php?title=GPS%23Options
https://www.ocad.com/wiki/ocad/en/index.php?title=GPS%23Options
https://en.wikipedia.org/wiki/Differential_GPS
https://en.wikipedia.org/wiki/HDOP
https://www.ocad.com/wiki/ocad/en/index.php?title=GPS%23Options
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_StartGPSMeasurement.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_PauseGPSMeasurement.PNG
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 Stop GPS Measurement: Click this icon to finish the line or area object. The object is displayed with the
assigned symbol.

 Find GPS Marker: Click this icon to move the view to the GPS marker. Enable the Auto Scroll option to
always move the view, when the GPS marker is leaving the current view.

 Filter: Turn on or off the filter by clicking this icon. The filter can be adjusted in the Real Time GPS
Settings dialog.

 Accuracy Circle: Turn on or off the accuracy circle by clicking this icon. This shows the accuracy of the
last 5 measurements with a circle around the GPS marker. This option is only available when the Filter is
enabled.
Select Vertex Type: In this dropdown list you can select between two types of Vertices:

Choose the Normal Vertex option when a point should be added to the object for every position
received from the GPS device.
Choose the Corner Vertex option when a position should be manually added to the object by clicking
the  Start GPS Measurement button. This option is typically used to draw objects with straight
parts and corners like a fence. If a point or text object is selected, the vertex type cannot be changed.

 Add GPS Position to Calculate Average: Click this button for every position you want include into an
average calculation. The number of added positions is shown in the button hint. Click the  Start GPS
Measurement icon to create the object at the calculated average position. This function is only available when
a point symbol is selected. This is especially useful when the GPS position of an uncrossable feature (e.g.
small house, deep hole, huge tree etc.) is to be measured. Some points around the feature have to be recorded
and by clicking the  Start GPS Measurement icon, the average point can be found.

 Open Real Time GPS Settings: This icon opens the Real Time GPS Settings dialog box.
 The GPS cursor is drawn with the mark color. Change the Mark Color in the Drawing and Editing part of the

OCAD Preferences.
 There is a better visible, thicker GPS cursor since OCAD version 11.3.0:

https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_StopGPSMeasurement.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_FindGPSMarker.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=GPS%23Options
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_GPSFilter.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=GPS%23Options
https://www.ocad.com/wiki/ocad/en/index.php?title=GPS%23Options
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_AccuracyCircle.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_StartGPSMeasurement.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_AddGPSPositionToCalculateAverage.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_StartGPSMeasurement.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_StartGPSMeasurement.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_OpenRealTimeGPSSettings.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=GPS%23Real_Time_GPS_Settings
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=OCAD_Preferences%23Mark
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=File:GpsRealTimeThickerCursor.png
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Import Data from GPS Device    
This function is obsolete! If you want to import GPS data from GPS devices, import the waypoints and tracks with
the corresponding software of the GPS device to the computer. Then use the Import from File function in OCAD.
As an alternative, for fieldwork, use the Real Time GPS function.
Choose this command to import tracks or waypoints from a GPS Garmin eTrex device. The GPS device must be
connected to the PC with a serial data cable or Bluetooth.
• GPS: In this field the information about the GPS device is displayed.
• Status: In this field the status between OCAD and GPS is displayed.
Connection

• Connect GPS: Click this button to connect OCAD with the GPS device. After a successful connection the GPS
information and the status are displayed.

• Settings: Click this button to change the GPS settings. The Import from GPS Settings dialog is displayed.
GPS data

• Get waypoints: Click this button to load all waypoints. Each waypoint is displayed with in a row in the GPS data
field.

• Get tracks: Click this button to download all tracks. Each track is displayed with in a row in the GPS data field.
Only the start point is displayed.

 This command can take several minutes!
OCAD objects

• Set labels: Check this option to create also text objects with the name of the waypoints and tracks.
• CRT: Use a Cross Reference Table to assign symbols to the waypoints and tracks. OCAD creates

Unsymbolized Objects if no Cross Reference Table is selected.
Each line of the cross reference table contains the OCAD symbol number and the Garmin symbol name.
Example of a cross reference table:

535.0 waypoint dot

536.0 campground symbol

540.0 scenic area symbol

• Create: Select the waypoints and tracks in the GPS data field and click this button to create OCAD objects from
the selected GPS data.

 A popup menu appears when clicking the list with the GPS data with the right mouse button. In this popup menu
you have the option to Select all, Unselect all and Clear list. With the Clear list command all waypoints and tracks
are removed. In addition, you can Make an OCAD object. By clicking this command, an OCAD object of the
selected track or waypoint is created.
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Import from GPS Settings
In this dialog box you can make the setting for the GPS data import. Verify also your settings on the GPS device
(e.g. data format: GARMIN)!
• Port: Choose the port where the GPS device is connected.
• Speed data import: Choose the speed of the serial port. Garmin defines 9600 bps.
• Coordinate system: Click the Change button to select or change the coordinate system. The Coordinate System

dialog box appears.

Import from File      
Choose this command from the GPS menu to import a GPS data file to the current map. The Load GPS data from
files dialog box is displayed. Initially all importable GPS data files are listed. The following file types can be
imported:
•• GPX files
•• FRWD files
•• NMEA files
The Import from File dialog appears, where all available waypoints and tracks from the imported file are listed.
There are several options in the OCAD objects part of the dialog:
• Set label: Check this option to create also text objects with the name of the waypoints and tracks.
• Assign Symbols: Check this option to assign a specified symbol to the imported objects. Otherwise OCAD will

create Unsymbolized Objects.

 A popup menu appears when clicking the list with the GPS data with the right mouse button. In this popup menu
you have the option to Select all, Unselect all and Clear list. With the Clear list command all waypoints and tracks
are removed. In addition, you can Make an OCAD object. By clicking this command, an OCAD object of the
selected track or waypoint is created.
Click the Import button to import all selected tracks or waypoints in the list.

GPS Map Offset
This dialog box appears if the GPS coordinates are out of the maximum map size. Adjust the following parameters:
• Coordinate system If you work with GPS you must select a coordinate system. Click the Change button to select

or change the coordinate system. The Coordinate System dialog box appears.
• Offset Choose here whether you want to change the OCAD real world coordinates or to keep the existing ones.
• New offset: Choose this option if no real world coordinates are defined for the map. OCAD already proposes

reasonable values. You can leave theme unchanged.
• Existing offset and angle: Choose this option if the map already has real world coordinates and you want to fit

the imported objects to the existing coordinates.
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Laser Rangefinder    
Read more about using the "TruPulse 360/360B" Laser Rangefinder on the Laser Rangefinder page

Back to Main Page
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Laser Rangefinder
 

TruPulse 360°B

Connect to Laser Rangefinder

A connection to Laser Rangefinder can be setup via a serial COM
port. Use bluetooth for the data transfer from the Laser
Rangefinder to the computer.
1.1. Switch on the Laser Rangefinder
2. Choose Connect to Laser Rangefinder from the GPS menu.
3.3. Set device, port and speed.
4. Click the Test... button to test the connection.
5. Click the Connect button to start the connection.
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Laser Rangefinder Connection Test
Measured data values are shown here if the connection settings are correctly.

Laser Rangefinder Drawing Tool

Choose the  Laser rangefinder drawing mode. The Laser Rangefinder dialog appears.

Drawing options
Settings for different working processes can be done in the Options tab.
Direction: Choose between foresight and backsight.
•• Foresight: Measure forwards from your known position to a place with unknown position.
•• Backsight: Measure backwards from a place with known position to your unknown position.
Traverse mode: Choose between linear traverse and radial traverse
•• Linear traverse: Measure a series of points. A measured point is the start position for the next measurement.
•• Radial traverse: Measure a series of points. The start position is always the same.
Draw measures data automatically: Turn on this option if measured positions should be added to the map
automatically. Otherwise each position must be confirmed by the user.
Add real world angle to azimut: Turn off this option if declination is already corrected by the laser range finder.
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Drawing
1. Set a reference point: Set it by clicking on the map, get the GPS position by clicking on the button or select the

option Automatically use GPS position.
2. Measure the features position. Depending on the Draw measures data automatically option the positions are

added to the map automatically or they must be confirmed.
3. Finish a feature by clicking the Stop button.
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Back to GPS
Back to Drawing an Object
Back to Main Page
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Menu Options

Options

OCAD Preferences
Please see the OCAD Preferences Page for your individual working methods.

Shortcuts   
Choose Shortcuts from the Options menu to edit and define shortcuts. The Shortcuts dialog box opens.

Define a Shortcut
1.1. Select a function (e.g. View - Normal Mode) in the dialog box.
2. Choose a shortcut in the Shortcut dropdown list.
3. Click the Close button. Now you can use the shortcut.

Reset a Shortcut to Standard
1.1. Select a function (e.g. View - Normal Mode) in the dialog box.
2. Click the Standard button to set a single shortcut to default or click the All standard button to set all shortcuts

to default.
3. Click the Close button to save and quit the dialog.
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Default Shortcuts
The following shortcuts are set by default:
• F2: Symbol -> Normal
• F3: Symbol -> Protect
• F4: Symbol -> Hide
• F5: View -> Redraw
• F6: View -> Pan
• F7: View -> Zoom In
• F8: View -> Zoom Out
• F9: Background Map -> Adjust
• F10: Background Map -> Hide All
• F11: Background Map -> Manage
• Shift+F5: View -> Zoom -> 0.25x
• Shift+F6: View -> Zoom -> 0.5x
• Shift+F7: View -> Zoom -> 1x
• Shift+F8: View -> Zoom -> 2x
• Shift+F9: View -> Zoom -> 4x
• Shift+F10: View -> Zoom -> 8x
• Shift+F11: View -> Zoom -> 16x
• Shift+F12: View -> Zoom -> 32x
• Shift+Ctrl+ F12: View -> Zoom -> 64x

Additional Shortcuts
The following shortcuts are unchangeable Windows shortcuts:
• F1: Help (Opens the OCAD Wiki)
• Ctrl+C: Copy Object
• Ctrl+X: Cut Object
• Ctrl+V: Paste Object
• Ctrl+Z: Undo
The following shortcuts are unchangeable drawing and editing shortcuts:
• V: Select and edit object
• A: Select object and edit vertex
•• P: Select last used drawing mode
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Tips with Keyboard and Mouse
For tips using the keyboard and the mouse visit the Tips with Keyboard and Mouse page.

Backup and Restore Options   
Choose the Backup and Restore the OCAD Options command in the Options menu to save or restore the OCAD
Options. The Background and Restore the OCAD Options dialog appears.

Backup
You can either save the OCAD Preferences, the Shortcuts or both of them. Check the desired options. When you
click the Backup button, you can save the OCAD Preferences and Shortcuts stored in Windows Registry in a reg
file (Windows Registry File).

Restore
Restore the backuped OCAD Preferences and Shortcuts from the reg file by clicking the Restore button. Select the
reg file and click the Open button in the Restore dialog.
Windows shows the following 3 messages. Close the dialog not before clicking through these 3 messages.

Click the Yes button.
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Click the Yes button.

Click the OK button.

 The reg file must be saved on the local disk (not network). Otherwise the Registry Editor shows the following
error message:

Language      
Choose the Language submenu in the Options menu to change the language. OCAD supports the following
languages at the moment:
•• English
•• Catalan
•• Czech
•• German
•• Spanish
•• French
•• Italian
•• Hungarian
•• Norwegian
•• Polish
•• Portuguese
•• Russian
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•• Finnish
•• Swedish
•• Turkish
•• Japanese
•• Traditional Chinese

 Changing the language has no effect on the language of symbol and color descriptions of the template files. The
language you choose during the installation process defines which template files are installed and therefore which
language they have.

OCAD Preferences
   

Some preferences are not available in the OCAD Starter and OCAD Course Setting editions.

GUI (Graphical User Interface)

Right click in drawing area opens context menu
If enabled, the context menu is shown by clicking on the drawing area with the right mouse button.

In the upper part of the Context menu, you can switch between the current Drawing Mode, the  Select and Edit
Object mode and the  Select Object and Edit Vertex mode.
In the lower part of the Context menu, you can change the view either with the  Pan,  Zoom In,  Zoom
Out or the  Show Entire Map tool.
If disabled, you can switch between the current Drawing Mode and the  Select Object and Edit Vertex mode
by clicking on the drawing area with the right mouse button.

Right mouse click change between drawing and editing
This option is only activated if the Context menu in drawing area option is deactivated.
We recommend to deactivate this option when drawing on a tablet with a pen. In this case OCAD ignores the right
click during drawing.

Wider splitter between drawing area and symbol box
If this option is enabled, the splitter between the symbol box and the drawing area appears wider as usual. This 
feature may improve the user-friendliness.
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Toolbars
Show or Hide the following toolbars in this field:
•• Editing and Drawing Toolbar
•• Edit Functions Toolbar
•• Mobile Toolbar
•• Numeric Keypad Toolbar
•• Standard Toolbar
•• View Toolbar

Click the Reset button to reset the toolbar positions to the default settings. Please restart OCAD for the changes to
take effect. This function is sometimes used if an undocked toolbar outside the screen.
Click the Customize button to add or remove icons to/from the toolbars.

Status bar
Choose the format of the coordinates appearing in the Status Bar in this box.
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Style
Change the virtual appearance of the GUI by choosing one in the dropdown list.

Reset docking panels
Reset the docking panels (symbol box, GPS box and database box). OCAD restart needed to take effect.
Use this function if the symbol box is hidden.

File

Auto file load when opening OCAD
Check this box to load the last map you worked on automatically when OCAD is started. Otherwise no map will be
loaded.

Create ocd file association
Click this button to associate the running OCAD edition with .ocd files. OCAD must run as administrator to execute
this function (change file association in Windows Registry).

Confirm to run as administrator.

Alternatively, go to Settings>Apps>Default apps and Chosse default apps by file type.

 Normally, default file type for .ocd files is set during installation. However, if you run OCAD in the Cloud, the
default file type is not set.
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Clear file history
Click this button to clear the file history from Recently Exported Documents and Recently Used OCAD Files. If a
drive from the file history files does not exist anymore, e.g. disconnected network drives, it may needs more time to
open the File menu. This function solves the problem.

Temporary OCAD Folder
While working on an open file OCAD is saving all changes to temporary file(s) in a tmp folder. This folder can be
changed here. By default it is C:\Users\[USERNAME]\AppData\Roaming\OCAD\tmp.
OCAD saves the WMS images in this folder.

Ghostscript File Path
OCAD using Ghostscript to converting a pdf background map to a jpg file when opening the pdf file.
Download [1] and install Ghostscript.
Click the Choose button to set the file path of the Ghostscript exe file (e.g. C:\Program Files
(x86)\gs\gs9.08\bin\gswin32.exe).

Auto-backup
Activate the checkbox Create auto-backup when opening OCAD file and every time you open an .ocd-file, OCAD
will save a backup of this file. You can also create a backup manually by using the Create Backup funktion in the
File menu.
Click the Choose button to set a file path for the auto-backup.
Activate Compress file to save disk space.

 Remember to clean out the auto-backup directory from time to time.

Default coordinate system
Set here the default coordinate system for your template files.

View

User defined zoom in menu item
Enter a value to specify the User Defined Zoom. Choose User Defined in the View menu to apply the specified
zoom to the map.
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View mode loop
With the View mode loop tool you can easily switch between different view modes. Select the view modes you want
to switch between in the View mode loop box in the View category of OCAD Preferences.
To use the View mode loop you have to define a Shortcut for View - View Mode Loop. Afterwards you can switch
between the set view modes using the Shortcut.
Visit the View Mode Loop article to get more information about this function.

Color Correction
On some monitors colors and gamma of the map are not displayed correctly. Use the controller to regulate the color
and gamma manually. Click on the Standard button to set the Color Correction back to default.

Redraw background automatically
If this option is enabled, the map is redrawn after every single modification of the map (This may reduce the
performance of OCAD). Otherwise you have to press the F5 key or select Redraw in the View menu to redraw the
map.

Faster text rendering
Enable the Faster text rendering option to render text faster and less precisely. This may increase the performance
of OCAD.
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https://www.ocad.com/wiki/ocad/en/index.php?title=View_Mode%23View_Mode_Loop
https://www.ocad.com/wiki/ocad/en/index.php?title=File:RedrawBackgroundAutomatically.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:FasterTextRendering.PNG
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Screen Grid

In this section of the OCAD Preferences the color and the appearance of the Screen Grid can be changed.

Change the Color by clicking the  Setup icon.
Click the Default button to reload the default gray color.
Choose a Style from the dropdown menu. The Screen Grid can either be Solid, Dashed or Dotted.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:OCADPreferencesScreenGrid.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=View%23Show_Screen_Grid
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_Setup.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=View%23Show_Screen_Grid
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Select
You can choose between two modes to select multiple objects:
•• All objects must be with at least one vertex in the selection.
•• All objects must be completely in the selection.

You can find more information about selecting multiple objects on this page: Select and Edit Multiple Objects.

Object

Object stretching

If this option is activated, you are able to stretch objects in the  Select and Edit Object mode.
You can find more about stretching objects on this page: Select and Edit Object.

Unsymbolized objects

Choose a color for Unsymbolized Objects by clicking on the Setup  icon. The Color Picker dialog appears and
you can configure the color.

Drawing and Editing

Drawing Bézier curves
Choose the preferred mode for drawing curves.
•• In OCAD mode, only the direction of a dragged tangent is used. The distance from the normal vertices to the

curve vertices is calculated automatically. This is the recommended mode.
•• In Illustrator mode, the length of the dragged tangent is used to calculate the distance of the curve vertex.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:OCADPreferences_Select.gif
https://www.ocad.com/wiki/ocad/en/index.php?title=Select%23Select_and_Edit_Multiple_Objects
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_SelectAndEditObject.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=Select%23Select_and_Edit_Object
https://www.ocad.com/wiki/ocad/en/index.php?title=Select%23Select_and_Edit_Object
https://www.ocad.com/wiki/ocad/en/index.php?title=Unsymbolized_Objects
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_Setup.PNG
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You can find more about drawing curves on the following page: Draw a Curve

Curve mode: Change to straight line mode when clicking in drawing area
Check this box to draw straight lines also in curve mode. See more in Change to Straight Line Mode

Convert freehand to curve when drawing
Check this box to convert lines and areas to curves when drawing in freehand mode. Otherwise they remain as
polygons. The settings made in the Smooth when drawing freehand dropdown list of the Tolerances field
determine the smoothing level.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:OCADPreferences_Bezier.gif
https://www.ocad.com/wiki/ocad/en/index.php?title=Drawing_an_Object%23Draw_a_Curve
https://www.ocad.com/wiki/ocad/en/index.php?title=Drawing_an_Object%23Change_to_Straight_Line_Mode
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Freehand_To_Curve.PNG
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Close area objects when drawing
OCAD closes area objects automatically if this option is checked. If the start and end point are different, OCAD adds
an end point with the same position as the start point.
Choose Close Area Objects in the Topology part of the Object menu to close already drawn area objects.

Move closed start and end points of line and area objects together
When this option is switched on, and the start and end points of a line or area object coincide (the line is closed),
they are moved together during editing. If you move the start point, then the end point will also move.

https://www.ocad.com/wiki/ocad/en/index.php?title=Topology%23Close_Area_Objects
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Close_Area_Objects_When_Drawing.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:OCADPreferences_MoveEndPoints.gif
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Move line and area segments
Activate this option to be able to move line and area segments.

Join affects all line symbols in symbol group
When this option is switched on, OCAD joins the ends of selected line objects that are in the same symbol group
(symbol tree). If deactivated, OCAD only joins if the line objects have the same symbol.

The option affects the  Join function and  Automatic Joining during drawing.

Following existing objects
Uncheck the Side lines of double lines option if side lines of double lines should not be traced when you are
following existing lines. You can find more about this topic on the Following Existing Objects page.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:MoveSegments.gif
https://www.ocad.com/wiki/ocad/en/index.php?title=Topology%23Join
https://www.ocad.com/wiki/ocad/en/index.php?title=Symbol_Box%23Symbol_Tree
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_Join.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=Topology%23Join
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_AutomaticJoining.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=Topology%23Automatic_Joining
https://www.ocad.com/wiki/ocad/en/index.php?title=Drawing_an_Object%23Following_Existing_Objects
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Side_Lines_Of_Double_Lines.PNG
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Tolerances
• Select objects: This tolerance defines the maximum distance on each side of a thin line where you can click to

select it. Objects with a thicker main line than the tolerance level can be selected by clicking on the entire line
width. The default value is 3 pixels.

 This tolerance is further used in multiple tools like Cut lines, Cut areas, Following existing objects,
Reshape, Add Vertex, Remove Vertex, Change Vertex Type.

• Snapping: If you activate the Snapping tool, moving a vertex close to an objects has a snapping effect. This
tolerance defines the maximum distance you have to approach to the object, so that the vertex snaps to it. The
default value is 5 pixels.

• Join when drawing lines: This tolerance defines the maximum distance a vertex has to approach to another line
end to join it. The default value is 0.25 mm. If the line width is bigger than this tolerance then OCAD takes the
line width as the tolerance. This tolerance is used for lines and areas

• Merge lines: This tolerance defines the maximum distance two line endes can be apart to still get merged.
• Smooth when drawing freehand: There are three smoothing levels for freehand drawing mode: slightly,

medium and strong. They correspond to 0, 1 and 2 in earlier OCAD versions.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=Cut%23Cut_Line
https://www.ocad.com/wiki/ocad/en/index.php?title=Cut%23Cut_Area
https://www.ocad.com/wiki/ocad/en/index.php?title=Drawing_an_Object%23Following_Existing_Objects
https://www.ocad.com/wiki/ocad/en/index.php?title=Topology%23Join
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Joining_Lines.PNG
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• Change to Bezier curve: This tolerance defines the maximum distance the vertices can move away from the
original position by changing from polyline to Bezier curve. The default value is 0.10 mm. Note that the distance
between the curve and the polyline can be greater between the vertices.

• Smooth (generalization): This tolerance is used by the Douglas-Peucker smoothing algorithm. Vertices that are
closer to the direct line between the previous and the next vertex are removed. The default value is 0.05 mm.

This smooth tolerance is also used in the 'Change to Polyline' function.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:Smoothing_Levels.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Change_To_Bezier.PNG
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Cursor color
You can change the cursor color to black, red, blue, purple or yellow by selecting a color in the dropdown list.

Scale Cursor Size

Check this option to enlarge the cursor to the default size on high-DPI monitors with Windows 10 Creators Update.

Mark
Set the mark size to normal, large or very large.

Choose a mark color by clicking the  Setup icon.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:Smooth.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Mark_Size.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_Setup.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Mark_Color.PNG
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The mark color is used during drawing and to mark the selected objects.

The GPS cursor in GPS Real Time mode is also drawn with the choosen mark color.

 OCAD uses the choosen mark color only on white background. Otherwise OCAD choose a color with high
contrast to the background color.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:Mark_Color_Drawing.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Mark_Color_GpsCursor.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Mark_Color_HighContrast.PNG
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Enable live preview
Enable this option to show the real line width when drawing line objects.

Auto scroll
Check this option if the map view should automatically scroll if you drag out of the drawing area. Disable Auto
scroll if you have a slow PC.

Change to Select and Edit Object mode when selecting two or more objects
Check this option to automatically get the Select and Edit Object mode when selecting two or more objects.

Symbol

Default symbol folder

You can change the default symbol folder by clicking on the  Browse icon. Choose a folder as default symbol
folder which you want to load symbols from when you create a new map. Click on the  Delete icon to clear the
current folder path. If no folder is selected, OCAD loads symbols from the Symbol folder in the OCAD program
directory (usually: C:\Program Files\OCAD\OCAD 20xx\Symbol\) when you want to create a new map.

Symbol
• Selected symbol blinks in symbol box: If you check this option, the selected symbol blinks in the symbol box.

This makes it easier to recognize the selected symbol.
• Lock symbol positions in symbol box: If you check this option, you are not able to drag and drop a symbol to a

new position in the symbol box.
• Auto select symbol when selecting object: If you check this option, the corresponding symbol is automatically

selected when you select an object. This does not work when you select multiple objects.

https://www.ocad.com/wiki/ocad/en/index.php?title=Select%23Select_and_Edit_Object
https://www.ocad.com/wiki/ocad/en/index.php?title=File:ChangeSelectMode.gif
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_Setup.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_Delete2.PNG


OCAD Preferences 487

• Change to drawing mode when selecting a symbol: If you check this option, OCAD change to a drawing mode
when selecting a symbol in the symbol box. If the symbol has a preffered drawing mode then OCAD change to
this drawing mode.

• Set symbol status visible when changing to Protected: Check this option if you prefer to have the same
behaviour as in earlier OCAD versions. In this case OCAD always sets the symbol status Visible when changing
to Protected.

GPS

GPS Log File
Check the Log all positions sent from gps option to save all position sent from a GPS device in real time to a log
file (Text-File). Click the  Browse icon to choose a folder, the log files are saved to. The log files are named with
the date and time the real time GPS is enabled.

Warnings

Warnings for hidden symbols
These warnings can be activated when you either print, export or import a map. If you check those options, you will
get a warning message if you have hidden symbols on the map and you are trying to carry out one of mentioned
operations.

Moving warnings
Enable the Move multiple objects option to get a warning message when you move multiple objects. Use this option
in order to guard against moving multiple objects accidentally.

Database warnings
Check these options to show Database Compatibility warnings about 32/64bit and dBase.

General

Updater
Disable the option Check for Service Updates when you start OCAD to not check for new free Service Updates
when you start OCAD. Is some cases this check takes too long.
Known bugs are corrected in Service Updates. Additionally, new functions are added constantly with the
subscription model. Therefore, we recommend using OCAD software always with the most recent Service Update to
benefit from the quality improvements. The latest Service Update is also available on our website in the Download
[1] section.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_Setup.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=Symbol%23Hide
https://www.ocad.com/wiki/ocad/en/index.php?title=Select%23Select_and_Edit_Multiple_Objects
https://www.ocad.com/wiki/ocad/en/index.php?title=Select%23Select_and_Edit_Multiple_Objects
https://www.ocad.com/wiki/ocad/en/index.php?title=Database%23Database_Compatibility
https://www.ocad.com/en/service-update/
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OCAD Blog
If this option is activated, new OCAD blog posts are shown when you start OCAD.

Google API Key
Enter here your Google API Key. This key is used in the New Map Wizard to create a DEM via the Google Maps
API.
Link: Get API Key [2]

References
[1] https:/ / www. ocad. com/ en/ service-update/
[2] https:/ / developers. google. com/ maps/ documentation/ javascript/ get-api-key

https://www.ocad.com/wiki/ocad/en/index.php?title=New_Map_Wizard%23Choose_Cross_Reference_Table
https://developers.google.com/maps/documentation/javascript/get-api-key
https://www.ocad.com/en/service-update/
https://developers.google.com/maps/documentation/javascript/get-api-key
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Menu Window

Window

Tile       
Choose the Horizontally command in the Tile submenu of the Window menu to arrange all opened OCAD projects
horizontally in the OCAD window.

Choose the Vertically command in the Tile submenu of the Window menu to arrange all opened OCAD projects
vertically in the OCAD window.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:Space.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Mas40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Ori40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Sta40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:View40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:CS40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:TileHorizontally.PNG
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Cascade       
Choose the Cascade command in the Window menu to cascade all opened OCAD projects.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:TileVertically.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Space.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Mas40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Ori40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Sta40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:View40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:CS40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Cascade.PNG
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Switch to Opened OCAD Window
In the lowermost part of the Window menu, all opened OCAD projects are listed. Choose a project to put it to the
foreground.
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Menu Help

Help

Help Menu
Contents: The contents of this help file.
Menu: Help for menu commands.
Toolbar: Help for toolbar buttons.
Tutorials: Link to the OCAD Tutorials.
What is New: Click on this menu item to open the What is New page.

OCAD Home page [1]: Connect to the OCAD homepage on the Internet.
Download Update: Download the current Service Update from the OCAD website.
YouTube Channel [2]: OCAD Youtube Channel
Getting Started with OCAD: Open the pdf file 'Getting Started with OCAD'. For different languages see
here [3] .
OCAD Blog [4]: Show the newest posts from OCAD Blog.

License Transfer Utility: Deactivate this license and transfer it to a new user.
License Manager: Overview about the licenses from your organization.

About OCAD: General Information about OCAD.

https://www.ocad.com/wiki/ocad/en/index.php?title=Main_Page
https://www.ocad.com/wiki/ocad/en/index.php?title=Graphical_User_Interface%23Menu
https://www.ocad.com/wiki/ocad/en/index.php?title=Graphical_User_Interface%23Toolbars
https://www.ocad.com/wiki/ocad/en/index.php?title=Tutorials
https://www.ocad.com/wiki/ocad/en/index.php?title=What_is_New
https://www.ocad.com/en/
https://www.ocad.com/wiki/ocad/en/index.php?title=Service_Update%23OCAD_Service_Update
https://www.youtube.com/user/ocadcom/
https://www.ocad.com/en/getting-started/
https://ocad.com/blog/
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License Transfer Utility
This function is only available when all ocd files are closed in the OCAD program. Otherwise this function is
disabled in the Help menu.
This function deactivates the OCAD license on your computer (User A) and allows you to install this license on
another one (User B).
After the deactivation, User A can open OCAD files in OCAD Viewer but not edit maps.

Click the Transfer button. You will read License unblocked for new user.
OCAD sends a confirmation email to the entered email addresses of User A and User B. The license can now get
activated by User B.
For the first activation, User B needs the order email from User A with the installation information.
OCAD for Single User: The request will be proceeded manually at the latest within 2 working days.
OCAD for Teams: The request will be proceeded automatically and the license can be activated immediately by the
new user. The license can only be transfered once within 24 hours.
If you don't know the new user then enter your name also in the new user fields.
Click the Close button. OCAD closes.
Until now, it's not possible that an adimistrator is doing the License Transfer. The Users with the activated license
need to transfer their licenses by their own.

https://www.ocad.com/wiki/ocad/en/index.php?title=Graphical_User_Interface%23Help_Menu
https://www.ocad.com/wiki/ocad/en/index.php?title=File:LicenseTransferUtility.png
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License Activation
When the license is deactivated and User A or User B starts OCAD, for both of them the License Activation dialog
appears.

You have two options:
• Click Open OCAD Viewer to open the OCAD Viewer. It is possible to view and print map, but not to edit. This

is what User A is supposed to do.
• Click Reactivate this License to start the Activation Wizard. This is what User B is supposed to do.

License Manager
Choose this command from the Help menu.
The License Manager tool shows an overview about the OCAD licenses which are assigned to your organization
(company or association).
The allocation of thousands of licenses to an organization was done manually. If a license has been misallocated then
report it to OCAD.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:LicenseActivation.png
https://www.ocad.com/wiki/ocad/en/index.php?title=Activation
https://www.ocad.com/wiki/ocad/en/index.php?title=Graphical_User_Interface%23Help_Menu
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Used License
• Search licenses: Click on this button to get all licenses assigned to this organization.
• Assign: If the license is not assigned or assigned to a wrong organization, enter the name of the organization and

click on the Assign button to send an email to OCAD.
• Add Additional Team Licenses: When you have several Team licenses, you can install OCAD on a Cloud

service like Dropbox and add additional licenses. See the OCAD as Cloudable App page for more information.
• Remove from organization: Click this button to remove this license from the assigned organization. An email

will be send to OCAD.

Licenses of the organisation
• No.: License number
• Version: OCAD version (2019, 12, 11, ...)
• Edition: OCAD Edition (Mapping Solution, Orienteering, Starter, Course Setting)
• Name: License Name
• Subscription end date: End date for OCAD subscription licenses. Earlier versions (OCAD 12 and earlier) are

life-time licenses.
• Last activated by: See the user, who activated OCAD the last time. Numbers in brackets indicate how many time

the license has been activated.
• Info button: Click on the Info button to see all activation from the selected license.
Status 1 means license is activated
Status 2 means license is deactivated by user
Status 3 means license is deactivated by OCAD AG

https://www.ocad.com/wiki/ocad/en/index.php?title=File:LicenseManager.png
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About OCAD
Choose this command from the Help menu.
It contains general Information about OCAD like license information and current version of OCAD.

License
See here your license information like...

License number: The number or your license.
Name: How the license is named.
Subscription start date: The date your Subscribtion has started.
Activation date: The date you have activated OCAD.
Last verification: The date your license was verified the last time.
Pending Verification: The date after that OCAD will verify again, if your license is still valid.
Subscription end date: When your Subscription will end. After this date, OCAD will not run anymore.

 Due to the subscription model OCAD needs to check, if your license is valid. If you have no internet connection
(e.g. during fieldwork), this can't be done. That's why there is a Pending Verification date. After the Pending
Verification Date, you need to start OCAD once within 30 days with an internet connection, so OCAD can verify the
license again (will be done automatically at the startup). Then, the date for the Pending Verification will be shifted
backwards. If you do not verify the license again in these 30 days, you can't use OCAD anymore offline until you
reactivate OCAD online.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:AboutOCAD.png
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
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Software
See here your exact Software Version.
Experiation date software version: It means that after this date, the software cannot be installed and opend
anymore. This is for security reson. When you install a new Service Update, the Experiation date ot the
software version will be extended.

License Term
Click here to see the License Terms.
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Course Setting

Course Setting for Orienteering
   

(The Course Setting functions are only available in course setting projects!)

OCAD provides completely integrated functions for course setting in orienteering.

O-training with OCAD
You want to learn how to create Normal Courses, Relay Courses or Multitechnique Trainings?
Visit the O-training with OCAD page for more information.

Start a New Course Setting Project
For a Course Setting Project, you need two OCAD files:
- A [Course Setting File]
This is the file where manage your Course Setting Project, set courses and load a Background Map.
Like map files it has the extension .ocd, but it has a special internal mark to identify it as a course setting file.
- A [Map File]
This is your OCAD map which will be loaded as Background Map in your [Course Setting File].

https://www.ocad.com/wiki/ocad/en/index.php?title=File:Mas40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Ori40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Sta40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:CS40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:CourseSettingExample.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:CS_Projekt.png
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To start a New Course Setting Project, you must create a new [Course Setting File]. You have two options to do so:

A) New Course Setting Project Wizard
Choose the New Course Setting Project Wizard command from the File menu. This wizard guides you through the
first steps like setting an event title and loading a map file in the background layer.

B) New Course Setting Project
1. Choose the New command from the File menu or click the New button. The New File dialog box is displayed.

2. In the Map type box select the Course setting project for orienteering item.
3. Select a symbol set from the Load symbol set from box. For a course setting project in a scale where no symbol

set is available please choose one of the available symbol sets.
4. Choose the desired Language (not available for all Symbol Sets) and set the map scale to the correct value. It is

important to do this before starting with course setting because the calculation of the courses length depends on
the map scale.

 You can also create own Symbol Sets and save them in your default symbol folder which is usually
C:\Program Files\OCAD\OCAD 20xx Orienteering\Symbol

5. Click the OK button.

6. Choose the Save command from the File menu or click the  Save button. The Save As dialog box appears.
Enter a file name for the [Course Setting File].

You can save your course setting project as OCAD 10, OCAD 11, OCAD 12 or OCAD 2019 file. Please note,
that some features may be lost according to the Compatibility Check.
Pay attention to open/save Course Setting Files from OCAD 11 in OCAD 12 and vice versa, as many symbols
and colors has changed between these two versions.

7. Choose the Open command from the Background Map menu to open a [Map File] as a Background Map. The
Background Map is normally an .ocd file, but you can also load a raster image (PNG, JPG, ...) as Background
Map.

8. Choose the Entire Map command from the View menu to show the whole map on the screen.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:CsFileNew.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=O-training_with_OCAD%23Pimp_your_Symbol_Set
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_Save.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=Background_Map%23Open_a_Background_Map
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The Course Setting Box is displayed on the right side of the OCAD window. This Course Setting Box provides a
lot of functions and options. Visit the Edit Course Setting Objects page to get more information.

Compose Course
Learn on the Compose Course page, how to create and edit orienteering courses easily. This tool is very intuitve and
fast.

Route Analyzer
Learn on the Route Analyzer page, how to analyze routes for sprint orienteering.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:CsBox.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:RouteAnalyzer_Example.png
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Add Course Setting Objects
The Add Course Setting Objects page goes deeper than the Compose Course page. Read the following articles:
1.1. Add Start, Controls and Finish
2.2. Add a Marked Route
3.3. Add the Map Issue Point
4.4. Add a Control Description
5.5. Add a Course Title
6. Add Variant for Relay Courses. Learn how to create relay courses on the Create Relay Courses page.
7. Add Start Numbers for Relay Courses. Learn how to create relay courses on the Create Relay Courses page.
8. Add Other Objects, like the event title, logos, corrections on the map etc.
9.9. Course Setting Dialog Box

Edit Course Setting Objects
Information about all functions which are provided by the course setting box on the right side of the window can be
found on the Edit Course Setting Objects page.
Most important functions:
Change Code of Course Objects
Insert a Text Block
Lock or Unlock Course Objects
Edit Control Description
Add, Edit or Remove Course Objects
Preview Mode

Controls
The following two functions can be found in the Controls submenu of the Course Setting menu:

Renumber all Controls
This function is useful if you did not know the available control numbers for your event when starting to plan the
courses.
Choose the Renumber all Controls command in the Controls submenu of the Course Setting menu to display the
Renumber all Controls dialog.

1. Enter a New first code to shift all control codes. All codes are shifted with the difference between the New first
code and the Old first code.

2. Check the option Close numbering gaps if gaps with not used numbers should be closed.
3. Click the OK button when finished.

https://www.ocad.com/wiki/ocad/en/index.php?title=Add_Course_Setting_Objects%23Add_Start_Controls_and_Finish
https://www.ocad.com/wiki/ocad/en/index.php?title=Add_Course_Setting_Objects%23Add_a_Marked_Route
https://www.ocad.com/wiki/ocad/en/index.php?title=Add_Course_Setting_Objects%23Add_the_Map_Issue_Point
https://www.ocad.com/wiki/ocad/en/index.php?title=Add_Course_Setting_Objects%23Add_a_Control_Description
https://www.ocad.com/wiki/ocad/en/index.php?title=Add_Course_Setting_Objects%23Add_a_Course_Title
https://www.ocad.com/wiki/ocad/en/index.php?title=Add_Course_Setting_Objects%23Add_Variant_for_Relay_Courses
https://www.ocad.com/wiki/ocad/en/index.php?title=Add_Course_Setting_Objects%23Add_Start_Numbers_for_Relay_Courses
https://www.ocad.com/wiki/ocad/en/index.php?title=Add_Course_Setting_Objects%23Add_Other_Objects
https://www.ocad.com/wiki/ocad/en/index.php?title=Add_Course_Setting_Objects%23Course_Object_Dialog_Box
https://www.ocad.com/wiki/ocad/en/index.php?title=Edit_Course_Setting_Objects%23Change_Code
https://www.ocad.com/wiki/ocad/en/index.php?title=Edit_Course_Setting_Objects%23Text_Block
https://www.ocad.com/wiki/ocad/en/index.php?title=Edit_Course_Setting_Objects%23Lock_or_Unlock_Objects
https://www.ocad.com/wiki/ocad/en/index.php?title=Edit_Course_Setting_Objects%23Text_Control_Description
https://www.ocad.com/wiki/ocad/en/index.php?title=Edit_Course_Setting_Objects%23Course
https://www.ocad.com/wiki/ocad/en/index.php?title=Edit_Course_Setting_Objects%23Preview
https://www.ocad.com/wiki/ocad/en/index.php?title=File:CsRenumberAllControls.PNG
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Control Elevation
Visit the Control Elevation page to find more information about this function.

Courses
As a next step you can Create a New Course. A course is basically a list of the start, controls, marked route(s) and
the finish. You may want to Insert Other Course Objects like mandatory crossing point, mandatory passage
through out of bound area, map exchange, relay team or leg variation.
OCAD supports:
• Individual Courses with symbol sets for foot-o, ski-o, mtb-o and trail-o
•• Relay Courses
•• One-Man Relay Courses
•• Score Orienteering

All information about courses can be found on the Create a New Course page.

Classes
In OCAD you can either work with courses only or you can use classes and courses. Different classes may use the
same course, e.g. Course A -> Class W18, W16, M16; Course B -> W14, M14, Open Short.
Visit the Create a New Class page for more information.

Insert Course Object to Courses
Choose this function from the Course Setting menu. Learn more about this function on the Add a Course Object to
Courses page.

Delete Course Object from Courses
This is the inverse function of the Insert Course Object to Courses function.
Read more about this function on the Delete Course Object from Courses page.

Make Graphic Modifications
Often it is necessary to Make Graphic Modifications to the courses generated by OCAD.

Move Control Number for All Courses
To move the control number for all courses (for example if it covers important map information):
1. Change to Preview mode.
2. Move a control number and keep it selected.
3. Choose the Move Control Number for all Courses command from the Course Setting menu.
4.4. The control number is moved for all other courses, too.

https://www.ocad.com/wiki/ocad/en/index.php?title=Edit_Course_Setting_Objects%23Preview
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Edit Connection Line for All Courses
To edit a connection line for all courses (for example if it covers important map information):
1. Change to Preview mode.
2. Edit the connection line and keep it selected.
3. Choose the Edit Connection Line for all Courses command from the Course Setting menu.
4.4. The connection line is edited in all other courses which use it, too.

Edit Text Control Description
Choose the Edit Text Control Description command in the Course Setting menu to edit the text control
description. Visit the Edit Text Control Description page for more information.

Auto Control Description
OCAD provides an Auto Control Description tool that recognizes map objects, where controls are placed, and sets
the corresponding IOF symbol to the control description. Visit the Auto Control Description page for more
information.

Punching Unit IDs
Choose the Punching Unit IDs command in the Course Setting menu to enter the punching unit IDs. Visit the
Punching Unit IDs page for more information.

Course Statistic and Event Statistic
Choose the command Course Statistic and Event Statistic from the Course Setting menu to display a course and
event statistic. Visit the page Course Statistic and Event Statistic for more information.

Consistency Check Report
Choose the command Consistency Check Report from the Course Setting menu to display the consistency check
report. Visit the page Consistency Check Report for more information.

Compare Course Setting Files
The function Compare Course Setting Files is only enabled if no ocd file is open.

 The Course Setting menu is not visible by default for OCAD Mapping Solution. Open and close a
course setting file to make it visible.

1. Add the files that should be compared to the files box.
2. Click the Compare files button.
3.3. The differences are shown in the dialog.
4. Click the Save As... to save the text as html file.
The function shows the following differences between course setting files:
•• Different Course Objects
•• Different Courses
•• Different Preview Objects
•• Different Course Setting Options

https://www.ocad.com/wiki/ocad/en/index.php?title=Edit_Course_Setting_Objects%23Preview
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
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Print
In the Print submenu of the Course Setting menu you have the option to print the Courses or the Control
Descriptions.
Courses can be printed together with the map or on an already printed map. OCAD provides adjustment functions to
adjust the course to the already printed map. In addition EPS files can be created to make plates for offset printing.
Visit the Print Courses page for more information.
To get more information about printing control descriptions, visit the Print Control Descriptions page.
Control descriptions can printed together with the course on the map: Add a Control Description Object.

Import
It is possible to import an OCAD Map, IOF XML Files or to import courses from ORware [1]. Visit the Course
Setting Import page for more information.

Export
OCAD provides different export options of course data for event software, courses as gpx file, course maps etc.
Visit the Course Setting Export page for more information.

Create PDF Files for Printing
Please use Export from the File menu if you want to create PDF files from the courses to provide them to the
printery.
Please select the courses/classes in the Select Courses/Classes dialog that appears after clicking the Export button
in the Export panel.

 You can also export the PDF files from exported Course Maps. In that case the Select Courses/Classes
dialog does no appear since a course map file contains only graphics.

https://www.ocad.com/wiki/ocad/en/index.php?title=Add_Course_Setting_Objects%23Add_a_Control_Description
http://www.picotiming.ch/indexsoft.html
https://www.ocad.com/wiki/ocad/en/index.php?title=Export_Files%23Export_PDF
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=Course_Setting_Export%23Export_Course_Maps
https://www.ocad.com/wiki/ocad/en/index.php?title=File:CsExportPdfSelectCoursesClasses.png
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Options
Choose the Options command from the Course Setting menu to get some Course Setting Options.

References
[1] http:/ / www. picotiming. ch/ indexsoft. html

O-training with OCAD
   

Lern how to start with an easy Course Setting Project.
Discover new sophisticated o-technical excercises.
Get background information for Course Setting.

Tutorials
The following PDF's contain the basic workflow of a Course Setting Project and can be used for workshops.
• Getting Started with Course Setting in OCAD [1] (PDF  )

Einführung in die Bahnlegung mit OCAD [2] (PDF  )

Preparation

Set up a Course Setting Project
For a Course Setting Project, you need two OCAD files:
- A [Course Setting File]
This is the file where manage your Course Setting Project, set courses and load a Background Map.
Like map files it has the extension .ocd, but it has a special internal mark to identify it as a course setting file.
- A [Map File]
This is your OCAD map which will be loaded as Background map in your [Course Setting File].

 You can also load a raster image (PNG, JPG, ...) as Background Map. However, for the trainings described
below, you need to modify your Background Map, so you need a OCAD file.
Now start a New Coure Setting Project. Make sure the map scale of your [Course Setting File] is the same as your
[Map File].

Correct Scale
It sometimes happens, that your course setting project and your background map have different scales without 
noticing it. 
Generally, OCAD checks if the Background Map comes in the same scale as the course setting project and in case 
the scales are different, there will be an Error Message.

http://www.picotiming.ch/indexsoft.html
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Mas40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Ori40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Sta40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:CS40px.PNG
http://www.ocad.com/docs/Getting_Started_with_Course_Setting_in_OCAD.pdf
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Grossbritanien.gif
http://www.ocad.com/docs/Einf�hrung_in_die_Bahnlegung_mit_OCAD.pdf
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Deutschland.gif
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=Course_Setting_for_Orienteering%23Start_a_New_Course_Setting_Project
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Check the scale of your course setting project under Map>Set Scale and Coodinate System.
Check the scale of your background map under Background Map>Manage. Click on the Information Icon behind
the Backgound Map.
To be really sure that the scale is correct:
•• Messure a line in OCAD and Google Maps and compare them.
• If your background map is georeferenced, you can export your courses in KMZ format and open them in

Google Earth (File>Open Recently Exported Documents). There you see if your map corresponds with the
terrain.

10'000 and 15'000
In the ISOM 2017, the 1:10'000 map is defined as a 150% magnification of the 1:15'000 map. This applies to all
objects including course setting objects (e.g. control circles are 7.5mm for 10'000 and 5mm for 15'000; in the past all
control circles were 6mm).
If your [Map File] is 1:15'000, you should start with the Course Setting 15 000 ISCD 2018 - ISOM 2017.ocd
symbol set. For a [Map File] in 1:10'000, use the Course Setting 10 000 ISCD 2018 - ISOM 2017.ocd symbol set.
Let's assume our Background Map has the scale 1:10'000:
• Open the Course Setting 10 000 ISCD 2018 - ISOM 2017.ocd symbol set.
•• When both 1:10'000 and 1:15'000 maps need to be printed, the entire course setting shall be done in a 1:10'000

project and only the print and/or export scale needs to be adjusted.
• The exact size of the Control Description is not defined according to ISCD 2018. It must be between 5-7mm. If

a Control Description is printed on the map, it is recommended to change the size of the Control Description
(Course setting>Options) before exporting 1:15'000 maps, e.g. to 7.5mm, which results in 5mm. Otherwise, the
Control Description is only 4mm on the 1:15'000 print, as it is set to 6mm for 1:10'000 by default.

The same works, if your [Map File] and your [Course Setting File] have the scale 1:15'000 and you want to
export a map in scale 1:10'000. This time, reduce the size of the Control Description (Course setting>Options)
before exporting to 4mm. Doing so, the Control Description will be 6mm wide on the 1:10'000 map.

• If the scale appears on the map (in our assumption 1:10'000), it should of course be changed before exporting
15'000 maps in the [Map File].

 Important: Only change the font and not the scale itself in the [Map File]. Save the [Map File] still in
1:10'000 under a new name and reload it as background map in the [Course Setting File]. Alternatively,
simply specify the scale in the [Course Setting File] with a font.

https://www.ocad.com/wiki/ocad/en/index.php?title=Background_Map%23I_.28Information.29
https://www.ocad.com/wiki/ocad/en/index.php?title=Course_Setting_Export%23Export_Courses_KMZ
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
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Pimp your Symbol Set
Are you regulary setting courses for your club? Shall all trainings have a common layout, similar to Corporate
Identity?
So, why not create your own Symbol Set and save it in the folder C:\Program Files\OCAD\OCAD 2018
Orienteering\Symbol? The Symbol Set will be on the list Load symbol set from:, if you open a new Course setting
project for Orienteering.

Example of the OCAD Symbol Set. A4/A3 frames, OCAD Logo, Corridor Symbol, Symbol for Parking, different
Text Symbols.

Tipps and Tricks
• Use the Compose Course tool for fast and easy course setting.
• Learn on the Route Analyzer page, how to analyze routes for sprint orienteering.
• Click on Add in the Course box to add a new course.
• To check your courses, use the Consistency Check Report under Menu>Course Setting>Consistencey Check

Report
• Enter Text into the Text field of the Marked Route and make the Text Control Description smaller.
• Read here how to export all relay variations to one file.
•• Pay attention to open/save Course Setting Files from OCAD 11 in OCAD 12 and vice versa, as many symbols

and colors has changed between these two versions.
• Press Shift while adding a new contol and you will skip the course object dialog box.
• Add Conrtol by moving the connection line between two existing controls.
• When you select controls for courses by double-clicking on them, lock their position beforehand in order not to

shift them.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:OCADSymbolSet.png
https://www.ocad.com/wiki/ocad/en/index.php?title=Edit_Course_Setting_Objects%23Add
https://www.ocad.com/wiki/ocad/en/index.php?title=Add_Course_Setting_Objects%23Add_a_Marked_Route
https://www.ocad.com/wiki/ocad/en/index.php?title=Create_Relay_Courses%23Export_a_Relay_Course
https://www.ocad.com/wiki/ocad/en/index.php?title=Add_Course_Setting_Objects%23Control
https://www.ocad.com/wiki/ocad/en/index.php?title=Add_Course_Setting_Objects%23Add_Control_to_Map_and_Course_at_once_by_Moving_the_Connection_Line
https://www.ocad.com/wiki/ocad/en/index.php?title=Edit_Course_Setting_Objects%23Lock_or_Unlock_Objects
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Course Setting functions
See the Course Setting for Orienteering page to get information about all functions of the Course Setting module.

O-trainings

Simple Course
This short video [3] shows you how to start a simple course, using the New Course Setting Project Wizard and the
Compose Course tool.

Relay Courses
Learn all about Relays on the Create Relay Courses page.

Sprint Relay
For a Sprint Relay with four different legs, you have to create only one course with different Leg Variation and
Team Variation.
• Open a new [Course Setting File], load your [Map File] as a Background Map.
• Go to the Course Setting Menu -> Courses and add a new Course. Choose Relay as Course type and enter the

number of legs (typically 4 for Sprint Relays).
• Add controls to your project and choose your Course afterwards in the Course Box.
• Insert a Team Variation: Each runner of the team gets a different variation, for example for the first control.
• Insert a Leg Variation: A leg variation means that there is a variation of the legs within the same team. In a

Sprint Relay, Women are running typically the 1st and 4th leg, whereas Men are running the 2nd and 3rd leg. To
make the Men legs longer, use a Leg Variation.

Learn all about Relays in general on the Create Relay Courses page.

https://youtu.be/SLHtPoS53nc
https://www.ocad.com/wiki/ocad/en/index.php?title=Create_Relay_Courses%23Insert_a_Team_Variation
https://www.ocad.com/wiki/ocad/en/index.php?title=Create_Relay_Courses%23Insert_a_Leg_Variation
https://www.ocad.com/wiki/ocad/en/index.php?title=File:SprintRelay_Example.png
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Corridor
• Open a new [Course Setting File] and load your [Map File] as a Background Map.
• Choose New in the Symbol Menu and create a new Line Symbol.

- In the Mail Line tab, activate Course setting symbol: Marked route.
- In the Double Line tab, choose the desired width of the corridor (e.g. 4mm) and the border lines.

 
•• Draw your corridor. Each corridor will appear as a Mared Route in the Course Setting Box. Insert the corridors in

your course.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:SprintRelay_Example2.png
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Corridor2.png
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Corridor1.png
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•• Edit your corridor in a next step.
- If needed, Cut overlapping parts.
- Insert additional vertices in sharp turns.

•• Cover the remaining parts with white.
- Use the White background (Symbol 760) to cover the remaining parts of the map.
- Activate Follow existing objects under Options> OCAD Preferences> Drawin and Editing to enable line
following for double lines (hold the Ctrl button).
- Instead of using White background (Symbol 760) for covering, first define a new white color
(Map>Colors>Add) and then create a new area symbol (Symbol>New>Area Symbol) where you use this
color as Fill Color. Like this you can set the Opacity of the white color to e.g. 90%, so you are not completly
lost when leaving the corridor.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:Corridor3.png
https://www.ocad.com/wiki/ocad/en/index.php?title=Cut%23Cut_Line
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Corridor8.png
https://www.ocad.com/wiki/ocad/en/index.php?title=Drawing_an_Object%23Following_Existing_Objects
https://www.ocad.com/wiki/ocad/en/index.php?title=Drawing_an_Object%23Following_Existing_Objects
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https://www.ocad.com/wiki/ocad/en/index.php?title=File:Corridor9.png
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Corridor4.png
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Corridor5.png
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Reduce Map
• Open your [Map File].
• Select the symbols you want to hide in the Symbol Box and go to Symbol>Hide Object or simply press F4.
• Save the map, load it as Background Map in your [Course Setting File] and set courses.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:ReduceMap.png
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Multitechnique
• Open your [Map File].
• Use the Crop funtion to differ which symbols you want to crop in which parts of your map. See an Animation

how to use the Crop funktionCrop.

In the following example, we used the yellow and green areas as Crop Objects. In the yellow part, all paths and
roads were cropped. In the green area, all terrain objects. You can use the Crop funktion as often as you like in the
same [Map File].

https://www.ocad.com/wiki/ocad/en/index.php?title=File:Multitechnique1.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Multitechnique2.PNG
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• Save the map, load it as Background Map in your [Course Setting File] and set courses.

Island O
• Open your [Map File].
• Draw an area object over your map and Cut Holes in it. In this example, we use a green area symbol.

• We select the green area symbol and use the Crop function to crop everything except the holes.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:Multitechnique3.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=Cut%23Cut_Hole
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Island1.PNG
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• Save the map, load it as Background Map in your [Course Setting File] and set courses.

Puzzle O
• Open a new [Course Setting File], load your [Map File] as a Background Map and set a course.
• Export your course as a Course Map under Course Setting>Export>Export Course Maps.
• Reopen your Course Map. Go to File>Open Recently Exported Documents.
• In a first step remove the Background Map (Background Map>Manage>Remove) and in a second step import

the Background Map (File>Import). Import all symbols and colors and Import colors at the bottom of the
color table.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:Island2.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Island3.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=Course_Setting_Export%23Export_Course_Maps
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• Export a Map Extract for each control (Map>Export Part of Map).
• Open a new [Course Setting File] for the final Layout.
• Import all Map Extracts one by one in the new [Course Setting File] and place them using the mouse

(File>Import). Again, import all symbols and colors and Import colors at the bottom of the color table.
• Edit each Map Extract manually in the new [Course Setting File].

 The imported symbols are protected by default, so it's not possible to move them after the first placement. Select 
the symbols in the symbol box and set their status to Normal (F2) to move them around. 

 A map flip at every control increases the difficulty. Arrange the Map Extracts in the Layout [Course Setting 
File] in a way, that you can print the odd numbers on the front and the even numbers on the back side of a map.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:ImportOcadMap.png
https://www.ocad.com/wiki/ocad/en/index.php?title=File:ExportedCourse.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=Map%23Export_Part_of_Map
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
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Map Change
Let's assume we add only one Map Exchange.

Print Course on two Maps

• Open a new [Course Setting File], load your [Map File] as a Background Map and set a course.
• Insert a Map Change into your course. A map exchange can be placed after a control (which is indicated with 0m

to the next start in the control description) or after a Marked Route (the length of the marked route appears in the
control description). Add a Start symbol after the map exchange.

•• When you print or export your map, two maps will be printed/ exported. The start on the second map is indicated
with a Start symbol.

Print Course on one Map

• Modify your [Map File] first. Crop the part you will use for your course and Duplicate it. Insert a Registration
Mark (Symbol 602 in ISOM 2017) into your map before you duplicate it.

• Save the modified [Map File] under a new name, e.g. [Map File - Layout].
• Open a new [Course Setting File], load your [Map File - Layout] as a Background Map.
• Set a course with a Map Change. Only use one map extract for course setting. Put a Registration Mark (Symbol

750 in ISCD 2018) at the same place as the Registartion Mark of your [Map File - Layout].

https://www.ocad.com/wiki/ocad/en/index.php?title=File:FileFolderPuzzleO.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=Insert_Course_Object%23Map_Exchange
https://www.ocad.com/wiki/ocad/en/index.php?title=Insert_Course_Object%23Map_Exchange
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• Export Course Maps under Course Setting>Export>Export Course Maps.
•• Open both course maps. Copy the course objects from one file and insert them into the other. Use the Registration

Marks for adjustment.

• Modify your course where needed and save your [Course Setting File] under a new name, e.g. [Course Setting
File -Final].

https://www.ocad.com/wiki/ocad/en/index.php?title=File:MapChange1.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:MapChange3.png
https://www.ocad.com/wiki/ocad/en/index.php?title=Course_Setting_Export%23Export_Course_Maps
https://www.ocad.com/wiki/ocad/en/index.php?title=File:MapChange2.png
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  As a different workaround, you
could proceed like in the Puzzle-O above. You don't modify your [Map File], but import it into both Course Maps,
where you export Map Extracts for the [Course Setting File -Final].

Score O
See the Score Orienteering page for more information.

References
[1] http:/ / www. ocad. com/ docs/ Getting_Started_with_Course_Setting_in_OCAD. pdf
[2] http:/ / www. ocad. com/ docs/ Einführung_in_die_Bahnlegung_mit_OCAD. pdf
[3] https:/ / youtu. be/ SLHtPoS53nc

https://www.ocad.com/wiki/ocad/en/index.php?title=File:MapChange4.png
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=File:ScoreO.PNG
http://www.ocad.com/docs/Getting_Started_with_Course_Setting_in_OCAD.pdf
http://www.ocad.com/docs/Einf�hrung_in_die_Bahnlegung_mit_OCAD.pdf
https://youtu.be/SLHtPoS53nc
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Create Relay Courses
   

This function is only available in course setting projects!

Create a Relay Course
To set courses for a relay, do the following steps:
1. Create a New Course Setting Project.
2. Add Course Setting Objects (e.g. Start, Controls, Finish) to the project.
3. Create a New Course. Choose Relay as the Course type and define the number of legs.
4. Create a New Class. Check the option Create classes automatically. Define the number of teams and allocate

start numbers to the class.
5. Add the Course Objects to a Course. You have special options for the relay.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:Pro40px.PNG
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Insert a Team Variation

A Team Variation means that runners of different teams go to different controls. OCAD allocates the chosen
amount of controls regularly to the teams, but, to make the relay fair, each runner of the team get a different variation
(e.g. Runner 1 goes to control 63, Runner 2 goes to control 55 and Runner 3 goes to control 125). The number of
possible variations is given by the number of legs of the relay. If a relay consists of three legs, you will have to make
three variations, so that the relay is fair. Variations can be equal to eachother, if for example you want to place only
two controls instead of three. In this case the equal variations are visited more often than the other one. In any case,
OCAD will force you to keep the relay fair (i.e. all teams have run the same leg variations at the end of the relay).
Although, you should verify the courses before printing.
1.1. Mark a position in the relay course where you want to insert the variation.
2. Click the Insert button in the Course Object Box on the ride side of the window.
3. The Insert Course Object dialog appears.
4. Choose the Team Variation option.
5. Click the OK button.

6. The team variation  appears in the course box.
7.7. You can add controls to the variation by marking the correct position and double clicking them.
8.8. The variation for the example above looks as follows:

 - It is also possible to leave a variation empty. This means that two runners in a team of three will have to get a
control and one runner leaves it out.

- OCAD will tell you with a warning message when you are trying to create something unfair.
- To delete a variation select it and press the Delete key or click the Delete icon.
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Insert a Leg Variation

A Leg Variation means that there is a variation of the legs within the same team. This can be used for when you
have a relay with three legs but the second leg is shorter than the other two legs. In the example above the first and
the third runner goes from control 92 to 87, then to 85 and finally to control number 84, whereas the second runner
goes from control number 92 to 107 and then directly to 84, which is the shorter leg. All runners who run the second
leg of the relay will have this shorter variation. It is also possible to make team or additional leg variations within a
leg variation itself. The same which applies to the team variation, applies also to the leg variation: OCAD will force
you to keep the relay fair (i.e. all teams have run the same leg variations at the end of the relay). Although, you
should verify the courses before printing.
1.1. Mark a position in the relay course where you want to insert the variation.
2. Click the Insert button in the Course Object Box on the ride side of the window.
3. The Insert Course Object dialog appears.
4. Choose the Leg Variation option.
5.5. Drag identical legs to the same column in the table.

6. Click the OK button when finished.

7. The leg variation  appears in the course box. The pink numbers indicate the leg number.
8.8. You can add controls to the variation by marking the correct position and double clicking them.
9.9. The variation for the example above looks as follows:
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 - It is also possible to leave a variation empty. This means that some legs have additional controls where other
legs go directly to the next control in common.

- OCAD will tell you with a warning message when you are trying to create something unfair.
- To delete a variation select it and press the Delete key or click the Delete icon.

Add the Variant to the Map
Read the Add Variant for Relay Courses article for more information.

Add the Start Number to the Map
Read the Add Start Numbers for Relay Courses article for more information.

Print a Relay Course
1. Choose Courses in the Print submenu of the Course Setting menu.
2. Adjust the print settings with help of the Print Courses and the Printing Maps pages of this Wiki.
3. Select the relay course in the Select Courses/Classes field.
4. Click the Print button.
5. The Print dialog appears.

You can print:
•• Variants
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• All: All variants are printed once.
• Variant: The variant selected in the dropdown list is printed once.

•• Start numbers

• All: All courses to all defined start numbers (in the Classes dialog) are printed. The variations are allocated
regularly to the teams.

• Number(s): All courses to the defined start numbers (in the Classes dialog) entered in this field are printed.
The variations are allocated regularly to the teams. You can enter a single start number (e.g. 23) or a range of
numbers (e.g. 23-31).

• Legs: If you choose the Start numbers option you also have to define which legs you want to print.
• All: All legs of the selected start numbers are printed.
• Leg: Enter a leg number if you want to print only single legs of the selected start numbers.

Click the OK button when finished. The courses are printed. This can take a moment.

 You can anytime reprint the course for a specific runner under the condition that nothing in the variations has
been changed.

Export

Export a Relay Course

1. Choose Export in the File menu.
2. Adjust the export settings with help of the Export Files page of this Wiki.
3. Click the Export button.
4. The Select Courses/Classes dialog appears.
5. Select the relay course and click the OK button.
6. The Export Relay dialog appears which is the same as the Print dialog.

You can export:

https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
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•• Variants

• All: All variants are exported once.
• Variant: The variant selected in the dropdown list is exported once.

•• Start numbers

• All: All courses to all defined start numbers (in the Classes dialog) are exported. The variations are allocated
regularly to the teams.

• Number(s): All courses to the defined start numbers (in the Classes dialog) entered in this field are exported.
The variations are allocated regularly to the teams. You can enter a single start number (e.g. 23) or a range of
numbers (e.g. 23-31).

• Legs: If you choose the Start numbers option you also have to define which legs you want to export.
• All: All legs of the selected start numbers are exported.
• Leg: Enter a leg number if you want to export only single legs of the selected start numbers.

Click the OK button when finished. The courses are exported. This can take a moment.

 If you want to export all relay variations to one file, do the following:
• Go to File->Print.
• Choose Microsoft Print to PDF as Printer and click on Print.
• Adjust the Print settings and click on Print.
•• A PDF with all your relay variations will be exported.

Export Relay Variations

1. Choose the Export Relay Variations command in the Export submenu of the Course Setting menu.
2. The Export Relay Variations dialog appears.
3.3. Browse a location and enter a name for the file to export.
4. Click the Save button to export the txt-file.
The Text-File contains all courses. The start numbers are listed with the corresponding variation.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
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Export the Relay Course Scheme

You can Export the Course Scheme or simply Copy the Course Scheme.

Example of a Relay Course
See here an Example of a Sprint Relay Course.
See below an example of a forest relay competition with 4 legs.

Back to the Course Setting for Orienteering page.
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One-Man Relay Courses
   

A one-man relay is a relay with mass-start and any number of legs competed by one single runner. The difference of
a one-man relay course to a normal relay course is mostly that the legs are a bit more different. This is to make the
course more attractive to the single runner.
One-man relay courses can be set similar to normal Relay Courses. Visit the Create Relay Courses page for more
information.

Example for a one-man relay with continous numbering.

Back to the Course Setting for Orienteering page.

Score Orienteering
   

Score orienteering is not implemented in OCAD yet. Although there are options to create a score orienteering event
with OCAD.
The idea behind a ScoreO is, that the runners have a certain timespan, in which they have to collect as many controls
(or points) as possible.

Use all Controls
The simplest way is to set controls, a start and a finish and then print all controls. There will be no need to Create a
New Course. The disadvantage of this method is that you cannot make classes, so all participants will have the same
controls.
You can Change the Code of the controls in a way: 31 -> 31-[20]; 32 -> 32-[10]; 33 -> 33-[20]
Like this you can weighten the controls (distant and more difficult controls give more points) and the runner see the
points on the map.
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Hide Connection Lines
A different method is hiding the connection lines. Do the following:
1. Create a New Course.
2. Add Course Objects to it.
3. Search the symbol for the Connection Line in the symbol box.
4. Hide the symbol.
5. Search the symbol for the Control Number in the Control Description.
6. Hide the symbol.
7. Set the numbering in the Course Setting Options to Code only.
8. Change the Code of the controls in a way: 31 -> 31-[20]; 32 -> 32-[10]; 33 -> 33-[20].
9. If you change to the Preview mode, the course looks like a score orienteering course now.

 Add controls in their numerical order to the course to get them rightly sorted on the control description. The
length of the course can be edited in the Courses dialog in the column for extra length. Extra length can be negative.

Hide Single Connection Lines
Deleting single connection lines is not possible but you can use a trick. Change to the Preview mode and drag the
end point of the connection line to the start point, so that they start and end at the same point. This makes the
connection line invisible. You can use this method when you have a part of arbitrary control order within a normal
course.

 Add controls in their numerical order to the course to get them rightly sorted on the control description. The
length of the course can be edited in the Courses dialog in the column for extra length. Extra length can be negative.
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Back to the Course Setting for Orienteering page.

Compatibility Check
OCAD 2019 files form Course Setting projects can be saved in a previous OCAD versions (10, 11 or 12) if the file
passes the Compatibility Check.
Example:

Possible Errors
•• Course XXX is a relay or one-man relay. This cannot be saved in older formats.
•• Continuous numbering for one-man relay not supported in older formats.
•• ISCD 2018 is not compatible with older OCAD versions.
•• Course name symbol is not compatible with older OCAD versions.
•• Class names symbol is not compatible with older OCAD versions.

PossibleWarnings
•• Full stop after control number: Removed
•• Number of start: Removed
•• Control description anchor: Removed
•• Route objects are deleted (not compatible with older OCAD versions).

https://www.ocad.com/wiki/ocad/en/index.php?title=File:CompatibilityCheck.png
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Compose Course
   

Compose a new course
 Short video as a starter: New Course Setting Functions [3]

1. Choose the Compose course tool from the toolbar.
2.2. Compose the course by clicking in the drawing area. First click adds a start object, each additional click adds a

control point and double click adds a finish object to the map and the course.
3. When you click on the Compose course tool, but no Course has been defined so far, OCAD will add a course

automatically. Enter the name. You will get to the Courses window, where you see the newly added course. Click
on Close.

4. If there are already Courses defined, but you have not chosen one in the Course List, a window appears where
you can select a course.
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Modify an existing course

Remove controls from the course
Use CTRL key + Click to remove a control from the course.

Insert controls into the course
•• Choose the Compose course tool from the toolbar.
• Initialize the Insert mode with entering and leaving a control circle with the mouse.
•• Once the insert mode is initialized each click inserts a control point.
• Use ESC key to exit the insert mode.

Move a control point
1.1. Enter a control circle with the mouse.
2.2. Press the left mouse key and drag the control point to the new position
3.3. Leave the left mouse key.

Limitations
The Compose course tool is not working for variations in Relay Courses.

Course Setting Objects Toolbar
Beside the Compose course tool, there are the most common Course Setting Symbols in the Toolbar. Click on one of
them and a Drawing Mode is activated automatically.
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Route Analyzer
This function is available in course setting projects for sprint orienteering maps, ski orienteering maps and mountain
bike orienteering maps.
It helps you to see and evaluate possible routechoises between two controls.
You will also get the shortest route for each course.

 --> See a short video on Youtube [1], which explains you the basics.

Open Route Analyzer      
When you are in a Course Setting project, you will see a purple bar at the right side called Route Analyzer. Click on
it and the bar will open.
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How it works
When you run the Route Analyzer the first time, the function will need some time to proceed all necessary steps to
show possible routes.
This includes:
•• Process impassible features
•• Create graph nodes
•• Connect nodes
•• Calculate routes
The larger your map is, the more time it will take to prepare the map. The calculation of the route itself will be quite
fast. You can follow the progress in the lower left corner of the OCAD window.
If you calculate additional routes, it will be much faster, as the function doesn't need to prepare the map again.
Here, too, the longer and more complex the route is, the longer it takes to calculate.
The shortest option is displayed with a solid blue line. The distance of the route is also shown with a text symbol.
Alternative routes are shown in red color.

Route Analyzer Box
You can either calculate only a route between two points, the whole route of a course or the routes for all courses at
once.
There are many ways to display the routes.
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Define the perimeter
• Entire Map: This may take quite long time to prepare the map, depending on its size.
• Define perimeter: Draw a perimeter on the map. The perimeter will be shown with a light blue line. Routes will

only be analyzed in this perimeter.

Draw leg and analyze route
You can calculate routes only between two points.

1. Click on Draw leg and analyze route. 
2.2. Click and drag a line in the OCAD window.
3.3. Repeat these two steps for further routes.
The routes will be saved in the Route Box.

Add route via point(s)

1. Click on Add route via point(s). 
2.2. Touch an existing route on the map and release where the new route should pass. The route is calculated again.
3.3. Insert multiple via points by pressing the SHIFT key.

Analyze routes (current course)
1. Select a course in the Course Box.
2. Click on Analyze routes (current course).
3. All routes will be saved in the Route Box.
A Text-File will be created to adjust the course length.

Analyze routes (all courses)
1. Click on Calculate routes (all courses).
2. All routes for all courses will be calculated and will be saved in the Route Box.
A Text-File will be created to adjust the course length.

Reset routing graph
Click on Reset routing graph to process again all impassible features and build up the nodes.
This may be necessary if you detect a mistake in your map (e.g. an unwanted gap between two impassible features),
which can be seen in the function Show Impassable Features.
After you corrected the mistake in your [Map File], you need to reset the routing graph, before calculating new
routes.

Route Box
All calculated routes will be shown in the Route Box. 
You see on the left side, if the route is visible or not. The right side shows you between which two controls the route 
has been calculated.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:RouteAnalyzer_DrawLeg.png
https://www.ocad.com/wiki/ocad/en/index.php?title=File:RouteAnalyzer_AddViaPoint.png
https://www.ocad.com/wiki/ocad/en/index.php?title=Edit_Course_Setting_Objects%23Course_Box
https://www.ocad.com/wiki/ocad/en/index.php?title=Route_Analyzer%23Adjust_Course_Length
https://www.ocad.com/wiki/ocad/en/index.php?title=Route_Analyzer%23Adjust_Course_Length


Route Analyzer 535

Show current course routes
Shows the routes of the select course in the Course Box. All routes of this course will be visible in the Route Box,
all other routes will be hidden.

Show all routes
Show all routes in the Route Box.

Hide all routes
Hide all routes in the Route Box.

Delete all routes
Delete all routes in the Route Box.

Adjust Course Length
When you click on Analyze routes (current course) or Analyze routes (all courses), a .txt-File will be created in
the same folder, where your course setting project is saved. This txt-File contains a summary of all routes, as well as
a summary for each course for itself.
Example:

Course Setting Project.Course 1.shortestRouteLengths.txt

Course Setting Project.AllLegsRouteLengths.txt

• Length: The length of your course.
• Extra length: The difference between the shortest possible route of the course and the course length.
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 For Sprint Orienteering Courses, it is common to show the length of the ideal route and not the course length.
Add the Extra length value to the corresponding field in the Courses dialog.
• Climb along route: If there is a DEM loaded in the course setting project, climbing is calculated along the

shortest route.

Limits of the function
The Route Analyzer is a great function. However, it's not working in every situation.
These are the limits of the function:
•• The function is not (yet) considering the runnability. It only distinguish between passable and impassable

features. The fastest route may go through a green area.
Positive side effect: You may notice routes that you have not thought off before (e.g. possible route through
green area).

•• The function can't deal with different running levels, e.g. underpass, overpass, bridges or tunnels.

• Further mistakes may also be a result of bad map drawing. Check the function Show Impassable Features.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=File:RouteAnalyser_vegetation.png
https://www.ocad.com/wiki/ocad/en/index.php?title=File:RouteAnalyser_bridge.png


Route Analyzer 537

Editing the routes
You can edit the routes and labels manually. Just click on the routes and edit them. The length will not yet be
adjusted automatically.

Shift + Ctrl + 
Add Vertex

Ctrl + 
Remove Vertex

Ctrl +  + Mouse
Remove Vertex with Mouse Over.

See the Tips with Keyboard and Mouse page or the Select Object and Edit Vertex page for more information.

Last but not least
-  Before printing/exporting your courses, be sure that all the calculated routes are hidden or deleted.
You probably don't want to give a map to the runners with all measured routes on it.
- The graph is automatically saved in the course setting project directory after calculating the first route (if the option
"whole map" is selected) and reloaded when the file is opened again. For that, three files are saved in the folder of
the course setting project:
•• [FILENAME CS PROJECT].ocdGraph
•• [FILENAME CS PROJECT]. ~imp.tiff
•• [FILENAME CS PROJECT]. ~imp.tfw
Whether a graph has been loaded or not can be seen by the fact that the "Reset routing graph" button is active.
- Credit goes to Fabian Hertner who helped us to develop this function with his ideas and knowledge.

References
[1] https:/ / youtu. be/ XbHSJn_2yXU
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Add Course Setting Objects
   

(This function is only available in course setting projects!)

Add Start, Controls and Finish

Start

1. Select the  Start symbol in the symbol box.
2.2. Select any drawing mode.
3. Click in the drawing area to place the object. Now the Course Object Dialog Box appears. It proposes the code

S1 for the start. Enter a different code if desired.
 Skip the course object dialog box by holding down the Shift key when clicking in the drawing area.

4. Click the OK button.
5. The Start object appears on the map.
6. You can now Add the Course Object to Courses.
7. Select it to get some editing options. Visit the Edit Course Setting Objects page to get more information (e.g.

how to edit the control description).

Control

1. Select the  Control symbol in the symbol box.
2.2. Select any drawing mode.
3. Click in the drawing area to place the object. Now the Course Object Dialog Box appears. It proposes a code.

Enter a different code if desired.
 Skip the course object dialog box by holding down the Shift key when clicking in the drawing area.

4. Click the OK button.
5. The Control object appears on the map.
6. You can now Add the Course Object to Courses.
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7. Select it to get some editing options. Visit the Edit Course Setting Objects page to get more information (e.g.
how to edit the control description).

Finish

1. Select the  Finish symbol in the symbol box.
2.2. Select any drawing mode.
3. Click in the drawing area to place the object. Now the Course Object Dialog Box appears. It proposes a code.

Enter a different code if desired.
 Skip the course object dialog box by holding down the Shift key when clicking in the drawing area.

4. Click the OK button.
5. The Finish object appears on the map.
6. You can now Add the Course Object to Courses.
7. Select it to get some editing options. Visit the Edit Course Setting Objects page to get more information.

 It is not possible to edit the control description for the finish. The control description is defined by the marked
route between the last control and the finish.

Add Control to Map and Course at once by Moving the Connection Line
1. Select the course in the dropdown list of the Course Object Box.
2.2. Make sure that you are not in the Preview Mode.

3. Select the  Control symbol in the symbol box.
4. Choose the Select Object and Edit Vertex tool.
5. Click on the connection line between those controls where the object should be added and drag the connection

line to the place where the object should be added. Now the Course Object Dialog Box appears. It proposes a
code. Enter a different code if desired.

 Skip the course object dialog box by holding down the Shift key when clicking in the drawing area.
6. Click the OK button.
7. The object appears on the map and is added to the course.

 Variant for step 5 and 6: If the connection line is moved to an existing control then this control is added to the
course without creating a new control on the map.
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Add a Marked Route
A marked route is mostly used from the last control to the finish. Sometimes you may also have marked routes
between controls (e.g. to cross a bridge or a dangerous area).
The marked route treated in this article applies to a route the runner must use. If you want to add a marked route just
for information, but which is not part of the course you have to add it as a different object, which is described at the
end of this aticle.
To create a marked route:

1. Select the  Marked Route symbol in the symbol box.
2.2. Select a drawing tool (e.g. the curve tool).
3.3. Draw the marked route in the direction in which the competitors are running (e.g. from the last control to the

finish).
4. Now the Course Object Dialog Box appears. It proposes a code. Enter a different code if desired (See below if

this dialog box does not appear automatically).
5. Click the OK button.
6. The Marked Route object is shown on the map.
7. You can now Add the Course Object to Courses.
8. Select it to get some editing options. Visit the Edit Course Setting Objects page to get more information.

Check Funnel tapes  in the Course Object Box when a marked route is selected to get the
corresponding symbol on the control description.

You can even enter a Text Control Description for the Marked Route. This text appears in the Text Control
Description and has no effect on the Symbol Control Description, but it can be useful to make the Text Control
Description smaller.
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The marked route defines how the finish is displayed on the control description. Marked routes can be drawn
anywhere in the course, but note that they must be drawn in the direction in which the competitors are running,
otherwise the course will not be drawn correctly.

 Marked routes must be added to each course like controls and the finish (Add a Course Object to Courses).

Marked Route 1: Starts at control, Funnel tapes disabled.
Marked Route 2: Starts not at control, Funnel tapes disabled.
Marked Route 3: Starts at control and ends at finish, Funnel tapes active.
If the Course Object Dialog Box does not appear automatically:

1. Right-click on the  Marked Route symbol in the symbol box.
2. Choose the Edit command from the context menu. The Line Symbol dialog box appears.
3. In the Main Line tab activate the Course setting symbol: Marked route option.
4. Click the OK button and draw the marked route again.
If you want to create a marked route without influence on the course:

1. Right-click on the  Marked Route symbol in the symbol box.
2. Choose the Duplicate command.

3. Right-click on the duplicated  Marked Route symbol in the symbol box.
4. Choose the Edit command from the context menu. The Line Symbol dialog box appears.
5. In the Main Line tab disable the Course setting symbol: Marked route option.
6. Click the OK button. Now you can draw a marked route which cannot be added to a course and is always visible.
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Add the Map Issue Point
Since ISOM 2017, there's a symbol for the map issue point (symbol number 702).
Draw a marked route to the start triangle and then add a Corner Vertex into the dashed line. The crossbar for the map
issue point appears.

 You can also draw the Map Issue Point like a normal point object (and not insert a Corner Vertex). However,
please note that in this case the Map Issue Point will be displayed in all courses.

Example for Map Issue Point at EOC 2018 Middle Distance Final Women.
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Add a Control Description
To print a control description together with the course you have to place a control description object. This object is a
placeholder and indicates the upper left corner of the control description.

1. Select the  Control Description symbol in the symbol box.
2.2. Select any drawing mode.
3.3. Place the upper left corner of the control description on the map.
4. Now the Course Object Dialog Box appears. It proposes a code. Enter a different code if desired.
5. Click the OK button.
6. The Control Description object is indicated by a hook on the map which is the upper left corner.
7. Select it to get some editing options. Read the IOF Symbol Control Description article to get more information.
Change Control Description Type

 1)
Select the control description corner on the drawing area or in the course setting objects list.
2) Change the Control description type from symbol to text or vice versa on the right side of the window.

 It's the same with changing the Control description anchor from top left to bottom left in the Course Object
Box.
Control Description with White Background
If the background map should be masked below the text description, activate the White background option in the
Options dialog of the Course Setting menu.
Click the Preview button to get a preview of the control description.
Control Description with White Background (Draft Mode)

If you prefer to print your maps in draft mode, you will face a problem, that there is no block-out of the control
description in draft mode.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:Cdsymbol.gif
https://www.ocad.com/wiki/ocad/en/index.php?title=Add_Course_Setting_Objects%23Course_Object_Dialog_Box
https://www.ocad.com/wiki/ocad/en/index.php?title=Edit_Course_Setting_Objects%23IOF_Symbol_Control_Description
https://www.ocad.com/wiki/ocad/en/index.php?title=File:ChangeControlDescriptionType.png
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=Edit_Course_Setting_Objects%23Preview
https://www.ocad.com/wiki/ocad/en/index.php?title=File:ControlDescriptionDraftMode.png


Add Course Setting Objects 544

In this case, activate the new option Draw white background even in draft mode in the Course Setting Options
dialog. Read more in the Course Setting Options article.

Add a Course Title
Normally you add the title of the course to the map. To add a course title, you place a text object which is a
placeholder for the course title. This text object will be filled with the course title in each course.

1. Select the  Course Title symbol in the symbol box.
2.2. Select any drawing mode.
3. Click in the drawing area to place the object. Now the Course Object Dialog Box appears. It proposes a code.

Enter a different code if desired. If this dialog does not appear automatically, you must make a modification to the
course title symbol which is described below.

4. Click the OK button.
5. The Course Title object appears on the map with the placeholder text Course.
6. Select it to get some editing options. Visit the Edit Course Setting Objects page to get more information.
Click the Preview button to get a preview of the course title.
OCAD allows you to use the course name (e.g. Course C), a list of all classes using that course (e.g. M16 - W20 -
M40) or both (e.g. Course C M16 - W20 - M40) as a course title. To define the appearance of the course title:
1. Choose the Options command from the Course Setting menu. The Course Options dialog box appears.
2. Select the desired course title in the Course title box.
The same course title will also appear in the control description.
If the Course Object Dialog Box does not appear automatically:

1. Right-click on the  Course Title symbol in the symbol box.
2. Choose the Edit command from the context menu. The Text Symbol dialog box appears.
3. In the General tab activate the Course setting symbol option and choose the Course title item from the

dropdown list.
4. Click the OK button and place the course title again.

 Instead of displaying the Course title, you can also display the Course name and/or Class name(s).

1. Right-click on the  Course Title symbol in the symbol box.
2. Choose the Edit command from the context menu. The Text Symbol dialog box appears.
3. In the General tab activate the Course setting symbol option and choose the Course name or Class name(s)

item from the dropdown list.
4. Click the OK button and place the course title again.
5. You can also display Course title, Course name and Class name(s) by duplicating the symbol (right click on

symbol in symbol box -> duplicate) and choose different items from the dropdown list.
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Add Variant for Relay Courses
For relay courses, you can add an overview of the variations (variant) to the map. To add the variant, a text object
which is a placeholder for the variant is placed. This text object will be filled with the variant of each runner when
printing or exporting the map. The variations are indicated with a letter in the variant text field. The leg is indicated
with the number at the beginning of the text field. The variations are indicated with letters (e.g. from A to C at a
three men relay). If two runners have the same sequence of letters,they have exactly the same variations on this leg.
Different letters mean different variations.

1. Select the  Variant (Relay) symbol in the symbol box.
2.2. Select any drawing mode.
3. Click in the drawing area to place the object. Now the Course Object Dialog Box appears. It proposes a code.

Enter a different code if desired. If this dialog does not appear automatically, you must make a modification to the
course title symbol which is described below.

4. Click the OK button.
5. The Variant object appears on the map with the placeholder text AB. This text is replaced with the variation

sequence when printing or exporting the map.
6. Select it to get some editing options. Visit the Edit Course Setting Objects page to get more information.
If the Course Object Dialog Box does not appear automatically:

1. Right-click on the  Variant (Relay) symbol in the symbol box.
2. Choose the Edit command from the context menu. The Text Symbol dialog box appears.
3. In the General tab activate the Course setting symbol option and choose the Code for variant (relay) item

from the dropdown list.
4. Click the OK button and place the Variant object again.

 Visit the Create Relay Courses page to get more information about relays.

Add Start Numbers for Relay Courses
For relay courses, you must add the start number to the course in order to give the right map to the right runner. To
add a start number, a text object which is a placeholder for the start number is placed. This text object will be filled
with the start number of each runner when printing or exporting the map.

1. Select the  Start Number (Relay) symbol in the symbol box.
2.2. Select any drawing mode.
3. Click in the drawing area to place the object. Now the Course Object Dialog Box appears. It proposes a code.

Enter a different code if desired. If this dialog does not appear automatically, you must make a modification to the
course title symbol which is described below.

4. Click the OK button.
5. The Start Number object appears on the map with the placeholder text 51.1. This text is replaced with the start

number when printing or exporting the map.
6. Select it to get some editing options. Visit the Edit Course Setting Objects page to get more information.
If the Course Object Dialog Box does not appear automatically:

1. Right-click on the  Start Number (Relay) symbol in the symbol box.
2. Choose the Edit command from the context menu. The Text Symbol dialog box appears.
3. In the General tab activate the Course setting symbol option and choose the Start number (relay) item from

the dropdown list.
4. Click the OK button and place the start number again.

 Visit the Create Relay Courses page to get more information about relays.
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Add Other Objects
In your Course Setting Project you may want to add other objects like:
•• Out-of-Bounds Boundary

An out-of-bounds boundary shall not be crossed  .

•• Out-of-Bounds Area

An Out-of-Bounds Area shall not be entered. Depending on the borderline type (none, dashed, solid) you can see if
the Out-of-Bound Area is marked in the terrain or not (no marking, intermittent marking, continuously marking)

 .

•• Crossing Point

A crossing point can be used for instance through or over a wall or fence, across a road or railway, through a tunnel
or out-of-bounds area, or over an uncrossable boundary. The lines shall reflect the length of the crossing  .

•• Out-of-Bounds Route

A route which is out-of-bounds. Competitors are allowed to cross directly over a forbidden route, but it is forbidden
to go along it  .

•• First Aid Point

Shows the location of a first aid post  .

•• Refreshment Point

Shows the location of a refreshment point which is not at a control  . If the refreshment point is at a control, it 
will be marked in the Control Description only.
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•• Event Title

Shows the event title  .

•• Reserve Fiels

In case of Sport Timing Software failure (SI, EMIT), punch into these fields  .

•• Registration Mark

At least three registration marks should be placed within the frame of a map in a nonsymmetrical position. These can
be used for course overprinting when overprinting on already printed maps or when exporting and merging different
Course Maps  .
See a possile use here.

•• Temporary construction or closed area

Obvious temporary constructions like platforms for spectators and speaker, closed area for spectators, outside
restaurant areas, etc. shall be represented with this symbol  .

•• White Background

White Background can be used to cover part of your Backgorund Map, e.g. for Corridor trainings  .

•• Logo of the Event
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Use the Layout Menu to insert Logos from the Event, Sponsors, ect. Note that you can save your Layout in order to
import it again the next time.

•• Date of the Event, Name of Course Setter, Corrections to the Map, Parking, Other information relevant to
the runner

For other text objects you may have to Create Your Own Symbols. It is important for these symbols that the option
Course Setting Symbol (in the symbol dialog, when you click the symbol with the right mouse button and choose
Edit from the context menu) is switched off. The option Course Setting Symbol must be used only for objects
which belong to a course like controls, the marked route from the last control to the finish or the course title.

Example If there is a marked route for children which you would like to appear on all other courses (just for
information) you proceed as follows:

1. Right-click on the  Marked Route symbol in the symbol box.
2. Choose the Duplicate command.

3. Right-click on the duplicated  Marked Route symbol in the symbol box.
4. Choose the Edit command from the context menu. The Line Symbol dialog box appears.
5. In the Main Line tab disable the Course setting symbol: Marked route option.
6. Click the OK button. Now you can draw a marked route which cannot be added to a course and is always visible.
Use this new symbol to draw the children course.

Course Object Dialog Box
This dialog box appears after placing a course object or clicking the Change Code button in the course setting box
on the right side of the window.

In this dialog box you can create or edit the code of a course object.
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Code
OCAD proposes the next free number for the controls and a letter plus a number for other course objects. It is
recommended to use this convention.
First Free Code button
Click this button to get the first free code available. For control objects OCAD first searches for the lowest number
you have defined and assumes that you want to use only numbers above this number. If you want to use a lower
number, you must enter it on the keyboard.
Next Free Code button
Click this button to get the next free code available.
Click the OK button when finished.

 - There are no restrictions for the code. You can enter an arbitrary code, even letters and some glyphs are
allowed.

- If Auto Control Description is activated, this dialog is extended with the control description part. Read the
Course Setting with Auto Control Description article for more information.
- Skip the course object dialog box by holding down the Shift key when clicking in the drawing area.

Back to the Course Setting for Orienteering page.

Edit Course Setting Objects
   

The Course Setting Box on the right side of the window provides several editing options for added course setting
objects (Start, Control, Finish, Marked Route etc.).
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Course Object List
To edit an Course object, you have to select it first in the Course Object List or in the map window.

Course Object Box

Change Code

Change the code of the selected course setting object by clicking the corresponding button  . The Course

Object Dialog Box appears. Enter a arbitrary new code (no restrictions) or click the arrows to find the first  or
the next  free code. Click the OK button when finished.
If you want to renumber all controls, use the Renumber all controls function in the Controls submenu of the
Course Setting menu.

Text Block

Click this button  to add a text block to the control description. The Course Object dialog appears. Enter a code
for the text block and click the OK button. The text block appears in the list of all course objects to the left of the
Object box. Select it and type a text in the field standing for the text control description. Now the text block has to
be added to a course. For this reason, select the course, mark the correct position in the course (e.g. after control
number 38) and double-click the text block in the course object list. The inserted text appears in the control
description of the chosen course.

Lock or Unlock Objects

Click the Lock button  to lock or unlock course setting objects. If the course setting objects are locked, they
cannot be moved in the drawing area. This can be useful if you add controls to the course by double-clicking on
them. There it can happen that you shift the control accidently when double-clicking on it. When locking the controls
before, this can not happen.

Text Control Description

Enter a text in this field  for the text control description. Alternatively, the text control
description can be edited using the Edit Text Control Description function in the Course Setting menu. Defining a
text for the text control description is possible for Starts, Controls, Marked Routes and Text Blocks (displayed
also in the symbol control description).
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IOF Symbol Control Description

You can edit the IOF symbol description by clicking one of the eight squares. OCAD proposes some symbols for the
corresponding field in a menu. To delete a symbol from the control description, click an empty field of OCAD's
proposals, when clicking the corresponding square (C-H).

A: Control Number: The control number is specified automatically depending on the sequence of the controls and
cannot be edited.
B: Control Code: To edit the control code use the Change Code button.

C: Which of any Similar Feature: Declare the position of the feature when there are similar features at close
quarters.
D: Control Feature: The control feature can be declared in this field.
E: Appearance: Add additional information characterizing the appearance of the feature.
F: Dimensions/Combinations: The dimensions or combinations of the feature can be declared in this field.

You can either choose the crossing or junction symbol for two combination symbols or enter the dimension of
the feature:

Enter a value in the upper field of this box to define the dimension of this feature.
Enter a value in both fields of this box to define the heights of two features.
Enter a value in both fields and check the diagonal box to define the heigh of a feature on a slope.

G: Location of the Control Flag: Declare the precise location of the control flag in this field.
H: Other Information: Other information can be given in this field (e.g. radio control or refreshments).

 - Sources and additional information to the IOF control description can be found here: IOF Control
Descriptions 2018.pdf [1]

- Editing the symbol control description is possible for Starts and Controls.
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- It is not possible to edit the control description for the finish. The control description is defined by the
marked route between the last control and the finish.

Add an Own Symbol to the Control Description

It is possible to add an own symbol to the control description.
1. Create a new point symbol with the correct appearance and dimensions for the control description. Learn how to

create a new point symbol on the Create a New Symbol page.
2. Unlike the Point Symbol Dialog in a normal map project, the Point Symbol Dialog of Course Setting projects

have an additional part, namely the Course setting project for orienteering part.
3. Check the Control description symbol option.
4.4. Check the fields (B-H), which you want OCAD to propose your own symbol.
5. Click the OK button when finished.

Classes and Runners
In this part of the dialog all Classes using the selected course setting objects are listed. In addition, the total number
of runners visiting this object is given. Define the number of runners per class in the Classes dialog.

Course Box

Course

Select a course in the dropdown list  . The course is now selected. You can add course objects
to it by double clicking them on the map or on the list with all objects. There are three special items in this list:
• All courses: Select this item and click on Preview to display all courses.
• Runners: Select this item to display all controls. In the Preview mode the total number of runners visiting this

control is given in brackets behind each control code. Define the number of runners per class in the Classes
dialog.

• All controls: Select this item to display all controls on the map. In the Preview mode each control is displayed
with its code.

Add

Click the Add icon  to add a new course. The Courses dialog opens with the added course listed in the last row.

Lock or Unlock Courses

Click the Lock icon  to lock or unlock all courses. When courses are locked, it is not possible to add or remove
course setting objects.

Preview

Click the Preview button  to get a preview of the selected course. You are now in the Preview mode.
In the Preview mode it is possible to make several graphical adjusments on the course.
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The following adjustments are allowed:
• Connection Lines: Connection lines can be edited with most of the editing tools (e.g. Reshape, Add, Move or

Remove Vertices, Cut etc.). This can be useful if for example a connection line crosses another control or covers
an important map object.

• Control Numbers: Select a control number and move it to another position. This can be useful if the control
number gets in the way of other course objects or important map information.

Visit the Make Graphic Modifications page to get more information.
Note: Other adjustments (e.g. move controls or add new course objects) are not allowed to make in the Preview
mode. Make sure you click the Preview button again before going on working on the courses.

 - If control circles cover important map information, they have to be cut in the normal mode and not in the
Preview mode.

- When moving a control or a course setting object on the map, all affecting graphical adjustments (e.g. moved
control numbers or cut connection lines) made in the preview mode get lost. Use the Lock button to prevent
from moving course objects accidentally.

Switch Between Courses

Use the arrow buttons  to switch between the courses.

Insert

Select a course and click the Insert button  . The following course objects can be inserted:
•• Mandatory crossing point(s)
•• Mandatory passage through out of bounds area
•• Map exchange
•• Team variation
•• Leg variation
Visit the Insert Course Object page for more information.
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Delete

Remove a course object from a course by selecting it and clicking the Delete button  . Alternatively, you can
press the Delete key on your keybord.

Reset

This button  is available when you are in the Preview mode. All graphical adjustments (e.g. moved
control numbers or cut connection lines) are removed when clicking this button.
You can also reset only selected preview objects or graphical adjustment. Select them in the drawing window (press
the SHIFT key to select multiple objects) and click the right mouse button. A pop-up window appears.

Course Length and Climb

The length and climb of the course  is displayed here. The length of the course is
calculated automatically. However, you can add an extra length in the Courses dialog. This can be useful for
example for Sprint Courses, when you want to show the length of the ideal running route.
If a DEM is used, the climb is calculated automatically, too (Climb Calculated). Although, you will have to adjust
this value in the Courses dialog (Climb Used) because OCAD calculates it using the linear distance from one
control to another. Both climb values are displayed in the Course Box, but only the Climb Used is displayed in the
Control Description.

Copy Course Scheme
Copy the Course Scheme to clipboard as Bitmap.

 
You can also Export the Course Scheme. Choose the corresponding command in the Export submenu of the
Course Setting menu.
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Main Page

Course Setting for Orienteering

References
[1] https:/ / orienteering. org/ wp-content/ uploads/ 2010/ 12/ control-description-a4-pages_copy. pdf

Control Elevation
   

(This function is only available in course setting projects!)

Control elevation is used to calculate the height climb for courses. This function doesn't work for relay courses.
Choose the Control Elevation command in the Controls submenu of the Course Setting menu to change the
elevation of a control.
The Control Elevation dialog box is displayed. It shows a table with four columns:

• Name: In this column the control code is displayed.
• Elevation DEM: This column shows the elevation of the control calculated with help of the DEM. If no DEM is

loaded, this column is empty.
• Elevation Used: In this column an elevation value can be entered if there is no DEM available or if elevation

DEM value is not correct. If a value is entered in this column, it is used for courses' height climb calculation.
• Difference: The difference between the Elevation DEM and the Elevation Used columns is displayed here.
Click the Close button to quit this dialog. Click the Export button to export the table as a XLS, TXT, HTM or
DOC-File.

Back to the Course Setting for Orienteering page.
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Create a New Course
   

(This function is only available in course setting projects!)

To create a new course, you first define its name and other parameters. Then you can add course objects and assign
Classes to the course.

Define the Name and Other Settings
1. Choose the Courses command in the Course Setting menu.
2. The Courses dialog appears.

3. Click the Add button.
4.4. Enter a course name in the first column.
5. Define the Course type in the corresponding column. You can choose between Normal Course, Relay or

One-man relay.
6. If you have chosen the Relay or One-man relay option, define the number of legs in the last column.
7. Click the OK button when finished. Other adjustments can be made after adding course objects to the course in

this dialog. Visit the corresponding article below.

 As a shortcut, just click on Add in the Course box.

Add Course Objects
Adding course objects is the next step. They must have been created before (Add Course Setting Objects).
To add a course object to a course follow these steps:
1. Select the course in the dropdown list of the Course Object Box.
2. Make sure that you are not in the Preview Mode.
3.3. Double click a course object either on the map or in the course objects list.
4. The course object is inserted at the position of the blue horizontal insertion line in the Course Object Box. Click

the correct position in the course (so that the line gets moved) before adding the course object.
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You can add a Start, a Finish, Controls or a Marked Route to the course, as well as some special objects (e.g.
relay variations or Text Blocks) listed on the Insert Course Object page.

Edit the Course
Find editing options on the Edit Course Setting Objects page.
Choose the Courses command in the Course Setting menu to display the Courses table with the following headers:
• Course: Edit the course name in this column.
• Length: The length is calculated automatically with help of the set scale. This column cannot be edited.
• Extra length: In this column you can enter extra length. The extra lenght is added to the calculated length and the

sum shows up in the control description. The extra length can also be negative to make the course length shorter.
For Sprint Orienteering Courses, it is common to show the length of the ideal route and not the calculated length.

• Climb calculated: In this column the calculated climbing is shown. Climbing is calculated with help of the DEM
or with the control elevations entered in the Control Elevation dialog. You most probably have to adjust this
value, because OCAD calculates it using by adding the net ascent from each control to the next one.

• Climb used: Enter a value here for the height climb which shall show up in the control description.
• Number of controls: The number of controls is listed in this column.
• Course type: Change between Normal course, Relay or One-man relay in this dropdown list.
• Legs: For Relays and One-man relays enter the number of legs in this column.
• Runners/teams: Edit the number of Runners/teams in the Classes function.
• Click the Move up or the Move down button to move the selected course up or down.
• Click the Add button to add a new course.
• Click the Delete button to delete the selected course.
• Click the Duplicate button to duplicate the selected course.
• Click the Report button to save the table as a XLS, TXT, HTM or DOC-File.
• Click the OK button to save all changes and quit the dialog.
• Click the Cancel button to quit the dialog without saving any changes.

Back to the Course Setting for Orienteering page.
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Create a New Class
   

(This function is only available in course setting projects!)

This function is used when different classes use the same course. You will have to define classes and allocate a
course to them.

 If you have two Classes (e.g. Women Elite and Women 20) and both have the same Course, it is a common
mistake to name the Course WE, W20 and not to create any Classes. You will get troubles with your timing
software this way.
Instead you can still name the Course WE, W20 (or simple name it A), but you need to create two Classes (WE and
W20) and allocate the same Course to both of them.
1. Choose the Classes command from the Course Setting menu.
2. The Classes dialog appears.

3. Uncheck the Create classes automatically option. If this option is enabled, courses and classes are equal which
means that every class has a different course.

4. Click the Add button to create a new class. A new row is inserted in the table.
5. Enter a name in the Class column (e.g. M20)
6. Allocate a course. Choose the course from the dropdown list in the Course column.
7. For Relay Courses:

Enter the Start numbers. The amount of Start numbers is the number of Teams. If you have 5 Start numbers
and 3 Legs, you will get 15 runners (1.1, 1.2, 1.3, 2.1, 2.2, ..., 5.3) On the basis of the start numbers, variations
get allocated to the teams.
Define the estimated number of teams in the corresponding column. This number is only used for the
calculation of course statistic. If you have 10 Teams and 4 Legs, it will give you 40 runners at a common
control.

8. For Normal Courses:
Mostly there's no need to enter Start numbers, as the printing of Start Numbers is done independently.
Define the estimated number of runners in the corresponding column. This number is only used for the
calculation of course statistic.

9. Optionally, you can add a Comment to eack class.
• Click the Move Up or Move Down button to move a class up or down in the table.
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• Click the Delete button to delete the selected class.
•• Click the Report button to save the table as a XLS, TXT, HTM or DOC-File.
• Click the OK button to save and quit the dialog.

Import Class Assignment
Click the Import button to import a class assignment file. The file contains four columns with course name, class
name, number of runners and comment column. OCAD ignores the first header line. The columns are separated by a
semikolon (';') or a tab. Do not use these characters, e.g. in the comment column.
Example file:

 Course;Class;Runners;Comment

 1;M17;64;7-8 km, medium, 1:10'000, A3 Portrait

 1;M40;21;6-7 km, difficult, 1:10'000, A3 Landscape

 2;W21;122; 8-9 km, very difficult, 1:15'000, A4 Portrait

3;W13-14;82;3-4 km, easy,1:5000, A4 Landscape

Insert Course Object
   

(This function is only available in course setting projects!)

This dialog box appears when you click the Insert button in the Course Box.

 To insert a Course Object to several Courses at once, see the Insert Course Objects to Courses page.
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Mandatory Crossing Point
Check this option to add a mandatory crossing point. The mandatory crossing point appears in the control
description.

 The connection line is not adapted to the crossing point because the runner may can choose between several.
Edit the Connection Line afterwards as needed.

Mandatory Passage Through Out of Bound Area
Check this option to add a mandatory passage through out of bound area. The mandatory passage appears in the
control description.

 The connection line is not adapted to the mandatory passage because the runner may can choose between several.
Edit the Connection Line afterwards as needed.

Map Exchange
Check this option to add a map exchange. The map exchange appears in the control description.

A map exchange can be placed after a control (which is indicated with 0m to the next start in the control description)
or after a Marked Route (the length of the marked route appears in the control description).
The map exchange also has an impact on printing. With an inserted map exchange, two maps are printed. To show a
start symbol on the second map, a start symbol must be added after the map exchange.
Add a Course Title (e.g. H21) to your original course with the map exchange. When you Export Course Maps, you
will get two ocd files. They are labeled H21 (1) and H21 (2).

Example of a Map Exchange.

Team Variation
This command is only available for relay and one-man relay courses.

Read the Insert a Team Variation article for more information.

Leg Variation
This command is only available for relay and one-man relay courses.

Read the Insert a Leg Variation article for more information.

Back to the Course Setting for Orienteering page.
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Add a Course Object to Courses
   

(This function is only available in course setting projects!)

Add a Course Object to Courses
To add a course object to a course follow these steps:
1. Select the course in the dropdown list of the Course Object Box.
2. Make sure that you are not in the Preview Mode.
3.3. Double click a course object either on the map or in the course objects list.
4. The course object is inserted at the position of the blue horizontal insertion line in the Course Object Box. Click

the correct position in the course (so that the line gets moved) before adding the course object.

You can add a Start, a Finish, Controls or a Marked Route to the course, as well as some special objects (e.g.
relay variations or Text Blocks) listed on the Insert Course Object page.

Insert Course Objects to Courses
With this function a course object (start, control, marked route, finish, mandatory crossing point, mandatory passage
or map exchange) can be inserted to multiple courses at a specified position.
1. Choose the Insert Course Objects to Courses command in the Course Setting menu.
2. The Insert Course Object dialog appears.

3. Choose an object to be inserted: Course Object from Map (select it in the dropdown list), Mandatory Crossing
Point(s), Mandatory Passage Through Out of Bounds Area or a Map Exchange.

4. Select the courses which the course object is to be inserted in the To Courses field. Select multiple courses by
holding the Ctrl key or by clicking the Select all button.

5. Define a condition. Choose between After, Before or Between and select the course objects in the drop down
lists.

6. Click the OK button when finished.
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Back to the Course Setting for Orienteering page.

Delete Course Object from Courses
   

(This function is only available in course setting projects!)

This is the inverse function of the Insert Course Object to Courses function.
With this function a course object (start, control, marked route, finish, mandatory crossing point, mandatory passage
or map exchange) can be deleted from multiple courses at a specified position.
1. Choose the Delete Course Objects from Courses command in the Course Setting menu.
2. The Delete Course Object from Courses dialog appears.

3. Choose an object to be deleted: Course Object from Map (select it in the dropdown list), Mandatory Crossing
Point(s), Mandatory Passage Through Out of Bounds Area or a Map Exchange.

4. Select the courses which the course object is to be removed from in the From Courses field. Select multiple
courses by holding the Ctrl key or by clicking the Select all button.

5. Define a condition. Choose between After, Before, Between or All and select the course objects in the drop
down lists.

6. Click the OK button when finished.

Back to the Course Setting for Orienteering page.
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Make Graphic Modifications
   

(This function is only available in course setting projects!)

Often it is necessary to make graphic modifications to the courses generated by OCAD because for example a course
object covers important map information. The common modifications made for the different courses are stored in the
course setting file.

Cut out Control Circles
If a control circle covers a map detail like a knoll, a part of the control circle should be cut out to make the knoll
visible. You need to make this cut-out only once. It will be visible for all courses that use this control.
1. Switch off the Preview mode.
2.2. Select the desired control.

3. Select the  Cut tool to cut out a part of the control circle.
 To close (repair) a cut, select the Cut tool and click into the gap.
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Modify Connection Lines and Moving Control Numbers
You can modify connection lines and move control numbers of a specific course.
1. Select the desired course in the Course Object Box on the right side of the window.
2. Make sure that you are in the Preview mode.
3.3. Select the desired control number or connection line.
Then:
•• Move the control number by dragging the small square to the desired position.

• Cut out a part of the connection line using the  Cut tool and dragging the mouse from the beginning to the the
end of the part that sould be cut out.

• Insert additional vertices into the connection line using the  Add Normal Vertex tool. Move these vertices
using the  Select Object and Edit Vertex tool.
 Use the Move Control Number for All Courses or the Edit Connection Line for All Courses functions to

modify course objects with an effect on all courses.

Make Other Modifications
To make further modifications choose Export Course Maps from the Export submenu in the Course Setting
menu.

Back to the Course Setting for Orienteering page.

Edit Text Control Description
   

(This function is only available in course setting projects!)

Choose the Edit Text Control Description command in the Course Setting menu to edit the text control
description. The Edit Text Control Description dialog appears:

You can write to each control a user defined text in the orange colored column. To copy the automatic text to the 
user defined text column use the corresponding button at the bottom of the dialog. Only the text in the User defined 
text column will appear in the text control description. The automatic text is generated according to the symbol
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names. To rename a symbol click the corresponding symbol with the right mouse button in the symbol box and
choose the Edit command in the context menu. Enter a new name in the Symbol description field of the dialog.

 Note that when you use the Copy automatic text to user defined text column button, all user defined text gets
overwritten with the automatic text. Make sure to copy the automatic text to the user defined column before you edit
the text by hand.

 Instead of defining the Control Description Symbols for each Control by yourself, use the Auto Control
Description

Click the OK button when finished.

To add a text control description to your course choose the  Control Description symbol and place it on the
map. Enter a code in the Course Object dialog and click the OK button. The upper right corner of the control
description is indicated with a hook. In the Course Object Box on the right side of the window you have the option
to change the Control description type from symbol to text.
The text symbol description can also be edited in the Course Object Box. Visit the Edit Course Setting Objects
page for more information.

Back to the Course Setting for Orienteering page.

Auto Control Description
   

(This function is only available in course setting projects!)

Automatic Control Description is a tool to support course setters with a semi-automatic identification of the
control feature. The course setting project and the map need to have the same scale and the same offset.

Activate the Auto Control Description
1. Choose the Automatic Control Descriptions command in the Course Setting menu. The Automatic Control

Descriptions dialog box is displayed.
2. Activate the Use automatic control descriptions option.
3. An .ocd or .eocd-Background Map must be chosen. The Automatic Control Descriptions tool does not work

with raster background maps.
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Allocation Table
Click the Allocation Table button in the Automatic Control Descriptions dialog to display the allocation table. In
the allocation table the relationship between the map symbols and the control description symbols are defined. The
allocation table must be adapted if the background map was not drawn with an actual ISOM compatible symbol set.
The allocation table contains nine columns:
• Map Symbol: The symbol numbers of the map symbols are listed here.
• Control Description, Symbol 1-6: This column contains the numbers of the symbols of the currently opened

course setting file which match to the map symbols. You can allocate up to six different symbols. When you set a
control later you can switch between these symbols using the Tab key. If you do not want to allocate a symbol
number for a column, enter 0.000.

• Mouse Event, Drag Direction: This column defines the symbol which is used for the location of the control flag
when you drag the mouse pointer in a direction after placing a control. The allowed inputs for this column are:

 None  Side  Edge  Part  CornerInside  CornerOutside  Tip  End  PartUpperLower  Top  Beneath  Foot  Footside  Between

The corresponding symbol is taken when you drag the mouse pointer in the direction which the control flag
stands (Location of the Control Flag part in the IOF Symbol Control Description).

• Mouse Event, Click: This column defines the symbol which is used for the location of the control flag when you
place the control by a simple click. The allowed inputs for this column are:

 None  Beneath  Between  Top  Foot  

The corresponding symbol is taken when you place a control by a simple click (Location of the Control Flag
part in the IOF Symbol Control Description).

Course Setting with Auto Control Description
1. Activate the Auto Control Description.
2.2. Place a control on the map.
3. The Course Object Dialog Box appears with an additional part for the IOF Symbol Control Description.

• If the control was placed by clicking exactly on an OCAD object, OCAD will identify the control feature and
add the corresponding symbol to the control description. If more than one symbol is defined for this feature in
the allocation table you can switch between them by pressing the Tab key.

•• If the control is placed exactly on an OCAD object by pressing the left mouse button and dragging in a defined
direction, OCAD will identify the control feature and additionally recognize the location of the control in
relation to the feature.

If the object is a contour line OCAD, sets a hill in the control description by default. But there is a way to bring
OCAD to add the hill, depression, re-entrant or spur symbol directly to the control description: When placing a
control at one of these features drag the mouse in one of the four main directions:

Up = hill
Down = depression
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Left = re-entrant
Right = spur

Use Auto Control Description for Text Control Description
Choose the Edit Text Control Description command in the Course Setting menu to transfer the Automatic
Generated Control Description into text.

Back to the Course Setting for Orienteering page.

Punching Unit IDs
   

(This function is only available in course setting projects!)

Choose the Punching Unit IDs command in the Course Setting menu to enter the punching unit IDs. The Punching
Unit IDs dialog appears.
Punching unit IDs are often used for Emit result systems. OCAD exports the punching unit IDs in IOF XML file
version 2 and 3.

After placing a control you can add the electrical ID of the Emit punching unit to it or, if there is more than one unit
at the same control, all the IDs which refer to this control. The ID of an Emit unit is often different from the code
shown in the control description.
Select a field in the Punching Unit IDs column and double click an ID in the list on the right side of the table to add
it. The ID can also be typed directly into the field. Per control code more than one punching unit IDs can be
allocated. They are separated by a semicolon (;).
Choose a punching system in the Punching system dropdown list. You can choose between SportIdent, Emit and
Other.
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In the Add default punching unit IDs-part of the dialog you can add the already existing codes of the controls to
the punching unit IDs. You have three options:
•• Choose the first option to add the existing control codes only to controls, which does not have a punching unit ID,

yet.
•• Choose the second option to add all existing control codes and replace the existing punching unit IDs.
•• Choose the third option to add all existing control codes without replacing the existing punching unit IDs.
Click the Add button to execute the chosen action.

Back to the Course Setting for Orienteering page.

Course Statistic and Event Statistic
   

(This function is only available in course setting projects!)

Choose this command from the Course Setting menu to see several course and event statistics. Before using this
command you must enter the estimated number of runners for each course, otherwise you will not get the full
functionality. Select Classes in the Course Setting menu to get to the Classes dialog box where you can enter this
number.
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Course Statistics
In this part of the dialog a table is shown with all course objects listed, the number of courses which use it and the
number of runners which will visit it. When you select a course object, you can see which courses and which classes
contain it in the two boxes on the right side.

Leg Statistics
Leg statistics includes only normal courses.

In this part of the dialog a table is shown with all legs listed and the number of courses which contain it. Select a leg
to see all courses containing it in the box on the right side.
Activate Hide legs used in one course only to see only legs which are used in more than one courses.

Event Statistics
The following information can be found in this part of the dialog:
•• Number of controls
•• Number of courses
•• Number of classes
•• Shortest distances between controls: All controls with a distance less than 60m (resp. 30m for sprint races) to each

other are listed here.
Competition Rules for IOF Foot Orienteering Events 2019: [1] 19.4 Controls (including the start control flag) shall
not be sited within 30 metres of each other (25 metres for map scales 1:5000 or 1:4000 or 1:3000). The distance
between the controls is measured in a straight line.

•• Legs between 2 controls in opposite direction: All legs which are used in two directions are listed here.
•• Identical courses: All identical courses are listed here.
•• Courses without start or finish: All courses with missing start or finish are listed here.

Control/Course diagram
A table is displayed in this part of the dialog. You can read out of this diagram which control is used in which course
at which position.

Export
Click the Export button to export the course statistic to a text file.

Back to the Course Setting for Orienteering page.

References
[1] https:/ / orienteering. sport/ orienteering/ competition-rules/
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Course Setting Consistency Check Report
   

(This function is only available in course setting projects!)

This dialog shows a html formatted report about the course setting Consistency Check.
Use the Print button to print the dialog content or the Save as button to save the content as a html file.

Missing Course Item(s)
This section lists missing start or finish items in a course or if no climb is set.

 The climb is not checked for relay courses.

Identical Courses
All identical courses are listed here.

Shortest Distances Between Controls
All controls that are closer than 30m (25m for sprint races) to each other are listed here.
Competition Rules for IOF Foot Orienteering Events 2019: [1] 19.4 Controls (including the start control flag) shall
not be sited within 30 metres of each other (25 metres for map scales 1:5000 or 1:4000 or 1:3000). The distance
between the controls is measured in a straight line.

Unused Control
This section lists controls that are not used in any course.

Control Description Shortcoming(s)
This section lists shortcomings in the control description:
•• No symbol defined in column D
•• No symbol defined in column D and E although "crossing/intersection", "junction" is chosen in column F
•• No symbol defined in column D and E although "between" is chosen in column G
•• No "crossing/intersection", "junction" or "between" chosen although symbols are defined in column D and E

Opposite Direction Legs
This section lists legs that are used in the opposite direction by different course

 Opposite direction legs are not checked for relay courses.

Back to the Course Setting for Orienteering page.
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Print Courses
   

(This function is only available in course setting projects!)

Choose the Courses command in the Print submenu of the Course Setting menu to print courses.
The Print Courses box appears on the right side of the screen. Adjust the settings which can be made in the Printer,
Page handling, Scale and Options part with help of the Printing Maps page. The differences of the Print Courses
to the Print box are that there is no Color field but in addition a Select Courses/Classes field. The Print map size
field has the extra option Course only on already printed map.

Print Course Only
Choose the Course only on already printed map option from the Print map size part of the Print Courses box.

Click the  Setup button.
The Course Only dialog appears:

Adjust bottom left corner of the print range:
• Intervall: Set the interval step for 1 click on an adjustment button (Left, Up, Right, Down).
• Left, Up, Right, Down: Click on the adjustment buttons Left, Up, Right or Down to adjust the print range in

relation to the map. The left/right and up/down adjustment is displayed on the left side of the dialog box, in the
Adjustment part.

• Horizontal Scaling, Vertical Scaling: Enter here a scaling to adjust the course to an already printed map.
Normally you will need here only very small corrections (99...101%) caused by the shrinking of the paper.

• Print black: Activate this option if the courses should be printed in black. Use this setting for making printing
films.

• Mirror: Activate this option if the courses should be mirrored. This is used for making printing films on laser or
inkjet printers.
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Select Courses/Classes
Choose wheter you want to select Courses or Classes. Select all courses/classes to be printed. Select several
courses/classes by holding the Ctrl key or all courses/classes by clicking the All button.

Print Relay Courses
Relay courses normally have variations. The start number and the leg number define the course for a specific runner.
You can anytime reprint the course for a specific runner under the condition that nothing in the variations has been
changed.
Read the Print a Relay Course article for more information.

Back to the Course Setting for Orienteering page.

Print Control Descriptions
   

(This function is only available in course setting projects!)

Choose the Control Descriptions command in the Print submenu of the Course Setting menu to print the control
descriptions. The Print Control Descriptions dialog box is displayed.

Make the following adjustments:
Printer
Select the printer to print the control description. In the box you can select one of the installed Windows printer
drivers. Click the Properties button to change printing options (for instance to print in landscape mode).
Print

• Control descriptions: Select this radio button to print the symbolic control descriptions.
• Text control descriptions: Select this option to print the control descriptions as text. A text must be defined for

each control (Edit Text Control Description).
Box size
Enter the size of the symbol boxes for the symbolic controls descriptions. Click the Standard button to set this value
to 6 mm.
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Copies
Enter the number of copies to be printed.

 If you enter more than 1 copy, OCAD will fill entire pages with the same course until the number of copies is
reached. Therefore if you enter "2" you will get one page per course filled with as many control descriptions as
possible of that course.
Select Courses/Classes
Choose wheter you want to select Courses or Classes. Select all courses/classes which the control descriptions are to
be printed. Select several courses/classes by holding the Ctrl key or all courses/classes by clicking the All button.

 You can enter the title for the control descriptions in the Course Setting Options dialog box.

Export Control Description in PDF File
In Windows 10 it is possible to export the control description in a pdf file without installing additional software like
FreePdf [1] or Adobe Acrobat [2].

Choose the Microsoft Print to PDF.
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Back to the Course Setting for Orienteering page.

References
[1] http:/ / freepdfxp. de/ index_de. html
[2] http:/ / www. acrobat. adobe. com/ Acrobat_DC
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Course Setting Import
   

(This function is only available in course setting projects!)

Import an OCAD Map
It is possible to import an OCAD map in a course setting project.
1. Choose the Import command from the File menu.
2. Select an OCAD map in the browser and click the Open button.
3. The Import OCAD Map dialog appears. Read the Import OCAD Map article if you do not know how to deal

with this dialog.
4. Click the OK button to finish.
Use this function for example to import ski or bike orienteering maps, where control circles and connection lines are
not printed over all map objects.

Import Courses from ORware
With this function course definitions exported as *.txt or *.csv file from the event software ORware [1] can be
imported to an OCAD course setting project. This import is primarily thought for events where the runners from a
class have individual courses (butterflies, loops etc.). The import creates one course per runner with it's individual
course definition.
The course setting objects (start, controls, finish etc.) have to be added to the course setting project before starting
with the import.
File Structure

[TYPE];[IDENT];[CLASS];[COMBINATION];[LENGTH];[CLIMB];[START];[CTRL1]; … ;[CTRLn];[FINISH]
•• [TYPE]: Course type (individual race or relay)
•• [IDENT]: Course identification. Example: M21-17 (course name and startnumber)
•• [CLASS]: Class name
•• [COMBINATION]: Variation code. Example: BCCA
•• [LENGTH]: Course length
•• [CLIMB]: Course climb
•• [START]: Start code
•• [CTRL1] ... [CTRLn]: Control 1 - n codes
•• [FINISH]: Finish code
File Example

[TYPE];[IDENT];[CLASS];[COMBINATION];[LENGTH];[CLIMB];[START];[CTRL1]; … ;[CTRLn];[FINISH];
Individual race;M20-1;M20;AA;3700;50;L1;31;33;34;36;M1
Individual race;M20-2;M20;AB;3700;50;L1;31;33;35;36;M1
Individual race;M20-3;M20;BA;3700;50;L1;32;33;34;36;M1
Individual race;M20-4;M20;BB;3700;50;L1;32;33;35;36;M1

 The header line has to be included into the *.txt or *.csv file. 
 [TYPE] column is not used in OCAD 2019. All imported courses are treated as individual courses. 
 Marked routes are imported as controls. Do not add them to the *.txt or *.csv file. Add marked routes to the 

courses with Insert Course Object to Courses function. 
 Map changes cannot be imported. Add map exchanges to the courses with Insert Course Object to Courses
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function.

IOF XML Import
Choose this function to import a XML file with course data, e.g. Eventor xml files with the same categories as in
Eventor.

Choose if you want to import Course object (start, controls, finish), Courses and/or Classes.

Back to the Course Setting for Orienteering page.
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Course Setting Export
   

(This function is only available in course setting projects!)

In the Export submenu of the Course Setting menu you have different options for an export.

Export Courses XML
Choose this command to export a XML file with the course data. OCAD supports the IOF Version 2.0.3 and 3.0.
The exported XML file is opened automatically. The IOFdata.dtd file also belongs to the XML file. This document
type definition file specifies the structure of the XML document.
The exported XML file can be read from several event softwares.

Export Courses Text
1.1. Choose this command to export a list of control numbers of the courses or classes in text file.
2. The dialog box Export Courses (Text) appears.
3. Choose wheter you want to export Courses or Classes
4. Check the Export climbing option when climbing shall be exported, too.
5. Check the Export number of controls option to export also the number of controls.
Format of the exported file:
1. The class name as entered in the Classes dialog box or the Course Name.
2. Length of the course in km (calculated length plus extra length entered in the Courses dialog box).
3. Climb of the course as entered in the Courses dialog box.
4.4. Number of controls.
5. Start, all controls and finish (Relay variations are indicated in brackets)
Example:
 Normal Course      5.7      130      19      S1-117-150-107-63-93-99-97-98-64-140-52-87-132-95-116-90-47-120-115-F1

 Relay.1      3.3       85      12      S1-(71/117/118)-64-(78/140/70)-52-(-(106-132/87-56))-95-116-90-47-120-115-F1

The exported file is opened automatically in a text editor.
 When you export Relay Courses each leg is exported individually.
 There is no option to choose courses or classes when Create classes automatically in the Classes dialog is

choosen.

Export Classes Version 8 Text
Choose this command to export a list of the control numbers of the classes.
The exported file can then be imported in several event softwares.
After choosing this command the Export Classes (Version 8) dialog box appears where you can choose a path and
enter the file name for the class file.
Format of the exported file The exported file is a text file. For normal courses there is one line per class, for relay
courses and one-man relay courses there is one line per runner (the range of start numbers must have been defined in
the Classes dialog box). The fields are separated with semicolons (;) and contain the following information:
1. Class name as entered in the Classes dialog box. If classes are created automatically, this field is empty.
2.2. Course name.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:Mas40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Ori40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Sta40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:CS40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
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3.3. Start number.
•• for normal courses this number is "0".
•• for relay courses this is the start number of the team, a point and the number of the leg-runner (e.g. "101.1")
•• for one-man relay courses this is the start number (e.g. "201")

4. Length of the course in km (calculated length plus extra length entered in the Course dialog box).
5. Climbing of the course as entered in the Courses dialog box.
6. All controls, starting with the start, then the controls and finally the finish. Between the controls the distance
to the next control is indicated.

Example:

 M16;Normal 

Course;0;5.700;130;S1;0.219;117;0.412;150;0.502;107;0.155;63;0.113;93;0.176;99;0.183;97;0.488;98;0.659;64;0.661;140;0.191;52;0.198;87;0.391;132;0.249;95;0.098;116;0.152;90;0.179;47;0.216;120;0.280;115;0.229;F1

 

Relay;Relay;1.1;3.300;205;S1;0.185;71;0.351;64;0.661;140;0.191;52;0.225;106;0.286;132;0.249;95;0.098;116;0.152;90;0.179;47;0.216;120;0.280;115;0.229;F1

 

Relay;Relay;1.2;3.400;205;S1;0.219;117;0.246;64;0.733;70;0.207;52;0.198;87;0.341;56;0.281;95;0.098;116;0.152;90;0.179;47;0.216;120;0.280;115;0.229;F1

 

Relay;Relay;1.3;3.400;205;S1;0.287;118;0.360;64;0.596;78;0.303;52;0.225;106;0.229;56;0.281;95;0.098;116;0.152;90;0.179;47;0.216;120;0.280;115;0.229;F1

The exported file is opened automatically in a text editor.

 Classes have to be defined to use this function. Otherwise, an error message will appear.

Export Courses GPX
Choose this command to export courses to a GPX-File. Relay Courses and One-Man Relay Courses cannot be
exported to a GPX-File.
All course setting objects (start, controls, finish) are exported as waypoints. All courses, including start, controls,
marked routes and finish are exported as tracks.

 This command needs real world coordinates and a coordinate system. Choose the Set Scale and Coordinate
System command from the Map menu to change these settings.

 To open the exported file choose the Recently Exported Documents command from the File menu.

Export Courses KMZ
Use this command to export your courses in KMZ format and watch them later in Google Earth. KMZ files can
contain both vector and raster objects in the same file. For its reference system, KML uses WGS84.
• Choose the Courses (KMZ) command from the Export submenu of the Course Setting menu.
• Select the desired extend and click on Export.
• Select which courses/classes shall be exported. Select multiple courses/classes by holding the Ctrl key or click

the Select all button to select all courses/classes. All courses/classes will be saved in the same KMZ file.
Click on the exported KMZ file. Google Earth will start automatically. You will find a folder for each course in your
temporary places with the course maps and all controls. A PNG file will be created for each course. The controls will
be displayed by placemarks.

 Your map has to be georeferenced and a coordinate system has to be set before the export. Naturally, Google 
Earth has to be installed on your device to opend the KMZ file. 

 Some Course Setting options are not supported, e.g. Map Change. 
 There are many further options for visualisation in Google Earth like Recording & Playing Tours or the Opacity

https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=Map%23Set_Scale_and_Coordinate_System
https://www.ocad.com/wiki/ocad/en/index.php?title=Map%23Set_Scale_and_Coordinate_System
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=File%23Open_Recently_Exported_Documents
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
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Slider. Check the Google Earth Help for futher information.

Export Course Statistic and Event Statistic
Use this command to export course, leg and event statistics to a text file. The text file contains the same information
as in the Course Statistic and Event Statistic dialog. This export is also available via the Course Statistic and
Event Statistic command in the Course Setting menu.

Export Course Maps
Use this command to Make Graphic Modifications to courses that are not possible within the course setting
project. The common modifications like moving the control numbers or modifying the connection lines are possible
without using this command. Visit the Make Graphic Modifications page for more information.
A course map file is a normal OCAD-File and not a course setting file. The Background Map will be the same as in
the course setting file. All symbols used for course setting are imported in the symbol set. Opening course maps is
also possible in the OCAD Course Setting edition. However, this works only for course maps, which were exported
from an OCAD Course Setting edition. However the functions for editing a course map in OCAD Course Setting
edition are restricted since not all editing tools are available in this edition.
Using this command may be dangerous. If you make modifications to the courses after exporting the course maps,
the exported course maps are not updated and are therefore not correct. Use this command only if you are absolutely
sure that the courses are final.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:Export_Courses_KMZ.PNG
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1. Choose the Course Maps command from the Export submenu of the Course Setting menu.
2. The Select Courses/Classes dialog appears.
3. Select wheter you want to export Courses or Classes.
4. Select all courses/classes to be exported. Select multiple courses/classes by holding the Ctrl key or click the

Select all button to select all courses/classes.
5. If multiple courses/classes are selected they are exported in different files unless you check the Export courses

to one file option. Choose wheter you want to place the courses beside each other, below each other or at the
original position.

6. Click the OK button when finished.
Option: Place courses beside each other

https://www.ocad.com/wiki/ocad/en/index.php?title=File:ExportCourseMaps.png
https://www.ocad.com/wiki/ocad/en/index.php?title=File:ExportCourseMapsPlaceCoursesBesideEachOther.png
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Option: Place courses below each other

Option: Place courses at original position

 There is no option to choose courses or classes when Create classes automatically in the Classes dialog is
choosen.

 If you want to export Relay Courses or One-Man Relay Courses, you will have to define which
legs/variations/start numbers you want to export. This dialog is the same as the dialog in the Export a Relay Course
article. Read this article for more information.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:ExportCourseMapsPlaceCoursesBelowEachOther.png
https://www.ocad.com/wiki/ocad/en/index.php?title=File:ExportCourseMapsPlaceCoursesAtOriginalPosition.png
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=Create_Relay_Courses%23Export_a_Relay_Course
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Export Control Descriptions
Available since Version 19, Build 2708.
Use this command to export control descriptions as .ocd files. After the export, the files can be edited.
1. Choose the Export Control Description command from the Export submenu of the Course Setting menu.

2. Choose which Courses/Classes you want to export.

3. Adjust Settings if needed.
4. Click the OK button.
A new file, named xxx.ControlDescriptions.xxx, will be created. Save the file.
Open the exported file (File->Recently Exported Documents).

https://www.ocad.com/wiki/ocad/en/index.php?title=File:ExportControlDescriptions1.png
https://www.ocad.com/wiki/ocad/en/index.php?title=File:ExportControlDescriptions2.png
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 Note: This function does not support relay or one-man-relay courses.

Merge Exported Files
The function Export Control Descriptions was originally developed for multi days orienteering events, to give the
runners an A4 page with the control description of all their stages.
How it works:
Export Control Descriptions

1.1. Export the Control Description from stage 1 as explained above.
•• Choose all classes.
•• Control description type: Symbol.
•• Placing: Below each other.
•• Box Size: Use 5.00 mm to get 6 stages on an A4 paper.
•• Horizontal distance between control description: Use 350 mm. Because not all Control Descriptions have

space together a new 'column' begins after approx. 10 classes. 350 mm is slightly larger than A4 landscape.
2.2. Export also the Control Description of all other stages as explained above. Each stage will give you one .ocd file.
Merge exported files

1.1. Open the .ocd file from the first stage.
2. Import the file from your second stage (File-> Import).

•• Position: Place with offset. Add 48mm for each stage (Stage 2=48mm, stage 3=96mm, ...).
•• Symbols: Import symbols only if symbol number does not exist.

3.3. Repeat the steps above for all stages.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:ExportControlDescriptions3.png
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
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Now you can print for every class the control description from all stages (or export as PDF).

https://www.ocad.com/wiki/ocad/en/index.php?title=File:ExportControlDescriptions5.png
https://www.ocad.com/wiki/ocad/en/index.php?title=File:ExportControlDescriptions4.png
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Export Control Description Text
Use this command to export control descriptions as text files. Control descriptions for Relay Courses and One-Man
Relay Courses cannot be exported.
1. Choose the Export Control Description (Text) command from the Export submenu of the Course Setting

menu.
2. The Select Courses/Classes dialog appears.
3. Select wheter you want to export control descriptions of Courses or Classes.
4. Select all courses/classes the control description is to be exported. Select multiple courses/classes by holding the

Ctrl key or click the Select all button to select all courses/classes.
5.5. If multiple courses/classes are selected they are exported in the same file beneath eachother.
6. Click the OK button when finished.

 A Text Control Description has to be defined to get an useful output of this function.
 There is no option to choose courses or classes when Create classes automatically in the Classes dialog is

choosen.
Example Output:

 Chlosterwald Orienteering Event

 Class M20

 Course A,  Length 3.3 km, Climb 205 m

 Start      Path, Path, Junction

 1.      71      Small depression

 2.      64      River, Watercourse, Junction

 3.      78      Pit

 4.      52      Erosion gully, Southwest end, Radio control

 5.      106      Small erosion gully, South end

 6.      132      Knoll, South side

 7.      95      Re-entrant

 8.      116      Copse, West side, TV control

 9.      90      Boulder, 2.0m, North side

 10.      47      Knoll, Northwest side

 11.      120      Spur, Southeastern foot

 12.      115      Re-entrant

 Follow taped route 230 m from last control to finish

https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
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Export Course Scheme
1. Choose the Export Course Scheme command in the Export submenu of the Course Setting menu.
2. Select from which Courses/Classes you want to export the course scheme and click on OK.
3. The Course Scheme will be exported in a new .ocd-File. You can now Import this file into your course setting

project.

  The Course Scheme will be exported vertically. If you need the Course Scheme
horizontally, do the following:
•• Select all object of the Course Scheme.
• Rotate the objects by 90° (Object>Rotate Object>Rotate (Enter Angle)).
• Again select all object of the Course Scheme and go to Object>Indicate Direction of Area Pattern, Point or

Text Object. Click once into the drawing area.
•• Adjust the Course Scheme manually.

Export Relay Variations
1. Choose the Export Relay Variations command in the Export submenu of the Course Setting menu.
2. The Export Relay Variations dialog appears.
3.3. Browse a location and enter a name for the file to export.
4. Click the Save button to export the TXT-file.
The Text-File contains all courses. The start numbers are listed with the corresponding variation.
Learn more about relays on the Create Relay Courses page.

Back to the Course Setting for Orienteering page.

https://www.ocad.com/wiki/ocad/en/index.php?title=Import_Files%23Import_OCAD_Map
https://www.ocad.com/wiki/ocad/en/index.php?title=File:ExportCourseScheme1.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=File:ExportCourseScheme2.PNG
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Course Setting Options
   

(This function is only available in course setting projects!)

Choose the Options command from the Course Setting menu to display the Course Options dialog box.

Titles

Event Title

Enter the name of the event. The event title appears on top of the control description.

Course Title

Choose wheter the Course Title shall be displayed with the Classes, the Course Name and Classes or the Course
Name only.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:Pro40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Std40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Sta40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:CS40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:CourseOptions.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=Add_Course_Setting_Objects%23Add_a_Course_Title
https://www.ocad.com/wiki/ocad/en/index.php?title=File:CourseTitleHelp.PNG
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Controls

Numbering

Choose wheter the controls shall be numbered with the Number, the Number and Code or the Code only.

Distance from Circle to Number

Enter the default distance from the control circle to the number in mm.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:NumberingHelp.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:DistanceFromCircleToNumberHelp.PNG
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Full Stop Behind Control Number

Check this option if a full stop shall be placed behind each control number.

White Outline on Control Number

This function is only available for ISSOM 2007 and ISOM 2017 course setting projects. Activate this funktion to add
white background to your control numbers for better visability.

 Be careful not to cover any important map information with the white background.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:FullStopHelp.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=File:WhiteOutlineControlNumber.PNG
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Connection Lines
Define a distance from the circle to the connection line in this field.

Control Description

Thicker Horizontal Line

Choose between a thicker horizontal line in the IOF Symbol Control Description every third or every fourth line or
not at all.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:DistanceFromCircleHelp.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=Edit_Course_Setting_Objects%23IOF_Symbol_Control_Description
https://www.ocad.com/wiki/ocad/en/index.php?title=File:ThickerHorizontalLineHelp.PNG
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Maximum Length

Define the maximum length of the control description in rows in this field.

Number of Start

Check this option so that the number of the start appears in the control description.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:MaximumLengthHelp.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:NumberOfStartHelp.PNG
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Control Description on the Map

Box Size

Define the size of a box in the control description in this field. Click the Standard button to set the value to 6.00
mm.

 IOF International Specification for Control Description 2004 [1]: The description sheet boxes should be between
5mm and 7mm.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:BoxSizeHelp.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
http://orienteering.org/wp-content/uploads/2010/12/IOF-Control-Descriptions-20041.pdf
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White Background

Check this option to get a white background behind the control description on the map.

Check the Draw white background even in draft mode option to show the control description with white
background also in draft mode. Use this option if you prefer to print your maps in draft mode.
Activate the option, switch to draft mode and move both draft mode sliders in the View toolbar to the right position.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:WhiteBackgroundHelp.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:DraftModeSliders.png
https://www.ocad.com/wiki/ocad/en/index.php?title=File:DraftModeSliders.png
https://www.ocad.com/wiki/ocad/en/index.php?title=File:ControlDescriptionBlockout.png
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Select a course and click the Preview button. The course overprint now is transparent, but the white background of
the control description is opaque and blocks out the orienteering map.
OCAD does not block out only the control description. Furthermore, OCAD blocks out all objects drawn with this
opaque color used in the symbol 760.00 White background. By default it is the color number 203 White
background.

Example: If you also like a framing of the control numbers in draft mode, select the symbol 703.000 Course:
Control number, edit the symbol and change the color from 204 Purple transparent to 202 Purple. Click on the
Framing tab, enter the new Line width (0.2mm) and change the Framing color to the opaque color 203 White
background.

Close this dialog. The control numbers have now a white framing.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:ControlNumberFraming.png
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Add Control Descriptions for All Controls

Check this option to add the control description on the All Controls map, too.

XML Export
Activate this check box to export the relay variation within the XML export, too. This is an extension of the IOF
specification.

Continuous Numbering
If the option is set, the numbering for one-man relay will be continuous on the maps for the 2nd and 3rd loop.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:AddControlDescriptionHelp.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:CsOptionsOneManRelayContinuousNumberingExample.png
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Back to the Course Setting for Orienteering page.

References
[1] http:/ / orienteering. org/ wp-content/ uploads/ 2010/ 12/ IOF-Control-Descriptions-20041. pdf

http://orienteering.org/wp-content/uploads/2010/12/IOF-Control-Descriptions-20041.pdf
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Tutorials

Using Airborne Laserscanning Data for
Orienteering Base Map Generation
This tutorial shows a possible way to proceed LiDAR data in OCAD and how to use them when drawing
orienteering maps.
In case you have access to LiDAR Data, we can highly recommend you working with it. As you will find out,
working with LiDAR Data makes mapping easier, more accurate and faster.

 Short videos as a starter:
- Learn how to create different kinds of contours in the DEM Wizard and how to use them -> DEM Wizard -
Contours [1]

- Learn how to use the output of the DEM Wizard for vegetation mapping -> DEM Wizard - Vegetation [2]

Open New File
Open OCAD.

Las files are very large and the calculating needs a lot of memory (RAM). Because of that it is
recommended to import the Las files with the 64-bit Version of OCAD.

Go to File -> New -> Orienteering map: Choose a symbol set for orienteering maps and choose the scale (e.g
Orienteering Map ISOM 2017 10000.ocd).
Save the newly created file under File -> Save.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
https://www.youtube.com/watch?v=yoPRylY_Scs
https://www.youtube.com/watch?v=nogycUy1Ixk
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DEM Wizard

Open the DEM Wizard
Open the DEM Import Wizard in the DEM Menu.
You find more detailed information about the DEM Wizward here.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:DEMImportWizrad.png
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Choose DEM Import File
Choose one or several importable files. In this tutorial we proceed a LAS-file.
Find more Information about this step here.

DEM Settings
Here you can choose your favourite folder (in the upper right corner under File name) where all files should be
stored .
In this tutorial, we have a look at all possible outputs. However, not all of them make sense for mapping as we
discuss later in the section How to use the output. Enter the DEM Settings as follows.
Find more Information about this step here.

https://www.ocad.com/wiki/ocad/en/index.php?title=DEM_Import_Wizard%23DEM_Import_Data
https://www.ocad.com/wiki/ocad/en/index.php?title=DEM_Import_Wizard%23Start_Import_DEM_Wizard
https://www.ocad.com/wiki/ocad/en/index.php?title=File:DEMImportFiles.png
https://www.ocad.com/wiki/ocad/en/index.php?title=Using_Airborne_Laserscanning_Data_for_Orienteering_Base_Map_Generation%23How_to_use_the_output.3F
https://www.ocad.com/wiki/ocad/en/index.php?title=DEM_Import_Wizard%23Settings
https://www.ocad.com/wiki/ocad/en/index.php?title=DEM_Import_Wizard%23Settings
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https://www.ocad.com/wiki/ocad/en/index.php?title=File:DEMSettings.png


Using Airborne Laserscanning Data for Orienteering Base Map Generation 601

LAS Settings
Select the LAS Settings as follows.
We will need the .ocdlas-File later in the LiDAR Point Cloud Manager section.
Find more information about this step here.

https://www.ocad.com/wiki/ocad/en/index.php?title=DEM_Import_Wizard%23LAS_Settings
https://www.ocad.com/wiki/ocad/en/index.php?title=Using_Airborne_Laserscanning_Data_for_Orienteering_Base_Map_Generation%23LiDAR_Point_Cloud_Manager
https://www.ocad.com/wiki/ocad/en/index.php?title=DEM_Import_Wizard%23LAS_Settings
https://www.ocad.com/wiki/ocad/en/index.php?title=File:DEMLasSettings.png
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DSM Intensity Map

DSM Classification Map

https://www.ocad.com/wiki/ocad/en/index.php?title=File:DEMResultLasIntensity.png
https://www.ocad.com/wiki/ocad/en/index.php?title=File:DEMResultLasClassification.png
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Create Contour Lines
Select the settings to Create Contour Lines as follows.

Activate both boxes Create custom contours (no smoothing) and Create smoothed contours using TPI.
Choose as contour intervall 1m/5m/25m.
Click on Load symbols from template to get 12 line symbols at the bottom of your symbol box. The boxes
will be filled automatically.
Choose Use different symbols for depression to distinguish depressions from hills.
Find more information about this step here.

https://www.ocad.com/wiki/ocad/en/index.php?title=DEM_Import_Wizard%23Create_Contour_Lines
https://www.ocad.com/wiki/ocad/en/index.php?title=DEM_Import_Wizard%23Create_Contour_Lines
https://www.ocad.com/wiki/ocad/en/index.php?title=File:DEMContourLines.png
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Contour Lines

https://www.ocad.com/wiki/ocad/en/index.php?title=File:DEMResulatContourLines.png


Using Airborne Laserscanning Data for Orienteering Base Map Generation 605

Create Hypsometric Map
Select the settings to create a Create Hypsometric Map as follows.
Find more information about this step here.

Hypsometric Map

https://www.ocad.com/wiki/ocad/en/index.php?title=DEM_Import_Wizard%23Create_Hypsometric_Map
https://www.ocad.com/wiki/ocad/en/index.php?title=DEM_Import_Wizard%23Create_Hypsometric_Map
https://www.ocad.com/wiki/ocad/en/index.php?title=File:DEMHypsometricMap.png
https://www.ocad.com/wiki/ocad/en/index.php?title=File:DEMResultHypsometric.png
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Create Hill Shading
Select the settings for Create Hill Shading as follows.
Find more information about this step here.

Hill Shading

https://www.ocad.com/wiki/ocad/en/index.php?title=DEM_Import_Wizard%23Create_Hill_Shading
https://www.ocad.com/wiki/ocad/en/index.php?title=DEM_Import_Wizard%23Create_Hill_Shading
https://www.ocad.com/wiki/ocad/en/index.php?title=File:DEMHillShading.png
https://www.ocad.com/wiki/ocad/en/index.php?title=File:DEMResultHillShading.png


Using Airborne Laserscanning Data for Orienteering Base Map Generation 607

Create Slope Gradient
Select the settings for Calculate Slope Gradient as follows.
Check Extract cliff features from black pixels.
Find more information about this step here.

Slope Gradient

https://www.ocad.com/wiki/ocad/en/index.php?title=DEM_Import_Wizard%23Calculate_Slope_Gradient
https://www.ocad.com/wiki/ocad/en/index.php?title=DEM_Import_Wizard%23Calculate_Slope_Gradient
https://www.ocad.com/wiki/ocad/en/index.php?title=File:CalculateSlopeGradient.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:DEMResultSlopeGradient.png
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Cliff features as vector symbol (Slope Gradient Map is dimmed).

https://www.ocad.com/wiki/ocad/en/index.php?title=File:DEMResulatExtractCliffs.png
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Classify Vegetation Height
Select the settings for Classify Vegetation Height as follows.
Find more information about this step here.

Vegetation Height Map

https://www.ocad.com/wiki/ocad/en/index.php?title=DEM_Import_Wizard%23Classify_Vegetation_Height
https://www.ocad.com/wiki/ocad/en/index.php?title=DEM_Import_Wizard%23Classify_Vegetation_Height
https://www.ocad.com/wiki/ocad/en/index.php?title=File:DEMVegetationHeight.png
https://www.ocad.com/wiki/ocad/en/index.php?title=File:DEMResultVegetationHeightMap.png
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Extract Features
Select the settings to Extract Features as follows.
Find more information about this step here.

Extracted Features

https://www.ocad.com/wiki/ocad/en/index.php?title=DEM_Import_Wizard%23Extract_Features
https://www.ocad.com/wiki/ocad/en/index.php?title=DEM_Import_Wizard%23Extract_Features
https://www.ocad.com/wiki/ocad/en/index.php?title=File:DEMExtractFeatures.png
https://www.ocad.com/wiki/ocad/en/index.php?title=File:DEMResulatExtractFeatures.png
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Create Vegetation Base Map
If you checked this option in the DEM Settings, a Vegetation Base Map will be calculated with default values.
To adjust the settings, you need to run the LiDAR Point Cloud Manager.

https://www.ocad.com/wiki/ocad/en/index.php?title=DEM_Import_Wizard%23Settings
https://www.ocad.com/wiki/ocad/en/index.php?title=File:DEMVegetationBaseMap.png
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Summary
This dialog shows the progress of the different functions.
During the calculation, a message concerning georeferncing the map will pop up (unless the map is already
georefernced). Do not change anything and click on Ok. After finishing the process the dialog closes
automatically.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:DEMSummary.png
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What is the output?
After finishing the DEM Wizard the dialog closes automatically and the results are shown.
All raster maps are loaded as background maps.
Contour lines, cliff features and extracted features are assigned to the corresponing symbols in the Symbol
box.
All files are stored in the folder you can specify in the DEM Settings.

 View
after the DEM Wizard is done. Note the newly added Symbols at the end of the Symbol box on the right side.

All background maps have been loaded automatically.

https://www.ocad.com/wiki/ocad/en/index.php?title=Using_Airborne_Laserscanning_Data_for_Orienteering_Base_Map_Generation%23DEM_Settings
https://www.ocad.com/wiki/ocad/en/index.php?title=File:DEMDone.png
https://www.ocad.com/wiki/ocad/en/index.php?title=File:DEMBackgroundMaps.png
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All generated files for this example. They are stored in the folder you specified in the DEM Settings.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:DEMFiles.png
https://www.ocad.com/wiki/ocad/en/index.php?title=Using_Airborne_Laserscanning_Data_for_Orienteering_Base_Map_Generation%23DEM_Settings
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How to use the output?
As you probably noticed, not all output files and derived data are usefull. We can give you the following
recommendations:

Intensity Map and Classification Map
The Intensity map can be useful for mapping. You can see quite well Vegetation boundaries, forest tracks,
single trees and open parts in the forest.

 Example
of an Intensity map. Compared to the Vegetation Height Map, you can see well vegetation boundaries (black forest=
coniferous forest; grey forest = deciduous forest.

The Classification map is of no use for mapping.

Contour Lines
• For mapping in the terrain, use the custom contour lines as background, where you have all details on it

(provided you choose the contour interval small enough. 1m is an appropriate interval.)
• To draw contour lines on the PC, first calculate and load the TPI contours and adapt them afterwards where

needed. Use the Reshape function for adapting. Keep in mind, that these contours are smoothed and therefore not
include all details. Some valleys or ridges appear flatter than they actually are. Nevertheless, especially in steep
and constant slopes, the biggest part of the TPI contours can be adopted to your map without redrawing. You save
a lot of time with it.

•• The destinction in hills and depression is recommended, as you get a faster and better understanding of the terrain.

https://www.ocad.com/wiki/ocad/en/index.php?title=Using_Airborne_Laserscanning_Data_for_Orienteering_Base_Map_Generation%23LAS_Settings
https://www.ocad.com/wiki/ocad/en/index.php?title=File:DEMIntensityExample.png
https://www.ocad.com/wiki/ocad/en/index.php?title=Using_Airborne_Laserscanning_Data_for_Orienteering_Base_Map_Generation%23Create_Contour_Lines
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Smoothed contour lines in green, custom contor lines in blue. Orange and red ones for depressions.

Hypsometic Map
This map may be used for visualisation, but is obsolete for field work and mapping puropse.

Hill shading Map
The hill shading map can be useful to detect point and line objects like pits, paths or watercourses.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:DEMResultContour1.png
https://www.ocad.com/wiki/ocad/en/index.php?title=Using_Airborne_Laserscanning_Data_for_Orienteering_Base_Map_Generation%23Create_Hypsometric_Map
https://www.ocad.com/wiki/ocad/en/index.php?title=Using_Airborne_Laserscanning_Data_for_Orienteering_Base_Map_Generation%23Create_Hill_Shading
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 Hill
Shading Map of Bürenflue. Small pits and knoll as well as tracks and pathes are much better visible here than with
contour lines.

Slope Gradient Map
The Slope Gradient Map also shows paths or relief features like the Hill Shading Map.

 The
Slope Gradient Map shows in this example basically the same as the Hill Shading Map. However, the features of the
Hill Shading Map appear clearer and more distinct.

Please see here how use the Extracted Cliff Features.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:DEMHillShadingExample.png
https://www.ocad.com/wiki/ocad/en/index.php?title=Using_Airborne_Laserscanning_Data_for_Orienteering_Base_Map_Generation%23Create_Slope_Gradient
https://www.ocad.com/wiki/ocad/en/index.php?title=File:DEMSlopeGradientExample.png
https://www.ocad.com/wiki/ocad/en/index.php?title=Using_Airborne_Laserscanning_Data_for_Orienteering_Base_Map_Generation%23Extract_features_2
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Classify Vegetation Height
The Vegetation Height Map is an very useful background map. You cannot see Vegetation boundaries like on
the Intensity Map, but also forest tracks, single trees and open parts in the forest, especially small open parts in
dense vegeation. Furthermore it gives you information about the density of the vegeation.

 Example
of a Vegetation Height Map.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:DEMVegetationHeightExample.png
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Extract features
This function is (1) very dependend on the quality of the data and (2) the results should be treated with
caution. In terms of LiDAR data, a small knoll looks very similar to a cluster of branches, a tree stump or a
small fir tree. However, the results can give you a hint, which places you should check carefully during
fieldwork.

Extracted Trees.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:DEMResultTrees.png
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Extracted Cliff Features. As you remember, you choose the settings to Extract Cliff Features in the Slope Gradient
function, but you should interpret the results in the same way as for the other extracted features.

Vegetation Base Map
The Vegetation Base Map is a product of the LiDAR Point Cloud Manager. Compared to the Vegetation Height
Map, the Vegetation Base Map shows both low or high vegetation
As mentioned above, the Vegetation Base Map will be calculated with default values. To adjust the settings, you
need to run the LiDAR Point Cloud Manager.
With the default settings, you will for sure get a good first impression of the vegetation, but they may not work
properly for your map. However, as classifying vegetation is a big task when drawing orienteering maps, we belive
that the Vegetation Base Map will become more and more important in the future.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:DEMResultContour2.png
https://www.ocad.com/wiki/ocad/en/index.php?title=Using_Airborne_Laserscanning_Data_for_Orienteering_Base_Map_Generation%23Classify_Vegetation_Height_2
https://www.ocad.com/wiki/ocad/en/index.php?title=Using_Airborne_Laserscanning_Data_for_Orienteering_Base_Map_Generation%23Classify_Vegetation_Height_2
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Raster map generated with the LiDAR Point Cloud Manager compared with the Orienteering map of the same area.

Summary
As we could see, there are several background maps which are very useful for mapping.
How we combine and use them best?

• You can arrange you background maps is a way, that the information of several background maps are visible. In
the OCAD Menu, go to Background Map -> Manage. Here you can set your favourite background maps visible.
To see several background maps at once, make them visible and use dimming. When you print this map, all
important information are on one paper.

•• When you go mapping with a tablet PC, you can easily switch betwenn all the background maps.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:LidarPointCloudManager_Example.png
https://www.ocad.com/wiki/ocad/en/index.php?title=Background_Map%23Manage_Background_Maps
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 Example
how to combine different background maps (Intensity Map, Hill Shading and Vegetation Height Map).

References
[1] https:/ / www. youtube. com/ watch?v=yoPRylY_Scs
[2] https:/ / www. youtube. com/ watch?v=nogycUy1Ixk

https://www.ocad.com/wiki/ocad/en/index.php?title=File:DEMReadyForMapping.PNG
https://www.youtube.com/watch?v=yoPRylY_Scs
https://www.youtube.com/watch?v=nogycUy1Ixk
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Drawing Orienteering Maps in OCAD
The focus of this tutorial is how to draw an orienteering map with OCAD. It doesn’t matter if you start a new
mapping project or update an old existing map.

About OCAD

Run OCAD
OCAD Orienteering and OCAD Mapping Solution are new available as 64-bit version and 32-bit version. The
OCAD Setup installs both versions.
For normal use, the 32-bit version is sufficient. Please note, the 64-bit version isn't faster than the 32-bit version. The
big advantage of 64-bit is that OCAD can allocate more than 3 GB RAM if available on the computer. That is
important when loading huge raster background maps or DEM files.

Structure of the OCAD User Interface
The image below shows you the OCAD User Interface.

https://www.ocad.com/wiki/ocad/en/index.php?title=Technical_Data%2364-bit_Version_vs._32-bit_Version
https://www.ocad.com/wiki/ocad/en/index.php?title=File:GUI.JPG
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OCAD Help
You will find the following submenus in the Help menu.

Contents: Opens the OCAD Main Page.
Menu: Help for menu commands.
Toolbar: Help for toolbar buttons.
Tutorial: Link to the OCAD Tutorials.
What is New: See the newly added functions on this page.
OCAD Home page [1]: Opens OCAD homepage on the Internet.
OCAD Service Update: Download the current Service Update.
OCAD Tutorial Videos [2]: Connect to Learning Videos on OCAD homepage.
OCAD Youtube Channel [2]: OCAD Youtube Channel
Getting Started with OCAD: Open the PDF file 'Getting Started with OCAD'. For different languages see
here [3]

OCAD Blog [3]: Show the newest posts from the OCAD Blog.
License Transfer Utility: Opens the License Transfer Utility to deactivate your license and transfer it to
another user.
License Manager: The License Manager tool shows an overview about the OCAD licenses which are
assigned to your organization (company or association).
About OCAD: General Information about OCAD like license information and current version of OCAD.

Service Update
Regular and free updates are included in the OCAD subscription model. The Service Update corrects known bugs
and adds the latest cartography tools and enhancements to your OCAD.
Therefore we recommend using OCAD software always with the most recent Service Update to benefit from the
quality improvements.
Please download the current Service Update from the Help -> OCAD Service Update function in the OCAD
program.
The content of the Service Update is listed in the Release notes [4]. Your current version of OCAD can be seen
under About OCAD in the Help menu.

https://www.ocad.com/wiki/ocad/en/index.php?title=Main_Page
https://www.ocad.com/wiki/ocad/en/index.php?title=Graphical_User_Interface%23Menu
https://www.ocad.com/wiki/ocad/en/index.php?title=Graphical_User_Interface%23Toolbars
https://www.ocad.com/wiki/ocad/en/index.php?title=Tutorials
https://www.ocad.com/wiki/ocad/en/index.php?title=What_is_New
http://www.ocad.com/en/
https://www.ocad.com/wiki/ocad/en/index.php?title=Service_Update%23OCAD_Service_Update
http://www.ocad.com/en/support/learn-video/
https://www.youtube.com/user/ocadcom/
https://www.ocad.com/en/getting-started/
http://ocad.com/blog/
http://ocad.com/OCAD2018/OCAD_2018_Update.txt
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New Map

Start a New Map File
Before start mapping you should define which type of map you want to draw, which symbol set you want to use and
which scale the map should have. For this tutorial we want to draw an normal forest orienteering map in scale
1:10'000.
To create a new map:
1. Select New in the File menu. The New File dialog box appears.

2. Choose a map type. OCAD provides predefined symbol sets to help you begin drawing your map immediately.
Choose the symbol set Orienteering Map ISOM 2017 10000.ocd.

3. Deside in which scale the map shall be drawn. Set the scale to 1:10'000.
4.4. Choose the language of the symbol set. (only at ISOM 2017 available)
5. By clicking the OK button, OCAD creates a new map and copies the chosen symbol set to it.
Click here to learn more about this step.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:NewFile.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=Create_a_New_Map%23Create_a_New_Map
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Set Scale and Coordinate System
Select the Set Scale and Coordinate System item from the Map menu. The Set Scale and Coordinate System
dialog box appears.

Enter the Map Scale

Enter a scale and click the OK button.
 Do not use this dialog to change the scale after entering the initial values. To increase or decrease the size of the

map subsequently, use the Change Scale function in the Map menu. Setting the current scale does not enlarge or
reduce the map. It only changes a number in the map file and georeferencing will be lost.

Georeference the Map

Before loading a georeferenced Background Map, work with GPS data or import Spatial Base Data, we
recommend that you first georeference the map. Georeferencing means, that you assign space-related reference
information to objects in a spatial reference system. Shortly: A georeferenced map is assigned to a coordinate
system. You should contact your data supplier, national surveying office or cartographic institute to find out which
coordinate system will best suit your needs.
1. Choose wheter you want define Paper coordinates (in mm) or Real world coordinates. We choose Real world

coordinates for this tutorial.
2. In the Easting offset and Northing offset fields, enter the coordinate values for the center of your map.
3. The coordinate system can be rotated by entering a value in the Angle field. The "Angle" is the deviation from

the magnetic North to the coordinate system. At the moment there are 0-degree deviation in Switzerland.
4. In the Grid distance field, enter the desired distance for the Coordinate Grid lines.

 Enter the coordinate values for the center of your map in the horizontal and vertical offset fields. This is 
important since the drawing area of OCAD is limited to 4 x 4 m in the  Orienteering edition, in the  
Starter edition as well as in the  Course Setting edition and 80 x 80 m in the  OCAD Mapping

https://www.ocad.com/wiki/ocad/en/index.php?title=File:SetScaleAnd_CoordinateSystem.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=Map%23Change_Scale
https://www.ocad.com/wiki/ocad/en/index.php?title=View%23Show_Screen_Grid
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Ori40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Sta40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:CS40px.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Mas40px.PNG
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Solution. This option is used to ensure that imported Spatial Base Data, georeferenced Background Maps and
GPS measurements do not lie outside the drawing area.

Coordinate System

Click the Choose button to define a coordinate system. The Coordinate System dialog appears.

Choose the desired coordinate system. OCAD supports a lot of coordinate systems.
Click here to learn more about Scale, Coordinat System and Georeferencing.

Create the Base Map for the Field Work
Before you go mapping into the terrain, you should try to create the best possible base map. The more you invest in
your base map, the faster and more accurate your mapping will be. In OCAD you can import spatial data, old
orienteering maps, derive own base maps with LiDAR data and combine them.

Raster Base Maps
Typically, the orthophotos and topographic maps for orienteering maps are delivered as raster files. OCAD supports,
among others, the most common used raster files: JPG, TIFF and PNG.
Orthophotos and topographic maps are mostly georeferenced. Raster files are georeferenced, when the pixels are
referenced with the coordinates. Normally the georeferencing data is saved in a world file. The world file has the
same file name as the raster file, but with another file extension: JPG → JGW, TIFF → TFW, PNG → PGW.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:CoordinateSystemDialog.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=Create_a_New_Map%23Set_Scale_and_Coordinate_System
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Open Georeferenced Raster Base Map as Background Map

Click to Background Map->Open

If there's not yet a coordinate system and offset, the Background Map (Georeferenced) dialog appears and shows
the georeferencing of the selected background map.
Click OK.

Open not Georeferenced Raster Base Map as a Background Map

Click to Background Map->Open

It the seleced file is not georeferenced, you need to enter a resolution for the background map (if a raster map is
loaded) and click the OK button.

The background map is displayed at the center of the current drawing area. The raster map (background map) now
needs to be adjusted with the map (Adjust a Background Map). In other words, it needs to be referenced with the
map coordinate system.

https://www.ocad.com/wiki/ocad/en/index.php?title=Background_Map%23Use_a_Georeferenced_Raster_Map_as_Background_Map
https://www.ocad.com/wiki/ocad/en/index.php?title=Background_Map%23Use_a_Non_Georeferenced_Raster_Map_as_Background_Map
https://www.ocad.com/wiki/ocad/en/index.php?title=File:NonGeoreferencedRasterMap.png
https://www.ocad.com/wiki/ocad/en/index.php?title=Background_Map%23Adjust_a_Background_Map
https://www.ocad.com/wiki/ocad/en/index.php?title=File:AdjustBackgroundMap.gif
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 We recommend you to print the grid on the base map. Thereby you can adjust your scanned base map easier. In
the dialog File->Print select Print screen grid and choose the Grid color.

Preparation of LiDAR Data
LiDAR data is often a base for orienteering maps and highly recommended to use if available. LiDAR data is
available as a point cloud in the las/laz file format. With LiDAR data, you can easily get lot of information about the
terrain and the vegetation, which will make mapping much faster and more accurate.
For this purpose, there's an extra tutorial about Using Airborne Laserscanning Data for Orienteering Base Map
Generation. There you will learn, how to proceed LiDAR data in OCAD and how to use them when drawing
orienteering maps..

Import Vector Data
Vector data can also be used to create the base map. The advantage is that vector data contain point, line, area and
text objects which are directly converted to map objects during the import into OCAD. It saves a lot of time because
especially in urban surroundings many map objects can be created automatically instead of being digitized manually.
Governmental data is generally available as DXF or Shape files. OCAD can also import other vector data formats
like PDF, AI, SVG or OSM (Open Street Map).
1. Go to File->Import
2. Choose an importable file, e.g. a dxf-file.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=File:DEMReadyForMapping.PNG
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3. The vector data is shown as Unsymbolized objects in the drawing area. You can symbolize the objects
automatically:

Map → Convert Imported Layers to Symbols…

4.4. The map now shows all objects with the assigned symbols.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:DxfImport1.png
https://www.ocad.com/wiki/ocad/en/index.php?title=Map%23Convert_Imported_Layers_to_Symbols
https://www.ocad.com/wiki/ocad/en/index.php?title=File:DxfImport3.png
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 You can also Convert the imported Layers manually.

Revision of an Existing Orienteering Map
If you use an old orienteering map as a base map for the revision, you have to consider following points:
•• Control if the scale is proper.
•• Check the declination.
• Correct the symbol set and match it to the current international specification.
•• Convert freehand lines into curves.
• Delete disturbing objects. The base map shouldn’t contain any dark area objects.
The preparation of an existing OCAD file for a revision needs experience. It is recommended to consult an
experienced map drawer or a map consultant.

 If your map is not georeferenced or no LiDAR/cadastral data has been used before, we recommend you to start
your new map from scratch. As you could see in the chapters above, high quality base maps can be produced in a
minute, where all objects are at the right place.

Mapping in the terrain
Nowadays, with the right background material and equipment, mapping in the terrain is not about the right place of
the object - it is about which objects should be on the map. This process is called generalisation and is done
differently by every cartographer.
In case your background material isn't that great, you can get help of a GPS device or a Laser Rangefinder. In this
case, mapping with a Tablet PC can make sense. OCAD supports real-time GPS so you can see you current position
on the tablet. Furthermore, switching between differnt background maps is easy.
However, most cartographer still prefer to map with pen and paper. This way, you are faster in the field and can
make the final drawing at home, where you work more efficiently and weather independent.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=Import_Files%23Converting_a_Layer_Manually
https://www.ocad.com/wiki/ocad/en/index.php?title=File:ConvertImportedLayers.gif
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
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In the example above, the following color were used:
Black: Buildings, streets, paved area, rocks, stones
Red: Terrain, canopies/passages, open land
Blue: Water, wells, walls, fences
Green: Vegetation, hedges, trees

Prepare your field work for digitizing

Scan Field Work, Open it as a Background Map and Adjust
When you are back from mapping...
1.1. Scan your field work and save it in a raster format (JPG, TIFF or PNG).
2. Background Map->Open
3. Adjust your Background Map (F9)

Background Map Options
Go to Background Map -> Manage In the Manage Background Map dialog a table is displayed, in which all
loaded background maps are listed.

• V (Visible): You can make a background map visible or hide it by clicking the corresponding cell in this column.
An eye icon in this column means that the background map is visible.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:MappingTerrain.png
https://www.ocad.com/wiki/ocad/en/index.php?title=Background_Map%23Adjust_a_Background_Map
https://www.ocad.com/wiki/ocad/en/index.php?title=File:ManageBackgroundMap1.png
https://www.ocad.com/wiki/ocad/en/index.php?title=File:ManageBackgroundMap1.png
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 To hide all background maps temporary use the Hide All command in the Background Map menu.
• F (Visible in Background Favorites view mode): You can make a background map visible or hide it in the

Background Favorites by clicking the corresponding cell in this column. An eye icon in this column means that
the background map is visible in the Background Favorites.

• Dim: In this column you can enter a value in percentage to make the background map appear brighter, i.e. to dim
it. 0% means the background map is displayed in its original colors. 100% means the background map appears
completely white. Dimming is used to get a better distinction between the background map and the map.

• T (Transparent): If more than one background map is opened you can set them transparent so that both are
visible. Activate this option by clicking the corresponding cell in this column.

 The order of the background maps can be changed with the arrow icons  or with drag and drop.

Background Map Options
Choose the Hide All command in the Background Map menu or press the F10 key to hide all background maps
temporarily or make them visible when they are hidden.

Draw an Object on the Map
To draw an object, click on the symbol in the symbol box first, then choose the drawing tool in the toolbar and
finally draw the object in the drawing area.
Please read the Wiki Page Drawing an Object to learn more about it.

Edit Objects
To edit an object, there are many edit tools:
•• Edit tools in the Edit and Drawing Toolbar

•• Edit functions in the Edit Functions Toolbar

To edit an object, the object has to been selected:

• Select and Edit Object(s)  e.g. move an object
• Select Object and Edit Vertex  e.g. insert, move, remove a vertex
Find more information on the Edit Object page.

Check Legibility of your Map
The term Generalisation was mentioned already above and deals with the question, which objects are important and
should be on a map and which are not. The problem is seldom that there are too few objects on the map, but often are
too many and too small objects on the map. This has to do with more accurate background maps, on which you see
every detail.
Be also aware, that orienteering maps are no cadastral maps. Readability is much more important than position
accuracy. You are allowed to cheat, e.g. make buildings smaller to emphasize a passage. Nobody will recognise.
OCAD has a function called Check Legibility that helps you verifying your map.
Use this function to check minimum distances between objects, minimum length of line objects or minimum size of
area objects according to ISOM 2017.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=Background_Map%23Hide_all_Background_Maps
https://www.ocad.com/wiki/ocad/en/index.php?title=View_Mode%23Draft_Mode_Only_Background_Map_Favorites
https://www.ocad.com/wiki/ocad/en/index.php?title=View_Mode%23Draft_Mode_Only_Background_Map_Favorites
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=File:MoveUpDown.png
https://www.ocad.com/wiki/ocad/en/index.php?title=File:EditAndDrawingToolbar.png
https://www.ocad.com/wiki/ocad/en/index.php?title=File:EditFunctionsToolbar.png
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_SelectAndEditObject.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Icon_SelectObjectAndEditVertex.PNG
https://www.ocad.com/wiki/ocad/en/index.php?title=Map%23Check_Legibility
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Colors and Symbols

Colors
In the Map -> Colors dialog you can manage the colors of the symbols. You shouldn’t change something in the list,
when you don’t know what you are doing. The order of the colors in the color list regulates the overlaying: a color
covers at the printing all the colors that are below.
The actual ISOM Symbol Sets of OCAD contains the latest CMYK color value. However, they may change from
time to time. The latest CMYK color values can be found [here [5]].

Symbols

Symbol Sets for Orienteering Maps

OCAD delivers many predefined Symbol Sets for Orienteering maps and are part of OCAD. Choose one of the
Symbol Set, when you start a new file File -> New. The latest ISOM (International Specification for Orienteering
Maps) is ISOM 2017 for Forest Maps. If your map is still in an older ISOM standard, you can change the symbols to
ISOM 2017 under Map -> Symbol Set Conversion.
For Sprint Maps the latest specification is only 2007 (ISSOM 2007). The symbol sets are also delivered for Ski and
Bike orienteering.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:CheckLegability_areaSize.PNG
https://orienteering.org/resources/mapping/
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Print and Export

Print
Go to File>Print (or Ctrl+P) to print your map. Select printer, scale and extend. Read more on the Printing Maps
page.

 Print your map in the intended scale after a while. Check if you can read all details. Remember to keep at least
the minimum dimensions defined by the IOF. The Check Legibility function helps you with that. When working
with 64x zoom level, you easily get too small and too many symbols on your map.

Export Files
Go to File>Export (or Ctrl+E) to export your map. Set output file, quality and extend. Read more on the Export
Files page.

 You can't export a PDF, when you are in the Draft View mode. Change to the Normal mode.
 Due to color display, we recommend you to always create a PDF first out of OCAD and print this PDF

afterwards. OCAD works with CMYK Colors and they will only be displayed correctly this way. What you see on
your screen are RGB-Colors from the Windows Graphics Device Interface (GDI). When you print maps directly out
of OCAD, the Windows GDI converts the CMYK values first in RGB values and your printer driver back to CMYK
values. This way it may come to changes in the color values.

References
[1] http:/ / www. ocad. com/ en/
[2] http:/ / www. ocad. com/ en/ support/ learn-video/
[3] http:/ / ocad. com/ blog/
[4] http:/ / ocad. com/ OCAD2018/ OCAD_2018_Update. txt
[5] https:/ / orienteering. org/ resources/ mapping/

https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=Map%23Check_Legibility
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=File:ColorDisplay.png
http://www.ocad.com/en/
http://www.ocad.com/en/support/learn-video/
http://ocad.com/blog/
http://ocad.com/OCAD2018/OCAD_2018_Update.txt
https://orienteering.org/resources/mapping/
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Technical Data

Computer / System Requirements
•• OCAD 2019 requires Windows 7, Windows 8 or Windows 10 (32- or 64-bit). OCAD 2019 is available as 32-bit

and 64-bit software.
•• We strongly recommend for Windows Vista und Windows 7 to use the default Aero Theme to avoid unnecessary

screen redraws or erased maps when moving dialogs.
•• 50 MB of free disk space for the installation
•• At least 1 GB RAM (depends on the size of open maps and background maps). The OCAD program without any

open map needs only 70 MB RAM.
• OCAD 2019 as 32-bit software can allocate up to approx. 3.5 GB RAM (32-bit Windows 7 consult the page

Physical Memory). OCAD 2019 as 64-bit software and can allocate more than 3.5 GB RAM if available.
•• Screen resolution: 1280 x 1024 or higher recommended
• OCAD 2019 Mapping Solution: We recommend to install the Borland Database Engine [4] (import shape files,

database connections to dBase files, using OCAD to create thematic maps) and the Microsoft Access Database
Engine 32-bit [4] (database connections to Access/Excel files, using OCAD to create thematic maps).

 OCAD 64-bit version cannot connect to Microsoft Excel/Access if the 32-bit version of Microsoft Access
Database Engine is installed. The same with 64-bit Microsoft Access Database Engine and OCAD 32 bit version. In
this case use the same OCAD version as installed Microsoft Access Database Engine..

64-bit Version vs. 32-bit Version
OCAD 2019 Orienteering and OCAD 2019 Mapping Solution are new available as 64-bit version. However, we
have still also a 32-bit version. The OCAD Setup installs both versions. Both versions uses the same resources,
nevertheless it is possible to run both version at the same time. The installer creates a program shortcut for each
version.
Please note, the 64-bit version isn't faster than the 32-bit version. The big advantage of 64-bit is that OCAD can
allocate more than 3 GB RAM if available on the computer. That is important when loading huge raster background
maps or DEM files.
OCAD 2019 Starter and OCAD 2019 Course Setting only come as a 32-bit verion.
You can check your Windows version in the OCAD map information dialog.
OCAD 64-bit runs only in Windows 64-bit version. Nowadays, most computers are running on a 64-bit Windows
version. OCAD 32-bit runs on both Windows 64-bit and 32-bit. The ocd files are 100% compatible between both
versions.
Please note that not all OCAD functions are available in both versions. The restrictions for OCAD 64-bit version are:
•• dbf database file cannot be used
•• GPS Real Time via COM interface does not work
•• Laser Range Finder does not work
After the installation ocd files are assicated with OCAD 2019 32-bit version. To change to 64-bit see How to
Change Default Program Association.

https://www.ocad.com/wiki/ocad/en/index.php?title=Physical_Memory
http://www.ocad.com/download/bde.exe
http://www.microsoft.com/download/en/details.aspx?id=13255
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Hint.jpg
https://www.ocad.com/wiki/ocad/en/index.php?title=How_to_Change_Default_Program_Association
https://www.ocad.com/wiki/ocad/en/index.php?title=How_to_Change_Default_Program_Association
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OCAD on Mac OS X
Read the OCAD on Mac OS X article for more information.

OCAD on Linux
Read the OCAD on Linux article for more information.

OCAD Limits
•• Maximal map size: 4 x 4 meters (OCAD Orienteering edition), 80 x 80 meters (Mapping Solution edition)
•• Resolution (accuracy of coordinates) 0.01 mm
•• 10000 objects (Starter edition), 16 million objects (OCAD Mapping Solution, Orienteering, Course Setting and

Viewer edition)
•• 4 million vertices for each object
•• Unlimited number of symbols (number range 0.001 to 999'999.999)
•• 32'000 colors (number range from 0 to 32'000)
•• 2 GB file size

OCAD File Format
This description of the OCAD file format is intended for programmers who want to directly access the information
in OCAD files.
•• OCAD 12 File Format
• OCAD 11 File Format [1]

• OCAD 10 File Format [2]

• OCAD 9/10 Graphic [3]

• OCAD 9 File Format [4]

• OCAD 6/7/8 File Format [5]

Recommendations
OCAD runs on all 7 / 8 or 10 computers except Windows 8 RT (ARM tablets).

Mapping on TabletPC
Hardware:
•• Tablet PC with Windows
•• Long battery life (8 hours or longer)
•• Outdoor screen
•• GPS with USB or Bluetooth connection
Software:
•• OCAD Orienteering Edition

https://www.ocad.com/wiki/ocad/en/index.php?title=OCAD_on_Linux
https://www.ocad.com/wiki/ocad/en/index.php?title=OCAD_12_File_Format
http://www.ocad.com/wiki/ocad11/en/?title=Main_Page
http://www.ocad.ch/docs/OCAD10Format.txt
http://www.ocad.ch/docs/OCAD9Format.pdf
http://www.ocad.ch/docs/OCAD9Format.txt
http://www.ocad.ch/docs/format8.txt
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Draw Orienteering Maps and Course Setting
Hardware:
•• Desktop or Laptop with Windows
•• 4 GB or more RAM (at least 8 GB RAM when working with big Airborne Laserscanning Files)
Software:
•• OCAD Orienteering Edition or OCAD Course Setting Edition

Map Publishing Companies
Hardware:
•• Desktop PC with Windows one or two screens
•• 4 or more GB RAM
Software:
•• OCAD Mapping Solution
Special OCAD Settings:
• Switch on the Faster text rendering in OCAD Preferences -> View tab in Options menu.
• Switch off the Anti-Aliasing mode in View menu. If Anti-Aliasing is switched off then OCAD draws the screen

color by color. Otherwise OCAD draws the screen once after a short time.

Digital Signature
The OCAD program file and the OCAD setup file are signed with the digital signature [6] of OCAD AG. That
confirms the software author and guarantee that the code has not been altered or corrupted since it was signed by use
of a cryptographic hash. OCAD uses the digital signature algorithm sha256RSA.
That is the reason why OCAD 2019 doesn't run on Windows XP and Vista.
The see the digital signature open the context menu of the OCAD setup file (.exe file) in File Explorer and click
Properies. The Properties dialog opens. Click the Digital Signature tab. Click Details. In Digital Signature
Details dialog is the Signer Name OCAD AG.

https://en.wikipedia.org/wiki/Code_signing
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Back to Main Page
Previous Chapter: Tutorials
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Service Update
Regular and free updates are included in the OCAD subscription model. The Service Update corrects known bugs
and adds the latest cartography tools and enhancements to your OCAD.
Therefore, we recommend using OCAD software always with the most recent Service Update to benefit from the
quality improvements.
Please download the current Service Update from the Help -> Download Update function in the OCAD program.
The content of the Service Update is listed in the Release notes [4].

Which OCAD version do I have?
You can find out your exact Software Version under Help -> About OCAD.
Also, the OCAD 12 and 2019 Updater can be used as a general overview and update tool for OCAD installations.

OCAD Updater
OCAD checks for the newest Service Update online, everytime when it is started. If there's a new Service Update
available, the OCAD Updater dialog appears.

You have three options:
• Skip this Update: Click this button to skip the current version. OCAD will not ask again to install the service

update until a new version is available.
• Remind me later: When this button is clicked, OCAD will ask you again to install the Service Update, when you

start OCAD the next time.
• Install Service Update: Click this button to install the update.

http://ocad.com/OCAD2018/OCAD_2018_Update.txt
https://www.ocad.com/wiki/ocad/en/index.php?title=OCAD_12_and_2019_Updater
https://www.ocad.com/wiki/ocad/en/index.php?title=File:OcadUpdater.png
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OCAD Service Update
In addition to the OCAD Updater you can also click on Download Update in the Help menu to download the
current Service Update from the OCAD website.
If there are still OCAD files open, a message appears to close all files.

Click on Download and install Update. OCAD will be closed automatically afterwards.

Installation
Confirm to install the update.

https://www.ocad.com/wiki/ocad/en/index.php?title=File:DownloadUpdate1.png
https://www.ocad.com/wiki/ocad/en/index.php?title=File:DownloadUpdate2.png
https://www.ocad.com/wiki/ocad/en/index.php?title=File:Ocad12And2019UpdaterInstall.png
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Please visit the Installation page for further proceeding.

Switch Off the OCAD Updater
To switch off the OCAD Updater disable the option in the Preferences.

https://www.ocad.com/wiki/ocad/en/index.php?title=OCAD_Preferences%23Updater



