Course Setting for Orienteering

From OCAD 12 Wiki - English
Jump to: navigation, search

This function is available in OCAD 12 Professional.This function is available in OCAD 12 Orienteering.This function is available in OCAD 12 Starter.This function is available in OCAD 12 Course Setting.

CourseSettingExample.PNG

(The Course Setting functions are only available in course setting projects!)

OCAD provides completely integrated functions for course setting in orienteering.


Start a New Course Setting Project

A course setting project is a special OCAD file. Like map files it has the extension .ocd, but it has a special internal mark to identify it as a course setting file. To create a course setting project, you must create a new map file.

  1. Choose the New command from the File menu or click the New button. The New File dialog box is displayed.
    CsFileNew.PNG
  2. In the Map type box select the 'Course setting project for orienteering item.
  3. Select a symbol set from the Load symbol set from box. For a course setting project in a scale where no symbol set is available please choose one of the available symbol sets.
  4. Click the OK button.
  5. Choose the Set Scale and Coordinate System command from the Map menu. Set the map scale to the correct value . It is important to do this before starting with course setting because the calculation of the courses length depends on the map scale.
  6. Choose the Save command from the File menu or click the Icon Save.PNG Save button. The Save As dialog box appears. Enter a file name for the course setting file.
  7. Choose the Open command from the Background Map menu to open a map file as a background map.
  8. Choose the Entire Map command from the View menu to show the whole map on the screen.
CsBox.PNG

The Course Setting Box is displayed on the right side of the OCAD window. This Course Setting Box provides a lot of functions and options. Visit the Edit Course Setting Objects page to get more information.


Add Course Setting Objects

To learn how to add course setting objects visit the Add Course Setting Objects page with the following articles:

  1. Add Start, Controls and Finish
  2. Add a Marked Route
  3. Add a Control Description
  4. Add a Course Title
  5. Add Variant for Relay Courses. Learn how to create relay courses on the Create Relay Courses page.
  6. Add Start Numbers for Relay Courses. Learn how to create relay courses on the Create Relay Courses page.
  7. Add Other Objects, like the event title, logos, corrections on the map etc.
  8. Course Setting Dialog Box

Edit Course Setting Objects

Information about all functions which are provided by the course setting box on the right side of the window can be found on the Edit Course Setting Objects page.

Most important functions:
Change Code of Course Objects
Insert a Text Block
Lock or Unlock Course Objects
Edit Control Description
Add, Edit or Remove Course Objects
Preview Mode

Controls

The following two functions can be found in the Controls submenu of the Course Setting menu:

Renumber all Controls

This function is useful if you did not know the available control numbers for your event when starting to plan the courses.
Choose the Renumber all Controls command in the Controls submenu of the Course Setting menu to display the Renumber all Controls dialog.

CsRenumberAllControls.PNG

  1. Enter a New first code to shift all control codes. All codes are shifted with the difference between the New first code and the Old first code.
  2. Check the option Close numbering gaps if gaps with not used numbers should be closed.
  3. Click the OK button when finished.

Control Elevation

Visit the Control Elevation page to find more information about this function.

Courses

As a next step you can Create a New Course. A course is basically a list of the start, controls, marked route(s) and the finish. You may want to Insert Other Course Objects like mandatory crossing point, mandatory passage through out of bound area, map exchange, relay team or leg variation.

OCAD supports:

All information about courses can be found on the Create a New Course page.

video available Create butterfly courses

Classes

In OCAD you can either work with courses only or you can use classes and courses. Different classes may use the same course. Visit the Create a New Class page for more information.

Insert Course Object to Courses

Choose this function from the Course Setting menu. Learn more about this function on the Add a Course Object to Courses page.

Delete Course Object from Courses

This is the inverse function of the Insert Course Object to Courses function.

Read more about this function on the Delete Course Object from Courses page.

Make Graphic Modifications

Often it is necessary to Make Graphic Modifications to the courses generated by OCAD.

Move Control Number for All Courses

To move the control number for all courses (for example if it covers important map information):

  1. Change to Preview mode.
  2. Move a control number and keep it selected.
  3. Choose the Move Control Number for all Courses command from the Course Setting menu.
  4. The control number is moved for all other courses, too.

Edit Connection Line for All Courses

To edit a connection line for all courses (for example if it covers important map information):

  1. Change to Preview mode.
  2. Edit the connection line and keep it selected.
  3. Choose the Edit Connection Line for all Courses command from the Course Setting menu.
  4. The connection line is edited in all other courses which use it, too.

Edit Text Control Description

Choose the Edit Text Control Description command in the Course Setting menu to edit the text control description. Visit the Edit Text Control Description page for more information.

Auto Control Description

OCAD provides an Auto Control Description tool that recognizes map objects, where controls are placed, and sets the corresponding IOF symbol to the control description. Visit the Auto Control Description page for more information.

Punching Unit IDs

Choose the Punching Unit IDs command in the Course Setting menu to enter the punching unit IDs. Visit the Punching Unit IDs page for more information.

Course Statistic and Event Statistic

Choose the command Course Statistic and Event Statistic from the Course Setting menu to display a course and event statistic. Visit the page Course Statistic and Event Statistic for more information.

Consistency Check Report

Choose the command Consistency Check Report from the Course Setting menu to display the consistency check report. Visit the page Consistency Check Report for more information.

Compare Course Setting Files

The function Compare Course Setting Files is only enabled if no ocd file is open.

hint The Course Setting menu is not visible by default for OCAD Professional and OCAD Mapping Solution. Open and close a course setting file to make it visible.
  1. Add the files that should be compared to the files box.
  2. Click the Compare files button.
  3. The differences are shown in the dialog.
  4. Click the Save As... to save the text as html file.

The function shows the following differences between course setting files:

  • Different Course Objects
  • Different Courses
  • Different Preview Objects
  • Different Course Setting Options

Print

In the Print submenu of the Course Setting menu you have the option to print the Courses or the Control Descriptions.

Courses can be printed together with the map or on an already printed map. OCAD provides adjustment functions to adjust the course to the already printed map. In addition EPS files can be created to make plates for offset printing. Visit the Print Courses page for more information.

To get more information about printing control descriptions, visit the Print Control Descriptions page.

Control descriptions can printed together with the course on the map: Add a Control Description Object.

Import

It is possible to import an OCAD Map or to import courses from ORware. Visit the Course Setting Import page for more information.

Export

OCAD provides different export options of course data for event software, courses as gpx file, course maps etc.
Visit the Course Setting Export page for more information.

Create PDF Files for Printing

Please use Export from the File menu if you want to create PDF files from the courses to provide them to the printery.
Please select the courses/classes in the Select Courses/Classes dialog that appears after clicking the Export button in the Export panel.

hint You can also export the PDF files from exported Course Maps. In that case the Select Courses/Classes dialog does no appear since a course map file contains only graphics.

Select courses/classes when exporting a PDF from a course setting project

Options

Choose the Options command from the Course Setting menu to get some Course Setting Options.

Save as OCAD 9, OCAD 10 or OCAD 11

You can save your course setting project as OCAD 9, OCAD 10 or OCAD 11 file. Please note, that some features may be lost according to the Compatibility Check.



Back to Main Page

Previous Chapter: XML Script

Next Chapter: Client Server Architecture